color-mate-vl.spec 5.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207
  1. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1 | grep -v "is not")
  2. %define emacsen_pkgdir /usr/lib/emacsen-common/packages
  3. Summary: colorize emacsens' window
  4. Name: color-mate
  5. Version: 10.6.3
  6. Release: 1%{?_dist_release}
  7. Group: Applications/Editors/Emacs
  8. License: distributable
  9. Url: http://www.netlab.is.tsukuba.ac.jp/~yokota/izumi/color_mate/
  10. Source0: color-mate-%{version}.tar.gz
  11. Source1: cm_select.sh
  12. Source2: emacs-color.sh
  13. Patch0: color-mate-fontset.patch
  14. Patch1: color-mate-10.6.3-color-mate-fontset-emacs.patch
  15. Patch2: color-mate-10.6.3-color-mate-fontset-xemacs.patch
  16. Patch3: color-mate-face-nound.patch
  17. Patch4: color-mate-SunnyDay-LCD.patch
  18. Patch5: color-mate-10.6.3-tail.patch
  19. Source10: color-mate-install.sh
  20. Source11: color-mate-remove.sh
  21. BuildArch: noarch
  22. Buildroot: %{_tmppath}/%{name}-%{version}-root
  23. PreReq: emacsen
  24. BuildPreReq: emacsen-common
  25. %prereq_ge emacsen-common
  26. Obsoletes: color-mate-emacs, color-mate-xemacs
  27. Vendor: Project Vine
  28. Distribution: Vine Linux
  29. %description
  30. Color-Mate is a colorize tool for emacs/xemacs.
  31. %description -l ja
  32. Color-Mate とは、 emacs/xemacs のカラー表示機能を使ってXウィンドウ版
  33. emacs/xemacs 画面を見やすくするものです。
  34. %prep
  35. %setup -q
  36. %patch -p0
  37. %patch1 -p1
  38. %patch2 -p1
  39. %patch3 -p0
  40. %patch4 -p1
  41. %patch5 -p1
  42. %build
  43. #just adding annoying file to the rpm filelist
  44. ./configure
  45. %install
  46. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  47. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/color-mate
  48. #mkdir -p ${RPM_BUILD_ROOT}/%{_libdir}/emacsen-common/packages/install
  49. #mkdir -p ${RPM_BUILD_ROOT}/%{_libdir}/emacsen-common/packages/remove
  50. mkdir -p ${RPM_BUILD_ROOT}/%{emacsen_pkgdir}/install
  51. mkdir -p ${RPM_BUILD_ROOT}/%{emacsen_pkgdir}/remove
  52. # install el files
  53. cp -ar Makefile* configure* *.el *.pl install-sh* kanakan-cursor contrib theme/\
  54. ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/color-mate
  55. # install contrib
  56. mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
  57. install -m 755 %{SOURCE1} ${RPM_BUILD_ROOT}%{_bindir}/cm_select
  58. install -m 755 %{SOURCE2} ${RPM_BUILD_ROOT}%{_bindir}/emacs-color
  59. pushd ${RPM_BUILD_ROOT}%{_bindir}/
  60. ln -s emacs-color xemacs-color
  61. popd
  62. # prepare docs
  63. mv contrib/README README.cm_select
  64. ## install script (bytecompile el and install elc, remove elc)
  65. %_installemacsenscript color-mate %{SOURCE10}
  66. %_removeemacsenscript color-mate %{SOURCE11}
  67. %clean
  68. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  69. %post
  70. ## bytecompile el and install elc
  71. if [ "$1" = 2 ] ; then
  72. %_emacsenPackageRemove color-mate
  73. fi
  74. %_addemacsenlist color-mate
  75. %_emacsenPackageInstall color-mate
  76. %preun
  77. if [ "$1" = 0 ] ; then
  78. %_emacsenPackageRemove color-mate
  79. %_removeemacsenlist color-mate
  80. fi
  81. %files
  82. %defattr(-,root,root)
  83. %doc Q_and_A.color-mate QuickStart.color-mate README.color-mate*
  84. %doc Customize* ChangeLog Dot*
  85. %doc kanakan-cursor/org-doc/* kanakan-cursor/README* contrib/
  86. %{_bindir}/cm_select
  87. %{_bindir}/emacs-color
  88. %{_bindir}/xemacs-color
  89. %{_datadir}/emacs/site-lisp/color-mate/
  90. #/usr/lib/emacsen-common/packages/*/*
  91. %{emacsen_pkgdir}/*/*
  92. %changelog
  93. * Sun Sep 21 2008 Shu KONNO <owa@bg.wakwak.com> 10.6.3-1vl5
  94. - applied new versioning policy, spec in utf-8
  95. - added macro %%emacsen_pkgdir
  96. * Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 10.6.3-0vl3
  97. - changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  98. * Sun Aug 13 2006 IWAI, Masaharu <iwai@alib.jp> 10.6.3-0vl2
  99. - update color-mate-install.sh for Emacs 22
  100. - using Licenes tag
  101. - add tail option patch ( Patch5 )
  102. * Wed Apr 9 2003 IWAI Masaharu <iwai@alib.jp> 10.6.3-0vl1
  103. - version up to 10.6.3
  104. - update color-mate-fontset-emacs.patch (Patch1)
  105. - update color-mate-fontset-xemacs.patch (Patch2)
  106. * Fri Mar 29 2002 Jun Nishii <jun@vinelinux.org> 10.1.1-0vl8
  107. - fix color-mate-{install,remove}.sh
  108. * Fri Mar 29 2002 Jun Nishii <jun@vinelinux.org> 10.1.1-0vl7
  109. - install missing .X files
  110. - use symlink for color-xemacs
  111. - update cm_select
  112. * Sun Dec 16 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 10.1.1-0vl6
  113. - install script (SOURCE10) modified a little
  114. * Sun Dec 16 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 10.1.1-0vl5
  115. - emacsen-common aware
  116. * Sun Dec 03 2000 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
  117. - 10.1.1-0vl4
  118. - fixed description
  119. - added BuildRequires and %%{emacs} / %%{xemacs} for each package to be
  120. built on anti-BuildRequired host (both set to be 1 by default).
  121. - cp -a for egg-cursor.el to work around with emacs's murmur :-)
  122. * Wed Oct 11 2000 Jun Nishii <jun@vinelinux.org>
  123. - 10.1.1-0vl3
  124. - with egg-cursor
  125. * Wed Sep 20 2000 Jun Nishii <jun@vinelinux.org>
  126. - 10.1.1-0vl2
  127. - modify emacs-color
  128. * Fri Sep 15 2000 Jun Nishii <jun@vinelinux.org>
  129. - 9.1.1-0vl1
  130. - enable to set default fontset in .emacs
  131. - obsletes SunnyDay-LCD 12
  132. - added cm_select in bins
  133. - added emacs-color, xemacs-color
  134. * Mon Sep 11 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
  135. - 10.0.1-8
  136. - added SunnyDay-LCD 12 dots fontset theme
  137. * Fri Feb 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  138. - 10.0.1-7
  139. - added %defattr(-,root,root)
  140. - added %clean section
  141. * Wed Jan 26 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  142. - 10.0.1-6
  143. - fixed SunnyDay-LCD.el for "wrong type argument" problem
  144. * Fri Dec 3 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  145. - 10.0.1-5
  146. - %files xemacs section modified for correct load-path
  147. to /usr/lib/xemacs/site-packages/lisp/color-mate
  148. * Wed Dec 1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  149. - change Group to Applications/Editors/EmacsLisp
  150. * Wed Nov 17 1999 Jun NISHII <jun@vinelinux.org>
  151. - build for Vine-2.0