qzion-vl.spec 3.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135
  1. %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. %{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  3. Name: qzion
  4. Version: 0.4.0
  5. Release: 6%{?_dist_release}
  6. Summary: A canvas abstraction
  7. Group: System Environment/Libraries
  8. License: GPLv3+
  9. URL: http://code.openbossa.org/projects/qzion
  10. Source0: http://code.openbossa.org/projects/%{name}/repos/mainline/archive/d32223eae1bba7f1b191c334668f3f7dd662f582.tar.gz
  11. Patch0: qzion-0.4.0-fix_python_install.patch
  12. Patch1: qzion-0.4.0-fix_char_conversion.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: qt4-devel
  15. BuildRequires: PyQt4-devel
  16. BuildRequires: cmake
  17. BuildRequires: pkgconfig
  18. BuildRequires: python-devel
  19. BuildRequires: sip-devel
  20. %description
  21. QZion is an canvas abstraction used by and made for QEdje.
  22. %package devel
  23. Summary: Development files for %{name}
  24. Group: Development/Libraries
  25. Requires: cmake
  26. Requires: pkgconfig
  27. Requires: %{name} = %{version}-%{release}
  28. %description devel
  29. The %{name}-devel package contains libraries and header files for
  30. developing applications that use %{name}.
  31. %package python
  32. Summary: Python bindings for %{name}
  33. Group: Development/Libraries
  34. Requires: PyQt4
  35. %description python
  36. The %{name}-python package contains python bindings for %{name}
  37. %package python-devel
  38. Summary: Python bindings for %{name}
  39. Group: Development/Libraries
  40. Requires: sip
  41. Requires: PyQt4-devel
  42. Requires: %{name}-python = %{version}-%{release}
  43. %description python-devel
  44. The %{name}-python-devel package contains the development files for
  45. the python bindings for %{name}
  46. %prep
  47. %setup -q -n %{name}-mainline
  48. %patch0 -p1
  49. %patch1 -p1
  50. %build
  51. mkdir -p %{_target_platform}
  52. pushd %{_target_platform}
  53. %cmake \
  54. -DPYTHON_SITE_PACKAGES_DIR=%{python_sitearch} \
  55. ..
  56. popd
  57. make %{?_smp_mflags} -C %{_target_platform}
  58. %install
  59. rm -rf %{buildroot}
  60. make install/fast -C %{_target_platform} DESTDIR=%{buildroot}
  61. %clean
  62. rm -rf %{buildroot}
  63. %post -p /sbin/ldconfig
  64. %postun -p /sbin/ldconfig
  65. %files
  66. %defattr(-,root,root,-)
  67. %doc README COPYING
  68. %{_libdir}/*.so.*
  69. %files devel
  70. %defattr(-,root,root,-)
  71. %{_libdir}/*.so
  72. %{_includedir}/*
  73. %{_libdir}/pkgconfig/%{name}.pc
  74. %files python
  75. %defattr(-,root,root,-)
  76. %{python_sitearch}/%{name}
  77. %files python-devel
  78. %defattr(-,root,root,-)
  79. %{_datadir}/sip/%{name}
  80. %changelog
  81. * Tue Mar 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.4.0-6
  82. - rebuilt with python2.6
  83. * Sun Sep 06 2009 NAKAMURA Kenta <kenta@vinelinux.org> - 0.4.0-5
  84. - use %%cmake macro
  85. * Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.4.0-4
  86. - Initial build for Vine Linux
  87. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.0-3
  88. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  89. * Thu Jul 16 2009 John5342 <john5342 at, fedoraproject.org> 0.4.0-2
  90. - Fix char* conversion (#511583)
  91. * Fri Mar 06 2009 John5342 <john5342 at, fedoraproject.org> 0.4.0-1
  92. - Updated to new upstream release (0.4.0)
  93. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.0-3
  94. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  95. * Fri Dec 19 2008 John5342 <john5342 at, fedoraproject.org> 0.3.0-2
  96. - Implemented package review suggestions
  97. - Remove BR: eet-devel
  98. * Fri Dec 19 2008 John5342 <john5342 at, fedoraproject.org> 0.3.0-1
  99. - Initial package