qca2-vl.spec 3.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135
  1. %define qt4_ver 4.6.3
  2. Name: qca2
  3. Summary: Qt Cryptographic Architecture
  4. Version: 2.0.2
  5. Release: 7%{?_dist_release}
  6. Group: System Environment/Libraries
  7. License: LGPLv2+
  8. URL: http://delta.affinix.com/qca
  9. Source0: http://delta.affinix.com/download/qca/2.0/qca-%{version}.tar.bz2
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. BuildRequires: qt4-devel = %{qt4_ver}
  12. BuildRequires: pkgconfig
  13. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
  14. %description
  15. Taking a hint from the similarly-named Java Cryptography Architecture,
  16. QCA aims to provide a straightforward and cross-platform crypto API,
  17. using Qt datatypes and conventions. QCA separates the API from the
  18. implementation, using plugins known as Providers. The advantage of this
  19. model is to allow applications to avoid linking to or explicitly depending
  20. on any particular cryptographic library. This allows one to easily change
  21. or upgrade crypto implementations without even needing to recompile the
  22. application!
  23. %package devel
  24. Summary: Qt Cryptographic Architecture development files
  25. Group: Development/Libraries
  26. Requires: %{name} = %{version}-%{release}
  27. Requires: qt4-devel = %{_qt4_version}
  28. Requires: pkgconfig
  29. %description devel
  30. This packages contains the development files for QCA
  31. %prep
  32. %setup -q -n qca-%{version}
  33. %build
  34. unset QTDIR || : ; . /etc/profile.d/qt4.sh
  35. MAKE=%{_bindir}/make \
  36. ./configure \
  37. --prefix=%{_prefix} \
  38. --includedir=%{_includedir} \
  39. --libdir=%{_libdir} \
  40. --datadir=%{_datadir} \
  41. --no-separate-debug-info \
  42. --verbose
  43. sed -i -e /strip/d Makefile
  44. make %{?_smp_mflags}
  45. %install
  46. rm -rf $RPM_BUILD_ROOT
  47. make install INSTALL_ROOT=$RPM_BUILD_ROOT
  48. %clean
  49. rm -rf $RPM_BUILD_ROOT
  50. %post -p /sbin/ldconfig
  51. %postun -p /sbin/ldconfig
  52. %files
  53. %defattr(-,root,root,-)
  54. %doc COPYING README TODO
  55. %{_bindir}/qcatool2
  56. %{_libdir}/*.so.*
  57. %{_mandir}/*/*
  58. %files devel
  59. %defattr(-,root,root,-)
  60. %{_includedir}/QtCrypto
  61. %{_libdir}/*.so
  62. %{_libdir}/pkgconfig/qca2.pc
  63. %{_libdir}/libqca.prl
  64. %{_libdir}/qt-%{_qt4_version}/mkspecs/features/crypto.prf
  65. %changelog
  66. * Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.0.2-7
  67. - rebuilt with qt-4.6.3 again
  68. - change BuildRequires: qt4-devel = %{qt4_ver} (add version)
  69. * Sat Jul 24 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-6
  70. - rebuilt with qt-4.6.3
  71. * Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.0.2-5
  72. - rebuilt with new toolchain, qt4-4.6.1
  73. * Sun Nov 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-4
  74. - rebuilt with qt-4.5.3
  75. * Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-3
  76. - Initial build for Vine Linux
  77. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.2-2
  78. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  79. * Tue May 05 2009 Sven Lankes <sven@lank.es> - 2.0.2-1
  80. - new upstream release - qt 4.5-compat-fixes
  81. * Wed Apr 08 2009 Sven Lankes <sven@lank.es> - 2.0.1-1
  82. - new upstream release
  83. - removed 64bit patch - now upstream
  84. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-4
  85. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  86. * Fri May 30 2008 Dennis Gilmore <dennis@ausil.us> - 2.0.0-3
  87. - crypto.prf is in libdir not datadir
  88. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.0.0-2
  89. - Autorebuild for GCC 4.3
  90. * Sun Oct 21 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-1
  91. - version 2.0.0 final
  92. * Sun Oct 21 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.4.beta7
  93. - fix build on x86_64
  94. * Sun Oct 21 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.3.beta7
  95. - missing BR: openssl
  96. * Thu Sep 13 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.2.beta7
  97. - review from bug 289681 (thanks Rex)
  98. * Sun Sep 09 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.1.beta7
  99. - initial package