gstreamer-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453
  1. # keep in sync with the VERSION. gstreamer can append a .0.1 to CVS snapshots.
  2. %define major 0.10
  3. %define _glib2_ver 2.20.0
  4. %define _libxml2_ver 2.6.15
  5. %define _gtk_doc_ver 1.3
  6. %define _check_ver 0.9.2
  7. %define _python_ver 2.1
  8. %define po_package %{name}-%{major}
  9. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  10. Name: gstreamer
  11. Summary: GStreamer streaming media framework runtime.
  12. Summary(ja): GStreamer ストリーミングメディアフレームワークランタイム
  13. Version: 0.10.30
  14. Release: 1%{?_dist_release}
  15. Group: System Environment/Libraries
  16. License: LGPL
  17. URL: http://gstreamer.freedesktop.org/
  18. Source: http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-%{version}.tar.bz2
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  20. BuildRequires: glib2-devel >= %{_glib2_ver}
  21. BuildRequires: libxml2-devel >= %{_libxml2_ver}
  22. BuildRequires: bison
  23. BuildRequires: gtk-doc >= %{_gtk_doc_ver}
  24. BuildRequires: flex
  25. BuildRequires: ghostscript
  26. BuildRequires: check >= %{_check_ver}
  27. BuildRequires: python >= %{_python_ver}, python-pyxml
  28. Requires: glib2 >= %{_glib2_ver}
  29. Requires: libxml2 >= %{_libxml2_ver}
  30. Obsoletes: gstreamer-tools
  31. Vendor: Project Vine
  32. Distribution: Vine Linux
  33. Packager: inagaki
  34. %description
  35. GStreamer is a streaming-media framework, based on graphs of filters which
  36. operate on media data. Applications using this library can do anything
  37. from real-time sound processing to playing videos, and just about anything
  38. else media-related. Its plugin-based architecture means that new data
  39. types or processing capabilities can be added simply by installing new
  40. plugins.
  41. %package devel
  42. Summary: Libraries/header files for GStreamer streaming media framework.
  43. Summary(ja): GStreamer ストリーミングメディアフレームワークのライブラリ/ヘッダファイル
  44. Group: Development/Libraries
  45. Requires: %{name} = %{version}-%{release}
  46. Requires: glib2-devel >= %{_glib2_ver}
  47. Requires: libxml2-devel >= %{_libxml2_ver}
  48. %description devel
  49. GStreamer is a streaming-media framework, based on graphs of filters which
  50. operate on media data. Applications using this library can do anything
  51. from real-time sound processing to playing videos, and just about anything
  52. else media-related. Its plugin-based architecture means that new data
  53. types or processing capabilities can be added simply by installing new
  54. plugins.
  55. This package contains the libraries and includes files necessary to develop
  56. applications and plugins for GStreamer.
  57. # compat32
  58. %package -n compat32-%{name}
  59. Summary: GStreamer streaming media framework runtime.
  60. Summary(ja): GStreamer ストリーミングメディアフレームワークランタイム
  61. Group: System Environment/Libraries
  62. %description -n compat32-%{name}
  63. GStreamer is a streaming-media framework, based on graphs of filters which
  64. operate on media data. Applications using this library can do anything
  65. from real-time sound processing to playing videos, and just about anything
  66. else media-related. Its plugin-based architecture means that new data
  67. types or processing capabilities can be added simply by installing new
  68. plugins.
  69. %package -n compat32-%{name}-devel
  70. Summary: Libraries/header files for GStreamer streaming media framework.
  71. Summary(ja): GStreamer ストリーミングメディアフレームワークのライブラリ/ヘッダファイル
  72. Group: Development/Libraries
  73. Requires: compat32-%{name} = %{version}-%{release}
  74. Requires: %{name}-devel = %{version}-%{release}
  75. Requires: compat32-glib2-devel >= %{_glib2_ver}
  76. Requires: compat32-libxml2-devel >= %{_libxml2_ver}
  77. %description -n compat32-%{name}-devel
  78. GStreamer is a streaming-media framework, based on graphs of filters which
  79. operate on media data. Applications using this library can do anything
  80. from real-time sound processing to playing videos, and just about anything
  81. else media-related. Its plugin-based architecture means that new data
  82. types or processing capabilities can be added simply by installing new
  83. plugins.
  84. This package contains the libraries and includes files necessary to develop
  85. applications and plugins for GStreamer.
  86. %prep
  87. %setup -q
  88. %build
  89. %configure \
  90. --with-package-name='Vine Linux gstreamer package' \
  91. --with-cachedir=%{_var}/cache/gstreamer-%{major} \
  92. --disable-docbook --enable-gtk-doc \
  93. --disable-static --disable-examples \
  94. --disable-tests --disable-debug
  95. make %{?_smp_mflags}
  96. %install
  97. [ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
  98. make install DESTDIR=$RPM_BUILD_ROOT
  99. mkdir -p $RPM_BUILD_ROOT%{_var}/cache/gstreamer-%{major}
  100. rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{major}/*.la
  101. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  102. #rm -f $RPM_BUILD_ROOT%{_libdir}/libgstmedia-info*.so.0.0.0
  103. %find_lang %{po_package}
  104. %clean
  105. [ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
  106. %post -p /sbin/ldconfig
  107. %postun -p /sbin/ldconfig
  108. %post -n compat32-%{name} -p /sbin/ldconfig
  109. %postun -n compat32-%{name} -p /sbin/ldconfig
  110. %files -f %{po_package}.lang
  111. %defattr(-, root, root)
  112. %doc AUTHORS ChangeLog COPYING README NEWS RELEASE
  113. %doc TODO ABOUT-NLS
  114. %{_bindir}/*
  115. %dir %{_libdir}/gstreamer-%{major}
  116. %{_libdir}/gstreamer-%{major}/*.so*
  117. %{_libdir}/*.so.*
  118. %dir %{_libexecdir}/gstreamer-%{major}
  119. %{_libexecdir}/gstreamer-%{major}/gst-plugin-scanner
  120. %{_mandir}/man1/*
  121. %dir %{_var}/cache/gstreamer-%{major}
  122. %files devel
  123. %defattr(-, root, root)
  124. %dir %{_includedir}/%{name}-%{major}
  125. %{_includedir}/%{name}-%{major}/*
  126. #{_libdir}/*.a
  127. %{_libdir}/*.so
  128. %{_libdir}/pkgconfig/gstreamer*.pc
  129. %{_datadir}/aclocal/*.m4
  130. %{_datadir}/gtk-doc/html/gstreamer-%{major}
  131. %{_datadir}/gtk-doc/html/gstreamer-libs-%{major}
  132. %{_datadir}/gtk-doc/html/gstreamer-plugins-%{major}
  133. # compat32
  134. %if %{build_compat32}
  135. %files -n compat32-%{name}
  136. %defattr(-, root, root)
  137. %dir %{_libdir}/gstreamer-%{major}
  138. %{_libdir}/gstreamer-%{major}/*.so*
  139. %{_libdir}/*.so.*
  140. %files -n compat32-%{name}-devel
  141. %defattr(-, root, root)
  142. #{_libdir}/*.a
  143. %{_libdir}/*.so
  144. %{_libdir}/pkgconfig/gstreamer*.pc
  145. %endif
  146. %changelog
  147. * Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.30-1
  148. - new upstream release
  149. * Sat May 01 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.29-1
  150. - new upstream release
  151. * Tue Mar 9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.28-1
  152. - new upstream release
  153. - used make install instead of %%makeinstall
  154. * Sun Feb 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.26-1
  155. - new upstream release
  156. - built with new toolchain
  157. * Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.25-1
  158. - new upstream release
  159. * Sun Aug 9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.24-1
  160. - new upstream release
  161. * Sat May 16 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.10.23-2
  162. - added compat32 package for x86_64 arch support
  163. * Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.23-1
  164. - new upstream release
  165. - removed static librairies from devel package
  166. - added Packager tag
  167. * Thu Mar 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.22-1
  168. - new upstream release
  169. - changed Group to System Environment/Libraries
  170. * Wed Oct 8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.21-1vl5
  171. - new upstream release
  172. - spec in UTF-8
  173. * Thu Jun 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.20-1vl5
  174. - new upstream release
  175. * Sat Apr 5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.19-1vl5
  176. - new upstream release
  177. * Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.18-1vl5
  178. - new upstream release
  179. * Sun Dec 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.15-0vl1
  180. - new upstream release
  181. * Sun Aug 5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.14-0vl1
  182. - new upstream release
  183. * Sat Jun 9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.13-0vl1
  184. - new upstream release
  185. * Sat Mar 10 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.12-0vl1
  186. - new upstream release
  187. - add Vendor/Distribution tag
  188. - add '-with-package-name' option to %%configure
  189. - use more macros
  190. * Sat Dec 09 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.11-0vl1
  191. - new upstream release
  192. * Sat Nov 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.10-0vl1
  193. - new upstream release
  194. * Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.9-0vl1
  195. - new upstream release
  196. * Sun Jun 18 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.8-0vl1
  197. - new upstream release
  198. * Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.6-0vl1
  199. - new upstream release
  200. * Sun Apr 30 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.comp> 0.10.5-0vl1
  201. - new upstream release
  202. * Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl1
  203. - new upstream release
  204. * Fri Feb 10 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.3-0vl1
  205. - new upstream release
  206. * Tue Jan 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.2-0vl1
  207. - new upstream release
  208. * Tue Jan 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl1
  209. - new upstream release
  210. - change major to 0.10
  211. - update URLs
  212. - update versions: glibc >= 2.8, gtk-doc >= 1.3
  213. - add BuildRequires: check >= 0.9.2, python >= 2.1, python-pyxml
  214. - remove from BuildRequires: popt, zlib-devel
  215. - remove obsolete options from %%configure
  216. - add --enable-gtk-doc to %%configure
  217. - add gtk-doc/html/gstreamer-* to gstreamer-devel package
  218. - add RELEASE to %%doc
  219. - remove REQUIREMENTS DOCBUILDING from %%doc
  220. - not exec gst-register-%%{major} at %%post
  221. * Fri Nov 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl1
  222. - new upstream release
  223. * Thu May 5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.10-0vl1
  224. - new upstream release
  225. * Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.9-0vl1
  226. - new upstream release
  227. - removed dependancy related to documentaion build
  228. * Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.7-0vl1
  229. - new upstream release
  230. * Tue Dec 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.4-0vl1
  231. - new upstream release
  232. * Sat Sep 06 2003 Tomoya TAKA <taka@vinelinux.org> 0.6.3-0vl2
  233. - update alpha-noWerror patch (Patch10)
  234. * Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-0vl1
  235. - new upstream release
  236. * Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
  237. - new upstream release
  238. * Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.0-0vl1
  239. - new upstream release
  240. * Sat Feb 01 2003 Tomoya TAKA <taka@vinelinux.org> 0.5.2-0vl2
  241. - build without -Werror on alpha (Patch10)
  242. * Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
  243. - new upstream release
  244. * Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl3
  245. - merge gstreamer-tools into gstreamer, obsoletes gstreamer-tools
  246. * Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
  247. - fix broken %files entries..
  248. * Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
  249. - new upstream release
  250. * Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.0-10vl1
  251. - build for Vine Linux
  252. * Thu Dec 19 2002 Elliot Lee <sopwith@redhat.com> 0.5.0-10
  253. - Add patch1 to fix C++ plugins on ia64
  254. * Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
  255. - %post -p was wrong
  256. * Tue Dec 17 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-7
  257. - explicitly add %{_libdir}/libgstreamer-{major}.so
  258. - explicitly add %{_libdir}/libgstcontrol-{major}.so
  259. * Mon Dec 16 2002 Jonathan Blandford <jrb@redhat.com>
  260. - bump release
  261. * Fri Dec 13 2002 Jonathan Blandford <jrb@redhat.com>
  262. - move .so files out of -devel
  263. * Tue Dec 10 2002 Jonathan Blandford <jrb@redhat.com>
  264. - new version 0.5.0
  265. - require docbook-style-xsl
  266. - add gstreamer-tools package too
  267. - New patch to use the right docbook prefix.
  268. * Tue Dec 10 2002 Jonathan Blandford <jrb@redhat.com>
  269. - downgrade to a release candidate. Should work better on other arches
  270. - build without Werror
  271. * Mon Dec 9 2002 Jonathan Blandford <jrb@redhat.com>
  272. - update to new version. Remove ExcludeArch
  273. * Tue Dec 3 2002 Havoc Pennington <hp@redhat.com>
  274. - excludearch some arches
  275. * Mon Dec 2 2002 Havoc Pennington <hp@redhat.com>
  276. - import into CVS and build "officially"
  277. - use smp_mflags
  278. - temporarily disable docs build, doesn't seem to work
  279. * Thu Nov 7 2002 Jeremy Katz <katzj@redhat.com>
  280. - 0.4.2
  281. * Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
  282. - 0.4.1
  283. * Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
  284. - minor cleanups
  285. * Sat Jun 22 2002 Thomas Vander Stichele <thomas@apestaart.org>
  286. - moved header location
  287. * Mon Jun 17 2002 Thomas Vander Stichele <thomas@apestaart.org>
  288. - added popt
  289. - removed .la
  290. * Fri Jun 07 2002 Thomas Vander Stichele <thomas@apestaart.org>
  291. - added release of gstreamer to req of gstreamer-devel
  292. - changed location of API docs to be in gtk-doc like other gtk-doc stuff
  293. - reordered SPEC file
  294. * Mon Apr 29 2002 Thomas Vander Stichele <thomas@apestaart.org>
  295. - moved html docs to gtk-doc standard directory
  296. * Tue Mar 5 2002 Thomas Vander Stichele <thomas@apestaart.org>
  297. - move version defines of glib2 and libxml2 to configure.ac
  298. - add BuildRequires for these two libs
  299. * Sun Mar 3 2002 Thomas Vander Stichele <thomas@apestaart.org>
  300. - put html docs in canonical place, avoiding %doc erasure
  301. - added devhelp support, current install of it is hackish
  302. * Sat Mar 2 2002 Christian Schaller <Uraeus@linuxrising.org>
  303. - Added documentation to build
  304. * Mon Feb 11 2002 Thomas Vander Stichele <thomas@apestaart.org>
  305. - added libgstbasicscheduler
  306. - renamed libgst to libgstreamer
  307. * Fri Jan 04 2002 Christian Schaller <Uraeus@linuxrising.org>
  308. - Added configdir parameter as it seems the configdir gets weird otherwise
  309. * Thu Jan 03 2002 Thomas Vander Stichele <thomas@apestaart.org>
  310. - split off gstreamer-editor from core
  311. - removed gstreamer-gnome-apps
  312. * Sat Dec 29 2001 Rodney Dawes <dobey@free.fr>
  313. - Cleaned up the spec file for the gstreamer core/plug-ins split
  314. - Improve spec file
  315. * Sat Dec 15 2001 Christian Schaller <Uraeus@linuxrising.org>
  316. - Split of more plugins from the core and put them into their own modules
  317. - Includes colorspace, xfree and wav
  318. - Improved package Require lines
  319. - Added mp3encode (lame based) to the SPEC
  320. * Wed Dec 12 2001 Christian Schaller <Uraeus@linuxrising.org>
  321. - Thomas merged mpeg plugins into one
  322. * Sat Dec 08 2001 Christian Schaller <Uraeus@linuxrising.org>
  323. - More minor cleanups including some fixed descriptions from Andrew Mitchell
  324. * Fri Dec 07 2001 Christian Schaller <Uraeus@linuxrising.org>
  325. - Added logging to the make statement
  326. * Wed Dec 05 2001 Christian Schaller <Uraeus@linuxrising.org>
  327. - Updated in preparation for 0.3.0 release
  328. * Fri Jun 29 2001 Christian Schaller <Uraeus@linuxrising.org>
  329. - Updated for 0.2.1 release
  330. - Split out the GUI packages into their own RPM
  331. - added new plugins (FLAC, festival, quicktime etc.)
  332. * Sat Jun 09 2001 Christian Schaller <Uraeus@linuxrising.org>
  333. - Visualisation plugins bundled out togheter
  334. - Moved files sections up close to their respective descriptions
  335. * Sat Jun 02 2001 Christian Schaller <Uraeus@linuxrising.org>
  336. - Split the package into separate RPMS,
  337. putting most plugins out by themselves.
  338. * Fri Jun 01 2001 Christian Schaller <Uraeus@linuxrising.org>
  339. - Updated with change suggestions from Dennis Bjorklund
  340. * Tue Jan 09 2001 Erik Walthinsen <omega@cse.ogi.edu>
  341. - updated to build -devel package as well
  342. * Sun Jan 30 2000 Erik Walthinsen <omega@cse.ogi.edu>
  343. - first draft of spec file