gnumeric-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444
  1. %define gnumeric_version %{version}-bonobo
  2. %define goffice_version 0.8.9
  3. Summary: A spreadsheet program for GNOME.
  4. Summary(ja): GNOME スプレッドシート
  5. Name: gnumeric
  6. Version: 1.10.9
  7. Release: 1%{?_dist_release}
  8. License: GPLv2
  9. Group: Applications/Productivity
  10. URL: http://www.gnome.org/projects/gnumeric
  11. Source: ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.8/%{name}-%{version}.tar.bz2
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. Distribution: Vine Linux
  14. Vendor: Project Vine
  15. BuildRequires: gtk2-devel >= 2.10.0
  16. BuildRequires: libglade2-devel >= 2.3.6
  17. BuildRequires: libgnomeprint-devel >= 2.8.2
  18. BuildRequires: libgnomeprintui-devel >= 2.8.2
  19. BuildRequires: libart_lgpl-devel >= 2.3.11
  20. BuildRequires: libxml2-devel >= 2.4.12
  21. BuildRequires: libgsf-devel >= 1.13.2
  22. BuildRequires: goffice-devel >= %{goffice_version}
  23. BuildRequires: libbonobo-devel libgnomeui-devel
  24. BuildRequires: libffi-devel
  25. #BuildPreReq: libgda-devel >= 1.9.100
  26. #BuildPreReq: libgnomedb-devel >= 1.9.100
  27. BuildRequires: perl python-devel
  28. BuildRequires: automake autoconf libtool docbook-utils
  29. BuildRequires: intltool >= 0.28 desktop-file-utils
  30. BuildRequires: libSM-devel
  31. Requires: gtk2 >= 2.10.0
  32. Requires: libglade2 >= 2.3.6
  33. Requires: libgnomeprint >= 2.8.2
  34. Requires: libgnomeprintui >= 2.8.2
  35. Requires: libgsf >= 1.14.6
  36. Requires: perl python
  37. Requires: GConf2 scrollkeeper
  38. # no longer devel package
  39. #Provides: %{name}-devel
  40. Obsoletes: %{name}-devel
  41. %description
  42. GNOME (GNU Network Object Model Environment) is a user-friendly set of
  43. applications and desktop tools to be used in conjunction with a window
  44. manager for the X Window System.
  45. This is the Gnumeric, a spreadsheet for GNOME. It aims to be a drop in
  46. replacement for commercial spreadsheets. It provides import/export from
  47. MS Excel files and many other formats (csv, latex, xbase, applix).
  48. %description -l ja
  49. GNOME (GNU Network Object Model Environment)は
  50. Xウィンドウシステム用の、ウィンドウマネージャと連結した
  51. GUIアプリケーションおよびデスクトップツールのセットです。
  52. これは Gnumeric, GNOMEスプレッドシート・プログラムです。
  53. 商用のスプレッドシート・プログラムを代替できるものを目指しています。
  54. MS Excelファイルや他の多くのフォーマット(csv, latex, xbase, applix)
  55. を読込み、出力できます.
  56. # %package devel
  57. #Summary: Files necessary to develop gnumeric-based applications.
  58. #Group: Development/Libraries
  59. #Requires: %{name} = %{PACKAGE_VERSION}
  60. #%#description devel
  61. #The gnumeric-devel package includes files necessary to develop gnumeric-based
  62. #applications.
  63. #Install gnumeric-devel if you want to develop programs which will use gnumeric.
  64. %prep
  65. %setup -q
  66. %build
  67. %ifarch alpha
  68. MYARCH_FLAGS="--host=alpha-redhat-linux"
  69. %endif
  70. export mllibname=%{_lib}
  71. %configure --with-gnome \
  72. --with-gda --without-gb --with-perl --with-python \
  73. --disable-schemas-install
  74. make
  75. %install
  76. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  77. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  78. make DESTDIR=$RPM_BUILD_ROOT install
  79. unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  80. ./mkinstalldirs $RPM_BUILD_ROOT%{_datadir}/applications
  81. desktop-file-install --vendor gnome --delete-original \
  82. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  83. --add-category Office \
  84. --add-category Application \
  85. --add-category Spreadsheet \
  86. --remove-mime-type="zz-application/zz-winassoc-xls" \
  87. $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
  88. %find_lang %{name}
  89. %find_lang %{name}-functions
  90. cat %{name}-functions.lang >> %{name}.lang
  91. rm -rf $RPM_BUILD_ROOT%{_libdir}/libspreadsheet.la
  92. rm -rf $RPM_BUILD_ROOT%{_libdir}/goffice/%{goffice_version}/plugins/gnumeric/*.la
  93. rm -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
  94. rm -rf $RPM_BUILD_ROOT%{_includedir}/libspreadsheet-1.10
  95. rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
  96. %clean
  97. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  98. %post
  99. /sbin/ldconfig
  100. scrollkeeper-update > /dev/null 2>&1 || :
  101. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  102. gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gnumeric*.schemas > /dev/null
  103. touch --no-create %{_datadir}/icons/hicolor || :
  104. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  105. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  106. fi
  107. %pre
  108. if [ "$1" -gt 1 ]; then
  109. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  110. gconftool-2 --makefile-uninstall-rule \
  111. %{_sysconfdir}/gconf/schemas/gnumeric*.schemas >& /dev/null ||:
  112. fi
  113. %preun
  114. if [ "$1" -eq 0 ]; then
  115. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  116. gconftool-2 --makefile-uninstall-rule \
  117. %{_sysconfdir}/gconf/schemas/gnumeric*.schemas >& /dev/null ||:
  118. fi
  119. %postun
  120. /sbin/ldconfig
  121. scrollkeeper-update > /dev/null 2>&1 || :
  122. touch --no-create %{_datadir}/icons/hicolor || :
  123. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  124. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  125. fi
  126. %files -f %{name}.lang
  127. %defattr (-, root, root)
  128. %doc AUTHORS BUGS *ChangeLog* COPYING HACKING NEWS README
  129. %config %{_sysconfdir}/gconf/schemas/*
  130. %{_bindir}/*
  131. %{_libdir}/lib*.so*
  132. %{_libdir}/gnumeric
  133. %{_libdir}/goffice/%{goffice_version}/plugins/gnumeric/*
  134. #{_libdir}/bonobo/servers/*
  135. %{_datadir}/applications/*.desktop
  136. %{_datadir}/gnome/help/gnumeric
  137. %{_datadir}/gnumeric
  138. %{_datadir}/pixmaps/*
  139. #{_datadir}/mime-info/*
  140. #{_datadir}/mc/templates/*
  141. %{_datadir}/omf/*
  142. %{_datadir}/icons/hicolor/*
  143. %{_mandir}/man*/*
  144. %exclude %{_datadir}/pixmaps/win32-gnumeric.ico
  145. #%{_libexecdir}/gnumeric-component
  146. #%#dir %{_libdir}/gnumeric
  147. #%#dir %{_libdir}/gnumeric/%{bonobover}
  148. #%#dir %{_libdir}/gnumeric/%{bonobover}/plugins
  149. #%#dir %{_libdir}/gnumeric/%{bonobover}/plugins/*
  150. # This is really silly. The .la files are useless for plugins.
  151. #%#{_libdir}/gnumeric/%{bonobover}/plugins/*/*.la
  152. #%#{_libdir}/gnumericConf.sh
  153. #%#if %{bonobo}
  154. #%#dir %{_datadir}/gnumeric
  155. #%#dir %{_datadir}/gnumeric/%{bonobover}
  156. #%#{_datadir}/gnumeric/%{bonobover}/idl
  157. #%#endif
  158. %changelog
  159. * Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.9-1
  160. - new upstream release
  161. - add desktop-file-install option: --remove-mime-type="zz-application/zz-winassoc-xls"
  162. (fix error of MIME type)
  163. * Sun Aug 15 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.8-1
  164. - new upstream release
  165. * Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.7-1
  166. - new upstream release
  167. * Wed Jun 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.6-1
  168. - new upstream release
  169. - fix %post and %postun
  170. * Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
  171. - new upstream release
  172. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-1
  173. - new upstream release
  174. - add BuildRequires: libSM-devel
  175. - fix BuildRequires: goffice-devel >= 0.8.1
  176. * Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-3
  177. - spec in UTF-8 (fixed)
  178. * Sat May 9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-2
  179. - spec in UTF-8
  180. - added BuildRequires: libffi-devel
  181. - added %%pre, %%preun section
  182. * Mon Jun 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-1
  183. - new upstream release
  184. - built with libgda-3.1.4, libgnomedb-3.1.2
  185. - applied new versioning policy
  186. * Mon Mar 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
  187. - new upstream release
  188. * Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.6.3-0vl2
  189. - rebuild
  190. * Fri May 5 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-0vl1
  191. - new upstream release
  192. * Sun Mar 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.2-0vl1
  193. - new upstream release
  194. - updated build dependancies
  195. - rebuilt with libgsf-1.14.0
  196. - built with libgda and libgnomedb again
  197. * Tue Nov 15 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.1-0vl1
  198. - new upstream release
  199. - updated build dependancies
  200. - not compile with libgda and libgnomedb in this version
  201. * Mon Mar 14 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.3-0vl1
  202. - new upstream release
  203. * Fri Feb 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl2
  204. - rebuild with libgda 1.2.0 and libgnome 1.2.0
  205. * Tue Jan 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl1
  206. - new upstream release
  207. * Mon Dec 13 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1-0vl1
  208. - new upstream release
  209. * Thu Dec 2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-0vl1
  210. - new upstream release
  211. * Fri Nov 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl2
  212. - rebuild with gnome-2.8 environment and libgsf-1.10.1
  213. * Tue Jun 29 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl1
  214. - new upstream release
  215. - added BuildRequires: desktop-file-utils
  216. * Thu May 6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-0vl1
  217. - new upstream release
  218. - Requires: libgsf >= 1.9.0, BuildPrereq: libgsf-devel >= 1.9.0
  219. * Wed Apr 21 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-0vl1
  220. - new upstream release
  221. * Wed Apr 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-0vl1
  222. - new upstream release
  223. * Sun Apr 11 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.9-0vl1
  224. - new upstream release
  225. * Thu Mar 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
  226. - new upstream release
  227. * Wed Mar 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.7-0vl1
  228. - new upstream release
  229. - clean up spec file (a little bit!)
  230. * Thu Jan 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl1
  231. - new upstream release
  232. * Fri Jan 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.4-0vl1
  233. - new upstream release
  234. - to use intltool-0.28
  235. * Sun Dec 28 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-0vl1
  236. - new upstream release
  237. - rebuild with new toolchains
  238. * Sun Nov 30 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.2-0vl1
  239. - new upstream release
  240. - build with new libgnomeprint, libgnomeprintui
  241. * Fri Oct 10 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-0vl1
  242. - new upstream release
  243. * Thu Oct 2 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl2
  244. - rebuild with newer libgda, libgnomedb
  245. * Thu Sep 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
  246. - updated to 1.2.0 (stable release)
  247. - guile support is temporarily off this version.
  248. * Mon Sep 9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-1vl1
  249. - update to 1.1.20 (gtk+-2 port)
  250. - based on Redhat Rawhide 1.1.20-1
  251. * Thu May 1 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.13-0vl1
  252. - update to 1.0.13
  253. - rebuild with gal 0.24
  254. * Sun Mar 9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.12-0vl2
  255. - guile support on
  256. - rebuild with new gal, bonobo, libgda
  257. * Fri Feb 7 2003 Masaki Shinomiya <shino@pos.to> 1.0.12-0vl1
  258. - New upstream release, remove xmliobackward.patch
  259. * Mon Dec 16 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl2
  260. - xml-io back to 1.0.10 because japanese corrups with new xml_parser
  261. * Sun Dec 15 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl1
  262. - New upstream release, fix for xml importing files with non ASCII characters.
  263. - Without guile, changelog.archive, requires, build scripts, description
  264. * Mon Nov 19 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl2
  265. - files: add gnumericConf.sh, which was missing
  266. * Mon Nov 4 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl1
  267. - New upstream release.
  268. - BuildPrereq oaf-devel
  269. * Mon Jul 29 2002 Masaki Shinomiya <shino@pos.to> 1.0.9-0vl1
  270. - New upstream release.
  271. * Mon Jul 1 2002 Masaki Shinomiya <shino@pos.to> 1.0.8-0vl1
  272. - New upstream release.
  273. - Default font and Japanese fonts in excel
  274. - requires
  275. * Sun Jun 30 2002 Masaki Shinomiya <shino@pos.to> 1.0.7-0vl1
  276. - New upstream release.
  277. - fixed plugins, apply patch2, remove patch3
  278. - files - no longer devel package
  279. - function-reference.html in help file
  280. * Thu Jan 24 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.3-0vl1
  281. - New upstream release.
  282. * Wed Jan 16 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.2-0vl1
  283. - New upstream release.
  284. - Fixed several owner dir.
  285. * Tue Jan 15 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl2
  286. - Build against with new gal
  287. * Mon Jan 7 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl1
  288. - New upstream release.
  289. * Fri Jan 4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.0-0vl1
  290. - New upstream release.
  291. * Fri Dec 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.1-0vl1
  292. - New upstream release.
  293. - Applied XIM over-the-spot patch.
  294. - Fixed directories owner.
  295. * Wed Dec 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.0-0vl1
  296. - New upstream release.
  297. - Enable Bonobo.
  298. - Merged several RH patches.
  299. - Added BuildPreReq tags.
  300. * Tue Jun 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl3
  301. - Fixed packaging mistake.
  302. * Mon May 14 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl2
  303. - Rebuild for GAL 0.7
  304. * Fri Mar 23 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl1
  305. - New upstream release.
  306. - Use rpmmacros.
  307. * Mon Feb 5 2001 Jun Nishii <jun@vinelinux.org>
  308. - 0.56-0vl2
  309. - update ja.po
  310. - avoid core dump when inserting a row
  311. * Mon Jul 10 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  312. - updated to 0.56
  313. - remake spec with the orginal gnumeric spec file.
  314. - added ms_excel_read and edit_item patch from Japanese gnome users mailing list.
  315. * Tue May 16 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  316. - updated to 0.53
  317. - remake SPEC based on gnumeric original.
  318. - added libxml183 patch for libxml 1.8.3
  319. * Thu Mar 29 2000 Kjartan Maraas <kmaraas@online.no>
  320. - Removed gnome-gnumeric-xl.png since it is nowhere to be found.
  321. - Added --without-bonobo and --without-gb.
  322. - Added %define for sysconfdir
  323. * Mon Feb 29 2000 Jody Goldberg <jgolbderg@home.com>
  324. - Updated version requirements for gnome-print, and gnome-libs.
  325. * Sun Jan 30 2000 Gregory McLean <gregm@comstar.net>
  326. - Added in some auto-detect the language files logic (rpm 3.0.xx only)
  327. * Mon Jan 12 2000 Jody Goldberg <jgolbderg@home.com>
  328. - Add depend on gtk+ >= 1.2.2 so that we can get gtk_object_get.
  329. * Mon Jan 03 2000 Gregory McLean <gregm@comstar.net>
  330. - Updated to 0.47
  331. * Mon Dec 20 1999 Jody Goldberg <jgolbderg@home.com>
  332. - Updated the libglade dependancy.
  333. - Remove req for guile. We can build without it.
  334. * Thu Sep 02 1999 Gregory McLean <gregm@comstar.net>
  335. - Added small fix so glade generated dialogs appear.
  336. * Wed Jul 14 1999 Gregory McLean <gregm@comstar.net>
  337. - Added the gnome-print requirement.
  338. - Updated the file list to try and quiet down the updating.
  339. - added the sysconfdir
  340. * Tue Mar 9 1999 Gregory McLean <gregm@comstar.net>
  341. - Updated the spec file.
  342. * Thu Sep 24 1998 Michael Fulbright <msf@redhat.com>
  343. - Version 0.2