cmake-vl.spec 4.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180
  1. # Set to bcond_with or use --without gui to disable qt4 gui build
  2. %bcond_without gui
  3. Name: cmake
  4. Summary: Cross-platform make system
  5. Summary(ja): クロスプラットフォームな Make システム
  6. Version: 2.8.2
  7. Release: 4%{?_dist_release}
  8. Group: Development/Tools
  9. License: BSD
  10. URL: http://www.cmake.org/
  11. Source0: http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
  12. Source1: macros.cmake
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: curl-devel
  15. BuildRequires: expat-devel
  16. BuildRequires: ncurses-devel
  17. BuildRequires: zlib-devel
  18. %if %{with gui}
  19. BuildRequires: qt4-devel, desktop-file-utils
  20. %define qt_gui --qt-gui
  21. %else
  22. %define qt_gui --no-qt-gui
  23. %endif
  24. Vendor: Project Vine
  25. Distribution: Vine Linux
  26. %description
  27. CMake is used to control the software compilation process using simple
  28. platform and compiler independent configuration files. CMake generates
  29. native makefiles and workspaces that can be used in the compiler
  30. environment of your choice. CMake is quite sophisticated: it is possible
  31. to support complex environments requiring system configuration, pre-processor
  32. generation, code generation, and template instantiation.
  33. %package gui
  34. Summary: Qt GUI for %{name}
  35. Group: Development/Tools
  36. Requires: %{name} = %{version}-%{release}
  37. Requires(post): desktop-file-utils, shared-mime-info
  38. Requires(postun): desktop-file-utils, shared-mime-info
  39. %description gui
  40. The %{name}-gui package contains the Qt based GUI for CMake.
  41. %prep
  42. %setup -q
  43. # Fixup permissions
  44. find -name \*.h -o -name \*.cxx -print0 | xargs -0 chmod -x
  45. %build
  46. ./bootstrap \
  47. --prefix=%{_prefix} \
  48. --datadir=/share/%{name} \
  49. --mandir=/share/man \
  50. --system-libs \
  51. %{?qt_gui}
  52. make VERBOSE=1 %{?_smp_mflags}
  53. %install
  54. rm -rf $RPM_BUILD_ROOT
  55. make install DESTDIR=$RPM_BUILD_ROOT
  56. find $RPM_BUILD_ROOT/%{_datadir}/%{name}/Modules -type f | xargs chmod -x
  57. rm -rf $RPM_BUILD_ROOT/usr/doc
  58. # RPM macros
  59. install -p -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
  60. sed -i -e "s|@@CMAKE_VERSION@@|%{version}|" $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
  61. touch -r %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
  62. %if %{with gui}
  63. # Desktop file
  64. desktop-file-install --delete-original \
  65. --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
  66. $RPM_BUILD_ROOT/%{_datadir}/applications/CMake.desktop
  67. %endif
  68. %clean
  69. rm -rf $RPM_BUILD_ROOT
  70. %if %{with gui}
  71. %post gui
  72. update-desktop-database &> /dev/null || :
  73. update-mime-database %{_datadir}/mime &> /dev/null || :
  74. %postun gui
  75. update-desktop-database &> /dev/null || :
  76. update-mime-database %{_datadir}/mime &> /dev/null || :
  77. %endif
  78. %files
  79. %defattr(-,root,root)
  80. %doc CMakeLogo.gif ChangeLog.* Copyright.txt
  81. %doc Docs/*
  82. %doc Example/
  83. %config(noreplace) %{_sysconfdir}/rpm/macros.cmake
  84. %{_bindir}/ccmake
  85. %{_bindir}/cmake
  86. %{_bindir}/cpack
  87. %{_bindir}/ctest
  88. %{_datadir}/%{name}/
  89. %{_mandir}/man1/*
  90. %if %{with gui}
  91. %files gui
  92. %defattr(-,root,root,-)
  93. %{_bindir}/cmake-gui
  94. %{_datadir}/applications/CMake.desktop
  95. %{_datadir}/mime/packages/cmakecache.xml
  96. %{_datadir}/pixmaps/CMakeSetup32.png
  97. %endif
  98. %changelog
  99. * Sun Sep 5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-4
  100. - fixed typo (not --with-system-libs, but --system-libs)
  101. - added BR: curl-devel, expat-devel, zlib-devel
  102. * Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-3
  103. - add BuildRequires: ncurses-devel
  104. * Sun Aug 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-2
  105. - generate gui package
  106. - renamed module directory
  107. * Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-1
  108. - new upstream release
  109. * Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-3
  110. - rebuilt with new toolchain
  111. * Sun Aug 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.4-2
  112. - imported RPM macros from Fedora (cmake-2.6.4-3.fc12)
  113. * Tue Aug 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.4-1
  114. - new upstream release
  115. - added Vendor/Distribution tag
  116. * Wed Mar 25 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.3-1
  117. - new upstream release
  118. * Tue Oct 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.2-1
  119. - new upstream release
  120. * Sat Mar 29 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.8-1
  121. - new upstream release
  122. * Wed Aug 15 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.7-0vl1
  123. - new upstream release
  124. * Mon May 14 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.6-0vl1
  125. - new upstream release
  126. - drop Patch100
  127. - use bootstrap script instead of configure
  128. - delete caches from %%doc
  129. * Sat May 12 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.3-0vl2
  130. - rebuilt with new toolchain
  131. * Tue Oct 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.3-0vl1
  132. - new upstream release
  133. - delete duped docs
  134. * Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl2
  135. - added Patch100 (especially for ppc to solve ppc/powerpc issue)
  136. * Mon Feb 06 2006 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.2.3-0vl1
  137. - source version up
  138. * Sun Mar 20 2005 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.0.5-0vl1
  139. - initial build for Vine Linux