chromium-vl.spec 21 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573
  1. # Thanks to malcolmlewis for help with this script
  2. # Thanks to Tom "spot" Callaway for much of the patchwork
  3. # Thanks to jhaygood for most of the icu patch
  4. # norootforbuild
  5. %if %{?_dist_release} == "vl6"
  6. %define with_system_icu 1
  7. %endif
  8. %define svn_rev 58225
  9. Name: chromium
  10. Summary: Google's opens source browser project
  11. Summary(ja): Googleのオープンソースウェブブラウザ
  12. #'
  13. Version: 7.0.513.0
  14. Release: 1%{?_dist_release}
  15. License: BSD
  16. Group: Applications/Internet
  17. Source0: %{name}.%{version}.svn%{svn_rev}.tar.lzma
  18. ## The following are included for source reasons only
  19. # Custom build tools for chromium, hammer is a fancy front-end for scons
  20. Source1: http://src.chromium.org/svn/trunk/tools/depot_tools.tar.gz
  21. # Script used to create the tar.lzma archive from the daily tarball downloadable at http://build.chromium.org/buildbot/archives/
  22. Source2: repack_chromium_archive.sh
  23. # Script used to create the tar.lzma archive from a checked out source
  24. Source3: pack_chromium_source.sh
  25. #Source10: chromium.desktop
  26. Source10: chromium-vine.desktop
  27. # Patch template which adds vendor to user agent
  28. ##!!Source20: chromium-vendor.patch.in
  29. Source20: chromium-vendor-vine.patch.in
  30. ##!!Source30: master_preferences
  31. Source30: master_preferences.vine
  32. #Source31: default_bookmarks.html
  33. #Source31: default_bookmarks.html.vine
  34. # icu-4.2.1 contained in chromium.5.0.353.0.svn41449 (for Vine Linux 5.X)
  35. Source100: icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2
  36. %{?nosrc:NoSource: 0}
  37. %{?nosrc:NoSource: 1}
  38. %{?nosrc:NoSource: 100}
  39. Provides: chromium-browser = %{version}
  40. #Obsoletes: chromium-browser < %{version}
  41. ## Start Patches
  42. # Many changes to the gyp system so we can use system libraries
  43. # My first ever patch set. I hope I did well.
  44. Patch3: chromium-gyp-system-icu.patch
  45. Patch4: chromium-no-sqlite-debug.patch
  46. Patch5: chromium-gyp-system-04-nss-nspr.patch
  47. Patch7: chromium-codechanges-nss-nspr.patch
  48. Patch8: chromium-codechanges-zlib.patch
  49. #Patch9: chromium-drop-sse.patch
  50. Patch10: chromium-fix-wrapper.patch
  51. Patch12: chromium-no-test-sources.patch
  52. Patch13: chromium-no-courgette.patch
  53. Patch14: chromium-master-prefs-path.patch
  54. #Patch15: chromium-media-probe.patch
  55. Patch17: chromium-system-glew.patch
  56. Patch18: chromium-system-expat.patch
  57. Patch19: chromium-system-zlib.patch
  58. Patch20: chromium-noffmpeg.patch
  59. Patch21: chromium-system-old-ffmpeg-way.patch
  60. Patch23: chromium-disable-mmx.patch
  61. #Patch24: chromium-fix-yuv_row_posix-shared.patch
  62. Patch25: tcmalloc-factory.patch
  63. # Vine
  64. BuildRequires: gcc gcc-c++
  65. %if %{?_dist_release} == "vl5"
  66. BuildRequires: libstdc++34 libstdc++34-devel
  67. %elseif %{?_dist_release} == "vl6"
  68. BuildRequires: libstdc++ libstdc++-devel
  69. %endif
  70. BuildRequires: libevent
  71. ##!!BuildRequires: pkg-config
  72. BuildRequires: python
  73. ##!!BuildRequires: python-xml
  74. BuildRequires: python-pyxml
  75. BuildRequires: perl bison flex gperf
  76. ##!!BuildRequires: wdiff
  77. ##!!BuildRequires: update-desktop-files
  78. BuildRequires: desktop-file-utils
  79. BuildRequires: lzma
  80. ##!!BuildRequires: mozilla-nss-devel
  81. BuildRequires: nss-devel
  82. ##!!BuildRequires: alsa-devel
  83. BuildRequires: alsa-lib-devel
  84. BuildRequires: gtk2-devel
  85. BuildRequires: glib2-devel
  86. BuildRequires: cairo-devel >= 1.6
  87. ##!!BuildRequires: mozilla-nspr-devel
  88. BuildRequires: nspr-devel
  89. ##!!BuildRequires: gconf2-devel
  90. BuildRequires: GConf2-devel
  91. BuildRequires: freetype2-devel
  92. ##!!BuildRequires: dbus-1-devel
  93. BuildRequires: dbus-devel
  94. BuildRequires: libxslt-devel
  95. BuildRequires: libxml2-devel
  96. BuildRequires: libjpeg-devel
  97. BuildRequires: zlib-devel
  98. ##!!BuildRequires: libbz2-devel
  99. BuildRequires: bzip2-devel
  100. BuildRequires: cups-devel
  101. %if %{?_dist_release} == "vl6"
  102. BuildRequires: fdupes
  103. %endif
  104. ##!!BuildRequires: libexpat-devel
  105. BuildRequires: expat-devel
  106. BuildRequires: libpng-devel
  107. BuildRequires: sqlite3-devel
  108. BuildRequires: gnutls-devel
  109. %if %{?_dist_release} == "vl5"
  110. BuildRequires: gnome-keyring-devel
  111. %elseif %{?_dist_release} == "vl6"
  112. BuildRequires: libgnome-keyring-devel
  113. %endif
  114. BuildRequires: glew-devel
  115. ##!!BuildRequires: Mesa-devel
  116. BuildRequires: mesa-libGLU-devel
  117. %{?with_system_icu:BuildRequires: libicu-devel >= 4.0}
  118. BuildRequires: libevent-devel
  119. ##Vine Linux
  120. BuildRequires: libXScrnSaver-devel
  121. #BuildRequires: gle-devel
  122. #BuildRequires: webkit-gtk-devel
  123. #BuildRequires: scons
  124. %ifarch x86_64
  125. Requires: nspluginwrapper
  126. %endif
  127. ##!!Requires: alsa
  128. Requires: alsa-lib
  129. # shouldn't be required to name all dependencies
  130. # Requires: mozilla-nss mozilla-nspr gtk2 glib2 cairo >= 1.6 freetype2 dbus-1 alsa v8 >= 1.3.15
  131. ## Recommends the ffmpeg libraries (available from packman)
  132. #Recommends: libavcodec52 libavformat52 libavutil50
  133. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  134. %description
  135. Chromium is the open-source project behind Google Chrome.
  136. We invite you to join us in our effort to help build a safer, faster,
  137. and more stable way for all Internet users to experience the web,
  138. and to create a powerful platform for developing a new generation of
  139. web applications.
  140. %description -l ja
  141. Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
  142. 私たちは、ウェブを体験しているすべてのインターネットユーザに対して
  143. より安全で、より速くて、より安定した方法を築き上げるのを助けるために、
  144. ウェブアプリケーションの新しい世代を発展させるように
  145. 強力なプラットホームを作成するために、
  146. 私たちの取り組みで私たちに加わるようにあなたを誘います。
  147. %prep
  148. [ -d %{name} ] && %__rm -rf %{name}
  149. lzma -cd %{SOURCE0} | tar xf -
  150. %setup -D -T -n %{name}
  151. # use static libicu
  152. %if %{?_dist_release} == "vl5"
  153. cd src/third_party || exit 1
  154. %__rm -rf icu || exit 1
  155. tar jxvf %{SOURCE100} || exit 1
  156. %__mv icu-4.2.1-chromium.5.0.353.0.svn41449 icu || exit 1
  157. cd - || exit 1
  158. %endif
  159. # use system libicu only if >= 4.0
  160. %{?with_system_icu:%patch3 -p1}
  161. %patch4 -p1
  162. %patch5 -p1
  163. %patch7 -p1
  164. %patch8 -p1
  165. #%patch9 -p1
  166. %patch10 -p1
  167. %patch12 -p1
  168. %patch13 -p1
  169. %patch14 -p1
  170. #%patch15 -p0
  171. %patch17 -p1
  172. %patch18 -p1
  173. %patch19 -p1
  174. %patch20 -p1
  175. %patch21 -p1
  176. %patch25 -p1
  177. %ifarch %ix86
  178. %patch23 -p1
  179. %endif
  180. #%patch24 -p1
  181. # apply vendor patch after substitution
  182. %__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
  183. %build
  184. ## create make files
  185. PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-ipa-cp -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
  186. for i in src/build/common.gypi; do
  187. %__sed -i "s|'-march=pentium4',||g" $i
  188. %__sed -i "s|'-msse2',||g" $i
  189. %__sed -i "s|'-mfpmath=sse',||g" $i
  190. %__sed -i "s|'-O<(debug_optimize)',||g" $i
  191. %__sed -i "s|'-m32',||g" $i
  192. %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
  193. %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
  194. done
  195. # '
  196. pushd src
  197. ./build/gyp_chromium -f make build/all.gyp \
  198. -Duse_system_ffmpeg=1 \
  199. -Duse_system_zlib=1 \
  200. -Duse_system_libpng=1 \
  201. -Duse_system_bzip2=1 \
  202. -Duse_system_libbz2=1 \
  203. -Duse_system_libjpeg=1 \
  204. -Duse_system_libxml=1 \
  205. -Duse_system_libxslt=1 \
  206. -Duse_system_libevent=1 \
  207. -Dproprietary_codecs=1 \
  208. -Dlinux_fpic=1 \
  209. %{?with_system_icu:-Duse_system_icu=1} \
  210. %{!?with_system_icu:-Duse_system_icu=0} \
  211. %ifarch %{ix86}
  212. -Dtarget_arch=ia32 \
  213. -Ddisable_sse2=1 \
  214. %endif
  215. %ifarch x86_64
  216. -Dtarget_arch=x64 \
  217. %endif
  218. %if %{?_dist_release} == "vl6"
  219. -Dno_strict_aliasing=1 -Dgcc_version=44 \
  220. %endif
  221. -Drelease_extra_cflags=-fPIC \
  222. ;
  223. #make -r %{?jobs:-j%jobs} chrome BUILDTYPE=Release
  224. #%__make -r -j5 chrome BUILDTYPE=Release
  225. %__make %{?_smp_mflags} chrome BUILDTYPE=Release
  226. popd
  227. %install
  228. %{__rm} -rf %{buildroot}
  229. ## Create install directories
  230. %{__mkdir_p} %{buildroot}%{_libdir}/%{name}
  231. %{__mkdir_p} %{buildroot}%{_bindir}
  232. %{__mkdir_p} %{buildroot}%{_datadir}/applications
  233. %{__mkdir_p} %{buildroot}%{_datadir}/pixmaps
  234. %{__mkdir_p} %{buildroot}%{_mandir}/man1
  235. %{__mkdir_p} %{buildroot}%{_sysconfdir}/%{name}
  236. # chromium 'make' deposits us back at the top level build directory
  237. pushd src/out/Release
  238. ls -l
  239. # clean somechromium-codechanges-zlib.patch
  240. # clean debug junk
  241. %{__rm} -rf obj/ mksnapshot obj.target obj.host
  242. find ./ -type f -name '*.d' | while read i; do %__rm -f $i; done
  243. # clean NaCl stuff... maybe NaCl will be in its own package in the future.
  244. %{__rm} -f ncdecode_table ncdecode_tablegen
  245. # clean other temporary binaries used in the compilation of chromium
  246. %{__rm} -f protoc xdg-settings
  247. %{__cp} -rf * %{buildroot}%{_libdir}/%{name}/
  248. # Man page
  249. [ ! -f %{name}.1 ] && %{__mv} chrome.1 %{name}.1
  250. %__install -m 0644 %{name}.1 %{buildroot}%{_mandir}/man1
  251. # Add startup file with plugins enabled
  252. %{__cat} > %{buildroot}%{_bindir}/%{name} <<EOF
  253. #!/bin/bash
  254. %{_libdir}/%{name}/chrome-wrapper --enable-plugins --enable-user-scripts --enable-extensions --enable-sync --enable-geolocation --enable-webgl --enable-nacl "\$@"
  255. EOF
  256. # # link to browser plugin path. Plugin patch doesn't work. Why?
  257. # %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
  258. # pushd %{buildroot}%{_libdir}/%{name}
  259. # %{__ln_s} %{_libdir}/browser-plugins plugins
  260. # popd
  261. pushd %{buildroot}%{_libdir}/%{name}
  262. %ifarch x86_64
  263. %{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
  264. %else
  265. %{__ln_s} %{_libdir}/mozilla/plugins plugins
  266. %endif
  267. ## support ffmpeg libs
  268. touch %{buildroot}%{_libdir}/libavcodec.so.52
  269. %{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
  270. touch %{buildroot}%{_libdir}/libavformat.so.52
  271. %{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
  272. touch %{buildroot}%{_libdir}/libavutil.so.50
  273. %{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
  274. popd
  275. # Install desktop-related files
  276. %__install -m 0644 %{SOURCE10} %{buildroot}%{_datadir}/applications/%{name}.desktop
  277. %__install -m 0644 product_logo_48.png %{buildroot}%{_datadir}/pixmaps/%{name}.png
  278. desktop-file-install --vendor Vine \
  279. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  280. --delete-original \
  281. --mode 644 \
  282. $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
  283. # Install the master_preferences file
  284. #%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}
  285. %__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}/$(basename %{SOURCE30} .vine)
  286. ## install o3d plugin
  287. #pushd src/o3d/build/out/Release
  288. #%{__cp} -rf * %{buildroot}%{_libdir}/browser-plugins
  289. %clean
  290. %{__rm} -rf %{buildroot}
  291. %files
  292. %defattr(-,root,root)
  293. %doc src/AUTHORS src/LICENSE
  294. %dir %{_libdir}/%{name}
  295. %attr(0755,root,root) %{_bindir}/%{name}
  296. %{_mandir}/man1/*
  297. %{_datadir}/applications/*%{name}.desktop
  298. %{_datadir}/pixmaps/%{name}.png
  299. %{_libdir}/%{name}/*
  300. %config %{_sysconfdir}/%{name}
  301. #%{_libdir}/browser-plugins/*
  302. %exclude %{_libdir}/libavcodec.so.52
  303. %exclude %{_libdir}/libavutil.so.50
  304. %exclude %{_libdir}/libavformat.so.52
  305. %changelog
  306. * Fri Sep 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.513.0-1
  307. - updated to snapshot 7.0.513
  308. - updated chromium-vendor-vine.patch.in
  309. * Sat Aug 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.507.0-1
  310. - updated to snapshot 7.0.507
  311. * Wed Aug 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.498.0-1
  312. - updated to snapshot 7.0.498
  313. * Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.493.0-1
  314. - updated to snapshot 6.0.493
  315. - used with_system_icu (for vl6)
  316. - added BuildRequires: libicu-devel
  317. * Thu Jul 22 2010 IWAI, Masaharu <iwai@alib.jp> 6.0.454.0-2vl5
  318. - build for Vine Linux 5.x
  319. - add BuildRequires: gnome-keyring-devel
  320. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
  321. - updated to snapshot 6.0.454
  322. - added BuildRequires:
  323. - sqlite3-devel
  324. - gnutls-devel
  325. - libgnome-keyring-devel
  326. * Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
  327. - updated to snapshot 6.0.431.0 r49253
  328. - added BuildRequires: cups-devel
  329. * Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
  330. - updated to snapshot 6.0.405.0 r47263
  331. * Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
  332. - unused with_system_icu (for vl6)
  333. - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
  334. * Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
  335. - updated to snapshot 5.0.378.0 r44472
  336. - used with_system_icu (for vl6)
  337. - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
  338. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
  339. - updated to snapshot 5.0.372.0 r43947
  340. - added BuildRequires: glew-devel
  341. - changed Group tag to Applications/Internet
  342. - added Summary(ja) and %%description -l ja
  343. * Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
  344. - updated to snapshot 5.0.365.0 r42966
  345. - merged 5.0.353.0-4vl5
  346. * Fri Apr 2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
  347. - build on Vine Linux 5.1
  348. - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
  349. * Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
  350. - updated to snapshot 5.0.364.0 r42779
  351. * Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
  352. - updated to snapshot 5.0.359.0 r42116
  353. - dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
  354. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
  355. - fixed master_preferences.vine, little
  356. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
  357. - fixed to install master_preferences
  358. - dropped chromium-5.0.353-no-ffmpeg-vine.patch
  359. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
  360. - applied chromium-5.0.353-no-ffmpeg-vine.patch
  361. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
  362. - updated to snapshot 5.0.353.0 r41449
  363. * Wed Mar 10 2010 bgmerrell@novell.com
  364. - Add master_preferences source file and install it to /etc/chromium.
  365. - Create a new patch (chromium-master-prefs-path.patch) which tells
  366. chromium to look in /etc/chromium for the master_preferences file
  367. (instead of looking in the default directory, which is the same
  368. directory as the 'chrome' binary).
  369. * Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
  370. - updated to snapshot 5.0.335.0 r39556
  371. * Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
  372. - applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
  373. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
  374. - updated to snapshot 5.0.330.0 r39074
  375. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
  376. - use_system_ffmpeg
  377. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
  378. - added Requires: nspluginwrapper
  379. - fixed a symbolic link of plugins directory with nspluginwrapper
  380. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
  381. - replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
  382. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
  383. - added BuildRequires: mesa-libGLU-devel
  384. - added BuildRequires: libstdc++34 libstdc++34-devel for vl5
  385. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
  386. - built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
  387. * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
  388. - Update to 4.0.260
  389. * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
  390. - Update to 4.0.259
  391. * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
  392. - Update to 4.0.258
  393. * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
  394. - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
  395. changed to having an built-in v8
  396. * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
  397. - Re-base patches. Fixed a few patch errors. Rename some patches to better correspond with function. Removed some patches.
  398. - Minor SPEC changes. I changed the v8 requirement to be exact, instead of greater than a specific version.
  399. * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
  400. - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
  401. * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
  402. - update to newer svn snapshot
  403. + Obsoletes fwrite patch (included upstream)
  404. * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
  405. - update to newer svn snapshot
  406. + Requires newer version of v8
  407. * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
  408. - do not force SSE on x86 (drop-sse.patch)
  409. * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
  410. - Update to newer svn snapshot
  411. - Fixed spec file in order to build
  412. - Included patch to build with system zlib
  413. * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
  414. - package renamed to chromium
  415. - cleaned up spec file
  416. * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
  417. - v8 is now built as a separate package, and is required
  418. - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
  419. * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
  420. - included a newer DEP than is in svn, native_client@823. So things should compile cleanly now
  421. * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
  422. - initial build
  423. #% changelog
  424. * Sun Jan 24 2010 prusnak@suse.cz
  425. - added vendor to user agent (chromium-vendor.patch.in)
  426. * Sun Nov 29 2009 prusnak@suse.cz
  427. - added --enable-sync to wrapper to enable bookmark sync
  428. * Fri Nov 13 2009 tittiatcoke@gmail.com
  429. - update to 247.0 svn 31928
  430. * Fri Oct 30 2009 tittiatcoke@gmail.com
  431. - update to 229.0 svn 30454
  432. + Fix regression where popups and app frames lost their titlebars.
  433. + Makes it so that when a folder is open on the bookmark bar
  434. and the mouse moves over another folder, the menu for that
  435. folder is shown.
  436. + Lazily create the find bar.
  437. + Polish to the gmail checker sample.
  438. * New, crisper icons that are exactly 19x19
  439. * Add a loading animation at the beginning before Gmail
  440. responds.
  441. * Fix a bug where we sometimes don't update the UI after a
  442. logout/login cycle.
  443. + Refactor widget methods to support desktop notifications,
  444. including GTK stubs.
  445. + Find-in-page should not ding while deleting characters.
  446. + Add SSL wrapper for linux and mac. This allows notifier to
  447. use chrome's SSL layer instead of OpenSSL.
  448. + Add three of the six extensions to PAC that Internet Explorer supports.
  449. + WebSocket support in chromium. (Run with --enable-web-sockets
  450. enables WebSocket features.)
  451. + Do not allow GTK File Chooser dialogs to return directories.
  452. + Fix the notifier SSL layer to make notifications work for
  453. Linux Bookmark sync.
  454. + linux: don't override mouse selection behavior in omnibox
  455. * Sun Oct 25 2009 tittiatcoke@gmail.com
  456. - Update to 224.4 svn 30027
  457. + First cut at new page and browser action docs based
  458. on new API. Deleted old stuff.
  459. + Add suppression for new memory leak caused by WebKit merge 49830:49844
  460. + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
  461. + Minimize dependency of user scripts
  462. + Fixup the flip_framer eof-handling semantics now that we have
  463. the FIN bit in place
  464. + app depends on x11 because of active_window_watcher_x
  465. + Adding two images for the new Extension managment UI
  466. + Removing hard-coded Chrome Frame output path
  467. + Rearrange clipboard code
  468. + Fix crash bug when attempting to download a url with unsupported scheme,
  469. e.g. 'data:', by 'Alt + Click'
  470. + GTK: Change text for extension download UI
  471. + Ignore invalid urls on command line
  472. + Make dropped tabs animate from where they were dropped.
  473. + Make room for the full width of the tab placeholder.
  474. + Make tab dragging as smooth as glass.
  475. + Remove an annoying NOTIMPLEMNETED
  476. + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
  477. + If we're in the middle of a drag, don't allow the user to middle
  478. click to close or right click for the context menu
  479. + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
  480. + Remove +x bit from files that shouldn't have it
  481. + Fold first 3 channels of multichannel instead of 5. Use fixed point
  482. + Adding new image needed for the managment UI
  483. + Fix a race bug where content scripts would not apply to the first page load
  484. + Make escape remove a bookmark if it's just been added (but not if it already existed)
  485. + Fix bubbles deactivating the opaque frame
  486. + Allow ESC to cancel ALT+SHIFT+T in Toolbar
  487. + ake all pepper plugins default to windowless and transparent
  488. + Add styles for printing
  489. + Implement the new extension management UI
  490. + Add support for to automation interface load install and load extensions
  491. + GTK: theme the info bar border
  492. + Update V8 to version 1.3.16.1
  493. + Introduce WebSecurityPolicy for security related methods
  494. + New button scheme...borders are separate from the inner contents so
  495. that they can be highlighted / depressed independently
  496. + When opening Chrome maximized with an application window already
  497. running, the Chrome window was not activated
  498. + Fix compatibility problems with FileZilla FTP Server
  499. + Remove the extension shelf on Linux
  500. + Fix the proxy host and port string to start with http:// if it does not already
  501. + Enable HTML5 databases for all extension renderer processes