libboost-vl.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549
  1. %define major 1
  2. %define minor 42
  3. %define teeny 0
  4. %define tarname boost
  5. %define lnkver %{major}_%{minor}
  6. %define ver %{major}_%{minor}_%{teeny}
  7. Summary: Portable C++ source libraries
  8. Summary(ja): ポータブルな C++ ソースライブラリ
  9. Name: libboost
  10. Version: %{major}.%{minor}.%{teeny}
  11. Release: 4%{?_dist_release}
  12. Source0: http://downloads.sourceforge.net/%{tarname}/%{tarname}_%{ver}.tar.bz2
  13. Source1: user-config.jam
  14. License: distributable
  15. Group: System Environment/Libraries
  16. URL: http://www.boost.org/
  17. BuildRequires: python-devel apache2-devel bzip2-devel zlib-devel libicu-devel
  18. BuildRequires: libaio-devel lam
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  20. Vendor: Project Vine
  21. Distribution: Vine Linux
  22. Obsoletes: %{name}-date-time-devel %{name}-filesystem-devel %{name}-graph-devel
  23. Obsoletes: %{name}-iostreams-devel %{name}-program-options-devel
  24. Obsoletes: %{name}-python-devel %{name}-regex-devel
  25. Obsoletes: %{name}-serialization-devel %{name}-signals-devel %{name}-test-devel
  26. Obsoletes: %{name}-thread-devel %{name}-wave-devel
  27. %description
  28. Boost provides free peer-reviewed portable C++ source libraries. The emphasis
  29. is on libraries which work well with the C++ Standard Library. The libraries
  30. are intended to be widely useful, and are in regular use by thousands of
  31. programmers across a broad spectrum of applications.
  32. A further goal is to establish "existing practice" and provide reference
  33. implementations so that Boost libraries are suitable for eventual
  34. standardization. Ten Boost libraries will be included in the C++ Standards
  35. Committee's upcoming C++ Standard Library Technical Report as a step toward
  36. becoming part of a future C++ Standard.
  37. %description -l ja
  38. Boost は公開レビューされたフリーのC++ライブラリ群です。 C++ の標準ライブラリに
  39. 準拠することに重点を置いて開発されています。使いやすく、広い分野のアプリ
  40. ケーションにおいて日常的に多くの開発者に用いられることを目指しています。
  41. さらなる目標は、最終的な標準化に適合した「存在する実例」としてリファレンス実装
  42. を提供することです。10 の Boost ライブラリが、将来の C++ 標準になるための一歩
  43. として、C++ 標準化委員会が策定中の C++ 標準ライブラリテクニカルレポートに
  44. 含まれる予定です。
  45. %package devel
  46. Summary: Header files and libraries for developing apps which will use %{name}
  47. Summary(ja): %{name}の開発に必要なヘッダファイル及びライブラリ
  48. Group: Development/Libraries
  49. Requires: %{name} = %{version}-%{release}
  50. %description devel
  51. The %{name}-devel package contains the header files and libraries needed
  52. to develop programs that use the Boost library.
  53. %description devel -l ja
  54. %{name}-devel パッケージは Boost ライブラリを使うプログラムの開発に必要な
  55. ヘッダファイルやライブラリを含んでいます。
  56. %package doc
  57. Summary: Documents of %{name}
  58. Summary(ja): %{name}のドキュメント
  59. Group: Applications/Documentation
  60. Requires: %{name} = %{version}-%{release}
  61. %description doc
  62. The %{name}-doc package contains the documents about the boost library.
  63. %description doc -l ja
  64. %{name}-doc パッケージは Boost ライブラリについてのドキュメントを含んでいます。
  65. %package date-time
  66. Summary: Set of data-time libralies in %{name}
  67. Group: System Environment/Libraries
  68. Requires: %{name} = %{version}-%{release}
  69. %description date-time
  70. Set of data-time libralies in %{name}
  71. #%package date-time-devel
  72. #Summary: Static libraries for developing apps which will use %{name}-date-time
  73. #Group: Development/Libraries
  74. #Requires: %{name}-devel = %{version}-%{release}
  75. #Requires: %{name}-date-time = %{version}-%{release}
  76. #
  77. #%description date-time-devel
  78. #Static libraries for developing apps which will use %{name}-date-time
  79. %package filesystem
  80. Summary: Set of filesystem operation libralies in %{name}
  81. Group: System Environment/Libraries
  82. Requires: %{name} = %{version}-%{release}
  83. %description filesystem
  84. Set of filesystem operation libralies in %{name}
  85. #%package filesystem-devel
  86. #Summary: Static libraries for developing apps which will use %{name}-filesystem
  87. #Group: Development/Libraries
  88. #Requires: %{name}-devel = %{version}-%{release}
  89. #Requires: %{name}-filesystem = %{version}-%{release}
  90. #
  91. #%description filesystem-devel
  92. #Static libraries for developing apps which will use %{name}-filesystem
  93. %package graph
  94. Summary: Set of Graphviz libralies in %{name}
  95. Group: System Environment/Libraries
  96. Requires: %{name} = %{version}-%{release}
  97. %description graph
  98. Set of Graphviz libralies in %{name}
  99. #%package graph-devel
  100. #Summary: Static libraries for developing apps which will use %{name}-graph
  101. #Group: Development/Libraries
  102. #Requires: %{name}-devel = %{version}-%{release}
  103. #Requires: %{name}-graph = %{version}-%{release}
  104. #
  105. #%description graph-devel
  106. #Static libraries for developing apps which will use %{name}-graph
  107. %package iostreams
  108. Summary: Set of streams and i/o filters libralies in %{name}
  109. Group: System Environment/Libraries
  110. Requires: %{name} = %{version}-%{release}
  111. %description iostreams
  112. Set of streams and i/o filters libralies in %{name}
  113. #%package iostreams-devel
  114. #Summary: Static libraries for developing apps which will use %{name}-iostreams
  115. #Group: Development/Libraries
  116. #Requires: %{name}-devel = %{version}-%{release}
  117. #Requires: %{name}-iostreams = %{version}-%{release}
  118. #
  119. #%description iostreams-devel
  120. #Static libraries for developing apps which will use %{name}-iostreams
  121. %package math
  122. Summary: Set of math libralies in %{name}
  123. Group: System Environment/Libraries
  124. Requires: %{name} = %{version}-%{release}
  125. %description math
  126. Set of math libralies in %{name}
  127. %package program-options
  128. Summary: Set of program options libralies in %{name}
  129. Group: System Environment/Libraries
  130. Requires: %{name} = %{version}-%{release}
  131. %description program-options
  132. Set of program options libralies in %{name}
  133. #%package program-options-devel
  134. #Summary: Static libraries for developing apps which will use %{name}-program-options
  135. #Group: Development/Libraries
  136. #Requires: %{name}-devel = %{version}-%{release}
  137. #Requires: %{name}-program-options = %{version}-%{release}
  138. #
  139. #%description program-options-devel
  140. #Static libraries for developing apps which will use %{name}-program-options
  141. %package python
  142. Summary: Set of Python libralies in %{name}
  143. Group: System Environment/Libraries
  144. Requires: %{name} = %{version}-%{release}
  145. %description python
  146. Set of Python libralies in %{name}
  147. #%package python-devel
  148. #Summary: Static libraries for developing apps which will use %{name}-python
  149. #Group: Development/Libraries
  150. #Requires: %{name}-devel = %{version}-%{release}
  151. #Requires: %{name}-python = %{version}-%{release}
  152. #
  153. #%description python-devel
  154. #Static libraries for developing apps which will use %{name}-python
  155. %package regex
  156. Summary: Set of regular expression libralies in %{name}
  157. Group: System Environment/Libraries
  158. Requires: %{name} = %{version}-%{release}
  159. %description regex
  160. Set of regular expression libralies in %{name}
  161. #%package regex-devel
  162. #Summary: Static libraries for developing apps which will use %{name}-regex
  163. #Group: Development/Libraries
  164. #Requires: %{name}-devel = %{version}-%{release}
  165. #Requires: %{name}-regex = %{version}-%{release}
  166. #
  167. #%description regex-devel
  168. #Summary: Static libraries for developing apps which will use %{name}-regex
  169. %package serialization
  170. Summary: Set of serialization libralies in %{name}
  171. Group: System Environment/Libraries
  172. Requires: %{name} = %{version}-%{release}
  173. %description serialization
  174. Set of serialization libralies in %{name}
  175. #%package serialization-devel
  176. #Summary: Static libraries for developing apps which will use %{name}-serialization
  177. #Group: Development/Libraries
  178. #Requires: %{name}-devel = %{version}-%{release}
  179. #Requires: %{name}-serialization = %{version}-%{release}
  180. #
  181. #%description serialization-devel
  182. #Static libraries for developing apps which will use %{name}-serialization
  183. %package signals
  184. Summary: Set of signals and slots libralies in %{name}
  185. Group: System Environment/Libraries
  186. Requires: %{name} = %{version}-%{release}
  187. %description signals
  188. Set of signals and slots libralies in %{name}
  189. #%package signals-devel
  190. #Summary: Static libraries for developing apps which will use %{name}-signals
  191. #Group: Development/Libraries
  192. #Requires: %{name}-devel = %{version}-%{release}
  193. #Requires: %{name}-signals = %{version}-%{release}
  194. #
  195. #%description signals-devel
  196. #Static libraries for developing apps which will use %{name}-signals
  197. %package test
  198. Summary: Set of libraries for writing and executing tests in %{name}
  199. Group: System Environment/Libraries
  200. Requires: %{name} = %{version}-%{release}
  201. %description test
  202. Set of libraries for writing and executing tests in %{name}
  203. #%package test-devel
  204. #Summary: Static libraries for developing apps which will use %{name}-test
  205. #Group: Development/Libraries
  206. #Requires: %{name}-devel = %{version}-%{release}
  207. #Requires: %{name}-test = %{version}-%{release}
  208. #
  209. #%description test-devel
  210. #Static libraries for developing apps which will use %{name}-test
  211. %package thread
  212. Summary: Set of multi-thread libraries in %{name}
  213. Group: System Environment/Libraries
  214. Requires: %{name} = %{version}-%{release}
  215. %description thread
  216. Set of multi-thread libraries in %{name}
  217. #%package thread-devel
  218. #Summary: Static libraries for developing apps which will use %{name}-thread
  219. #Group: Development/Libraries
  220. #Requires: %{name}-devel = %{version}-%{release}
  221. #Requires: %{name}-thread = %{version}-%{release}
  222. #
  223. #%description thread-devel
  224. #Static libraries for developing apps which will use %{name}-thread
  225. %package wave
  226. Summary: Set of wave libraries in %{name}
  227. Group: System Environment/Libraries
  228. Requires: %{name} = %{version}-%{release}
  229. %description wave
  230. Set of wave libraries in %{name}
  231. #%package wave-devel
  232. #Summary: Static libraries for developing apps using %{name} wave libraries
  233. #Group: Development/Libraries
  234. #Requires: %{name}-devel = %{version}-%{release}
  235. #
  236. #%description wave-devel
  237. #Static libraries for developing apps using %{name} wave libraries
  238. %package system
  239. Summary: Operating system support
  240. Group: System Environment/Libraries
  241. Requires: %{name} = %{version}-%{release}
  242. %description system
  243. Operating system support, including the diagnostics support
  244. that will be part of the C++0x standard library
  245. %prep
  246. %setup -q -n %{tarname}_%{ver}
  247. cp %SOURCE1 user-config.jam
  248. %build
  249. ## ./configure --prefix=/usr --libdir=%{_libdir} --with-icu
  250. ## make EXPAT_INCLUDE=/usr/include EXPAT_LIBPATH=/usr/lib
  251. ./bootstrap.sh \
  252. --prefix=%{_prefix} \
  253. --libdir=%{_libdir} \
  254. --includedir=%{_includedir} \
  255. --with-icu=%{_prefix} \
  256. --with-python-version=%{pyver}
  257. ./bjam -sICU_LINK="-L%{_libdir} -licui18n" --user-config=./user-config.jam link=shared
  258. %install
  259. rm -rf $RPM_BUILD_ROOT
  260. ## ./tools/jam/src/bin.linux*/bjam -sICU_PATH=/usr -sEXPAT_INCLUDE=/usr/include -sEXPAT_LIBPATH=/usr/lib --user-config=user-config.jam --prefix=${RPM_BUILD_ROOT}/usr --libdir=${RPM_BUILD_ROOT}%{_libdir} install
  261. ./bjam \
  262. --prefix=${RPM_BUILD_ROOT}%{_prefix} \
  263. --libdir=${RPM_BUILD_ROOT}%{_libdir} \
  264. --user-config=./user-config.jam \
  265. link=shared \
  266. install
  267. ln -s ./%{tarname} ${RPM_BUILD_ROOT}/%{_includedir}/%{tarname}-%{lnkver}
  268. # remove unuse files
  269. rm -f ${RPM_BUILD_ROOT}/%{_libdir}/%{name}_*.a
  270. # unnead for libboost-1.42
  271. ## pushd $RPM_BUILD_ROOT/%{_libdir}
  272. ## for i in libboost_*-mt.so
  273. ## do
  274. ## ln -sf $i $(echo $i | cut -f1 -d-).so
  275. ## done
  276. ## popd
  277. ## %post devel
  278. ## if [ $1 = 2 ]; then
  279. ## rm -rf %{_includedir}/%{tarname}
  280. ## fi
  281. ## ln -s %{_includedir}/%{tarname}-%{lnkver}/%{tarname} %{_includedir}/%{tarname}
  282. ##
  283. ## %postun devel
  284. ## if [ $1 = 0 ]; then
  285. ## rm -rf %{_includedir}/%{tarname}
  286. ## fi
  287. %post date-time -p /sbin/ldconfig
  288. %post filesystem -p /sbin/ldconfig
  289. %post graph -p /sbin/ldconfig
  290. %post iostreams -p /sbin/ldconfig
  291. %post math -p /sbin/ldconfig
  292. %post program-options -p /sbin/ldconfig
  293. %post python -p /sbin/ldconfig
  294. %post regex -p /sbin/ldconfig
  295. %post serialization -p /sbin/ldconfig
  296. %post signals -p /sbin/ldconfig
  297. %post system -p /sbin/ldconfig
  298. %post test -p /sbin/ldconfig
  299. %post thread -p /sbin/ldconfig
  300. %post wave -p /sbin/ldconfig
  301. %postun date-time -p /sbin/ldconfig
  302. %postun filesystem -p /sbin/ldconfig
  303. %postun graph -p /sbin/ldconfig
  304. %postun iostreams -p /sbin/ldconfig
  305. %postun math -p /sbin/ldconfig
  306. %postun program-options -p /sbin/ldconfig
  307. %postun python -p /sbin/ldconfig
  308. %postun regex -p /sbin/ldconfig
  309. %postun serialization -p /sbin/ldconfig
  310. %postun signals -p /sbin/ldconfig
  311. %postun system -p /sbin/ldconfig
  312. %postun test -p /sbin/ldconfig
  313. %postun thread -p /sbin/ldconfig
  314. %postun wave -p /sbin/ldconfig
  315. %clean
  316. rm -rf $RPM_BUILD_ROOT
  317. %files
  318. %defattr(-,root,root)
  319. %doc LICENSE_1_0.txt
  320. %files devel
  321. %defattr(-,root,root)
  322. %{_includedir}/boost/
  323. %{_includedir}/boost-%{lnkver}/
  324. %files doc
  325. %doc index.htm index.html boost.css boost.png rst.css doc libs more people wiki
  326. %files date-time
  327. %{_libdir}/%{name}_date_time*.so*
  328. %files filesystem
  329. %{_libdir}/%{name}_filesystem*.so*
  330. %files graph
  331. %{_libdir}/%{name}_graph*.so*
  332. %{_libdir}/%{name}_mpi*.so*
  333. %{_libdir}/mpi*.so*
  334. %files iostreams
  335. %{_libdir}/%{name}_iostreams*.so*
  336. %files math
  337. %{_libdir}/%{name}_math_*.so*
  338. %files program-options
  339. %{_libdir}/%{name}_program_options*.so*
  340. %files python
  341. %{_libdir}/%{name}_python*.so*
  342. %files regex
  343. %{_libdir}/%{name}_regex*.so*
  344. %files serialization
  345. %{_libdir}/%{name}_serialization*.so*
  346. %{_libdir}/%{name}_wserialization*.so*
  347. %files signals
  348. %{_libdir}/%{name}_signals*.so*
  349. %files test
  350. %{_libdir}/%{name}_prg_exec_monitor*.so*
  351. %{_libdir}/%{name}_unit_test_framework*.so*
  352. %files thread
  353. %{_libdir}/%{name}_thread*.so*
  354. %files wave
  355. %{_libdir}/%{name}_wave*.so*
  356. %files system
  357. %{_libdir}/%{name}_system*.so*
  358. %changelog
  359. * Wed Apr 14 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.42.0-4
  360. - rebuilt again on ppc
  361. * Sat Apr 10 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.42.0-3
  362. - rebuilt with libicu-4.4
  363. * Mon Feb 08 2010 Shu KONNO <owa@bg.wakwak.com> 1.42.0-2
  364. - added "-licui18n" to bjam
  365. - added BR: lam
  366. * Sun Feb 07 2010 Shu KONNO <owa@bg.wakwak.com> 1.42.0-1
  367. - updated to boost_1_42_0
  368. - rebuilt with new toolchain and python-2.6
  369. - added user-config.jam to make libboost_mpi
  370. - added BR: libaio-devel
  371. - added %%{post,postun} -p /sbin/ldconfig
  372. - dropt no use parameter EXPAT_INCLUDE and EXPAT_LIBPATH
  373. - dropt %{_libdir}/%{name}_test_exec_monitor-*.a in %%files %{name}-test
  374. - dropt %%{post,postun} devel section
  375. * Sun Mar 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.36.0-2vl5
  376. - rebuilt with libicu-4.0.1
  377. - changed Group to System Environment/Libraries (except devel package)
  378. * Sat Aug 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.36.0-1vl5
  379. - new upstream release
  380. - add -math subpackage
  381. * Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.35.0-2vl5
  382. - build with python-2.5
  383. - add libboost_XXXX.so symlinks
  384. * Thu May 8 2008 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.35.0-1vl5
  385. - upstream release
  386. - applied new versioning policy
  387. - add EXPAT_INCLUDE and EXPAT_LIBPATH to enable GraphML support
  388. - add new package libboost-system
  389. - Obsolete: *-devel packages
  390. * Sat Sep 8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.34.1-0vl3
  391. - rebuilt with libicu-3.6
  392. - changed doc Group to Applications/Documentation
  393. * Sat Aug 18 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.34.1-0vl2
  394. - upstream release
  395. * Thu Jun 14 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.34.0-0vl3
  396. - add --libdir=%%{_libdir} to cope with x86_64 environment
  397. * Sun Jun 10 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.34.0-0vl2
  398. - upstream release
  399. - use Easy Build and Install process with ./configure
  400. - add BuildRequires: libicu-devel
  401. - remove %%{_libdir}/libboost_test_exec_monitor-*.so* from %%files -n libboost-test
  402. - add new packages: libboost-graph, libboost-graph-devel, libboost-wave
  403. - add files to doc package
  404. * Sun May 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.33.1-0vl2
  405. - rebuilt with new toolchain
  406. * Sat Feb 4 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.33.1-0vl1
  407. - upstream release
  408. * Mon Dec 12 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.33.0-0vl3
  409. - fixed typo in Groups:
  410. - devel packages also moved to Development/Libraries group
  411. * Mon Sep 19 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.33.0-0vl2
  412. - spec modified to avoid errors on non-ix86 archtecture
  413. (previously the path linuxx86 was explicitly used)
  414. * Sun Sep 11 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.33.0-0vl1
  415. - initial release for Vine Linux
  416. * Sat Sep 10 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.33.0-0vl0.3
  417. - link /usr/include/boost_%{lnkver}/boost to /usr/include/boost
  418. * Sat Sep 10 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.33.0-0vl0.2
  419. - change package name from boost to libboost
  420. - separated into sub-packages
  421. * Fri Jun 17 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.33.0-0vl0.1
  422. - upstream release
  423. - add BuildRequires: bzip2-devel zlib-devel
  424. * Fri Jun 17 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.7
  425. - added so.* file
  426. * Mon Apr 25 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.6
  427. - moved %post, %postun script to -devel package
  428. * Mon Apr 25 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.5
  429. - moved doc/html to -devel package
  430. - make a symbolic link on %{_includedir}/boost
  431. * Mon Apr 25 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.4
  432. - fixed character code to euc-jp
  433. * Mon Apr 25 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.3
  434. - add %doc files
  435. * Fri Apr 22 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.2
  436. - remove Requires
  437. - split -devel package
  438. * Fri Apr 22 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.1
  439. - initial build for Vine Linux