expect-vl.spec 8.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296
  1. %define tcl_major 8.4
  2. %define thread_major 2.5
  3. %define majorver 5.43
  4. Summary: A Tcl/Tk development environment: expect
  5. Summary(ja): Tcl/Tk 開発環境: expect
  6. Name: expect
  7. Version: %{majorver}.0
  8. Release: 5%{?_dist_release}
  9. Group: Development/Languages
  10. URL: http://expect.nist.gov/
  11. License: BSD
  12. Source0: http://expect.nist.gov/src/%{name}-%{version}.tar.gz
  13. Patch0: expect-5.32.2-random.patch
  14. Patch6: expect-5.38.0-spawn-43310.patch
  15. Patch8: expect-5.32.2-setpgrp.patch
  16. Patch10: expect-5.38.0-lib-spec.patch
  17. Patch11: expect-5.39.0-libdir.patch
  18. Buildroot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: tcl >= %{tcl_major}
  20. BuildRequires: thread >= %{thread_major}
  21. BuildRequires: autoconf213
  22. BuildRequires: libX11-devel
  23. %description -n expect
  24. Expect is a tcl extension for automating interactive applications such
  25. as telnet, ftp, passwd, fsck, rlogin, tip, etc. Expect is also useful
  26. for testing the named applications. Expect makes it easy for a script
  27. to control another program and interact with it.
  28. Install the expect package if you'd like to develop scripts which interact
  29. with interactive applications. You'll also need to install the tcl
  30. package.
  31. %package devel
  32. Summary: Development files for expect library.
  33. Group: Development/Libraries
  34. Requires: expect = %{version}-%{release}
  35. Obsoletes: expect <= 5.43-0vl4
  36. %description devel
  37. This package contains development files for the expect library.
  38. %package -n expectk
  39. Summary: expectk and some scripts
  40. Group: Development/Languages
  41. Requires: expect = %{version}-%{release}
  42. Obsoletes: expect <= 5.43-0vl4
  43. %description -n expectk
  44. This package contains expectk and some scripts that use it.
  45. %prep
  46. %setup -q -n %{name}-%{majorver}
  47. %patch0 -p1 -b .random
  48. %patch6 -p2 -b .spawn
  49. %patch8 -p2 -b .pgrp
  50. %patch10 -p1 -b .libspec
  51. %patch11 -p1 -b .libdir
  52. # patch10 touch configure.in
  53. autoconf-2.13
  54. %build
  55. %configure --enable-64bit \
  56. --with-tcl=%{_libdir} --with-tk=%{_libdir} \
  57. --with-tclinclude=%{_includedir}/tcl-private/generic \
  58. --with-tkinclude=%{_includedir}/tk-private/generic \
  59. --enable-shared --enable-threads --with-x=yes --enable-gcc
  60. make
  61. %install
  62. rm -rf ${RPM_BUILD_ROOT}
  63. mkdir -p ${RPM_BUILD_ROOT}
  64. make INSTALL_ROOT=%{buildroot} install
  65. # for linking with -lexpect
  66. ln -s libexpect%{majorver}.so "$RPM_BUILD_ROOT"%{_libdir}/libexpect.so
  67. # remove cryptdir/decryptdir, as Linux has no crypt command (bug 6668).
  68. rm -f "$RPM_BUILD_ROOT"%{_bindir}/{cryptdir,decryptdir}
  69. rm -f "$RPM_BUILD_ROOT"%{_mandir}/man1/{cryptdir,decryptdir}.1*
  70. rm -f "$RPM_BUILD_ROOT"%{_bindir}/autopasswd
  71. %post -p /sbin/ldconfig -n expect
  72. %postun -p /sbin/ldconfig -n expect
  73. %clean
  74. rm -rf $RPM_BUILD_ROOT
  75. %files
  76. %%defattr(-,root,root)
  77. %doc FAQ HISTORY NEWS README
  78. %{_bindir}/expect
  79. %{_bindir}/autoexpect
  80. %{_bindir}/dislocate
  81. %{_bindir}/ftp-rfc
  82. %{_bindir}/kibitz
  83. %{_bindir}/lpunlock
  84. %{_bindir}/mkpasswd
  85. %{_bindir}/passmass
  86. %{_bindir}/rftp
  87. %{_bindir}/rlogin-cwd
  88. %{_bindir}/timed-read
  89. %{_bindir}/timed-run
  90. %{_bindir}/unbuffer
  91. %{_bindir}/weather
  92. %{_bindir}/xkibitz
  93. %dir %{_libdir}/expect%{majorver}
  94. %{_libdir}/expect%{majorver}/pkgIndex.tcl
  95. %{_libdir}/libexpect%{majorver}.so
  96. %{_mandir}/man1/autoexpect.1.gz
  97. %{_mandir}/man1/dislocate.1.gz
  98. %{_mandir}/man1/expect.1.gz
  99. %{_mandir}/man1/kibitz.1.gz
  100. %{_mandir}/man1/mkpasswd.1.gz
  101. %{_mandir}/man1/passmass.1.gz
  102. %{_mandir}/man1/tknewsbiff.1.gz
  103. %{_mandir}/man1/unbuffer.1.gz
  104. %{_mandir}/man1/xkibitz.1.gz
  105. %files devel
  106. %defattr(-,root,root,-)
  107. %exclude %{_libdir}/expect%{majorver}/libexpect%{majorver}.a
  108. %exclude %{_libdir}/libexpect%{majorver}.a
  109. %{_libdir}/libexpect.so
  110. %{_mandir}/man3/libexpect.3*
  111. %{_includedir}/*
  112. %files -n expectk
  113. %defattr(-,root,root,-)
  114. %{_bindir}/expectk
  115. %{_bindir}/multixterm
  116. %{_bindir}/tknewsbiff
  117. %{_bindir}/tkpasswd
  118. %{_bindir}/xpstat
  119. %{_mandir}/man1/expectk.1*
  120. %{_mandir}/man1/multixterm.1*
  121. %{_mandir}/man1/tknewsbiff.1*
  122. %changelog
  123. * Tue Apr 19 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.43-5
  124. - add missing BuildRequires: libX11-devel
  125. * Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 5.43-4
  126. - rebuilt with rpm-4.8.1-3
  127. * Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 5.43-3
  128. - rebuilt with tcl/tk-8.4.19-2
  129. * Tue May 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.43-2
  130. - rebuilt with new toolchain
  131. - changed devel Group to Development/Libraries
  132. * Sun Jul 27 2008 Shu KONNO <owa@bg.wakwak.com> 5.43-1vl5
  133. - applied new versioning policy and spec in utf-8
  134. * Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl6
  135. - rebuilt with tcl/tk-8.4.18
  136. * Fri Nov 09 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 5.43-0vl5
  137. - split to expect-devel and expectk sub package.
  138. - add libexpect.so to expect-devel (<BTS:wishes:0136>)
  139. * Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl4
  140. - rebuilt with tcl/tk-8.4.16
  141. * Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl3
  142. - rebuilt with new toolchain
  143. * Sun Jan 29 2006 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl2
  144. - rebuild for tcl/tk-8.4.12
  145. - added --enable-64bit to configure's option
  146. * Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl1
  147. - updated expect to 5.43.0
  148. - dropped expect-5.39.0-64bit-82547.patch (for fixed)
  149. - dropped expect-5.32.2-kibitz.patch (for fixed)
  150. - dropped expect-5.38.0-autopasswd-9917.patch (for fixed)
  151. - rebuilt with tcl/tk 8.4.11
  152. * Wed Jun 30 2004 Shu KONNO <owa@bg.wakwak.com> 5.39-95vl2
  153. - rebuild for tcl/tk-8.4.6
  154. * Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 5.39-95vl1
  155. - update based on fedora
  156. * Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
  157. - update based on BitWalk's tcltk-8.4.2-83bw and RawHide tcltk-8.3.5-89
  158. * Thu Nov 15 2001 Kazuhusa TAKEI <takei@linux.or.jp> 8.0.5_jp-10vl3
  159. - splite source package
  160. - add include files
  161. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
  162. - expand some macros.. (FIXME)
  163. * Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
  164. - use %configure macros
  165. - add Patch 47,50
  166. * Thu May 31 2001 <sagami@vinelinux.org>
  167. - 8.0.5_jp-10
  168. - unexpand old %%{configure}, new one causes build failure
  169. - fixed missing libtkx.so libtclx.so symlink in /usr/lib
  170. - install manpages into %%{_mandir} and mode 644
  171. * Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  172. - 8.0.5_jp-9
  173. - modified %install section to handle compressed man pages
  174. - fixed /usr/lib/tk8.0jp/demos.jp/images symlink
  175. * Sun Jul 2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
  176. - changed default fonts
  177. * Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
  178. - added defattr
  179. * Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
  180. - added some symlinks, such as libtcl8.0.so.
  181. - obsoletes version number using _jp, now 8.0.5-31vl1
  182. * Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
  183. - Apply Tcl/Tk 8.0 Japanese Patch 1.7
  184. * Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
  185. - fix tclX symlinks.
  186. - compile on systems where SIGPWR == SIGLOST.
  187. * Sat May 1 1999 Jeff Johnson <jbj@redhat.com>
  188. - update tcl/tk to 8.0.5.
  189. - avoid "containing" in Tix (#2332).
  190. * Thu Apr 8 1999 Jeff Johnson <jbj@redhat.com>
  191. - use /usr/bin/write in kibitz (#1320).
  192. - use cirrus.sprl.umich.edu in weather (#1926).
  193. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  194. - auto rebuild in the new build environment (release 28)
  195. * Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
  196. - whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
  197. * Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
  198. - expect does unaligned access on alpha (#989)
  199. - upgrade tcl/tk/tclX to 8.0.4
  200. - upgrade expect to 5.28.
  201. - add itcl 3.0.1
  202. * Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
  203. - call libtoolize to allow building on the arm
  204. - build for glibc 2.1
  205. - strip binaries
  206. * Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
  207. - update tcl/tk/tclX to 8.0.3, expect is updated also.
  208. * Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
  209. - expect: mkpasswd needs delay before sending password (problem #576)
  210. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  211. - translations modified for de, fr, tr
  212. * Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
  213. - fixed expect binaries exec permissions
  214. * Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
  215. - updated to Tix 4.1.0.006
  216. - updated version numbers of tcl/tk to relflect includsion of p2
  217. * Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
  218. - updated tcl/tk to patch level 2
  219. - updated tclX to 8.0.2
  220. * Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
  221. - fixed filelist for tix... replacing path to the expect binary in scripts
  222. was leaving junk files around.
  223. * Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
  224. - added patch to remove libieee test in configure.in for tcl and tk.
  225. Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
  226. solution for all systems
  227. - fixed src urls
  228. * Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
  229. - removed version numbers from descriptions
  230. * Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
  231. - updated to tcl/tk 8.0 and related versions of packages
  232. * Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
  233. - built against glibc
  234. - fixed dangling tclx/tkx symlinks