nettle-vl.spec 6.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: nettle
  3. Version: 3.2
  4. Release: 1%{?_dist_release}
  5. Summary: A low-level cryptographic library
  6. Summary(ja): 低レベル暗号化ライブラリ
  7. Group: System Environment/Libraries
  8. License: LGPLv2+
  9. URL: http://www.lysator.liu.se/~nisse/nettle/
  10. Source0: http://www.lysator.liu.se/~nisse/archive/%{name}-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: gmp-devel
  13. BuildRequires: m4
  14. Requires(post): /sbin/install-info
  15. Requires(preun): /sbin/install-info
  16. Vendor: Project Vine
  17. Distribution: Vine Linux
  18. %package devel
  19. Summary: Development headers for a low-level cryptographic library
  20. Summary(ja): 低レベル暗号化ライブラリの開発ヘッダ
  21. Group: Development/Libraries
  22. Requires: %{name} = %{version}-%{release}
  23. Requires: gmp-devel
  24. #%package static
  25. #Summary: Static libraries for a low-level cryptographic library
  26. #Group: Development/Libraries
  27. #Requires: %{name}-devel = %{version}-%{release}
  28. %if %{build_compat32}
  29. %package -n compat32-%{name}
  30. Summary: A low-level cryptographic library
  31. Summary(ja): 低レベル暗号化ライブラリ
  32. Group: System Environment/Libraries
  33. Requires: %{name} = %{version}-%{release}
  34. %package -n compat32-%{name}-devel
  35. Summary: Development headers for a low-level cryptographic library
  36. Summary(ja): 低レベル暗号化ライブラリの開発ヘッダ
  37. Group: Development/Libraries
  38. Requires: %{name}-devel = %{version}-%{release}
  39. Requires: compat32-%{name} = %{version}-%{release}
  40. Requires: compat32-gmp-devel
  41. %endif
  42. %description
  43. Nettle is a cryptographic library that is designed to fit easily in more
  44. or less any context: In crypto toolkits for object-oriented languages
  45. (C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
  46. kernel space.
  47. %description devel
  48. Nettle is a cryptographic library that is designed to fit easily in more
  49. or less any context: In crypto toolkits for object-oriented languages
  50. (C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
  51. kernel space. This package contains kernel headers.
  52. %if %{build_compat32}
  53. %description -n compat32-%{name}
  54. Nettle is a cryptographic library that is designed to fit easily in more
  55. or less any context: In crypto toolkits for object-oriented languages
  56. (C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
  57. kernel space.
  58. %description -n compat32-%{name}-devel
  59. Nettle is a cryptographic library that is designed to fit easily in more
  60. or less any context: In crypto toolkits for object-oriented languages
  61. (C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
  62. kernel space. This package contains compat libraries.
  63. %endif
  64. #%description static
  65. #Nettle is a cryptographic library that is designed to fit easily in more
  66. #or less any context: In crypto toolkits for object-oriented languages
  67. #(C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
  68. #kernel space. This package contains a static library.
  69. %prep
  70. %setup -q
  71. %build
  72. %configure --enable-shared
  73. make %{?_smp_mflags}
  74. %install
  75. rm -rf $RPM_BUILD_ROOT
  76. make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
  77. make install-shared DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
  78. #/usr/bin/iconv -f iso8859-1 -t utf-8 README > README.conv && /bin/mv -f README.conv README
  79. #/usr/bin/iconv -f iso8859-1 -t utf-8 ChangeLog > ChangeLog.conv && /bin/mv -f ChangeLog.conv ChangeLog
  80. #/usr/bin/iconv -f iso8859-1 -t utf-8 nettle.info > nettle.info.conv && /bin/mv -f nettle.info.conv nettle.info
  81. mkdir -p $RPM_BUILD_ROOT%{_infodir}
  82. install -p -m 644 nettle.info $RPM_BUILD_ROOT%{_infodir}/
  83. chmod 755 $RPM_BUILD_ROOT%{_libdir}/libhogweed.so.*
  84. chmod 755 $RPM_BUILD_ROOT%{_libdir}/libnettle.so.*
  85. rm -rf %{buildroot}/%{_libdir}/*.a
  86. rm -rf %{buildroot}/%{_infodir}/dir
  87. %check
  88. make check
  89. %clean
  90. rm -rf $RPM_BUILD_ROOT
  91. %files
  92. %defattr(-,root,root,-)
  93. %doc AUTHORS ChangeLog NEWS README TODO
  94. %{_infodir}/nettle.info.gz
  95. %{_bindir}/nettle-hash
  96. %{_bindir}/nettle-lfib-stream
  97. %{_bindir}/pkcs1-conv
  98. %{_bindir}/sexp-conv
  99. %{_bindir}/nettle-pbkdf2
  100. %{_libdir}/libhogweed.so.*
  101. %{_libdir}/libnettle.so.*
  102. %files devel
  103. %defattr(-,root,root,-)
  104. %doc descore.README nettle.html nettle.pdf
  105. %{_libdir}/libhogweed.so
  106. %{_libdir}/libnettle.so
  107. %{_includedir}/nettle
  108. %{_libdir}/pkgconfig/
  109. # compat32
  110. %if %{build_compat32}
  111. %files -n compat32-%{name}
  112. %defattr(-, root, root, 0755)
  113. %{_libdir}/libhogweed.so.*
  114. %{_libdir}/libnettle.so.*
  115. %files -n compat32-%{name}-devel
  116. %defattr(-, root, root, 0755)
  117. %{_libdir}/libhogweed.so
  118. %{_libdir}/libnettle.so
  119. %{_libdir}/pkgconfig/
  120. %endif
  121. #%files static
  122. #%defattr(-,root,root,-)
  123. #%doc COPYING
  124. #%{_libdir}/libhogweed.a
  125. #%{_libdir}/libnettle.a
  126. %post
  127. /sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir || :
  128. /sbin/ldconfig
  129. %preun
  130. if [ $1 = 0 ]; then
  131. /sbin/install-info --delete %{_infodir}/%{name}.info.gz %{_infodir}/dir || :
  132. fi
  133. %postun -p /sbin/ldconfig
  134. %if %{build_compat32}
  135. %post -n compat32-%{name} -p /sbin/ldconfig
  136. %postun -n compat32-%{name} -p /sbin/ldconfig
  137. %endif
  138. %changelog
  139. * Tue Jul 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.2-1
  140. - new upstream release.
  141. * Mon Dec 28 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.1.1-1
  142. - new upstream release
  143. * Thu Dec 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.7.1-4
  144. - fixed Requires typo of compat32-nettle-devel package
  145. * Sun Oct 26 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.7.1-3
  146. - moved nettle to System Environment/Libraries Group
  147. * Sun Feb 9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.7.1-2
  148. - add compat32,compat32-devel packages
  149. * Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.7.1-1
  150. - update to 2.7.1
  151. * Fri Dec 02 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.4-1
  152. - initial build for VineSeed
  153. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.15-7
  154. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  155. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.15-6
  156. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  157. * Thu Apr 10 2008 Ian Weller <ianweller@gmail.com> 1.15-5
  158. - Moved static lib to -static
  159. * Mon Mar 24 2008 Ian Weller <ianweller@gmail.com> 1.15-4
  160. - Added libraries and ldconfig
  161. * Mon Feb 18 2008 Ian Weller <ianweller@gmail.com> 1.15-3
  162. - Added provides -static to -devel
  163. * Sun Feb 17 2008 Ian Weller <ianweller@gmail.com> 1.15-2
  164. - Removed redundant requires
  165. - Removed redundant documentation between packages
  166. - Fixed license tag
  167. - Fixed -devel description
  168. - Added the static library back to -devel
  169. - Added make clean
  170. * Fri Feb 08 2008 Ian Weller <ianweller@gmail.com> 1.15-1
  171. - First package build.