gtk3-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372
  1. # Note that this is NOT a relocatable package
  2. %define glib2_base_version 2.30.0
  3. %define glib2_version %{glib2_base_version}-1
  4. %define pango_base_version 1.29.3
  5. %define pango_version %{pango_base_version}-1
  6. %define atk_base_version 2.2.0
  7. %define atk_version %{atk_base_version}-1
  8. %define cairo_base_version 1.10.2
  9. %define cairo_version %{cairo_base_version}-1
  10. %define gdkpixbuf2_base_version 2.24.0
  11. %define gdkpixbuf2_version %{gdkpixbuf2_base_version}-1
  12. %define gobject_introspection_version 1.30.0
  13. %define base_version 3.2.1
  14. %define bin_version 3.0.0
  15. # biarch support
  16. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  17. %define _query_suffix %{nil}
  18. %if %{build_compat32}
  19. %define _query_suffix -32
  20. %endif
  21. Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X.
  22. Summary(ja): X 用 GUI 作成ライブラリ: GIMP ツールキット(GTK+)
  23. Name: gtk3
  24. Version: %{base_version}
  25. Release: 1%{?_dist_release}
  26. License: LGPL
  27. Group: System Environment/Libraries
  28. Source: http://ftp.gnome.org/pub/GNOME/sources/gtk+/3.2/gtk+-%{version}.tar.xz
  29. Patch0: gtk3-3.1.12-gtk-widget-size-allocate.patch
  30. Patch1: gtk3-3.2.1-bug658772.patch
  31. Patch100: gtk+-2.99.3-vine-default-theme.patch
  32. BuildRequires: atk-devel >= %{atk_version}
  33. BuildRequires: pango-devel >= %{pango_version}
  34. BuildRequires: glib2-devel >= %{glib2_version}
  35. BuildRequires: cairo-devel >= %{cairo_version}
  36. BuildRequires: gdk-pixbuf2-devel >= %{gdkpixbuf2_version}
  37. BuildRequires: gobject-introspection-devel >= %{gobject_introspection_version}
  38. BuildRequires: libtiff-devel >= 3.7
  39. BuildRequires: libjpeg-turbo-devel
  40. BuildRequires: libpng-devel
  41. BuildRequires: jasper-devel
  42. BuildRequires: colord-devel
  43. BuildRequires: gtk-doc
  44. BuildRequires: gamin-devel
  45. BuildRequires: cups-devel
  46. BuildRequires: libICE-devel
  47. BuildRequires: libXext-devel
  48. BuildRequires: libXi-devel
  49. BuildRequires: libXrandr-devel >= 1.3.0
  50. BuildRequires: libXrender-devel
  51. BuildRequires: libXcursor-devel
  52. BuildRequires: libXfixes-devel
  53. BuildRequires: libXinerama-devel
  54. BuildRequires: libXcomposite-devel
  55. BuildRequires: libXdamage-devel
  56. BuildRoot: %{_tmppath}/gtk-%{version}-root
  57. URL: http://www.gtk.org
  58. # required for icon themes apis to work
  59. Requires: hicolor-icon-theme
  60. # We need to prereq these so we can run gtk-query-immodules-2.0
  61. Requires(post): glib2 >= %{glib2_version}
  62. Requires(post): atk >= %{atk_version}
  63. Requires(post): pango >= %{pango_version}
  64. Requires(post): libSM >= 1.1.0
  65. # We need to prereq libtiff >= 3.7 to run gdk-pixbuf-query-loaders
  66. Requires(post): libtiff >= 3.7
  67. Requires: libXrandr >= 1.3.0
  68. Vendor: Project Vine
  69. Distribution: Vine Linux
  70. Packager: Takemikaduchi
  71. %description
  72. GTK+ is a multi-platform toolkit for creating graphical user
  73. interfaces. Offering a complete set of widgets, GTK+ is suitable for
  74. projects ranging from small one-off tools to complete application
  75. suites.
  76. %package devel
  77. Summary: Development tools for GTK+ applications.
  78. Summary(ja): GTK+ (GIMP ツールキット) アプリケーション開発ツール
  79. Group: Development/Libraries
  80. Requires: %{name} = %{version}-%{release}
  81. Requires: pango-devel >= %{pango_version}
  82. Requires: atk-devel >= %{atk_version}
  83. Requires: glib2-devel >= %{glib2_version}
  84. Requires: gdk-pixbuf2-devel >= %{gdkpixbuf2_version}
  85. Requires: libX11-devel, libXcursor-devel, libXinerama-devel
  86. Requires: libXext-devel, libXi-devel, libXrandr-devel
  87. Requires: libXfixes-devel, libXcomposite-devel
  88. Requires: libpng-devel
  89. %description devel
  90. The gtk+-devel package contains the header files and developer
  91. docs for the GTK+ widget toolkit.
  92. #######################################################################
  93. # compat32
  94. %package -n compat32-%{name}
  95. Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X.
  96. Summary(ja): X 用 GUI 作成ライブラリ: GIMP ツールキット(GTK+)
  97. Group: System Environment/Libraries
  98. Requires(post): compat32-glib2 >= %{glib2_version}
  99. Requires(post): compat32-atk >= %{atk_version}
  100. Requires(post): compat32-pango >= %{pango_version}
  101. Requires(post): compat32-libSM >= 1.1.0
  102. Requires(post): compat32-libtiff >= 3.7
  103. Requires: compat32-libXrandr >= 1.3.0
  104. %description -n compat32-%{name}
  105. GTK+ is a multi-platform toolkit for creating graphical user
  106. interfaces. Offering a complete set of widgets, GTK+ is suitable for
  107. projects ranging from small one-off tools to complete application
  108. suites.
  109. %package -n compat32-%{name}-devel
  110. Summary: Development tools for GTK+ applications.
  111. Summary(ja): GTK+ (GIMP ツールキット) アプリケーション開発ツール
  112. Group: Development/Libraries
  113. Requires: compat32-%{name} = %{version}-%{release}
  114. Requires: %{name}-devel = %{version}
  115. Requires: compat32-libX11-devel, compat32-libXcursor-devel, compat32-libXinerama-devel
  116. Requires: compat32-libXext-devel, compat32-libXi-devel, compat32-libXrandr-devel
  117. Requires: compat32-libXfixes-devel, compat32-libXcomposite-devel
  118. Requires: compat32-libpng-devel
  119. %description -n compat32-%{name}-devel
  120. The gtk+-devel package contains the header files and developer
  121. docs for the GTK+ widget toolkit.
  122. %prep
  123. %setup -q -n gtk+-%{version}
  124. %patch0 -p1 -b .allocate
  125. %patch1 -p1 -b .bug658772
  126. %patch100 -p1 -b .vine-default-theme
  127. #for i in config.guess config.sub ; do
  128. # test -f %{_datadir}/libtool/$i && cp %{_datadir}/libtool/$i .
  129. #done
  130. %build
  131. # if ! pkg-config --exists pangoxft ; then
  132. # echo "No pangoxft.pc!"
  133. # exit 1
  134. # fi
  135. #libtoolize --force --copy
  136. #autoreconf -i
  137. %configure --enable-gtk-doc \
  138. --enable-man \
  139. --enable-debug=minimum \
  140. --disable-rebuilds \
  141. --disable-glibtest \
  142. --enable-introspection=yes \
  143. --enable-xrandr \
  144. --enable-xfixes \
  145. --enable-xcomposite \
  146. --enable-xdamage \
  147. --enable-x11-backend
  148. make ARCH=%{_arch}
  149. #make
  150. %install
  151. rm -rf $RPM_BUILD_ROOT
  152. make install DESTDIR=$RPM_BUILD_ROOT RUN_QUERY_IMMODULES_TEST=false RUN_QUERY_LOADER_TEST=false
  153. %find_lang gtk30
  154. %find_lang gtk30-properties
  155. cat gtk30.lang gtk30-properties.lang > all.lang
  156. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/gtk-3.0
  157. #
  158. # Make cleaned-up versions of examples and tutorial for installation
  159. #
  160. mkdir -p tmpdocs/tutorial
  161. # install -m 0644 docs/html/gtk_tut.html docs/html/gtk_tut-[0-9]*.html docs/html/*.gif tmpdocs/tutorial
  162. for dir in examples/* ; do
  163. if [ -d $dir ] ; then
  164. mkdir -p tmpdocs/$dir
  165. for file in $dir/* ; do
  166. case $file in
  167. *pre1.2.7)
  168. ;;
  169. *)
  170. install -m 0644 $file tmpdocs/$dir
  171. ;;
  172. esac
  173. done
  174. fi
  175. done
  176. # We need to have separate 32-bit and 64-bit binaries
  177. # for places where we have two copies of the GTK+ package installed.
  178. # (we might have x86_64 and i686 packages on the same system, for example.)
  179. %if %{build_compat32}
  180. cp $RPM_BUILD_ROOT%{_bindir}/gtk-query-immodules-3.0 \
  181. $RPM_BUILD_ROOT%{_bindir}/gtk-query-immodules-3.0%{_query_suffix}
  182. %endif
  183. touch $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/%{bin_version}/immodules.cache
  184. mkdir -p $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/modules
  185. mkdir -p $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/immodules
  186. # Remove unpackaged files
  187. find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
  188. rm -rf $RPM_BUILD_ROOT%{_datadir}/themes/Raleigh
  189. mv $RPM_BUILD_ROOT%{_bindir}/gtk-update-icon-cache \
  190. $RPM_BUILD_ROOT%{_bindir}/gtk-update-icon-cache-3.0
  191. %clean
  192. rm -rf $RPM_BUILD_ROOT
  193. %post
  194. /sbin/ldconfig
  195. %{_bindir}/gtk-query-immodules-3.0 --update-cache || : > /dev/null 2>&1
  196. %postun
  197. /sbin/ldconfig
  198. if [ $1 -gt 0 ]; then
  199. %{_bindir}/gtk-query-immodules-3.0 --update-cache || : > /dev/null 2>&1
  200. fi
  201. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  202. %posttrans
  203. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  204. %if %{build_compat32}
  205. %post -n compat32-%{name}
  206. /sbin/ldconfig
  207. %{_bindir}/gtk-query-immodules-3.0%{_query_suffix} --update-cache || : > /dev/null 2>&1
  208. %postun -n compat32-%{name}
  209. /sbin/ldconfig
  210. if [ $1 = 0 ]; then
  211. %{_bindir}/gtk-query-immodules-3.0%{_query_suffix} --update-cache || : > /dev/null 2>&1
  212. fi
  213. %endif
  214. %files -f all.lang
  215. %defattr(-, root, root)
  216. %doc AUTHORS COPYING ChangeLog NEWS README
  217. %{_bindir}/gtk3-demo
  218. %{_bindir}/gtk-query-immodules-3.0
  219. %{_bindir}/gtk-update-icon-cache-3.0
  220. %{_libdir}/libgtk-3.so.*
  221. %{_libdir}/libgdk-3.so.*
  222. %{_libdir}/libgailutil-3.so.*
  223. %dir %{_libdir}/gtk-3.0
  224. %{_libdir}/gtk-3.0/%{bin_version}
  225. %dir %{_libdir}/gtk-3.0/modules
  226. #%{_libdir}/gtk-3.0/modules/lib*.so
  227. %{_libdir}/girepository-1.0/*.typelib
  228. %{_datadir}/gtk-3.0
  229. %{_datadir}/themes/Default
  230. %{_datadir}/themes/Emacs
  231. %dir %{_sysconfdir}/gtk-3.0
  232. %{_sysconfdir}/gtk-3.0/im-multipress.conf
  233. %{_datadir}/glib-2.0/schemas/*.xml
  234. %files devel
  235. %defattr(-, root, root)
  236. %{_libdir}/lib*.so
  237. %dir %{_libdir}/gtk-3.0
  238. %{_datadir}/gtk-doc/
  239. %{_datadir}/gir-1.0/*.gir
  240. %{_mandir}/man1/*
  241. %exclude %{_mandir}/man1/gtk-update-icon-cache.1.gz
  242. %{_includedir}/*
  243. %{_datadir}/aclocal/*
  244. %{_libdir}/pkgconfig/*
  245. %doc tmpdocs/tutorial
  246. # compat32
  247. %if %{build_compat32}
  248. %files -n compat32-%{name}
  249. %defattr(-, root, root)
  250. %{_bindir}/gtk-query-immodules-3.0%{_query_suffix}
  251. %{_libdir}/libgtk-3.so.*
  252. %{_libdir}/libgdk-3.so.*
  253. %{_libdir}/libgailutil-3.so.*
  254. %dir %{_libdir}/gtk-3.0
  255. %{_libdir}/gtk-3.0/%{bin_version}
  256. %dir %{_libdir}/gtk-3.0/modules
  257. #%{_libdir}/gtk-3.0/modules/lib*.so
  258. %dir %{_sysconfdir}/gtk-3.0
  259. %files -n compat32-%{name}-devel
  260. %defattr(-, root, root)
  261. %{_libdir}/lib*.so
  262. %dir %{_libdir}/gtk-3.0
  263. %{_libdir}/pkgconfig/*
  264. %endif
  265. %changelog
  266. * Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  267. - new upstream release
  268. - add Patch1 (gtk3-3.2.1-bug658772.patch)
  269. * Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  270. - new upstream release
  271. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  272. - new upstream release
  273. * Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.18-1
  274. - new upstream release
  275. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.16-1
  276. - new upstream release
  277. * Tue Aug 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.12-1
  278. - new upstream release
  279. - add Patch0 (gtk3-3.1.12-gtk-widget-size-allocate.patch)
  280. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.10-2
  281. - fix %%files
  282. * Sat Jul 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.10-1
  283. - new upstream release
  284. - add BuildRequires: colord-devel
  285. * Sun Jun 26 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.11-1
  286. - new upstream release
  287. * Sun Apr 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.9-1
  288. - new upstream release
  289. * Sun Apr 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.8-1
  290. - new upstream release
  291. * Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.7-1
  292. - new upstream release
  293. * Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.6-1
  294. - new upstream release
  295. * Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.4-1
  296. - new upstream release
  297. * Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.3-1
  298. - new upstream release
  299. * Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
  300. - new upstream release
  301. * Fri Feb 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-1
  302. - new upstream release
  303. * Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.0-1
  304. - initial build for Vine Linux