make-vl.spec 8.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259
  1. Summary: A GNU tool which simplifies the build process for users.
  2. Summary(ja): ユーザのビルド手続きを平易にする GNU ツール
  3. Name: make
  4. Epoch: 1
  5. Version: 4.2.1
  6. Release: 1%{?_dist_release}
  7. License: GPL
  8. Group: Development/Tools
  9. URL: http://www.gnu.org/software/make/
  10. Source: https://ftp.gnu.org/gnu/make/make-%{version}.tar.bz2
  11. Source1: http://translationproject.org/PO-files/ja/make-%{version}.ja.po
  12. Patch0: make-4.2-getcwd.patch
  13. Patch1: make-4.0-newlines.patch
  14. # Assume we don't have clock_gettime in configure, so that
  15. # make is not linked against -lpthread (and thus does not
  16. # limit stack to 2MB).
  17. Patch2: make-4.0-noclock_gettime.patch
  18. # BZs #142691, #17374
  19. Patch3: make-4.2-j8k.patch
  20. # Upstream: https://savannah.gnu.org/bugs/?30748
  21. # The default value of .SHELL_FLAGS is -c.
  22. Patch4: make-4.0-weird-shell.patch
  23. # Upstream patch: https://git.savannah.gnu.org/cgit/make.git/patch/?id=193f1e81edd6b1b56b0eb0ff8aa4b41c7b4257b4
  24. # Fixes wrong assumptions of glibc's glob internals.
  25. Patch5: make-4.2.1-glob-fix-2.patch
  26. # Upstream patch: https://git.savannah.gnu.org/cgit/make.git/patch/?id=48c8a116a914a325a0497721f5d8b58d5bba34d4
  27. # Fixes incorrect use of glibc 2.27 glob internals.
  28. Patch6: make-4.2.1-glob-fix.patch
  29. Patch7: make-4.2.1-glob-fix-3.patch
  30. # Perl 5.26 removed the implicit CWD in @INC.
  31. Patch8: make-4.2.1-test-driver.patch
  32. # Upstream patch: https://git.savannah.gnu.org/cgit/make.git/commit/?id=fbf71ec25a5986d9003ac16ee9e23675feac9053
  33. # Adds support of guile 2.2
  34. Patch9: 0001-configure.ac-SV-50648-Detect-Guile-2.2-packages.patch
  35. Buildroot: %{_tmppath}/%{name}-%{version}-root
  36. Requires(post): /sbin/install-info
  37. Requires(preun): /sbin/install-info
  38. BuildRequires: automake >= 1.7.3
  39. BuildRequires: guile-devel
  40. BuildRequires: perl
  41. BuildRequires: procps
  42. BuildRequires: texinfo
  43. Vendor: Project Vine
  44. Distribution: Vine Linux
  45. %description
  46. A GNU tool for controlling the generation of executables and other
  47. non-source files of a program from the program's source files. Make
  48. allows users to build and install packages without any significant
  49. knowledge about the details of the build process. The details about
  50. how the program should be built are provided for make in the program's
  51. makefile.
  52. The GNU make tool should be installed on your system because it is
  53. commonly used to simplify the process of installing programs.
  54. %description -l ja
  55. プログラムのソースファイルから実行ファイル及びその他のファイルを
  56. 生成する GNU ツールです.Make を使うことでユーザは build 時の
  57. 細かいプロセスを気にせず build しインストールすることが出来ます.
  58. プログラムがどの様に build されるのかは,プログラムの Makefile に
  59. 書かれています.
  60. GNU make ツールは,プログラムのインストールを容易にするのに
  61. 非常によく使われますので,このパッケージは是非インストールして下さい.
  62. %prep
  63. %autosetup -p1
  64. rm -f tests/scripts/features/parallelism.orig
  65. cp -f %{SOURCE1} po/ja.po
  66. %build
  67. autoreconf -vfi
  68. %if %{?_dist_release} == "vl6"
  69. %configure
  70. %else
  71. %configure --with-guile
  72. %endif
  73. make -C po ja.gmo
  74. make %{?_smp_mflags}
  75. %install
  76. rm -rf ${RPM_BUILD_ROOT}
  77. make DESTDIR=$RPM_BUILD_ROOT install
  78. ln -sf make ${RPM_BUILD_ROOT}/%{_bindir}/gmake
  79. ln -sf make.1 ${RPM_BUILD_ROOT}/%{_mandir}/man1/gmake.1
  80. rm -f ${RPM_BUILD_ROOT}/%{_infodir}/dir
  81. %find_lang %name
  82. %check
  83. echo ============TESTING===============
  84. /usr/bin/env LANG=C make check
  85. echo ============END TESTING===========
  86. %clean
  87. rm -rf ${RPM_BUILD_ROOT}
  88. %post
  89. /sbin/install-info %{_infodir}/make.info.gz %{_infodir}/dir --entry="* Make: (make). The GNU make utility." || :
  90. %preun
  91. if [ $1 = 0 ]; then
  92. /sbin/install-info --delete %{_infodir}/make.info.gz %{_infodir}/dir --entry="* Make: (make). The GNU make utility." || :
  93. fi
  94. %files -f %{name}.lang
  95. %defattr(-,root,root)
  96. %doc NEWS README COPYING AUTHORS
  97. %{_bindir}/*
  98. %{_mandir}/man*/*
  99. %{_infodir}/*.info*
  100. %{_includedir}/gnumake.h
  101. %changelog
  102. * Wed Sep 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.2.1-1
  103. - new upstream release.
  104. - updated patches.
  105. - updated ja.po.
  106. * Wed May 25 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1-1
  107. - new upstream release.
  108. - dropped all patches.
  109. - imported patches from rawhide.
  110. - added Patch1000 to fix ja.po.
  111. * Sun Feb 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.82-2
  112. - rebuild with VineSeed environment
  113. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.82-1
  114. - new upstream release
  115. * Wed Apr 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.81-8
  116. - rebuild for Vine6
  117. * Mon Jun 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.81-7
  118. - applied new versioning policy
  119. - added BuildRequires: perl (for %%check)
  120. - spec in UTF-8
  121. * Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.81-6vl1
  122. - updated to 3.81 based on Fedora packages
  123. * Fri Mar 16 2007 Petr Machata <pmachata@redhat.com> - 1:3.81-6
  124. - Always run testsuite with C locale.
  125. - Resolves: #232607
  126. * Thu Feb 22 2007 Petr Machata <pmachata@redhat.com> - 1:3.81-5
  127. - Fix newline handling for quoted SHELL.
  128. - Resolves: #219409
  129. * Tue May 23 2006 Petr Machata <pmachata@redhat.com> - 1:3.81-1
  130. - Upstream 3.81:
  131. - Contains several backwards incompatible changes. See NEWS inside
  132. the source package to find out more.
  133. - memory patch and error reporting patch were ported to this version.
  134. - updated ja.po
  135. * Tue Dec 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.80-0vl4
  136. - added URL
  137. - s/Copyright/License/
  138. - added some patches from fedora development 3.80-8
  139. * Mon Aug 22 2005 Jakub Jelinek <jakub@redhat.com> 3.80-8
  140. - make sure errno for error reporting is not lost accross _() calls
  141. - report EOF on read pipe differently from read returning < 0 reporting
  142. * Mon Dec 13 2004 Jakub Jelinek <jakub@redhat.com> 3.80-6
  143. - refuse -jN where N is bigger than PIPE_BUF (#142691, #17374)
  144. * Tue Dec 02 2003 Florian La Roche <Florian.LaRoche@redhat.de>
  145. - add important bug-fixes from make home-page
  146. * Wed Apr 09 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.80-0vl3
  147. - some patches was included from 3.79.1-17
  148. * Wed Nov 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.80-0vl2
  149. - update ja.po
  150. * Wed Nov 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.80-0vl1
  151. - new upstream release
  152. * Fri Dec 22 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  153. - 3.79.1-5vl1
  154. - based on 3.79.1-5 from Rawhide
  155. - rebuilt for Vine Linux
  156. - added Japanese summary and description
  157. * Mon Aug 7 2000 Tim Waugh <twaugh@redhat.com>
  158. - change info-dir entry so that 'info make' works (#15029).
  159. * Tue Aug 1 2000 Jakub Jelinek <jakub@redhat.com>
  160. - assume we don't have clock_gettime in configure, so that
  161. make is not linked against -lpthread (and thus does not
  162. limit stack to 2MB).
  163. * Sat Jul 22 2000 Jeff Johnson <jbj@redhat.com>
  164. - add locale files (#14362).
  165. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  166. - automatic rebuild
  167. * Sat Jun 24 2000 Preston Brown <pbrown@redhat.com>
  168. - 3.79.1 bugfix release
  169. * Mon Jun 5 2000 Jeff Johnson <jbj@redhat.com>
  170. - FHS packaging.
  171. * Sun May 7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  172. - Fix build for some odd situations, such as
  173. - previously installed make != GNU make
  174. - /bin/sh != bash
  175. * Mon Apr 17 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  176. - update to 3.79
  177. * Thu Feb 24 2000 Cristian Gafton <gafton@redhat.com>
  178. - add patch from Andreas Jaeger to fix dtype lookups (for glibc 2.1.3
  179. builds)
  180. * Mon Feb 7 2000 Jeff Johnson <jbj@redhat.com>
  181. - compress man page.
  182. * Fri Jan 21 2000 Cristian Gafton <gafton@redhat.com>
  183. - apply patch to fix a /tmp race condition from Thomas Biege
  184. - simplify %install
  185. * Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
  186. - update to 3.78.1.
  187. * Thu Apr 15 1999 Bill Nottingham <notting@redhat.com>
  188. - added a serial tag so it upgrades right
  189. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  190. - auto rebuild in the new build environment (release 5)
  191. * Wed Sep 16 1998 Cristian Gafton <gafton@redhat.com>
  192. - added a patch for large file support in glob
  193. * Tue Aug 18 1998 Jeff Johnson <jbj@redhat.com>
  194. - update to 3.77
  195. * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
  196. - translations modified for de, fr, tr
  197. * Thu Oct 16 1997 Donnie Barnes <djb@redhat.com>
  198. - udpated from 3.75 to 3.76
  199. - various spec file cleanups
  200. - added install-info support
  201. * Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
  202. - built against glibc