graphviz-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385
  1. %define _unpackaged_files_terminate_build 1
  2. Name: graphviz
  3. Summary: Graph Visualization Tools
  4. Summary(ja): グラフ可視化ツール
  5. Version: 2.40.1
  6. Release: 2%{?_dist_release}
  7. Group: Applications/Graphics
  8. License: EPL
  9. URL: http://www.graphviz.org/
  10. Source0: http://www.graphviz.org/pub/graphviz/ARCHIVE/%{name}-%{version}.tar.gz
  11. Patch0: graphviz-2.40.1-visio.patch
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: bison
  14. BuildRequires: cairo-devel
  15. BuildRequires: expat-devel
  16. BuildRequires: flex
  17. BuildRequires: fontconfig-devel
  18. BuildRequires: freetype2-devel
  19. BuildRequires: gd-devel
  20. BuildRequires: gmp-devel
  21. BuildRequires: gtk2-devel
  22. BuildRequires: guile-devel
  23. BuildRequires: libjpeg-turbo-devel
  24. BuildRequires: libpng-devel
  25. BuildRequires: libSM-devel
  26. BuildRequires: libtool-ltdl-devel >= 2.2.6a
  27. BuildRequires: libXaw-devel
  28. BuildRequires: libXext-devel
  29. BuildRequires: librsvg2-devel
  30. BuildRequires: lua-devel
  31. BuildRequires: m4
  32. BuildRequires: perl
  33. BuildRequires: python-devel
  34. BuildRequires: ruby-devel
  35. BuildRequires: swig
  36. BuildRequires: tcl-devel >= 8.4
  37. BuildRequires: tk-devel >= 8.4
  38. BuildRequires: zlib-devel
  39. Requires: urw-fonts
  40. # only for this release
  41. # BuildConflicts: graphviz-devel
  42. Vendor: Project Vine
  43. Distribution: Vine Linux
  44. Packager: daisuke
  45. %description
  46. A collection of tools and tcl packages for the manipulation and layout
  47. of graphs (as in nodes and edges, not as in barcharts).
  48. %package devel
  49. Summary: Development tools for version %{version} of %{name}
  50. Group: Development/Libraries
  51. Requires: %{name} = %{version}
  52. %description devel
  53. The %{name}-devel package contains the header files
  54. and man3 pages necessary for developing programs
  55. using version %{version} of the %{name} libraries.
  56. %package doc
  57. Summary: PDF and HTML documents for graphviz
  58. Group: Applications/Documentation
  59. %description doc
  60. Provides some additional PDF and HTML documentation for graphviz.
  61. %package guile
  62. Group: Applications/Graphics
  63. Summary: Guile extension for graphviz
  64. Requires: %{name} = %{version}-%{release}, guile
  65. %description guile
  66. Guile extension for graphviz.
  67. %package lua
  68. Group: Applications/Graphics
  69. Summary: Lua extension for graphviz
  70. Requires: %{name} = %{version}-%{release}, lua
  71. %description lua
  72. Lua extension for graphviz.
  73. %package perl
  74. Group: Applications/Graphics
  75. Summary: Perl extension for graphviz
  76. Requires: %{name} = %{version}-%{release}
  77. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  78. %description perl
  79. Perl extension for graphviz.
  80. %package python
  81. Group: Applications/Graphics
  82. Summary: Python extension for graphviz
  83. Requires: %{name} = %{version}-%{release}
  84. Requires: python
  85. %description python
  86. Python extension for graphviz.
  87. %package ruby
  88. Group: Applications/Graphics
  89. Summary: Ruby extension for graphviz
  90. Requires: %{name} = %{version}-%{release}
  91. Requires: ruby
  92. %description ruby
  93. Ruby extension for graphviz.
  94. %package tcl
  95. Group: Applications/Graphics
  96. Summary: Tcl extension & tools for graphviz
  97. Requires: tcl >= 8.4, tk >= 8.4
  98. Requires: %{name} = %{version}
  99. %description tcl
  100. Various tcl packages (extensions) for the graphviz tools.
  101. %prep
  102. %setup -q
  103. %patch0 -p1 -b .visio
  104. %build
  105. autoreconf -if
  106. # using archdir instead of sitearchdir for Vine
  107. sed -i -e "s|sitearchdir|archdir|g" config/config_ruby.rb
  108. # Rewrite config_ruby.rb to work with Ruby 2.1
  109. sed -i 's|expand(|expand(RbConfig::|' config/config_ruby.rb
  110. sed -i 's|sitearchdir|vendorarchdir|' config/config_ruby.rb
  111. # get the path to search for ruby/config.h to CPPFLAGS, so that configure can find it
  112. export CPPFLAGS=-I`ruby -e "puts File.join(RbConfig::CONFIG['includedir'], RbConfig::CONFIG['sitearch'])" || echo /dev/null`
  113. # XXX ix86 only used to have -ffast-math, let's use everywhere
  114. %{expand: %%define optflags %{optflags} -ffast-math}
  115. %configure \
  116. --with-x \
  117. --disable-static \
  118. --with-mylibgd \
  119. --with-ipsepcola \
  120. --with-pangocairo \
  121. --with-gdk-pixbuf \
  122. --without-mylibgd \
  123. --without-ming \
  124. --without-qt \
  125. --disable-sharp \
  126. --enable-guile \
  127. --disable-java \
  128. --enable-lua \
  129. --disable-ocaml \
  130. --enable-perl \
  131. --disable-php \
  132. --enable-python \
  133. --disable-r \
  134. --enable-ruby \
  135. --enable-swig \
  136. --enable-tcl
  137. make %{?_smp_mflags}
  138. %install
  139. rm -rf $RPM_BUILD_ROOT __doc
  140. make DESTDIR=$RPM_BUILD_ROOT \
  141. docdir=$RPM_BUILD_ROOT%{_docdir}/%{name} \
  142. pkgconfigdir=%{_libdir}/pkgconfig \
  143. install
  144. find ${RPM_BUILD_ROOT} -type f -name "*.la" -exec rm -f {} ';'
  145. chmod -x $RPM_BUILD_ROOT%{_datadir}/%{name}/lefty/*
  146. cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/doc __doc
  147. rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/doc
  148. %clean
  149. rm -rf $RPM_BUILD_ROOT
  150. # run "dot -c" to generate plugin config in %{_libdir}/%{name}/config
  151. %post
  152. /sbin/ldconfig
  153. %{_bindir}/dot -c
  154. # if there is no dot after everything else is done, then remove config
  155. %postun
  156. if [ $1 -eq 0 ]; then
  157. rm -f %{_libdir}/graphviz/config || :
  158. fi
  159. /sbin/ldconfig
  160. %files
  161. %defattr(-,root,root)
  162. %license COPYING
  163. %doc AUTHORS ChangeLog NEWS README
  164. %{_bindir}/*
  165. %dir %{_datadir}/%{name}
  166. %{_datadir}/%{name}/gvpr
  167. %{_datadir}/%{name}/lefty
  168. %{_mandir}/man1/*
  169. %{_mandir}/man7/*
  170. %dir %{_libdir}/%{name}
  171. %{_libdir}/*.so.*
  172. %{_libdir}/%{name}/*.so.*
  173. %exclude %{_libdir}/graphviz/*/*
  174. %files devel
  175. %defattr(-,root,root)
  176. %{_includedir}/%{name}
  177. %{_libdir}/*.so
  178. %{_libdir}/%{name}/*.so
  179. %{_libdir}/pkgconfig/*.pc
  180. %{_datadir}/%{name}/graphs
  181. %{_mandir}/man3/*.3.gz
  182. %files doc
  183. %defattr(-,root,root,-)
  184. %doc __doc/*
  185. %files guile
  186. %defattr(-,root,root,-)
  187. %{_libdir}/graphviz/guile/
  188. %{_mandir}/man3/gv.3guile*
  189. %files lua
  190. %defattr(-,root,root,-)
  191. %{_libdir}/graphviz/lua/
  192. %{_libdir}/lua*/*
  193. %{_mandir}/man3/gv.3lua*
  194. %files perl
  195. %defattr(-,root,root,-)
  196. %{_libdir}/graphviz/perl/
  197. %{perl_vendorarch}/*
  198. %{_mandir}/man3/gv.3perl*
  199. %files python
  200. %defattr(-,root,root,-)
  201. %{_libdir}/graphviz/python/
  202. %{_libdir}/python*/*
  203. %{_mandir}/man3/gv.3python*
  204. %files ruby
  205. %defattr(-,root,root,-)
  206. %{_libdir}/graphviz/ruby/
  207. %{_libdir}/*ruby*/*
  208. %{_mandir}/man3/gv.3ruby*
  209. %files tcl
  210. %defattr(-,root,root)
  211. %{_libdir}/%{name}/tcl/*
  212. %{_libdir}/tcl*/*
  213. %{_datadir}/%{name}/demo
  214. # hack to include gv.3tcl only if available
  215. # always includes tcldot.3tcl, gdtclft.3tcl
  216. %{_mandir}/man3/*.3tcl*
  217. %changelog
  218. * Tue Sep 10 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.40.1-2
  219. - rebuilt with guile-2.2.
  220. * Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.40.1-1
  221. - updated to 2.40.1.
  222. - dropped all patches.
  223. - imported Patch0 from rawhide.
  224. * Wed Jun 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.0-4
  225. - rebuild with gcc-5.4.0
  226. * Sat Sep 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.0-3
  227. - rebuild with ruby-2.2.3
  228. * Sun Mar 15 2015 Ryoichi INAGAKI <ryo1@toki.waaseda.jp> 2.38.0-2
  229. - added Patch0-5 from Fedora
  230. - rebuilt with guile 2.0.11
  231. - changed BR: tcl-devel, tk-devel instead of tcl, tk
  232. - added lua subpackage
  233. * Sat Jun 28 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 2.38.0-1
  234. - update to 2.38.0
  235. * Wed Jan 15 2014 NAKAMURA Kenta <kenta@vinelinux.org> 2.36.0-1
  236. - new upstream release
  237. * Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.30.1-2
  238. - rebuilt with gd-2.1.0.
  239. * Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
  240. - new upstream release
  241. * Mon Jan 7 2013 IWAI, Masaharu <iwai@alib.jp> 2.28.0-3
  242. - build with Tcl/Tk 8.5.7-1
  243. - stop running autoreconf
  244. - add Vendor and Distribution tags
  245. * Sun Nov 11 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-2
  246. - re-enable ruby binding, which is accidentally disabled in 2.28.0-1
  247. - rewrite config_ruby.rb to build with ruby-1.9.3
  248. - add search path for ruby/config.h to CPPFLAGS for configure
  249. * Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
  250. - new upstream release
  251. - remove Patch10 (graphviz-2.26.3_dont_regard_tiger_as_the_only_ppc.patch)
  252. - add BuildRequires: librsvg2-devel
  253. * Sun Oct 10 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.26.3-2
  254. - add Patch10 to avoid build failure on ppc
  255. * Sat Oct 9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.3-1
  256. - new upstream release
  257. - built with rpm-4.8.1
  258. - split doc, guile, perl, python, ruby subpackage
  259. * Thu Apr 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-3
  260. - rebuild with libtool-2.2.6a
  261. * Sun Nov 09 2008 Shu KONNO <owa@bg.wakwak.com> 2.20.3-1
  262. - new upstream release
  263. * Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
  264. - rebuild with libXaw.so.7 (libXaw-1.0.5)
  265. * Wed Jul 16 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.20.2-1
  266. - new upstream release
  267. * Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.16.1-0vl1
  268. - new upstream release
  269. - build with expat-2.0.1
  270. - add man7
  271. * Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 2.12-0vl2
  272. - rebuild with tcl/tk-8.4.16
  273. * Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.12-0vl1
  274. - new upstream release
  275. - add BuildPrereq: swig
  276. - delete BuildPrereq: gd-progs gd-devel
  277. - add --with-mylibgd and --disable-FEATURE to configure option
  278. - update %%files
  279. * Sun Jul 30 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.6-0vl2
  280. - added BuildPrereq: ruby-devel
  281. * Tue Oct 11 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6-0vl1
  282. - new upstream release
  283. - add BuildPrereq: libtool-ltdl-devel
  284. - move pkgconfig files to %%{_libdir}/pkgconfig
  285. - add --disable-rpath --disable-static to configure option
  286. - add %%post to every package
  287. * Mon Jan 24 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2-0vl1
  288. - new upstream release
  289. - BuildPrereq: tcl >= 8.4, tk >= 8.4
  290. - add BuildPrereq: gd-progs gd-devel flex bison pkgconfig
  291. - update %%files
  292. - remove lines about Vine2.6
  293. - change License to CPL
  294. * Sun May 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.12-0vl1
  295. - source upgrade
  296. - remove patch0 and commented lines
  297. * Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl2
  298. - build for VineSeed
  299. * Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl1
  300. - source upgrade
  301. - change spec to build both VineSeed and Vine2.5/2.6
  302. - add BuildPrereq: expat-devel and Requires: libexpat
  303. - add patch0 to build against freetype2-2.1.7
  304. - stop using autogen.sh script
  305. - add BuildPrereq: tcl >= 8.3 tk >= 8.3 (VineSeed)
  306. - add graphviz-tcl package (VineSeed)
  307. * Thu Aug 7 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.9-0vl2
  308. - rebuild for new Vine
  309. * Wed Mar 05 2003 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 1.9-0vl1
  310. - import from offical site (src.rpm)