xerces-c-vl.spec 4.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152
  1. Summary: Validating XML Parser
  2. Name: xerces-c
  3. Version: 3.1.3
  4. Release: 1%{?_dist_release}
  5. License: ASL 2.0
  6. Group: System Environment/Libraries
  7. URL: http://xml.apache.org/xerces-c/
  8. Source0: http://www.apache.org/dist/xerces/c/3/sources/xerces-c-%{version}.tar.xz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  10. BuildRequires: dos2unix
  11. %description
  12. Xerces-C is a validating XML parser written in a portable subset of
  13. C++. Xerces-C makes it easy to give your application the ability to
  14. read and write XML data. A shared library is provided for parsing,
  15. generating, manipulating, and validating XML documents. Xerces-C is
  16. faithful to the XML 1.0 recommendation and associated standards:
  17. XML 1.0 (Third Edition), XML 1.1 (First Edition), DOM Level 1, 2, 3
  18. Core, DOM Level 2.0 Traversal and Range, DOM Level 3.0 Load and Save,
  19. SAX 1.0 and SAX 2.0, Namespaces in XML, Namespaces in XML 1.1, XML
  20. Schema, XML Inclusions).
  21. %package devel
  22. Summary: Header files, libraries and development documentation for %{name}
  23. Summary(ja): %{name} のヘッダファイル、ライブラリ、開発用ドキュメント
  24. Group: Development/Libraries
  25. Requires: %{name} = %{version}-%{release}
  26. %description devel
  27. This package contains the header files, static libraries and development
  28. documentation for %{name}. If you like to develop programs using %{name},
  29. you will need to install %{name}-devel.
  30. %package doc
  31. Summary: Documentation for Xerces-C++ validating XML parser
  32. Group: Documentation
  33. BuildArch: noarch
  34. %description doc
  35. Documentation for Xerces-C++.
  36. Xerces-C++ is a validating XML parser written in a portable subset of C++.
  37. Xerces-C++ makes it easy to give your application the ability to read and
  38. write XML data. A shared library is provided for parsing, generating,
  39. manipulating, and validating XML documents.
  40. %prep
  41. %setup -q
  42. # Copy samples before build to avoid including built binaries in -doc package
  43. mkdir -p _docs
  44. cp -a samples/ _docs/
  45. %build
  46. # --disable-sse2 makes sure explicit -msse2 isn't passed to gcc so
  47. # the binaries would be compatible with non-SSE2 i686 hardware.
  48. # This only affects i686, as on x86_64 the compiler uses SSE2 by default.
  49. export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
  50. export CXXFLAGS="$CFLAGS"
  51. %configure --disable-static \
  52. --disable-pretty-make \
  53. --disable-sse2
  54. make %{?_smp_mflags}
  55. %install
  56. rm -rf $RPM_BUILD_ROOT
  57. make install DESTDIR="$RPM_BUILD_ROOT"
  58. # Correct errors in encoding
  59. iconv -f iso8859-1 -t utf-8 CREDITS > CREDITS.tmp && mv -f CREDITS.tmp CREDITS
  60. # Correct errors in line endings
  61. pushd doc; dos2unix -k *.xml; popd
  62. # Remove unwanted binaries
  63. rm -rf $RPM_BUILD_ROOT%{_bindir}
  64. # Remove .la files
  65. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  66. %post -p /sbin/ldconfig
  67. %postun -p /sbin/ldconfig
  68. %clean
  69. rm -rf $RPM_BUILD_ROOT
  70. %files
  71. %defattr(-,root,root,-)
  72. %doc LICENSE
  73. %{_libdir}/libxerces-c-3.*.so
  74. %files devel
  75. %defattr(-,root,root,-)
  76. %{_libdir}/libxerces-c.so
  77. %{_libdir}/pkgconfig/xerces-c.pc
  78. %{_includedir}/xercesc/
  79. %files doc
  80. %defattr(-,root,root,-)
  81. %doc README LICENSE NOTICE CREDITS doc _docs/*
  82. %changelog
  83. * Tue Apr 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.3-1
  84. - updated to 3.1.3.
  85. * Sat Jan 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.1.1-1
  86. - updated to 3.1.1
  87. * Sat Feb 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-3
  88. - rebuild with Vine6 environment
  89. * Tue Mar 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.0-2
  90. - rebuilt with new toolchain
  91. * Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-1
  92. - initial build for Vine Linux
  93. * Mon Jun 30 2008 Peter Lemenkov <lemenkov@gmail.com> 2.8.0-2
  94. - Spec cleanups ( https://bugzilla.redhat.com/show_bug.cgi?id=435132 )
  95. * Sun Feb 10 2008 Peter Lemenkov <lemenkov@gmail.com> 2.8.0-1
  96. - Ver. 2.8.0
  97. * Sat Nov 25 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-6
  98. - typo fix
  99. * Sat Nov 25 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-5
  100. - fixed some rpmlint warnings
  101. * Fri Nov 24 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-4
  102. - Added samples to docs-package
  103. * Sat Nov 18 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-3
  104. - improvements suggested by Aurelien Bompard
  105. * Sat Oct 14 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-2
  106. - Disabled package 'samples'
  107. * Fri Oct 13 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-1
  108. - initial build for FE
  109. * Fri Jan 06 2006 Dag Wieers <dag@wieers.com> - 2.7.0-1 - 3891/dag
  110. - Cleaned SPEC file.
  111. * Tue Jan 03 2006 Dries Verachtert <dries@ulyssis.org> - 2.7.0-1
  112. - Updated to release 2.7.0.
  113. * Thu Sep 22 2005 C.Lee Taylor <leet@leenx.co.za> 2.6.1-1
  114. - Update to 2.6.1
  115. - Build for FC4 32/64bit
  116. * Sat Aug 20 2005 Che
  117. - initial rpm release