ffmpeg-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435
  1. #TODO: Build with openjpeg, opencore-amr, vo-amrwbenc
  2. #TODO: add make test to %%check section
  3. #% define svndate 20100625
  4. %global with_faac 1
  5. %global with_vaapi 1
  6. %global with_libvpx 1
  7. %global major_version 2.8
  8. Summary: Digital VCR and streaming server
  9. Name: ffmpeg
  10. Version: %{major_version}.6
  11. Release: 1%{?svndate:.%svndate}%{?_dist_release}
  12. Source: http://ffmpeg.org/releases/%{name}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
  13. ## prebuilt man pages
  14. %if 0%{?_with_amr:1}
  15. License: GPLv3+
  16. %else
  17. License: GPLv2+
  18. %endif
  19. Group: Applications/Multimedia
  20. URL: http://ffmpeg.org/
  21. BuildRequires: bzip2-devel
  22. BuildRequires: celt-devel
  23. ##BuildRequires: dirac-devel
  24. BuildRequires: freetype2-devel
  25. ##BuildRequires: frei0r-devel
  26. BuildRequires: gnutls-devel
  27. BuildRequires: gsm-devel
  28. BuildRequires: imlib2-devel
  29. BuildRequires: libdc1394-devel
  30. BuildRequires: libogg-devel
  31. BuildRequires: libass-devel
  32. %{!?_without_cdio:BuildRequires: libcdio-devel}
  33. %{!?_without_cdio:BuildRequires: libcdio-paranoia-devel}
  34. #libcrystalhd is currently broken
  35. %{?_with_crystalhd:BuildRequires: libcrystalhd-devel}
  36. BuildRequires: libraw1394-devel
  37. BuildRequires: librtmp-devel >= 2.3
  38. BuildRequires: libtheora-devel
  39. %{?with_vaapi:BuildRequires:libva-devel >= 0.31.0}
  40. BuildRequires: libvdpau-devel
  41. BuildRequires: libvorbis-devel
  42. %{?with_libvpx:BuildRequires: libvpx-devel >= 0.9.7}
  43. BuildRequires: libXvMC-devel
  44. %{?_with_opencore_amr:BuildRequires: opencore-amr-devel vo-amrwbenc-devel}
  45. %{!?_without_openal:BuildRequires: openal-soft-devel}
  46. %{?_with_opencv:BuildRequires: opencv-devel}
  47. %{?_with_openjpeg:BuildRequires: openjpeg-devel}
  48. ##BuildRequires: schroedinger-devel
  49. BuildRequires: SDL-devel
  50. BuildRequires: speex-devel
  51. ##BuildRequires: texi2html
  52. BuildRequires: zlib-devel
  53. BuildRequires: yasm
  54. # *-devel packages provided by other self-build-* should only be listed
  55. # in self-build-%{name}.spec as PreReq.
  56. #BuildRequires: a52dec-devel
  57. #BuildRequires: faac-devel
  58. #BuildRequires: lame-devel
  59. #BuildRequires: libdca-devel
  60. #BuildRequires: x264-devel >= 0.0.0-18.20111216
  61. #BuildRequires: xvidcore-devel
  62. Requires: %{name}-libs = %{version}-%{release}
  63. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  64. Obsoletes: ffmpeg < %{major_version}, ffmpeg-libs < %{major_version}, ffmpeg-devel < %{major_version}
  65. %description
  66. FFMpeg is a complete and free Internet live audio and video
  67. broadcasting solution for Linux/Unix. It also includes a digital
  68. VCR. It can encode in real time in many formats including MPEG1 audio
  69. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  70. %package libs
  71. Summary: Libraries for %{name}
  72. Group: System Environment/Libraries
  73. %description libs
  74. FFMpeg is a complete and free Internet live audio and video
  75. broadcasting solution for Linux/Unix. It also includes a digital
  76. VCR. It can encode in real time in many formats including MPEG1 audio
  77. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  78. This package contains the libraries for %{name}.
  79. %package devel
  80. Summary: Development package for %{name}
  81. Group: Development/Libraries
  82. Requires: %{name}-libs = %{version}-%{release}
  83. Requires: pkgconfig
  84. %description devel
  85. FFMpeg is a complete and free Internet live audio and video
  86. broadcasting solution for Linux/Unix. It also includes a digital
  87. VCR. It can encode in real time in many formats including MPEG1 audio
  88. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  89. This package contains development files for %{name}.
  90. %prep
  91. %setup -q -n %{name}-%{?svndate:%svndate}%{!?svndate:%version}
  92. %__sed -i "s/-O3 -g/$RPM_OPT_FLAGS/" configure
  93. %build
  94. %ifarch ppc
  95. # compile with -mlongcall on ppc/ppc64 (rf804)
  96. export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
  97. %endif
  98. ./configure \
  99. --prefix=%{_prefix} \
  100. --incdir=%{_includedir}/%{name} \
  101. --shlibdir=%{_libdir} \
  102. --libdir=%{_libdir} \
  103. --mandir=%{_mandir} \
  104. --arch=%{_target_cpu} \
  105. %ifarch %{ix86}
  106. --cpu=%{_target_cpu} \
  107. %endif
  108. %ifarch ppc
  109. --cpu=g3 \
  110. --enable-pic \
  111. %endif
  112. --enable-runtime-cpudetect \
  113. --extra-cflags="$RPM_OPT_FLAGS" \
  114. %{?_with_opencore_amr:--enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libvo-amrwbenc --enable-version3} \
  115. --enable-bzlib \
  116. %{!?_with_crystalhd:--disable-crystalhd} \
  117. --enable-zlib \
  118. %{?_with_frei0r:--enable-frei0r} \
  119. --enable-gnutls \
  120. --enable-libass \
  121. %{!?_without_cdio:--enable-libcdio} \
  122. --enable-libcelt \
  123. --enable-libdc1394 \
  124. %{?_with_libdirac:--enable-libdirac} \
  125. %{?with_faac:--enable-libfaac --enable-nonfree} \
  126. --enable-libfreetype \
  127. --enable-libgsm \
  128. --enable-libmp3lame \
  129. %{!?_without_openal:--enable-openal} \
  130. %{?_with_opencv:--enable-libopencv} \
  131. %{?_with_openjpeg:--enable-libopenjpeg} \
  132. --enable-librtmp \
  133. --enable-libspeex \
  134. --enable-libtheora \
  135. --enable-libvorbis \
  136. %{?with_libvpx:--enable-libvpx} \
  137. --enable-libx264 \
  138. --enable-libx265 \
  139. --enable-libxvid \
  140. \
  141. --enable-x11grab \
  142. --enable-avfilter \
  143. --enable-postproc \
  144. --enable-pthreads \
  145. --disable-static \
  146. --enable-shared \
  147. --enable-gpl \
  148. --disable-debug \
  149. --disable-stripping \
  150. \
  151. --disable-doc --disable-htmlpages --disable-podpages --disable-txtpages \
  152. %{?enable_avconv:--enable-avconv} \
  153. ;
  154. %__make %{?_smp_mflags}
  155. %__make alltools
  156. %install
  157. %__make install DESTDIR=$RPM_BUILD_ROOT
  158. ## install tool/qt-faststart
  159. %__install -pm755 tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
  160. # ## install man
  161. # %__mkdir_p $RPM_BUILD_ROOT%{_mandir}/man1/
  162. # %__install -m0644 doc/*.1 $RPM_BUILD_ROOT%{_mandir}/man1/
  163. %clean
  164. %{__rm} -rf $RPM_BUILD_ROOT
  165. %post libs -p /sbin/ldconfig
  166. %postun libs -p /sbin/ldconfig
  167. %files
  168. %defattr(-,root,root,-)
  169. %doc COPYING.* CREDITS Changelog README doc/ffserver.conf
  170. %{?enable_avconv:%{_bindir}/avconv}
  171. %{_bindir}/ffmpeg
  172. %{_bindir}/ffplay
  173. %{_bindir}/ffprobe
  174. %{_bindir}/ffserver
  175. %{_bindir}/qt-faststart
  176. %{?enable_avconv:%{_mandir}/man1/avconv.1*}
  177. # %{_mandir}/man1/ffmpeg*.1*
  178. # %{_mandir}/man1/ffplay*.1*
  179. # %{_mandir}/man1/ffprobe*.1*
  180. # %{_mandir}/man1/ffserver*.1*
  181. %{_datadir}/ffmpeg
  182. %files libs
  183. %defattr(-,root,root,-)
  184. %{_libdir}/lib*.so.*
  185. # %{_mandir}/man3/lib*.3.gz
  186. %files devel
  187. %defattr(-,root,root,-)
  188. %doc MAINTAINERS doc/APIchanges doc/*.txt doc/*.html
  189. %{_includedir}/ffmpeg
  190. %{_libdir}/pkgconfig/lib*.pc
  191. %{_libdir}/lib*.so
  192. %changelog
  193. * Mon Feb 15 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2.8.6-1
  194. - new upstream release
  195. * Sat Jan 23 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2.8.5-1
  196. - new upstream release
  197. * Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.7.1-2
  198. - rebuild with gnutls-3.4.7
  199. * Sat Jul 11 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.7.1-1
  200. - new upstream release
  201. * Sun May 24 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.6.3-1
  202. - new upstream release
  203. * Mon Apr 20 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.6.2-1
  204. - new upstream release
  205. * Sun Mar 22 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.6.1-1
  206. - new upstream release
  207. * Mon Mar 9 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.6-1
  208. - new upstream release
  209. * Sat Feb 21 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.4-1
  210. - new upstream release
  211. * Mon Jan 19 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.3-1
  212. - new upstream release
  213. * Fri Jan 2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.2-1
  214. - new upstream release
  215. * Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-2
  216. - add BuildRequires: libcdio-paranoia-devel
  217. * Sun Mar 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-1
  218. - new upstream release
  219. * Fri Oct 4 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.4-1
  220. - new upstream release
  221. * Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.3-1
  222. - new upstream release
  223. * Wed May 22 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.1-1
  224. - new upstream release
  225. - added man pages
  226. - added Source10: ffmpeg-1.2.1-doc.tar.xz
  227. * Thu Apr 4 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2-1
  228. - new upstream release
  229. * Tue Mar 12 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.3-1
  230. - new upstream release
  231. * Sun Feb 3 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-2
  232. - libvpx >= 0.9.7
  233. * Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-1
  234. - new upstream release /x264-0.129
  235. * Thu Sep 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.2-1
  236. - new upstream release
  237. * Mon Jun 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.1-1
  238. - new upstream release
  239. * Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11-1
  240. - new upstream release
  241. * Sat Feb 18 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.10-1
  242. - new upstream release
  243. * Wed Jan 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.1-1
  244. - new upstream release
  245. * Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9-1
  246. - new upstream release
  247. - enable CELT decoding via libcelt
  248. - enable FreeType support
  249. - drop faad2 support (dropped upstream)
  250. * Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
  251. - change release to sync with self-build-ffmpeg-vl.spec
  252. * Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
  253. - new upstream release
  254. * Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
  255. - new upstream release
  256. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
  257. - required latest x264 build
  258. - added BuildRequires: librtmp-devel >= 2.3
  259. - build PIC objects on PPC
  260. #- add qt-faststart tool
  261. * Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
  262. - new upstream release
  263. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
  264. - change release to sync with self-build-ffmpeg-vl.spec
  265. * Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
  266. - added BuildRequires: libvpx-devel >= 0.9.1
  267. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
  268. - new upstream release
  269. * Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
  270. - bumped version to pre-0.6
  271. * Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-13.20100410
  272. - updated source snapshot 20100410
  273. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
  274. - change release to sync with self-build-ffmpeg-vl.spec
  275. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
  276. - change release to sync with self-build-ffmpeg-vl.spec
  277. * Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
  278. - updated source snapshot 20100401
  279. * Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-9.20100216
  280. - updated source snapshot 20100326
  281. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
  282. - change release to sync with self-build-ffmpeg
  283. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
  284. - updated source snapshot 20100216
  285. - rebuild with recent x264-devel
  286. - updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
  287. - added BuildRequires: libvdpau-devel
  288. * Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
  289. - change release to sync with self-build-ffmpeg
  290. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
  291. - change release to sync with self-build-ffmpeg
  292. * Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
  293. - applied ffmpeg-0.5-disable-texi2html.patch
  294. - dropped BuildRequires: texi2html
  295. * Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
  296. - change release to sync with self-build-ffmpeg
  297. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
  298. - corrected release number
  299. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
  300. - new upstream release
  301. - added BuildRequires:
  302. - speex-devel
  303. - bzip2-devel
  304. * Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090227.8
  305. - 20090227 snapshot
  306. * Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
  307. - added %%{?_with_amr:%%{_datadir}/%%{name}} in %%files
  308. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
  309. - changed to PreReq: self-build-faad2 >= 2.0 from faad2-devel
  310. - dropped Requires: a52dec, faad2 in ffmpeg-libs
  311. * Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
  312. - 20090202 snapshot
  313. * Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
  314. - 20090110 snapshot
  315. - dropped some patches
  316. * Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
  317. - source updated (r15488)
  318. - fixed License: GPLv2+
  319. - added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
  320. - added BuildRequires: yasm (only %%ix86)
  321. - applied ffmpeg-cpu.patch (merged from RPM Fusion)
  322. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
  323. - spec in utf8
  324. * Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
  325. - change release to sync with self-build-ffmpeg
  326. * Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
  327. - drop "Patch100: ffmpeg-vine.patch".
  328. * Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
  329. - build with new versioning policy
  330. - change to use svn export from svn checkout on post install
  331. - fix ffmpeg-vine.patch for libswscale/swscale.c.rej
  332. * Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
  333. - [self-build-ffmpeg.spec]
  334. For all pre-required package that is provied by self-build,
  335. changed to its self-build package
  336. * Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
  337. - initial build for Vine Linux 4.2
  338. - snapshot 2008/01/28 + some Rev.11662 2008/01/29
  339. ### end of file