123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398 |
- %bcond_with check
- %{!?python_version: %define python_version %(%{__python} -c 'import sys; print sys.version.split(" ")[0]' || echo "2.3")}
- Name: numpy
- Summary: A fast multidimensional array facility for Python
- Version: 1.16.5
- Release: 1%{?_dist_release}
- Group: Development/Languages
- Vendor: Project Vine
- Distribution: Vine Linux
- License: BSD and Python and ASL 2.0
- URL: https://www.numpy.org/
- Source0: https://github.com/%{name}/%{name}/releases/download/v%{version}/%{name}-%{version}.tar.gz
- Source1: https://numpy.org/doc/1.17/numpy-html-1.16.0.zip
- Patch0: numpy-1.0.1-f2py.patch
- Patch1: numpy_doublefree.patch
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- BuildRequires: python-devel
- BuildRequires: python-rpm-macros
- BuildRequires: python-setuptools
- %if %{with check}
- BuildRequires: python-pytest
- %endif
- BuildRequires: Cython
- BuildRequires: gcc-gfortran gcc
- BuildRequires: lapack-devel
- BuildRequires: openblas-devel
- Requires: %{name}-common
- %description
- NumPy is a general-purpose array-processing package designed to
- efficiently manipulate large multi-dimensional arrays of arbitrary
- records without sacrificing too much speed for small multi-dimensional
- arrays. NumPy is built on the Numeric code base and adds features
- introduced by numarray as well as an extended C-API and the ability to
- create arrays of arbitrary type.
- There are also basic facilities for discrete fourier transform,
- basic linear algebra and random number generation. Also included in
- this package is a version of f2py that works properly with NumPy.
- %package common
- Summary: common files for numpy
- Group: Development/Libraries
- %description common
- This package includes header files for numpy.
- %package -n python-numpy-f2py
- Summary: f2py for numpy
- Group: Development/Libraries
- Requires: %{name} = %{version}-%{release}
- Requires: python-devel
- Provides: python-f2py = %{version}-%{release}
- Provides: numpy-f2py = %{version}-%{release}
- Provides: f2py = %{version}-%{release}
- Obsoletes: f2py <= 2.45.241_1927
- Obsoletes: numpy-f2py < 1.17.0
- %description -n python-numpy-f2py
- This package includes a version of f2py that works properly with NumPy.
- %package -n python3-numpy
- Summary: A fast multidimensional array facility for Python
- License: BSD
- %{?python_provide:%python_provide python3-numpy}
- Provides: libnpymath-static = %{version}-%{release}
- Provides: libnpymath-static%{?_isa} = %{version}-%{release}
- Requires: %{name}-common = %{version}-%{release}
- BuildRequires: python3-devel
- BuildRequires: python3-rpm-macros
- BuildRequires: python3-setuptools
- %if %{with check}
- BuildRequires: python3-pytest
- %endif
- BuildRequires: python3-Cython
- BuildRequires: gcc-gfortran gcc
- BuildRequires: lapack-devel
- BuildRequires: openblas-devel
- %description -n python3-numpy
- NumPy is a general-purpose array-processing package designed to
- efficiently manipulate large multi-dimensional arrays of arbitrary
- records without sacrificing too much speed for small multi-dimensional
- arrays. NumPy is built on the Numeric code base and adds features
- introduced by numarray as well as an extended C-API and the ability to
- create arrays of arbitrary type.
- There are also basic facilities for discrete fourier transform,
- basic linear algebra and random number generation. Also included in
- this package is a version of f2py that works properly with NumPy.
- %package -n python3-numpy-f2py
- Summary: f2py for numpy
- Requires: python3-numpy%{?_isa} = %{version}-%{release}
- Requires: python3-devel
- Provides: python3-f2py = %{version}-%{release}
- Obsoletes: python3-f2py <= 2.45.241_1927
- %{?python_provide:%python_provide python3-numpy-f2py}
- %description -n python3-numpy-f2py
- This package includes a version of f2py that works properly with NumPy.
- %package -n python3-numpy-doc
- Summary: Documentation for numpy
- Requires: python3-numpy = %{version}-%{release}
- BuildArch: noarch
- %description -n python3-numpy-doc
- This package provides the complete documentation for NumPy.
- %prep
- %setup -q -n %{name}-%{version}
- rm -f PKG-INFO
- cat >> site.cfg <<EOF
- [openblas]
- libraries = openblasp
- library_dirs = %{_libdir}
- EOF
- %build
- env OPENBLAS=%{_libdir} \
- BLAS=%{_libdir} \
- LAPACK=%{_libdir} CFLAGS="%{optflags}" \
- %{__python} setup.py build
- env OPENBLAS=%{_libdir} \
- BLAS=%{_libdir} \
- LAPACK=%{_libdir} CFLAGS="%{optflags}" \
- %{__python3} setup.py build
- %install
- rm -rf %{buildroot}
- mkdir docs
- pushd docs
- unzip %{SOURCE1}
- popd
- env OPENBLAS=%{_libdir} \
- FFTW=%{_libdir} BLAS=%{_libdir} \
- LAPACK=%{_libdir} CFLAGS="%{optflags}" \
- %{__python} setup.py install --root %{buildroot}
- pushd %{buildroot}%{_bindir} &> /dev/null
- ln -s f2py2 f2py.numpy2
- popd &> /dev/null
- env OPENBLAS=%{_libdir} \
- FFTW=%{_libdir} BLAS=%{_libdir} \
- LAPACK=%{_libdir} CFLAGS="%{optflags}" \
- %{__python3} setup.py install --root %{buildroot}
- pushd %{buildroot}%{_bindir} &> /dev/null
- ln -s f2py3 f2py.numpy
- popd &> /dev/null
- mkdir -p %{buildroot}%{_includedir}
- cp -rf %{buildroot}%{python3_sitearch}/%{name}/core/include/numpy %{buildroot}%{_includedir}/
- rm -f $RPM_BUILD_ROOT%{python_sitearch}/%{name}/COMPATIBILITY
- rm -f $RPM_BUILD_ROOT%{python_sitearch}/%{name}/DEV_README.txt
- rm -f $RPM_BUILD_ROOT%{python_sitearch}/%{name}/INSTALL.txt
- rm -f $RPM_BUILD_ROOT%{python_sitearch}/%{name}/LICENSE.txt
- rm -f $RPM_BUILD_ROOT%{python_sitearch}/%{name}/README.txt
- rm -f $RPM_BUILD_ROOT%{python_sitearch}/%{name}/THANKS.txt
- rm -f $RPM_BUILD_ROOT%{python_sitearch}/%{name}/site.cfg.example
- %if %{with check}
- %check
- pushd doc &> /dev/null
- PYTHONPATH="%{buildroot}%{python_sitearch}" %{__python} -c "import pkg_resources, numpy ; numpy.test()" \
- popd &> /dev/null
- %endif
- %clean
- rm -rf $RPM_BUILD_ROOT
- %files common
- %{_includedir}/numpy
- %files
- %defattr(-,root,root,-)
- %license LICENSE.txt
- %doc THANKS.txt site.cfg.example
- %dir %{python_sitearch}/%{name}
- %{python_sitearch}/%{name}/*
- %exclude %{python_sitearch}/%{name}/f2py
- %{python_sitearch}/%{name}-*.egg-info
- %exclude %{python3_sitearch}/%{name}/LICENSE.txt
- %files -n python-numpy-f2py
- %defattr(-,root,root,-)
- %{_bindir}/f2py2*
- %{_bindir}/f2py.numpy2
- %{python_sitearch}/%{name}/f2py
- %files -n python3-numpy
- %license LICENSE.txt
- %doc THANKS.txt site.cfg.example
- %dir %{python3_sitearch}/%{name}
- %{python3_sitearch}/%{name}/*
- %exclude %{python3_sitearch}/%{name}/f2py
- %{python3_sitearch}/%{name}-*.egg-info
- %exclude %{python3_sitearch}/%{name}/LICENSE.txt
- %files -n python3-numpy-f2py
- %{_bindir}/f2py
- %{_bindir}/f2py3
- %{_bindir}/f2py.numpy
- %{_bindir}/f2py%{python3_version}
- %{python3_sitearch}/%{name}/f2py
- %files -n python3-numpy-doc
- %doc docs/*
- %changelog
- * Wed Oct 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.16.5-1
- - new upstream release: this version is not newest but final version to suppot python2.
- - added python3 support.
- * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.1-9
- - rebuild with python-2.7.2
- * Wed Aug 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.1-8
- - add Patch3(changeset_r8510.diff) and Patch4(changeset_r8511.diff) from debian
- * Fri Aug 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.1-7
- - Initial build for Vine Linux
- * Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1:1.4.1-6
- - actually add the patch this time
- * Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1:1.4.1-5
- - fix segfault within %check on 2.7 (patch 2)
- * Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 1:1.4.1-4
- - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
- * Sun Jul 18 2010 Dan Horák <dan[at]danny.cz> 1.4.1-3
- - ignore the "Ticket #1299 second test" failure on s390(x)
- * Thu Jun 24 2010 Jef Spaleta <jspaleta@fedoraprject.org> 1.4.1-2
- - source commit fix
- * Thu Jun 24 2010 Jef Spaleta <jspaleta@fedoraprject.org> 1.4.1-1
- - New upstream release. Include backported doublefree patch
- * Mon Apr 26 2010 Jon Ciesla <limb@jcomserv.net> 1.3.0-8
- - Moved distutils back to the main package, BZ 572820.
- * Thu Apr 08 2010 Jon Ciesla <limb@jcomserv.net> 1.3.0-7
- - Reverted to 1.3.0 after upstream pulled 1.4.0, BZ 579065.
- * Tue Mar 02 2010 Jon Ciesla <limb@jcomserv.net> 1.4.0-5
- - Linking /usr/include/numpy to .h files, BZ 185079.
- * Tue Feb 16 2010 Jon Ciesla <limb@jcomserv.net> 1.4.0-4
- - Re-enabling atlas BR, dropping lapack Requires.
- * Wed Feb 10 2010 Jon Ciesla <limb@jcomserv.net> 1.4.0-3
- - Since the previous didn't work, Requiring lapack.
- * Tue Feb 09 2010 Jon Ciesla <limb@jcomserv.net> 1.4.0-2
- - Temporarily dropping atlas BR to work around 562577.
- * Fri Jan 22 2010 Jon Ciesla <limb@jcomserv.net> 1.4.0-1
- - 1.4.0.
- - Dropped ARM patch, ARM support added upstream.
- * Tue Nov 17 2009 Jitesh Shah <jiteshs@marvell.com> - 1.3.0-6.fa1
- - Add ARM support
- * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-6
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
- * Thu Jun 11 2009 Jon Ciesla <limb@jcomserv.net> 1.3.0-5
- - Fixed atlas BR, BZ 505376.
- * Fri Apr 17 2009 Jon Ciesla <limb@jcomserv.net> 1.3.0-4
- - EVR bump for pygame chainbuild.
- * Fri Apr 17 2009 Jon Ciesla <limb@jcomserv.net> 1.3.0-3
- - Moved linalg, fft back to main package.
- * Tue Apr 14 2009 Jon Ciesla <limb@jcomserv.net> 1.3.0-2
- - Split out f2py into subpackage, thanks Peter Robinson pbrobinson@gmail.com.
- * Tue Apr 07 2009 Jon Ciesla <limb@jcomserv.net> 1.3.0-1
- - Update to latest upstream.
- - Fixed Source0 URL.
- * Thu Apr 02 2009 Jon Ciesla <limb@jcomserv.net> 1.3.0-0.rc1
- - Update to latest upstream.
- * Thu Mar 05 2009 Jon Ciesla <limb@jcomserv.net> 1.2.1-3
- - Require python-devel, BZ 488464.
- * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
- * Fri Dec 19 2008 Jon Ciesla <limb@jcomserv.net> 1.2.1-1
- - Update to 1.2.1.
- * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.2.0-2
- - Rebuild for Python 2.6
- * Tue Oct 07 2008 Jon Ciesla <limb@jcomserv.net> 1.2.0-1
- - New upstream release, added python-nose BR. BZ 465999.
- - Using atlas blas, not blas-devel. BZ 461472.
- * Wed Aug 06 2008 Jon Ciesla <limb@jcomserv.net> 1.1.1-1
- - New upstream release
- * Thu May 29 2008 Jarod Wilson <jwilson@redhat.com> 1.1.0-1
- - New upstream release
- * Tue May 06 2008 Jarod Wilson <jwilson@redhat.com> 1.0.4-1
- - New upstream release
- * Mon Feb 11 2008 Jarod Wilson <jwilson@redhat.com> 1.0.3.1-2
- - Add python egg to %%files on f9+
- * Wed Aug 22 2007 Jarod Wilson <jwilson@redhat.com> 1.0.3.1-1
- - New upstream release
- * Wed Jun 06 2007 Jarod Wilson <jwilson@redhat.com> 1.0.3-1
- - New upstream release
- * Mon May 14 2007 Jarod Wilson <jwilson@redhat.com> 1.0.2-2
- - Drop BR: atlas-devel, since it just provides binary-compat
- blas and lapack libs. Atlas can still be optionally used
- at runtime. (Note: this is all per the atlas maintainer).
- * Mon May 14 2007 Jarod Wilson <jwilson@redhat.com> 1.0.2-1
- - New upstream release
- * Tue Apr 17 2007 Jarod Wilson <jwilson@redhat.com> 1.0.1-4
- - Update gfortran patch to recognize latest gfortran f95 support
- - Resolves rhbz#236444
- * Fri Feb 23 2007 Jarod Wilson <jwilson@redhat.com> 1.0.1-3
- - Fix up cpuinfo bug (#229753). Upstream bug/change:
- http://projects.scipy.org/scipy/scipy/ticket/349
- * Thu Jan 04 2007 Jarod Wilson <jwilson@redhat.com> 1.0.1-2
- - Per discussion w/Jose Matos, Obsolete/Provide f2py, as the
- stand-alone one is no longer supported/maintained upstream
- * Wed Dec 13 2006 Jarod Wilson <jwilson@redhat.com> 1.0.1-1
- - New upstream release
- * Tue Dec 12 2006 Jarod Wilson <jwilson@redhat.com> 1.0-2
- - Rebuild for python 2.5
- * Wed Oct 25 2006 Jarod Wilson <jwilson@redhat.com> 1.0-1
- - New upstream release
- * Wed Sep 06 2006 Jarod Wilson <jwilson@redhat.com> 0.9.8-1
- - New upstream release
- * Wed Apr 26 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.9.6-1
- - Upstream update
- * Thu Feb 16 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.9.5-1
- - Upstream update
- * Mon Feb 13 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.9.4-2
- - Rebuild for Fedora Extras 5
- * Thu Feb 2 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.9.4-1
- - Initial RPM release
- - Added gfortran patch from Neal Becker
|