rhythmbox-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621
  1. # -*- coding: utf-8-unix -*-
  2. %define desktop_file_utils_version 0.9
  3. %define enable_DLNA_UPnP 0
  4. Summary: Music Management Application
  5. Summary(ja): 音楽管理アプリケーション
  6. Name: rhythmbox
  7. Version: 2.98
  8. Release: 1%{?_dist_release}
  9. License: GPL2+ with exceptions and GFDL
  10. Group: Applications/Multimedia
  11. URL: http://projects.gnome.org/rhythmbox/
  12. Source0: http://download.gnome.org/sources/rhythmbox/2.98/%{name}-%{version}.tar.xz
  13. Source101: rhythmbox-png.tar.bz2
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: gtk3-devel
  16. BuildRequires: avahi-glib-devel >= 0.6
  17. BuildRequires: brasero-devel >= 2.32.0
  18. BuildRequires: dbus-glib-devel
  19. BuildRequires: gstreamer-plugins-base-devel >= 0.10
  20. BuildRequires: json-glib-devel
  21. BuildRequires: libSM-devel
  22. BuildRequires: libgnome-keyring-devel >= 2.30.0
  23. BuildRequires: libgpod-devel
  24. BuildRequires: libgudev1-devel
  25. BuildRequires: libmusicbrainz3-devel >= 3.0.2
  26. BuildRequires: libnotify-devel
  27. BuildRequires: libsoup-devel
  28. BuildRequires: pygobject3-devel
  29. BuildRequires: totem-pl-parser-devel
  30. BuildRequires: WebKit3-gtk-devel
  31. BuildRequires: libpeas-devel
  32. BuildRequires: clutter-gtk-devel
  33. BuildRequires: clutter-gst-devel
  34. BuildRequires: libmx-devel
  35. BuildRequires: check-devel
  36. BuildRequires: libmtp-devel
  37. BuildRequires: libtdb-devel
  38. BuildRequires: grilo-devel
  39. BuildRequires: libdmapsharing-devel
  40. BuildRequires: lirc
  41. BuildRequires: gnome-doc-utils >= 0.3.2
  42. Requires: libgpod
  43. Requires: libnotify
  44. Requires: lirc
  45. Requires: libmtp
  46. Requires: brasero
  47. Requires: gnome-themes
  48. Requires: libgnome-keyring
  49. %if %{enable_DLNA_UPnP}
  50. Requires: python-Coherence
  51. %endif
  52. Requires: desktop-file-utils >= %{desktop_file_utils_version}
  53. Requires: scrollkeeper
  54. # # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
  55. # # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
  56. # # respectively.
  57. # Requires: self-build-gstreamer-plugins-ffmpeg
  58. # Requires: self-build-gstreamer-plugins-ugly
  59. Vendor: Project Vine
  60. Distribution: Vine Linux
  61. %description
  62. Rhythmbox is an integrated music management application based on the powerful
  63. GStreamer media framework. It has a number of features, including an easy to
  64. use music browser, searching and sorting, comprehensive audio format support
  65. through GStreamer, Internet Radio support, playlists and more.
  66. Rhythmbox is extensible through a plugin system.
  67. %description -l ja
  68. Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
  69. 統合音楽管理アプリケーションです。
  70. 見やすいユーザインターフェースを備え、検索や整列ができ、
  71. GStreamer により数多くの音声フォーマットをサポート、
  72. インターネットラジオをサポート、プレイリスト管理などの
  73. 数多くの特徴を持ちます。
  74. %package devel
  75. Summary: Development tools for rhythmbox applications.
  76. Summary(ja): rhythmbox アプリケーションの開発用ファイル
  77. Group: Development/Libraries
  78. Requires: %{name} = %{version}-%{release}
  79. Requires: pkgconfig
  80. Requires: libxml2-devel
  81. Requires: glib2-devel
  82. Requires: gtk3-devel
  83. Requires: libsoup-devel
  84. Requires: totem-pl-parser-devel
  85. Requires: gstreamer-devel
  86. %description devel
  87. Header files and libraries for building a extension library for the rhythmbox.
  88. %description devel -l ja
  89. %prep
  90. %setup -q
  91. tar xjf %{SOURCE101}
  92. %build
  93. # work around a gstreamer bug
  94. /usr/bin/gst-inspect-0.10 --print-all >& /dev/null || :
  95. libtoolize --force --copy
  96. autoreconf
  97. %configure --with-ipod \
  98. --with-mtp \
  99. --with-mdns=avahi \
  100. --enable-lirc \
  101. --enable-python \
  102. --disable-vala \
  103. --disable-browser-plugin \
  104. --disable-static \
  105. --disable-scrollkeeper \
  106. --enable-browser-plugin \
  107. --without-hal
  108. %__make %{?_smp_mflags}
  109. %install
  110. %__rm -rf $RPM_BUILD_ROOT
  111. %__make install DESTDIR=$RPM_BUILD_ROOT
  112. %__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
  113. %__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
  114. %__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
  115. %__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
  116. %__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
  117. %__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
  118. %__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
  119. ## Don't package DLNA/UPnP plugin
  120. %if !%{enable_DLNA_UPnP}
  121. %__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
  122. %endif
  123. %find_lang %{name} --all-name --with-gnome
  124. # Don't package api docs
  125. %__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
  126. # Don't package scrollkeeper catalogs
  127. %__rm -rf $RPM_BUILD_ROOT%{_localstatedir}
  128. # And don't package vala
  129. %__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
  130. %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
  131. # remove sample plugins
  132. rm -rf $RPM_BUILD_ROOT/%{_libdir}/%{name}/sample-plugins
  133. %clean
  134. %__rm -rf $RPM_BUILD_ROOT
  135. %post
  136. /sbin/ldconfig
  137. update-desktop-database -q
  138. scrollkeeper-update -q
  139. touch --no-create %{_datadir}/icons/hicolor
  140. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  141. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  142. fi
  143. %postun
  144. /sbin/ldconfig
  145. update-desktop-database -q
  146. scrollkeeper-update -q
  147. touch --no-create %{_datadir}/icons/hicolor
  148. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  149. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  150. fi
  151. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  152. %posttrans
  153. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  154. %files -f %{name}.lang
  155. %defattr(-, root, root)
  156. %doc AUTHORS COPYING ChangeLog README NEWS
  157. %{_bindir}/*
  158. %{_libdir}/girepository-1.0/*.typelib
  159. %{_libdir}/lib*.so.*
  160. %{_libdir}/mozilla/plugins/librhythmbox-itms-detection-plugin.so
  161. %{_libdir}/rhythmbox/plugins
  162. %{_datadir}/applications/rhythmbox.desktop
  163. %{_datadir}/applications/rhythmbox-device.desktop
  164. %{_datadir}/dbus-1/services/org.gnome.Rhythmbox3.service
  165. %{_datadir}/glib-2.0/schemas/org.gnome.rhythmbox.gschema.xml
  166. %{_datadir}/icons/*
  167. %{_datadir}/rhythmbox
  168. %{_mandir}/man1/*
  169. %{_libexecdir}/rhythmbox-metadata
  170. %files devel
  171. %defattr(-, root, root)
  172. %{_includedir}/%{name}/*
  173. %{_libdir}/*.so
  174. %{_libdir}/pkgconfig/*.pc
  175. %{_datadir}/gir-1.0/*.gir
  176. %changelog
  177. * Mon Oct 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.98-1
  178. - new upstream release
  179. - add BuildRequires: grilo-devel, libdmapsharing-devel
  180. * Tue Jun 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.97-1
  181. - new upstream release
  182. * Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.96-1
  183. - new upstream release
  184. * Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.95-1
  185. - new upstream release
  186. - add BuildRequires: gtk3-devel, libtdb-devel, pygobject3-devel
  187. - remove BuildRequires: gnome-vfs2-devel, gstreamer-python-devel, libffi-devel, libgnome-media-profiles-devel, libgnomeui-devel, libsexy-devel, popt-devel, python-devel, pygtk2-devel, sqlite3-devel
  188. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-4
  189. - rebuild with cogl-0.8.0
  190. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-3
  191. - rebuild with libnotify-0.7
  192. - change BuildRequires: libmusicbrainz3-devel instead of libmusicbrainz-devel
  193. - change BuildRequires: libgnome-media-profiles-devel instead of gnome-media-devel
  194. - add BuildRequires: WebKit3-gtk-devel, libpeas-devel, clutter-gtk-devel, clutter-gst-devel, libmx-devel
  195. - add Patch0 (rhythmbox-0.13.3-git20110809.patch)
  196. - add Source101 (rhythmbox-png.tar.bz2)
  197. * Fri Aug 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-2
  198. - add BuildRequires: json-glib-devel
  199. - remove unrecognized configure option (--with-dbus, --with-cd-burning, --with-metadata-helper)
  200. * Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-1
  201. - new upstream release
  202. - change BuildRequires: gstreamer-python-devel instead of gstreamer-python
  203. * Sat Nov 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.2-1
  204. - new upstream release
  205. * Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-3
  206. - rebuild with brasero-2.32.0
  207. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-2
  208. - rebuild with rpm-4.8.1 for pkg-config file
  209. * Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-1
  210. - new upstream release
  211. - fix %files (add rhythmbox-device.desktop)
  212. * Sun Aug 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.0-1
  213. - new upstream release
  214. - change BuildRequires: gnome-media-devel instead of gnome-media
  215. - add devel package
  216. - drop Patch0
  217. * Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.8-1
  218. - new upstream release
  219. - drop Patch1, Patch2, Patch3
  220. - change BuildRequires: nautilus-cd-burner -> brasero-devel
  221. - change Requires: nautilus-cd-burner -> brasero
  222. - change BuildRequires: hal-devel -> libgudev1-devel
  223. - change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
  224. - change Requires: gnome-keyring -> libgnome-keyring
  225. - add configure option (--without-hal)
  226. * Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
  227. - rebuilt with new environment
  228. * Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
  229. - new upstream release
  230. - dropped upstreamed/obsolete patches
  231. - added patches applied Fedora development
  232. * Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
  233. - new upstream release
  234. - added configure options:
  235. --disable-vala
  236. --disable-browser-plugin
  237. * Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
  238. - added Japanese description
  239. * Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
  240. - new upstream release
  241. - dropped rb-disable-power-plugin-by-default.patch
  242. - added BuildRequires:
  243. - libSM-devel
  244. - gnome-media
  245. * Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
  246. - rebuild with libgpod-0.7.2
  247. * Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
  248. - new upstream release
  249. - corrected License tag
  250. - dropped rhythmbox-0.11.6-libmtp.patch
  251. - added BuildRequires:
  252. - sqlite3-devel
  253. - libffi-devel
  254. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
  255. - defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
  256. - applied rhythmbox-0.11.6-libmtp.patch
  257. - added Requires:
  258. - libgpod
  259. - libnotify
  260. - libsexy
  261. - lirc
  262. - libmtp
  263. - libgnomeui
  264. - nautilus-cd-burner
  265. - gstreamer-python
  266. - gnome-vfs2
  267. - gnome-themes
  268. - gnome-keyring
  269. - python-Coherence, if enable_DLNA_UPnP = 1
  270. - added BuildRequires:
  271. - libnotify-devel
  272. - libsexy-devel
  273. - lirc
  274. - libmtp-devel
  275. - gnome-vfs2-devel, instead of gnome-vfs2
  276. - gnome-keyring-devel
  277. - dropped --with-internal-libsexy in configure options
  278. - added in configure options:
  279. --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
  280. - added %%preun to remove the schema
  281. * Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
  282. - new upstream release
  283. - changed to --with-metadata-helper in configure options
  284. - added BuildRequires:
  285. - gstreamer-python
  286. - intltool >= 0.35.0
  287. - popt-devel
  288. * Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
  289. - added BuildRequires: totem-pl-parser-devel, instead of totem-devel
  290. - rebuilt with python-2.5.2
  291. - applied new versioning policy
  292. - spec in utf-8
  293. * Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
  294. - rebuilt with libgpod-0.6.0
  295. * Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
  296. - new upstream release
  297. * Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
  298. - new upstream release
  299. * Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
  300. - rebuilt with new toolchain and libgpod-0.4.2
  301. - add BuildRequires: dbus-glib-devel
  302. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
  303. - new upstream release
  304. * Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
  305. - rebuilt for VineSeed
  306. * Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
  307. - new upstream release
  308. - added --enable-python option to %%configure
  309. - added Requires: gnome-python
  310. * Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
  311. - new upstream release
  312. - built with libsoup 2.2.99
  313. * Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
  314. - added --with-cd-burner to configure
  315. - added BuildRequires: libsexy-devel hal-devel libsoup-devel
  316. * Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
  317. - add BuildRequires:
  318. - gnome-doc-utils >= 0.3.2
  319. - python-devel
  320. - pygtk2-devel
  321. - check >= 0.8.2
  322. * Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
  323. - rebuild with gnutls-1.4.1
  324. * Sun Oct 1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
  325. - new upstream release
  326. * Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
  327. - new upstream release
  328. - run scrollkeeper-update at %post and %postun
  329. - added BuildRequires: libnotify-devel
  330. * Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
  331. - new upstream release (dropped patch0)
  332. - added --without-metadata-helper at configure
  333. * Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
  334. - Initial build for Vine Linux based on FC pacakge
  335. * Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
  336. - add patch from James "Doc" Livingston to stop a hang
  337. for new users (bug 183883)
  338. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
  339. - bump again for double-long bug on ppc(64)
  340. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
  341. - rebuilt for new gcc4.1 snapshot and glibc changes
  342. * Sat Feb 4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
  343. - Update to 0.9.3.1
  344. - Use gstreamer (0.10)
  345. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
  346. - Remove hack for 173869, as its no longer needed.
  347. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
  348. - 0.9.3
  349. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
  350. - Newer CVS snapshot
  351. * Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
  352. - Update to latest CVS
  353. - Add hack to workaround bug #173869
  354. * Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
  355. - Rebuild, now that gstreamer08-plugins has been fixed
  356. * Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
  357. - bonobo multilib issue (bug 156982)
  358. * Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
  359. - rebuild with ipod support
  360. * Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
  361. - rebuilt again
  362. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  363. - rebuilt
  364. * Mon Dec 5 2005 Matthias Clasen <mclasen@redhat.com>
  365. - rebuild
  366. * Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
  367. - rebuild for new dbus
  368. * Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
  369. - Update to 0.9.2
  370. * Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
  371. - Update to 0.9.1
  372. * Fri Sep 02 2005 Colin Walters <walters@redhat.com>
  373. - Add configure flags --with-bonobo --with-dbus
  374. - BR nautilus-cd-burner-devel
  375. - New upstream CVS snapshot for testing
  376. - Drop IDL file and ui .xml
  377. - Add dbus service file
  378. - Drop upstreamed rhythmbox-bluecurve.tar.gz
  379. - Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
  380. * Fri Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
  381. - Add Bluecurve-ized icons from Jeff Schroeder (157716)
  382. - Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
  383. cell renderer for playback icon (no longer necessary) and
  384. changes the rating renderer to work with non-b&w icons
  385. * Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
  386. - Rebuild for GCC4
  387. * Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
  388. - New upstream version
  389. - Remove librb-nautilus-context-menu.so, killed upstream
  390. * Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
  391. - PreReq desktop-file-utils >= 0.9
  392. * Sat Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
  393. - New upstream version
  394. * Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
  395. - Fix postun to use correct syntax, thanks Nils Philippsen
  396. * Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
  397. - New upstream version
  398. - Call update-desktop-database in post and postun
  399. * Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
  400. - New upstream version
  401. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  402. - rebuilt
  403. * Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
  404. - New upstream version
  405. - Remove backported patches
  406. - Gratuitiously bump various BuildRequires versions
  407. * Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
  408. - Remove code to unregister GConf schema for now (Closes: #122532)
  409. * Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
  410. - Apply tiny patch from 0.8 arch to fix GConf key used
  411. for initial sorting
  412. * Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
  413. - Apply patch from 0.8 arch tree to fix a number of memleaks
  414. * Thu May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
  415. - Update to 0.8.3: fixes showstopper bug with internet radio
  416. * Thu Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
  417. - Update to 0.8.2
  418. - Fix Source url
  419. - Add smp_mflags
  420. - Bump BuildRequires on gstreamer to 0.8.1
  421. * Tue Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
  422. - Uninstall GConf schemas on removal
  423. * Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
  424. - Update to 0.8.1
  425. * Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
  426. - Update to 0.8.0
  427. * Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
  428. - Update to 0.7.2
  429. * Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
  430. - Remove BuildRequires on autoconf and libvorbis-devel
  431. * Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
  432. - New major version - I know we are past major version slush, but
  433. this should have been done two weeks ago along with the GNOME 2.6
  434. upload. As upstream author as well, I believe this version is
  435. good enough for FC2.
  436. - Remove --disable-mp3
  437. - Remove id3, flac variables
  438. - Remove GStreamer major version patch
  439. - Fix typo in description
  440. * Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
  441. - rebuild for new gstreamer
  442. * Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
  443. - update to 0.6.8
  444. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  445. - rebuilt
  446. * Mon Mar 1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
  447. - update to 0.6.7
  448. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  449. - rebuilt
  450. * Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
  451. - New upstream version
  452. - Don't re-run the autotools; upstream incorporates newer versions.
  453. * Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
  454. - new version
  455. - remove smp_flags
  456. * Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
  457. - remove the initial iradio channels as they all are mp3 based.
  458. * Wed Oct 8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
  459. - Fix category from Development/Libraries to Applications/Multimedia.
  460. - Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
  461. - Fix SCHEMES vs. SCHEMAS in the post scriplet.
  462. - Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
  463. - Removed unnecessary date expansion define.
  464. - Updated description, including mp3 reference removal.
  465. - Added libid3tag and flac optional support for convenient rebuild.
  466. - Removed obsolete omf.make and xmldocs.make (included ones are the same now).
  467. * Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
  468. - new version
  469. - use %{_sysconfdir} instead of /etc
  470. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  471. - rebuilt
  472. * Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
  473. - gave up on other archs for the Beta
  474. - new version
  475. - remove werror and add missing files
  476. * Thu Nov 7 2002 Jeremy Katz <katzj@redhat.com>
  477. - update to newer cvs snap
  478. * Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
  479. - update to cvs snap
  480. * Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
  481. - use %%(lang)
  482. * Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
  483. - fix post to actually install the schema
  484. * Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
  485. - Added gconf file
  486. - Added i18n directory
  487. * Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
  488. - Updated for new rewrite of rhythmbox, thanks to Jeroen
  489. * Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
  490. - removed bonobo dependency
  491. * Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
  492. - created new spec file