123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388 |
- Summary: Tools for configuring the console (keyboard, virtual terminals, etc.)
- Summary(ja): コンソール(キーボードや仮想ターミナル等)を設定するツール群
- Name: kbd
- Version: 1.12
- Release: 21%{?_dist_release}
- License: GPL
- Group: System Environment/Base
- Source0: ftp://ftp.kernel.org/pub/linux/utils/kbd/kbd-%{version}.tar.bz2
- Source1: ftp://ftp.kernel.org/pub/linux/utils/kbd/kbd-%{version}.tar.bz2.sign
- #Source2: kbdrate.apps
- #Source3: kbdrate.pam
- Source4: kbd-latsun-fonts.tar.bz2
- Requires: pam >= 0.66-4, /etc/pam.d/system-auth, usermode
- BuildRequires: bison, flex, gettext
- BuildRoot: %{_tmppath}/%{name}-root
- Patch0: kbd-1.12-sparc.patch
- Patch1: kbd-1.08-compose.patch
- Patch2: kbd-1.08-terminal.patch
- Patch3: kbd-1.08-rukbd.patch
- Patch4: kbd-1.12-setfont-man.patch
- Patch5: kbd-1.12-Meta_utf8.patch
- Patch6: kbd-1.12-nostrip.patch
- Patch7: kbd-1.12-alias.patch
- Patch8: kbd-1.12-dir.patch
- Patch9: kbd-1.12-no-user-map.patch
- Patch10: kbd-1.12-resizecon-man.patch
- Patch11: kbd-1.12-gr-el.patch
- Patch12: kbd-1.12-keycodes-man.patch
- Obsoletes: console-tools open
- Provides: console-tools open
- Conflicts: util-linux < 2.11r-9
- Prereq: initscripts >= 5.86-1
- ExcludeArch: s390 s390x
- %description
- The %{name} package contains tools for managing a Linux
- system's console's behavior, including the keyboard, the screen
- fonts, the virtual terminals and font files.
- %prep
- %setup -q -a 4
- %patch0 -p1 -b .sparc
- %patch1 -p1
- %patch2 -p1 -b .terminal
- %patch3 -p1
- %patch4 -p1 -b .man
- %patch5 -p1 -b .Meta_utf8
- %patch6 -p1 -b .nostrip
- %patch7 -p1 -b .alias
- %patch8 -p1 -b .dir
- %patch9 -p1 -b .no-user-map
- %patch10 -p1 -b .resizecon-man
- %patch11 -p1 -b .gr-el
- %patch12 -p1 -b .keycodes-man
- # 7-bit maps are obsolete; so are non-euro maps
- pushd data/keymaps/i386
- mv qwerty/fi.map qwerty/fi-old.map
- cp qwerty/fi-latin9.map qwerty/fi.map
- cp qwerty/pt-latin9.map qwerty/pt.map
- cp qwerty/sv-latin1.map qwerty/se-latin1.map
- mv azerty/fr.map azerty/fr-old.map
- cp azerty/fr-latin9.map azerty/fr.map
- cp azerty/fr-latin9.map azerty/fr-latin0.map # legacy alias
- popd
- # Default to latarcyrheb-sun16 font for unicode
- perl -pi -e 's/LatArCyrHeb-16/latarcyrheb-sun16/' src/unicode_start
- %build
- export OLD_PO_FILE_INPUT=yes
- # We don't use % {configure} because the ./configure included here does not
- # understand most of the options.
- CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
- ./configure --prefix=%{_prefix} --datadir=/lib/kbd --mandir=%{_mandir}
- # Override CFLAGS because this configure ignores them anyway, and LDFLAGS
- # because it defaults to -s, but that's a build policy decision.
- make CFLAGS="$RPM_OPT_FLAGS" LDFLAGS=
- %install
- rm -rf $RPM_BUILD_ROOT
- # Basic install.
- make install DESTDIR=$RPM_BUILD_ROOT
- # The rhpl keyboard layout table is indexed by kbd layout names, so we need a
- # Korean keyboard
- ln -s us.map.gz $RPM_BUILD_ROOT/lib/kbd/keymaps/i386/qwerty/ko.map.gz
- # Move binaries which we use before /usr is mounted from %{_bindir} to /bin.
- for binary in setfont dumpkeys kbd_mode unicode_start unicode_stop ; do
- mv $RPM_BUILD_ROOT%{_bindir}/$binary $RPM_BUILD_ROOT/bin
- done
- # Some microoptimization
- sed -i -e 's,\<kbd_mode\>,/bin/kbd_mode,g;s,\<setfont\>,/bin/setfont,g' \
- $RPM_BUILD_ROOT/bin/unicode_start
- # Set up kbdrate to be userhelpered.
- #mkdir -p $RPM_BUILD_ROOT%{_sbindir}
- #mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/security/console.apps
- #mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pam.d
- #mv $RPM_BUILD_ROOT%{_bindir}/kbdrate $RPM_BUILD_ROOT%{_sbindir}
- #ln -s consolehelper $RPM_BUILD_ROOT%{_bindir}/kbdrate
- #install -c -m644 %{SOURCE2} \
- # $RPM_BUILD_ROOT%{_sysconfdir}/security/console.apps/kbdrate
- #install -c -m644 %{SOURCE3} \
- # $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/kbdrate
- rm -f %{buildroot}/%{_bindir}/kbdrate
- # Link open to openvt
- ln -s openvt $RPM_BUILD_ROOT%{_bindir}/open
- %find_lang %{name}
- %clean
- [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
- %triggerun -- kbd < 1.08-10.2
- /sbin/chkconfig --del keytable || :
- %files -f %{name}.lang
- %defattr(-,root,root)
- %doc CHANGES CREDITS README doc/kbd.FAQ*.html doc/font-formats/*.html doc/utf/utf*
- /bin/*
- %{_bindir}/*
- %{_mandir}/*/*
- /lib/kbd
- %changelog
- * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.12-21vl5
- - applied new versioning policy, spec in utf-8
- * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12-21vl1
- - initial build for Vine Linux based on Fedora package.
- * Tue Jan 9 2007 Miloslav Trmac <mitr@redhat.com> - 1.12-21
- - Add a "ko" (Korean) keyboard layout, equivalent to the "us" layout
- Resolves: #220151
- * Thu Dec 7 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-20
- - Document that setkeycodes doesn't affect USB keyboards and that the kernel
- doesn't provide the raw scan codes by default
- Resolves: #211803
- * Tue Oct 31 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-19
- - Ship "el" translation instead of the obsolete "gr" translation
- Resolves: #210749
- - Fix %% quoting in %%changelog
- * Fri Sep 29 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-18
- - Add a missing tilde to U+00E3 in latarcyrheb-sun16.psfu (#204470)
- * Fri Jul 14 2006 Jesse Keating <jkeating@redhat.com> - 1.12-17
- - Obsoletes/Provides open
- - Create a symlink from open to openvt
- * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.12-16.1
- - rebuild
- * Sun Jul 9 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-16
- - Don't include <asm/kbdio.h> on SPARC (#198040, patch by Dennis Gilmore
- <dennis@ausil.us>)
- * Mon May 29 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-15
- - Fix missing BuildRequires (#193406)
- * Mon Mar 27 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-14
- - Don't install resizecons.8 on non-x86 (#186877, patch by Keiichi Mori
- <kmori@redhat.com>)
- * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.12-13.2
- - bump again for double-long bug on ppc(64)
- * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.12-13.1
- - rebuilt for new gcc4.1 snapshot and glibc changes
- * Fri Jan 20 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-13
- - Fix build with new coreutils
- - Hardcode paths in unicode_start to avoid a few file lookups (#178329)
- - Drop unnecessary Prereq: sed mktemp
- * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
- - rebuilt
- * Thu Dec 1 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-12
- - Don't reload the keymap in unicode_start (#172425)
- * Fri Nov 11 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-11
- - Don't ship character set lists (they are already in glibc-common) and an
- obsolete copy of kbd.FAQ
- * Fri May 20 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-10
- - Don't attempt to open directories as source files (#141634, original patch by
- Paul Nasrat)
- * Tue May 17 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-9
- - Fix another violation of C aliasing rules (#157720, patch by Jan Kratochvil)
- * Sat Mar 12 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-8
- - Fix violation of C aliasing rules (#150440)
- * Sun Mar 6 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-7
- - Don't run ldconfig
- - Don't strip executables
- * Fri Mar 4 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-6
- - Rebuild with gcc4
- * Sun Feb 20 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-5
- - Put "Meta_acute" back in German keymaps, just ignore it in (loadkeys -u)
- (patch by Jochen Schmitt)
- - Don't ship patch backup files, simpler way
- * Sat Feb 19 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-4
- - Don't ship a patch backup file
- - Mention in setfont.8 that 512-glyph fonts reduce the number of available
- colors (#140935, patch by Dmitry Butskoj)
- - Remove "Meta_acute" from German keymaps (#143124)
- - Make the %%triggerun script condition more precise, ignore failure of the
- script
- * Mon Feb 14 2005 Adrian Havill <havill@redhat.com>
- - rebuilt
- * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
- - rebuilt
- * Thu Feb 26 2004 Adrian Havill <havill@redhat.com>
- - update to 1.12
- * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
- - rebuilt
- * Wed Jan 14 2004 Bill Nottingham <notting@redhat.com> 1.08-12
- - remove speakup patch at request of author
- * Fri Oct 10 2003 Bill Nottingham <notting@redhat.com> 1.08-11
- - remove keytable init script (#106783)
- * Tue Aug 12 2003 Adrian Havill <havill@rtedhat.com> 1.08-10.1
- - bump for RHEL
- * Tue Aug 12 2003 Adrian Havill <havill@rtedhat.com> 1.08-10
- - apply the rukbd patch (#78218)
- * Thu Jul 31 2003 Adrian Havill <havill@redhat.com> 1.08-9
- - don't print "plus before..." warnings about non-supported capslock
- in unimode <Andries.Brouwer@cwi.nl> (#81855)
- * Wed Jul 30 2003 Adrian Havill <havill@redhat.com> 1.08-8
- - replaced Russian keyboard map with working UTF-8 equivalent (#79338)
- * Thu Jul 24 2003 Adrian Havill <havill@redhat.com> 1.08-7
- - make euro/latin-9 the default instead of latin-1 and 7-bit (#97013)
- - fix swedish keymap; se, not sv (#88791)
- - add fr-latin0 legacy alias of fr-latin-9 (#88324)
- - add ".map" ext to filename param of init script (#90562)
- * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
- - rebuilt
- * Thu Mar 06 2003 Florian La Roche <Florian.LaRoche@redhat.de>
- - build new rpm
- * Fri Feb 21 2003 Florian La Roche <Florian.LaRoche@redhat.de>
- - ExcludeArch mainframe
- * Thu Jan 30 2003 Bill Nottingham <notting@redhat.com> 1.08-4
- - remove condrestart from initscript
- * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
- - rebuilt
- * Fri Dec 6 2002 Nalin Dahyabhai <nalin@redhat.com> 1.08-2
- - only output terminal unicode init sequence if both stdout and stderr are
- connected to terminals, so that it doesn't show up when script outputs
- get piped to files
- * Fri Nov 22 2002 Nalin Dahyabhai <nalin@redhat.com> 1.08-1
- - update to 1.08
- - drop updates which went mainline
- * Mon Nov 11 2002 Nalin Dahyabhai <nalin@redhat.com> 1.06-27
- - add detached signature
- - remove directory names from PAM configuration so that the same config file
- can be used for any arch on multilib systems
- * Wed Sep 4 2002 Bill Nottingham <notting@redhat.com> 1.06-26
- - don't munge /etc/sysconfig/i18n
- * Tue Sep 3 2002 Bill Nottingham <notting@redhat.com> 1.06-25
- - don't run setsysfont in upgrade trigger on console-tools
- * Thu Aug 29 2002 Jakub Jelinek <jakub@redhat.com> 1.06-24
- - use cyr-sun16 cyrillic chars in latarcyrheb-sun16 font
- instead of old LatArCyrHeb-16 chars
- - add Euro character to latarcyrheb-sun16
- - use latarcyrheb-sun16 by default in unicode_start script
- * Tue Aug 27 2002 Jakub Jelinek <jakub@redhat.com> 1.06-23
- - add back lat[02]-sun16 fonts plus latarcyrheb-sun16 font
- * Thu Aug 22 2002 Karsten Hopp <karsten@redhat.de>
- - needs to conflict with older util-linux packages
- (kbdrate moved between packages)
- * Tue Aug 13 2002 Bill Nottingham <notting@redhat.com> 1.06-21
- - remove Evil Hack in favor of slightly-less-evil-hack in initscripts
- * Tue Jul 9 2002 Bill Nottingham <notting@redhat.com> 1.06-20
- - fix speakup keymap names
- * Tue Jul 09 2002 Phil Knirsch <pknirsch@redhat.com> 1.06-19
- - Evil hack to make setfont work correctly on all consoles (#68018)
- * Thu Jun 27 2002 Bill Nottingham <notting@redhat.com> 1.06-18
- - move unicode_stop to /bin too
- - fix path to loadkeys in keytable.init
- - add in speakup keymaps
- * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
- - automated rebuild
- * Tue Jun 11 2002 Nalin Dahyabhai <nalin@redhat.com> 1.06-16
- - fix incorrect path in console.apps configuration file
- * Thu May 30 2002 Bill Nottingham <notting@redhat.com> 1.06-14
- - move some more stuff to /bin (unicode_start and dependencies)
- * Thu May 23 2002 Tim Powers <timp@redhat.com>
- - automated rebuild
- * Mon Feb 25 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-12
- - Rebuild in new environment
- * Wed Jan 30 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-11
- - Oops, actually list the pam files in %%files
- * Tue Jan 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-10
- - Add and consolehelper'ify kbdrate
- * Tue Jan 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-9
- - Re-remove kbdrate
- * Thu Jan 24 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-7
- - Fix build in current environment
- - Get rid of kbdrate, it's in util-linux these days
- * Wed Jul 18 2001 Matt Wilson <msw@redhat.com>
- - added a patch (Patch4) that allows --tty= in setfont
- - modified patch not to break translations
- * Tue Jul 3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-4
- - Add cyrillic patches from leon@geon.donetsk.ua (#47144)
- * Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-3
- - Fix "Alt+AltGr=Compose" in qwertz-keyboards
- * Mon Jun 25 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-2
- - Fix "make install" and init script (#45327)
- * Sat Jun 16 2001 Than Ngo <than@redhat.com>
- - update to 1.0.6
- - use %%{_tmppath}
- - use find_lang
- - support new gettext
- - remove some patch files, which are included in 1.0.6
- - fix to use RPM_OPT_FLAGS
- * Thu May 3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.05-3
- - Fix up resizecons
- * Wed May 2 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.05-2
- - Build everything, obsoletes console-tools
- - s/Copyright:/License:/
- - License is GPL, not just distributable
- - Add our compose mappings from old console-tools
- - Add triggerpostun -- console-tools magic to get sane fonts and mappings
- * Tue Apr 17 2001 Erik Troan <ewt@redhat.com>
- - initial packaging for kbdrate
|