setup-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391
  1. Summary: A set of system configuration and setup files.
  2. Summary(ja): システム設定およびセットアップファイル一式
  3. Name: setup
  4. Version: 2.8.31
  5. Release: 1%{?_dist_release}
  6. License: Public Domain
  7. Group: System Environment/Base
  8. URL: https://fedorahosted.org/setup/
  9. Source: setup-%{version}.tar.bz2
  10. Patch: setup-2.8.1-vine.patch
  11. Buildroot: %{_tmppath}/%{name}-%{version}-root
  12. BuildArch: noarch
  13. Conflicts: initscripts < 4.26, bash <= 2.0.4-21
  14. %description
  15. The setup package contains a set of important system configuration and
  16. setup files, such as passwd, group, and profile.
  17. %description -l ja
  18. このsetupパッケージには、passwd, group, profile などの、
  19. 重要なシステム設定ファイルが含まれてます。
  20. %prep
  21. %setup -q
  22. %patch -p1
  23. ./shadowconvert.sh
  24. %install
  25. rm -rf %{buildroot}
  26. mkdir -p %{buildroot}/etc/profile.d
  27. cp -ar * %{buildroot}/etc
  28. rm -f %{buildroot}/etc/uidgid
  29. rm -f %{buildroot}/etc/COPYING
  30. mkdir -p %{buildroot}/var/log
  31. touch %{buildroot}/etc/{shadow,gshadow}
  32. touch %{buildroot}/var/log/lastlog
  33. touch %{buildroot}/etc/environment
  34. chmod 0644 %{buildroot}/etc/environment
  35. chmod 0400 %{buildroot}/etc/{shadow,gshadow}
  36. chmod 0644 %{buildroot}/var/log/lastlog
  37. touch %{buildroot}/etc/fstab
  38. # remove unpackaged files
  39. rm -f %{buildroot}/etc/Makefile
  40. rm -f %{buildroot}/etc/services.orig
  41. rm -f %{buildroot}/etc/serviceslint
  42. rm -f %{buildroot}/etc/uidgidlint
  43. rm -f %{buildroot}/etc/shadowconvert.sh
  44. rm -f %{buildroot}/etc/setup.spec
  45. rm -f $RPM_BUILD_ROOT/etc/{bashrc,aliases}
  46. %clean
  47. rm -rf %{buildroot}
  48. #throw away useless and dangerous update stuff until rpm will be able to
  49. #handle it ( http://rpm.org/ticket/6 )
  50. %post -p <lua>
  51. for i, name in ipairs({"passwd", "shadow", "group", "gshadow"}) do
  52. os.remove("/etc/"..name..".rpmnew")
  53. end
  54. %files
  55. %defattr(-,root,root)
  56. %doc uidgid COPYING
  57. %verify(not md5 size mtime) %config(noreplace) /etc/passwd
  58. %verify(not md5 size mtime) %config(noreplace) /etc/group
  59. %verify(not md5 size mtime) %config(noreplace,missingok) /etc/shadow
  60. %verify(not md5 size mtime) %config(noreplace,missingok) /etc/gshadow
  61. %verify(not md5 size mtime) %config(noreplace) /etc/services
  62. %verify(not md5 size mtime) %config(noreplace) /etc/exports
  63. %config(noreplace) /etc/environment
  64. %config(noreplace) /etc/filesystems
  65. %config(noreplace) /etc/host.conf
  66. %verify(not md5 size mtime) %config(noreplace) /etc/hosts
  67. %verify(not md5 size mtime) %config(noreplace) /etc/hosts.allow
  68. %verify(not md5 size mtime) %config(noreplace) /etc/hosts.deny
  69. %verify(not md5 size mtime) %config(noreplace) /etc/motd
  70. %config(noreplace) /etc/printcap
  71. %verify(not md5 size mtime) %config(noreplace) /etc/inputrc
  72. # config(noreplace) /etc/bashrc
  73. %config(noreplace) /etc/profile
  74. %verify(not md5 size mtime) %config(noreplace) /etc/protocols
  75. %attr(0600,root,root) %config(noreplace,missingok) /etc/securetty
  76. %config(noreplace) /etc/csh.login
  77. %config(noreplace) /etc/csh.cshrc
  78. %dir /etc/profile.d
  79. %config(noreplace) %verify(not md5 size mtime) /etc/shells
  80. %ghost %attr(0644,root,root) %verify(not md5 size mtime) /var/log/lastlog
  81. %ghost %verify(not md5 size mtime) %config(noreplace,missingok) /etc/fstab
  82. %changelog
  83. * Thu Apr 14 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.31-1
  84. - update to 2.8.31
  85. - use <lua> for post scriptlet
  86. * Sat Mar 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-1
  87. - update to 2.8.1
  88. - spec in utf-8
  89. - new versioning policy
  90. - add %%postun to remove dangerous .rpmnew files
  91. * Sat May 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.7-2vl5
  92. - add /etc/environment
  93. - add /etc/{fstab,mtab} as %%ghost
  94. - add console to /etc/securetty
  95. - import /etc/services from FC
  96. - set mark-symlinked-directories in /etc/inputrc
  97. - add /sbin/nologin to /etc/shells
  98. * Fri Mar 04 2005 Satoshi MACHINO <machino@vinelinux.org> 2.5.7-2vl4
  99. - updated setup-2.5.7-vine.patch
  100. -- changed /etc/printcap for using cups
  101. * Mon Jun 28 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.5.7-2vl3
  102. - source /etc/profile.d/*.sh in /etc/profile
  103. * Sun Feb 24 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.7-2vl1
  104. - merge with new upstream version
  105. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  106. - automated rebuild
  107. * Mon Aug 27 2001 Preston Brown <pbrown@redhat.com>
  108. - add ext3 to /etc/filesystems
  109. * Mon Aug 20 2001 Bill Nottingham <notting@redhat.com>
  110. - change FTP user's home dir to /var/ftp (#52091)
  111. - %%ghost /etc/shadow, /etc/gshadow
  112. * Fri Aug 17 2001 Bill Nottingham <notting@redhat.com>
  113. - add /etc/shells to filelist (#51813)
  114. * Mon Aug 13 2001 Bill Nottingham <notting@redhat.com>
  115. - put lock in /etc/group (#51654)
  116. * Wed Aug 8 2001 Bill Nottingham <notting@redhat.com>
  117. - lock only needs to be a gid
  118. - don't set dspmbyte=euc here; do it in lang.csh, and only if necessary (#50318)
  119. * Mon Aug 6 2001 Jeff Johnson <jbj@redhat.com>
  120. - add lock.lock uid/gid 54 to own /var/lock directory.
  121. * Thu Jul 19 2001 Bill Nottingham <notting@redhat.com>
  122. - add forward/backward-word mappings (#48783)
  123. - add pgpkeyserver port to /etc/services (#49407)
  124. * Thu Jul 19 2001 Preston Brown <pbrown@redhat.com>
  125. - core files disabled by default. Developers can enable them.
  126. * Fri Jul 13 2001 Bill Nottingham <notting@redhat.com> 2.5.1-1
  127. - revert news user back to no shell (#48701)
  128. * Tue Jul 10 2001 Bill Nottingham <notting@redhat.com> 2.5.0-1
  129. - move profile.d parsing from csh.cshrc to csh.login (#47417)
  130. * Sat Jul 7 2001 Nalin Dahyabhai <nalin@redhat.com> 2.4.15-1
  131. - reorder /etc/services to match comments again
  132. - protocol 118 is stp, not st
  133. - update URLs in /etc/protocols and /etc/services
  134. * Thu Jul 5 2001 Preston Brown <pbrown@redhat.com> 2.4.14-1
  135. - put */sbin in path if user ID is 0.
  136. * Mon Jun 25 2001 Bill Nottingham <notting@redhat.com>
  137. - add an entry to /etc/services for ssh X11 forwarding (#44944)
  138. * Wed Jun 13 2001 Bill Nottingham <notting@redhat.com>
  139. - take ttyS0 out of securetty on main tree
  140. * Tue Jun 12 2001 Philip Copeland <bryce@redhat.com>
  141. - added ttyS0 to securetty for serial console usage
  142. * Tue Jun 12 2001 Bill Nottingham <notting@redhat.com>
  143. - add rndc to /etc/services (#40265)
  144. - test for read bit, not execute bit, for profile.d (#35714)
  145. * Sun Jun 03 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  146. - add "canna" entry to /etc/services
  147. * Mon May 21 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.4.10-1
  148. - Fix bugs #24159 and #30634 again; whoever moved bashrc from bash
  149. to setup used an old version. :((
  150. * Wed May 2 2001 Preston Brown <pbrown@redhat.com> 2.4.9-1
  151. - bashrc moved here from bash package
  152. - set umask in bashrc, so it applies for ALL shells.
  153. * Fri Apr 27 2001 Preston Brown <pbrown@redhat.com> 2.4.8-1
  154. - /sbin/nologin for accounts that aren't "real."
  155. * Sat Apr 7 2001 Preston Brown <pbrown@redhat.com>
  156. - revert control-arrow forward/backward word (broken)
  157. * Tue Mar 27 2001 Preston Brown <pbrown@redhat.com>
  158. - fix japanese input with tcsh (#33211)
  159. * Tue Mar 6 2001 Bill Nottingham <notting@redhat.com>
  160. - fix some weirdness with rxvt (#30799)
  161. * Wed Feb 28 2001 Bill Nottingham <notting@redhat.com>
  162. - add SKK input method (#29759)
  163. * Fri Feb 23 2001 Preston Brown <pbrown@redhat.com>
  164. * Wed Feb 21 2001 Bill Nottingham <notting@redhat.com>
  165. - fix inputrc, Yet Again. (#28617)
  166. * Thu Feb 15 2001 Bill Nottingham <notting@redhat.com>
  167. - add in uidgid file, put it in %doc
  168. * Wed Feb 7 2001 Adrian Havill <havill@redhat.com>
  169. - bindkey for delete in the case of tcsh
  170. * Wed Feb 7 2001 Bill Nottingham <notting@redhat.com>
  171. - add some more stuff to /etc/services (#25396, patch from
  172. <pekkas@netcore.fi>)
  173. * Tue Feb 6 2001 Nalin Dahyabhai <nalin@redhat.com>
  174. - add gii/tcp = 616 for gated
  175. * Tue Jan 30 2001 Bill Nottingham <notting@redhat.com>
  176. - wrap some inputrc settings with tests for mode, term (#24117)
  177. * Mon Jan 29 2001 Bill Nottingham <notting@redhat.com>
  178. - overhaul /etc/protocols (#18530)
  179. - add port 587 to /etc/services (#25001)
  180. - add corbaloc (#19581)
  181. - don't set /usr/X11R6/bin in $PATH if it's already set (#19968)
  182. * Fri Dec 1 2000 Nalin Dahyabhai <nalin@redhat.com>
  183. - Clean up /etc/services, separating registered numbers from unregistered
  184. ("squatted") numbers, and adding some.
  185. * Mon Nov 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  186. - Add smtps (465/tcp) and submission (587/tcp) to /etc/services for TLS
  187. support (postfix >= 20001030-2)
  188. * Mon Nov 6 2000 Kazuhisa TAKEI <takei@vinelinux.org>
  189. - rebuild in rpm 3.0.6
  190. * Wed Oct 11 2000 Jun Nishii <jun@vinelinux.org>
  191. - remove reading profile.d process from /etc/profile
  192. the process moved to /etc/bashrc...
  193. * Thu Sep 07 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  194. - 2.2.1-1vl2
  195. - removed /etc/filesystems in %files section
  196. * Sun Aug 6 2000 Bill Nottingham <notting@redhat.com>
  197. - /var/log/lastlog is %config(noreplace) (#15412)
  198. - some of the various %verify changes (#14819)
  199. * Thu Aug 3 2000 Nalin Dahyabhai <nalin@redhat.com>
  200. - linuxconf should be 98, not 99
  201. * Tue Jul 25 2000 Bill Nottingham <notting@redhat.com>
  202. - fix some of the csh stuff (#14622)
  203. * Sun Jul 23 2000 Nalin Dahyabhai <nalin@redhat.com>
  204. - stop setting "multi on" in /etc/host.conf
  205. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  206. - automatic rebuild
  207. * Tue Jun 27 2000 Bill Nottingham <notting@redhat.com>
  208. - add hfs filesystem
  209. * Wed Jun 21 2000 Preston Brown <pbrown@redhat.com>
  210. - printcap is a noreplace file now
  211. * Sun Jun 18 2000 Bill Nottingham <notting@redhat.com>
  212. - fix typo
  213. * Tue Jun 13 2000 Lisa Sagami <czs14350@nifty.ne.jp>
  214. - merged RH 2.2.1-1 and Vine 2.0.5-1vl3
  215. * Tue Jun 13 2000 Nalin Dahyabhai <nalin@redhat.com>
  216. - add linuxconf/tcp = 99 to /etc/services
  217. * Sat Jun 10 2000 Bill Nottingham <notting@redhat.com>
  218. - add some stuff to /etc/services
  219. - tweak ulimit call again
  220. * Tue Jun 6 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  221. - homedir of ftp is now /var/ftp
  222. * Sun May 14 2000 Nalin Dahyabhai <nalin@redhat.com>
  223. - move profile.d logic in csh.login to csh.cshrc
  224. * Tue Apr 18 2000 Nalin Dahyabhai <nalin@redhat.com>
  225. - redirect ulimit -S -c to /dev/null to avoid clutter
  226. * Thu Apr 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  227. - s/ulimit -c/ulimit -S -c/ - bash 2.x adaption
  228. * Mon Apr 03 2000 Nalin Dahyabhai <nalin@redhat.com>
  229. - Add more of the kerberos-related services from IANA's registry and krb5
  230. * Wed Mar 29 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  231. - Add 2.4'ish vc/* devices to securetty
  232. * Thu Feb 17 2000 Preston Brown <pbrown@redhat.com>
  233. - add /etc/filesystems with sane defaults
  234. * Wed Feb 16 2000 Bill Nottingham <notting@redhat.com>
  235. - don't set prompt in /etc/profile (it's done in /etc/bashrc)
  236. * Fri Feb 5 2000 Bill Nottingham <notting@redhat.com>
  237. - yet more inputrc tweaks from Hans de Goede (hans@highrise.nl)
  238. * Sun Jan 30 2000 Bill Nottingham <notting@redhat.com>
  239. - yet more inputrc tweaks from Hans de Goede (hans@highrise.nl)
  240. * Sun Jan 23 2000 Bill Nottingham <notting@redhat.com>
  241. - fix mailq line. (#7140)
  242. * Fri Jan 21 2000 Bill Nottingham <notting@redhat.com>
  243. - add ldap to /etc/services
  244. * Tue Jan 18 2000 Bill Nottingham <notting@redhat.com>
  245. - kill HISTFILESIZE, it's broken
  246. * Tue Jan 18 2000 Preston Brown <pbrown@redhat.com>
  247. - some inputrc tweaks
  248. * Wed Jan 12 2000 Bill Nottingham <notting@redhat.com>
  249. - make some more stuff noreplace
  250. * Fri Nov 19 1999 Bill Nottingham <notting@redhat.com>
  251. - fix mailq line. (#7140)
  252. * Fri Oct 29 1999 Bill Nottingham <notting@redhat.com>
  253. - split csh.login into csh.login and csh.cshrc (#various)
  254. - fix pop service names (#6206)
  255. - fix ipv6 protocols entries (#6219)
  256. * Thu Sep 2 1999 Jeff Johnson <jbj@redhat.com>
  257. - rename /etc/csh.cshrc to /etc/csh.login (#2931).
  258. - (note: modified /etc/csh.cshrc should end up in /etc/csh.cshrc.rpmsave)
  259. * Fri Aug 20 1999 Jeff Johnson <jbj@redhat.com>
  260. - add defattr.
  261. - fix limit command in /etc/csh.cshrc (#4582).
  262. * Thu Jul 8 1999 Bill Nottingham <notting@redhat.com>
  263. - move /etc/inputrc here.
  264. * Mon Apr 19 1999 Bill Nottingham <notting@redhat.com>
  265. - always use /etc/inputrc
  266. * Wed Mar 31 1999 Preston Brown <pbrown@redhat.com>
  267. - added alias pointing to imap from imap2
  268. * Tue Mar 23 1999 Preston Brown <pbrown@redhat.com>
  269. - updated protocols/services from debian to comply with more modern
  270. - IETF/RFC standards
  271. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  272. - auto rebuild in the new build environment (release 4)
  273. * Thu Feb 18 1999 Jeff Johnson <jbj@redhat.com>
  274. - unset variables used in /etc/csh.cshrc (#1212)
  275. * Mon Jan 18 1999 Jeff Johnson <jbj@redhat.com>
  276. - compile for Raw Hide.
  277. * Tue Oct 13 1998 Cristian Gafton <gafton@redhat.com>
  278. - fix the csh.cshrc re: ${PATH} undefined
  279. * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
  280. - translations modified for de, fr, tr
  281. * Fri Dec 05 1997 Erik Troan <ewt@redhat.com>
  282. - /etc/profile uses $i, which needs to be unset
  283. * Mon Nov 03 1997 Donnie Barnes <djb@redhat.com>
  284. - made /etc/passwd and /etc/group %config(noreplace)
  285. * Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
  286. - removed /etc/inetd.conf, /etc/rpc
  287. - flagged /etc/securetty as missingok
  288. - fixed buildroot stuff in spec file
  289. * Thu Jul 31 1997 Erik Troan <ewt@redhat.com>
  290. - made a noarch package
  291. * Wed Apr 16 1997 Erik Troan <ewt@redhat.com>
  292. - Don't verify md5sum, size, or timestamp of /var/log/lastlog, /etc/passwd,
  293. or /etc/group.