medit-vl.spec 5.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191
  1. %define name medit
  2. %define version 1.0.3
  3. Name: %{name}
  4. Version: %{version}
  5. Release: 1%{?_dist_release}
  6. Summary: Multiplatform GTK+2 text editor
  7. Summary(ja): マルチプラットフォームな GTK+2 テキストエディタ
  8. Group: Applications/Editors
  9. License: GPLv2+
  10. URL: http://mooedit.sourceforge.net/
  11. Source0: http://prdownloads.sourceforge.net/mooedit/%{name}-%{version}.tar.bz2
  12. Source1: medit_ja.po
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. Buildrequires: cairo-devel
  15. BuildRequires: desktop-file-utils
  16. BuildRequires: gettext
  17. BuildRequires: gtk2-devel glib2-devel
  18. BuildRequires: intltool
  19. BuildRequires: libxml2-devel
  20. BuildRequires: libX11-devel libXext-devel libICE-devel
  21. BuildRequires: libSM-devel
  22. Buildrequires: perl-XML-Parser pango-devel
  23. BuildRequires: pcre-devel
  24. BuildRequires: python-devel
  25. BuildRequires: pygtk2-devel
  26. %description
  27. Medit is a multiplatform GTK+2 text editor.
  28. Features:
  29. * Configurable syntax highlighting.
  30. * Configurable keyboard accelerators.
  31. * Multiplatform - works both on unix and windows.
  32. * Plugins: can be written in C or Python.
  33. * Configurable tools available from the main and context menus.
  34. They can be written in Python or Lua, or it can be a shell script.
  35. * Regular expression search/replace, grep and find frontends, builtin file selector, etc.
  36. %description -l ja
  37. Medit はマルチプラットフォームな GTK+2 テキストエディタです。
  38. 機能一覧:
  39. * 設定可能な構文強調機能。
  40. * 設定可能なキーボードアクセラレータ。
  41. * マルチプラットフォーム - unix と windows の両者で動作。
  42. * プラグイン: C あるいは Python で作成可能。
  43. * メインメニューおよびコンテキストメニューから設定可能なツールを利用可能。
  44. Python あるいは lua 、シェルスクリプトで作成可能。
  45. * 正規表現による検索/置換、grep と find のフロントエンド、組み込みファイルセレクタなどなど。
  46. %prep
  47. %setup -q
  48. sed -i 's|fr|fr\nja|g' po/LINGUAS
  49. %__cp -f %{SOURCE1} po/ja.po
  50. %build
  51. #cmake -D CMAKE_INSTALL_PREFIX=/usr .
  52. %configure
  53. make %{?_smp_mflags}
  54. %install
  55. rm -rf %{buildroot}
  56. make install DESTDIR=$RPM_BUILD_ROOT
  57. desktop-file-install --vendor="" \
  58. --dir=${RPM_BUILD_ROOT}%{_datadir}/applications \
  59. --mode 0644 \
  60. $RPM_BUILD_ROOT/%{_datadir}/applications/%{name}.desktop
  61. %post
  62. update-desktop-database %{_datadir}/applications
  63. touch --no-create %{_datadir}/icons/hicolor
  64. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  65. gtk-update-icon-cache -q %{_datadir}/icons/hicolor ||:
  66. fi
  67. %postun
  68. update-desktop-database %{_datadir}/applications
  69. touch --no-create %{_datadir}/icons/hicolor
  70. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  71. gtk-update-icon-cache -q %{_datadir}/icons/hicolor ||:
  72. fi
  73. %clean
  74. rm -rf %{buildroot}
  75. %files
  76. %defattr(-,root,root)
  77. %doc COPYING README
  78. %{_bindir}/*
  79. %{_datadir}/applications/%{name}.desktop
  80. %{_datadir}/%{name}-1/*
  81. %{_datadir}/icons/hicolor/48x48/
  82. %exclude %{_datadir}/icons/hicolor/icon-theme.cache
  83. %{_datadir}/locale/*
  84. %{_docdir}/%{name}-1/*
  85. %{_mandir}/man?/
  86. %changelog
  87. * Sat Apr 30 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.3-1
  88. - new upstream release
  89. * Mon Feb 28 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.1-1
  90. - new upstream release
  91. * Sat Feb 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.0-1
  92. - new upstream release
  93. - updated Source1
  94. - dropt BuildRequires: cmake
  95. - added BuildRequires: libSM-devel
  96. - fixed %%files
  97. * Sun Oct 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.5-2
  98. - updated Source1
  99. * Fri Oct 8 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.5-1
  100. - new upstream release
  101. - cleaned up spec
  102. * Sat Jul 3 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.4-2
  103. - updated Source1
  104. - added BuildRequires: cairo-devel, gettext, libX11-devel, perl-XML-Parser, pango-devel
  105. - changed BuildRequires: cmake >= 2.6
  106. * Wed May 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.4-1
  107. - new upstream release
  108. - added Japanese language file
  109. - added man directory in %files
  110. * Sun Mar 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.1-1
  111. - new upstream release
  112. - applied new naming policy to spec
  113. * Fri Mar 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.0-1
  114. - initial build for VineSeed
  115. * Mon Jan 21 2008 Funda Wang <fundawang@mandriva.org> 0.9.2-1mdv2008.1
  116. + Revision: 155675
  117. - New version 0.9.2
  118. - rediff patch0
  119. + Olivier Blin <oblin@mandriva.com>
  120. - restore BuildRoot
  121. + Thierry Vignaud <tvignaud@mandriva.com>
  122. - kill re-definition of %%buildroot on Pixel's request
  123. * Sat Dec 01 2007 Funda Wang <fundawang@mandriva.org> 0.9.0-1mdv2008.1
  124. + Revision: 114221
  125. - New version 0.9.0
  126. * Sat Nov 17 2007 Jérôme Soyer <saispo@mandriva.org> 0.8.11-1mdv2008.1
  127. + Revision: 109208
  128. - New release 0.8.11
  129. * Tue Aug 07 2007 Funda Wang <fundawang@mandriva.org> 0.8.10-1mdv2008.0
  130. + Revision: 59667
  131. - New version 0.8.10
  132. * Wed Aug 01 2007 Funda Wang <fundawang@mandriva.org> 0.8.9-1mdv2008.0
  133. + Revision: 57568
  134. - New version 0.8.9
  135. * Thu Jul 12 2007 Funda Wang <fundawang@mandriva.org> 0.8.8-1mdv2008.0
  136. + Revision: 51500
  137. - Fix file list
  138. - New version
  139. * Thu Jun 14 2007 Funda Wang <fundawang@mandriva.org> 0.8.6-1mdv2008.0
  140. + Revision: 39539
  141. - SILent renew tarball
  142. - New version
  143. - New version
  144. add dirty patch that skips update-icon-cache and mime database when building
  145. + Jérôme Soyer <saispo@mandriva.org>
  146. - Import medit
  147. * Tue May 09 2006 UTUMI Hirosi <utuhiro78@dummy.org> 0.6.98-1mdk
  148. - new release
  149. * Mon May 08 2006 UTUMI Hirosi <utuhiro78@dummy.org> 0.6.97-1mdk
  150. - first spec for Mandriva