conky-vl.spec 6.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248
  1. # TODO: - make libXNVCtrl-devel
  2. # - with --enable-lua-imlib2
  3. %define with_alsa 0
  4. %define with_audacious 0
  5. %define with_imlib 1
  6. %define with_lua 1
  7. %define with_lua_cairo 1
  8. %define with_lua_imlib 1
  9. %define with_moc 1
  10. %define with_mpd 0
  11. %define with_nvidia 0
  12. %define with_rss 1
  13. %define with_smapi 0
  14. %define with_ibm 0
  15. %define with_wlan 0
  16. Name: conky
  17. Version: 1.8.1
  18. Release: 1%{?_dist_release}
  19. Summary: A lightweight system monitor for X
  20. Summary(ja): X 用軽量システムモニタ
  21. Group: User Interface/X
  22. License: GPLv3+
  23. URL: http://conky.sf.net/
  24. Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
  25. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  26. BuildRequires: glib2-devel
  27. BuildRequires: libxml2-devel
  28. BuildRequires: libXft-devel
  29. BuildRequires: libXt-devel
  30. BuildRequires: libXdamage-devel
  31. BuildRequires: libXext-devel
  32. %if %{with_alsa}
  33. BuildRequires: alsa-lib-devel
  34. %endif
  35. %if %{with_imlib}
  36. BuildRequires: imlib2-devel
  37. %endif
  38. %if %{with_lua}
  39. BuildRequires: lua-devel
  40. %endif
  41. %if %{with_lua_cairo}
  42. BuildRequires: cairo-devel tolua++-devel
  43. %endif
  44. %if %{with_lua_imlib}
  45. BuildRequires: imlib2-devel tolua++-devel
  46. %endif
  47. %if %{with_audacious}
  48. BuildRequires: audacious-devel
  49. BuildRequires: dbus-glib-devel
  50. %endif
  51. %if %{with_nvidia}
  52. BuildRequires: libXNVCtrl-devel
  53. %endif
  54. %if %{with_rss}
  55. BuildRequires: curl-devel
  56. %endif
  57. %if %{with_wlan}
  58. BuildRequires: wireless-tools-devel
  59. %endif
  60. %description
  61. A system monitor for X originally based on the torsmo code. but more kickass.
  62. It just keeps on given'er. Yeah.
  63. #'
  64. %description -l ja
  65. torsmo をベースにした X 用のシステムモニタです。
  66. %prep
  67. %setup -q
  68. for i in AUTHORS ChangeLog; do
  69. iconv -f iso8859-1 -t utf8 -o ${i}{_,} && touch -r ${i}{,_} && mv -f ${i}{_,}
  70. done
  71. %build
  72. #sh autogen.sh
  73. %configure \
  74. --disable-rpath \
  75. %if !%{with_alsa}
  76. --disable-alsa \
  77. %endif
  78. %if %{with_audacious}
  79. --enable-audacious=yes \
  80. %endif
  81. %if %{with_imlib}
  82. --enable-imlib2 \
  83. %endif
  84. %if !%{with_lua}
  85. --disable-lua \
  86. %endif
  87. %if %{with_lua_cairo}
  88. --enable-lua-cairo \
  89. %endif
  90. %if %{with_lua_imlib}
  91. --enable-lua-imlib2 \
  92. %endif
  93. %if !%{with_moc}
  94. --disable-moc \
  95. %endif
  96. %if !%{with_mpd}
  97. --disable-mpd \
  98. %endif
  99. %if %{with_nvidia}
  100. --enable-nvidia \
  101. %endif
  102. %if %{with_rss}
  103. --enable-rss \
  104. %endif
  105. %if %{with_ibm}
  106. --enable-ibm \
  107. %endif
  108. %if %{with_smapi}
  109. --enable-smapi \
  110. %endif
  111. %if %{with_wlan}
  112. --enable-wlan \
  113. %endif
  114. ;
  115. # don't use rpath
  116. %__sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  117. %__sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  118. %__make %{?_smp_mflags}
  119. %install
  120. %__rm -rf $RPM_BUILD_ROOT
  121. %__make install DESTDIR=$RPM_BUILD_ROOT
  122. %__rm -f $RPM_BUILD_ROOT%{_sysconfdir}/conky/conky_no_x11.conf
  123. %__rm -f $RPM_BUILD_ROOT%{_libdir}/conky/*.{la,a}
  124. %clean
  125. %__rm -rf $RPM_BUILD_ROOT
  126. %files
  127. %defattr(-,root,root,-)
  128. %doc AUTHORS ChangeLog COPYING TODO README NEWS extras/* doc/docs.html
  129. %dir %{_sysconfdir}/%{name}
  130. %config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
  131. %{_bindir}/%{name}
  132. %if %{with_lua_cairo} || %{with_lua_imlib}
  133. %{_libdir}/conky
  134. %endif
  135. %{_mandir}/man1/*
  136. %changelog
  137. * Sun Jun 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.8.1-1
  138. - new upstream release
  139. * Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.7.2-1
  140. - new upstream release
  141. - enable lua, lua-cairo
  142. - added BuildRequires: glib2-devel
  143. * Mon Feb 15 2010 Miroslav Lichvar <mlichvar@redhat.com> - 1.7.2-2
  144. - fix building with new audacious (#556317)
  145. * Tue Aug 25 2009 Miroslav Lichvar <mlichvar@redhat.com> - 1.7.2-1
  146. - Update to 1.7.2
  147. * Thu Jul 30 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.7.1.1-1
  148. - new upstream release
  149. * Sat Nov 15 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.6.1-1
  150. - initial build based on Fedora package
  151. - applied conky-1.6.0-rdtsc.patch, conky-1.6.1-ifaddrs.patch
  152. * Tue Aug 26 2008 Miroslav Lichvar <mlichvar@redhat.com> - 1.6.1-1
  153. - Update to 1.6.1
  154. - Fix buffer overflow when reading interface addresses
  155. * Tue Jul 22 2008 Miroslav Lichvar <mlichvar@redhat.com> - 1.6.0-1
  156. - Update to 1.6.0
  157. - Fix freq_dyn on x86_64
  158. * Tue Apr 01 2008 Miroslav Lichvar <mlichvar@redhat.com> - 1.5.1-1
  159. - Update to 1.5.1
  160. * Sun Mar 23 2008 Miroslav Lichvar <mlichvar@redhat.com> - 1.5.0-1
  161. - Update to 1.5.0
  162. - Convert doc files to UTF-8
  163. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.9-2
  164. - Autorebuild for GCC 4.3
  165. * Tue Nov 27 2007 Miroslav Lichvar <mlichvar@redhat.com> - 1.4.9-1
  166. - Update to 1.4.9
  167. - Enable support for Audacious 1.4.0
  168. * Sun Oct 21 2007 Miroslav Lichvar <mlichvar@redhat.com> - 1.4.8-1
  169. - Update to 1.4.8
  170. - Enable mpd, rss and wireless support
  171. - Update license tag
  172. * Wed Apr 18 2007 Michael Rice <errr[AT]errr-online.com> - 1.4.5-4
  173. - Rebuild to match audacious lib in fc6 bug: 236989
  174. * Mon Apr 09 2007 Michael Rice <errr[AT]errr-online.com> - 1.4.5-3
  175. - Rebuild for devel
  176. * Thu Dec 14 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.5-2
  177. - Ship NEWS
  178. - Add patch for license of timed_thread and NEWS
  179. * Tue Dec 12 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.5-1
  180. - version bump
  181. - change group
  182. * Wed Dec 06 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.4-3
  183. - rebuild for new audacious lib version
  184. * Thu Nov 30 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.4-2
  185. - Move nano and vim files into docs
  186. - remove unneeded BR's
  187. * Tue Nov 21 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.4-1
  188. - Version bump
  189. - Add vim and nano syntax files to package
  190. * Thu Oct 05 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.3-1
  191. - Version bump
  192. - Remove Install file from docs
  193. * Mon Oct 02 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.2-4
  194. - moved to configure macro from ./configure
  195. - clean up changelog and make more informative entrys
  196. - Fixed sumary in spec file
  197. - remove NEWS file since it was empty
  198. - remove xmms support due to possible security issue
  199. - remove bmp support due to possible security issue
  200. - add missing BR for libXext-devel and remove unneeded libX11-devel
  201. * Thu Sep 28 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.2-3
  202. - use the GPL as licence since the whole package is GPL
  203. * Thu Sep 28 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.2-2
  204. - remove unneeded deps
  205. * Tue Sep 26 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.2-1
  206. - Initial RPM release