check-vl.spec 3.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123
  1. Summary: A unit test framework for C
  2. Summary(ja): C 言語用単体テストフレームワーク
  3. Name: check
  4. Version: 0.9.8
  5. Release: 2%{?_dist_release}
  6. License: LGPL
  7. Group: Development/Tools
  8. URL: http://check.sourceforge.net/
  9. Source0: http://prdownloads.sourceforge.net/check/%{name}-%{version}.tar.gz
  10. Patch0: %{name}-examples-bootstrap.patch
  11. Patch1: check-0.9.5-fPIC.patch
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: docbook-utils
  14. Requires(post,preun): /sbin/install-info
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. Packager: USAMI Kosuke <usami-k@yc5.so-net.ne.jp>
  18. %description
  19. Check is a unit test framework for C. It features a simple interface
  20. for defining unit tests, putting little in the way of the developer.
  21. Tests are run in a separate address space, so Check can catch both
  22. assertion failures and code errors that cause segmentation faults or
  23. other signals. The output from unit tests can be used within source
  24. code editors and IDEs.
  25. %package devel
  26. Summary: Libraries and headers for developing programs with check
  27. Summary(ja): Check を使ったプログラム開発用ライブラリとヘッダファイル
  28. Group: Development/Libraries
  29. Requires: pkgconfig
  30. Requires: %{name} = %{version}-%{release}
  31. %description devel
  32. Libraries and headers for developing programs with check
  33. %prep
  34. %setup -q
  35. %patch0 -p1
  36. #patch1 -p1 -b .fPIC
  37. %build
  38. %configure --disable-static
  39. make %{?_smp_mflags}
  40. %install
  41. rm -rf $RPM_BUILD_ROOT
  42. %makeinstall
  43. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  44. rm -rf $RPM_BUILD_ROOT%{_infodir}/dir
  45. rm -rf example
  46. cp -pr $RPM_BUILD_ROOT%{_datadir}/doc/check/example .
  47. rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/check
  48. %clean
  49. rm -rf $RPM_BUILD_ROOT
  50. %post
  51. /sbin/ldconfig
  52. /sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir || :
  53. %postun -p /sbin/ldconfig
  54. %preun
  55. if [ $1 = 0 ]; then
  56. /sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir || :
  57. fi
  58. %files
  59. %defattr(-,root,root)
  60. %doc AUTHORS COPYING.LESSER ChangeLog ChangeLogOld NEWS README SVNChangeLog
  61. %{_libdir}/libcheck.so.*
  62. %{_infodir}/check.info*
  63. %files devel
  64. %defattr(-,root,root)
  65. %doc example
  66. %{_includedir}/check.h
  67. %{_libdir}/libcheck.so
  68. %{_libdir}/pkgconfig/check.pc
  69. %{_datadir}/aclocal/check.m4
  70. %changelog
  71. * Thu Sep 30 2010 Shu KONNO <owa@bg.wakwak.com> 0.9.8-2
  72. - rebuilt with rpm-4.8.1 for pkg-config
  73. * Sat Apr 24 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.9.8-1
  74. - new upstream release
  75. - dropt Patch1
  76. * Mon May 26 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.9.5-2
  77. - spec in UTF-8
  78. - split devel subpackage
  79. * Sat Apr 5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-1vl5
  80. - new upstream release
  81. - updated Patch1
  82. * Mon Sep 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.3-0vl2
  83. - enable -fPIC to build gstreamer on x86_64
  84. * Mon Jan 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.3-0vl1
  85. - upstream release
  86. - add BuildRequires: docbook-utils instead of lyx
  87. * Fri Aug 1 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 0.8.4-0vl2
  88. - Rebuild for new Vine.
  89. * Wed Jun 18 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> 0.8.4-0vl1
  90. - Initial build.