zabbix-vl.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697
  1. %bcond_with systemd
  2. %define only_agent 0
  3. %if %{only_agent}
  4. %bcond_with server
  5. %bcond_with proxy
  6. %bcond_with frontend
  7. %else
  8. %bcond_without server
  9. %bcond_without proxy
  10. %bcond_without frontend
  11. %endif
  12. %bcond_without agent
  13. Summary: The Enterprise-class Monitoring Solution for Everyone
  14. Name: zabbix
  15. Version: 5.0.2
  16. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  17. Group: Applications/Services
  18. Vendor: Project Vine
  19. Distribution: Vine Linux
  20. Packager: iwaim
  21. License: GPLv2
  22. URL: https://www.zabbix.com/
  23. %global shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
  24. Source0: https://cdn.zabbix.com/zabbix/sources/stable/%{shortver}/%{name}-%{version}.tar.gz
  25. Source1: zabbix_server.init
  26. Source2: zabbix_proxy.init
  27. Source3: zabbix_agentd.init
  28. Source4: zabbix_server.logrotate
  29. Source5: zabbix_proxy.logrotate
  30. Source6: zabbix_agentd.logrotate
  31. Source9: %{name}-tmpfiles-zabbix.conf
  32. # systemd units -- Alternatives switches between them (they state their dependencies)
  33. # https://support.zabbix.com/browse/ZBXNEXT-1593
  34. Source10: %{name}-agent.service
  35. Source11: %{name}-proxy-mysql.service
  36. Source12: %{name}-proxy-pgsql.service
  37. Source14: %{name}-server-mysql.service
  38. Source15: %{name}-server-pgsql.service
  39. Source17: %{name}-tmpfiles-zabbixsrv.conf
  40. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
  41. %if %{with server}%{with proxy}
  42. BuildRequires: libpq-devel
  43. BuildRequires: libmariadb-devel
  44. %endif
  45. BuildRequires: libevent-devel
  46. BuildRequires: pcre-devel
  47. BuildRequires: curl-devel
  48. BuildRequires: net-snmp-devel
  49. BuildRequires: OpenIPMI-devel
  50. BuildRequires: unixODBC-devel
  51. BuildRequires: libssh2-devel
  52. BuildRequires: openssl-devel
  53. Requires(pre): glibc-common
  54. Requires(pre): shadow-utils
  55. %if %{with systemd}
  56. BuildRequires: systemd
  57. %endif
  58. %description
  59. The Enterprise-class Monitoring Solution for Everyone.
  60. %if %{with server}
  61. %package server-common
  62. Summary: common files for Zabbix Server
  63. Requires: %{name} == %{version}-%{release}
  64. %if %{with systemd}
  65. %{?systemd_requires}
  66. %else
  67. Requires(post,preun): chkconfig
  68. Requires(preun,postun): initscripts
  69. %endif
  70. %description server-common
  71. This package include common files for Zabbix Server.
  72. %package server-mysql
  73. Summary: Zabbix Server for MySQL/MariaDB
  74. Provides: %{name}-server
  75. Requires: %{name}-server-common == %{version}-%{release}
  76. %description server-mysql
  77. Zabbix Server for MySQL/MariaDB
  78. %package server-postgresql
  79. Summary: Zabbix Server for PostgreSQL
  80. Provides: %{name}-server
  81. Requires: %{name}-server-common == %{version}-%{release}
  82. %description server-postgresql
  83. Zabbix Server for PostgreSQL
  84. %endif
  85. %if %{with agent}
  86. %package agent
  87. Summary: Zabbix Agent
  88. Requires: %{name} == %{version}-%{release}
  89. %if %{with systemd}
  90. %{?systemd_requires}
  91. %else
  92. Requires(post,preun): chkconfig
  93. Requires(preun,postun): initscripts
  94. %endif
  95. %description agent
  96. Zabbix Agent
  97. %endif
  98. %if %{with proxy}
  99. %package proxy-common
  100. Summary: common files for Zabbix Proxy
  101. Requires: %{name} == %{version}-%{release}
  102. %if %{with systemd}
  103. %{?systemd_requires}
  104. %else
  105. Requires(post,preun): chkconfig
  106. Requires(preun,postun): initscripts
  107. %endif
  108. %description proxy-common
  109. This package include common files for Zabbix Proxy
  110. %package proxy-mysql
  111. Summary: Zabbix Proxy for MySQL/MariaDB
  112. Provides: %{name}-proxy
  113. Requires: %{name}-proxy-common == %{version}-%{release}
  114. %description proxy-mysql
  115. Zabbix Proxy for MySQL/MariaDB
  116. %package proxy-postgresql
  117. Summary: Zabbix Proxy for PostgreSQL
  118. Provides: %{name}-proxy
  119. Requires: %{name}-proxy-common == %{version}-%{release}
  120. %description proxy-postgresql
  121. Zabbix Proxy for PostgreSQL
  122. %endif
  123. %if %{with frontend}
  124. %package frontend-php
  125. Summary: Zabbix web frontend with PHP
  126. Group: Applications/Internet
  127. Requires: php74
  128. Requires: TrueType-vlgothic
  129. %description frontend-php
  130. Zabbix web frontend with PHP.
  131. %package frontend-php-mysql
  132. Summary: Zabbix web frontend with PHP and MySQL/MariaDB
  133. Group: Applications/Internet
  134. Provides: %{name}-frontend-php == %{version}-%{release}
  135. Requires: php74-mysql
  136. %description frontend-php-mysql
  137. Zabbix web frontend with PHP and MySQL/MariaDB.
  138. %package frontend-php-postgresql
  139. Summary: Zabbix web frontend with PHP and PostgreSQL
  140. Group: Applications/Internet
  141. Provides: %{name}-frontend-php == %{version}-%{release}
  142. Requires: php74-pgsql
  143. %description frontend-php-postgresql
  144. Zabbix web frontend with PHP and PostgreSQL.
  145. %endif
  146. %prep
  147. %setup -q -T -a 0 -c -n zabbix-%{version}
  148. mv zabbix-%{version} zabbix_mysql
  149. %if %{with server}%{with proxy}
  150. %setup -q -D -T -a 0 -n zabbix-%{version}
  151. mv zabbix-%{version} zabbix_pgsql
  152. %endif
  153. for v in mysql pgsql; do
  154. pushd zabbix_$v
  155. sed -i -e 's/DejaVuSans/VL-Gothic-Regular/g' ./ui/include/defines.inc.php
  156. sed -i \
  157. -e '\|^# PidFile=.*|a PidFile=/run/zabbix/zabbix_agentd.pid' \
  158. -e 's|^LogFile=.*|LogFile=%{_localstatedir}/log/zabbix/zabbix_agentd.log|' \
  159. conf/zabbix_agentd.conf
  160. sed -i \
  161. -e '\|^# PidFile=.*|a PidFile=/run/zabbix/zabbix_proxy.pid' \
  162. -e 's|^LogFile=.*|LogFile=%{_localstatedir}/log/zabbix/zabbix_proxy.log|' \
  163. conf/zabbix_proxy.conf
  164. sed -i \
  165. -e '\|^# PidFile=.*|a PidFile=/run/zabbix/zabbix_server.pid' \
  166. -e 's|^LogFile=.*|LogFile=%{_localstatedir}/log/zabbix/zabbix_server.log|' \
  167. conf/zabbix_server.conf
  168. popd
  169. done
  170. %build
  171. Build()
  172. {
  173. perl -pi -e 's|/usr/bin/traceroute|/bin/traceroute|' \
  174. ./database/{ibm_db2,mysql,oracle,postgresql,sqlite3}/data.sql
  175. %configure \
  176. %{?with_server:--enable-server} \
  177. %{?with_proxy:--enable-proxy} \
  178. %{?with_agent:--enable-agent} \
  179. --enable-ipv6 \
  180. --sysconfdir=%{_sysconfdir}/zabbix \
  181. --with-libcurl \
  182. --with-openipmi \
  183. --with-net-snmp \
  184. --with-unixodbc \
  185. --with-ssh2 \
  186. --with-openssl \
  187. $@
  188. %__make
  189. }
  190. %if %{with server}%{with proxy}
  191. pushd zabbix_mysql
  192. Build --with-mysql
  193. popd
  194. pushd zabbix_pgsql
  195. Build --with-postgresql
  196. popd
  197. %else
  198. pushd zabbix_mysql
  199. Build
  200. popd
  201. %endif
  202. %install
  203. %__rm -rf %{buildroot}
  204. pushd zabbix_mysql
  205. make DESTDIR=%{buildroot} install
  206. %if %{with server}
  207. mv -f %{buildroot}%{_sbindir}/zabbix_server %{buildroot}%{_sbindir}/zabbix_server.mysql
  208. %endif
  209. %if %{with proxy}
  210. mv -f %{buildroot}%{_sbindir}/zabbix_proxy %{buildroot}%{_sbindir}/zabbix_proxy.mysql
  211. %endif
  212. # make directories
  213. %__mkdir_p %{buildroot}%{_localstatedir}/{log,run}/%{name}
  214. # DB
  215. %__mkdir_p %{buildroot}%{_datadir}/zabbix
  216. %if %{with server}%{with proxy}
  217. %__cp -a database/postgresql %{buildroot}%{_datadir}/zabbix/
  218. %__cp -a database/mysql %{buildroot}%{_datadir}/zabbix/
  219. %endif
  220. %if %{with systemd}
  221. # unit files
  222. %__mkdir_p %{buildroot}%{_unitdir}
  223. # Install different systemd units because of the requirements for DBMS daemons
  224. install -m 0644 -p %{SOURCE10} %{buildroot}%{_unitdir}/zabbix-agent.service
  225. install -m 0644 -p %{SOURCE11} %{buildroot}%{_unitdir}/zabbix-proxy-mysql.service
  226. install -m 0644 -p %{SOURCE12} %{buildroot}%{_unitdir}/zabbix-proxy-pgsql.service
  227. install -m 0644 -p %{SOURCE14} %{buildroot}%{_unitdir}/zabbix-server-mysql.service
  228. install -m 0644 -p %{SOURCE15} %{buildroot}%{_unitdir}/zabbix-server-pgsql.service
  229. # systemd tmpfiles
  230. mkdir -p %{buildroot}%{_prefix}/lib/tmpfiles.d
  231. install -m 0644 -p %{SOURCE9} %{buildroot}%{_prefix}/lib/tmpfiles.d/zabbix.conf
  232. %else
  233. # init.d
  234. %__mkdir_p %{buildroot}%{_initddir}
  235. %if %{with server}
  236. %__cp %{SOURCE1} %{buildroot}%{_initddir}/zabbix_server
  237. %endif
  238. %if %{with proxy}
  239. %__cp %{SOURCE2} %{buildroot}%{_initddir}/zabbix_proxy
  240. %endif
  241. %if %{with agent}
  242. %__cp %{SOURCE3} %{buildroot}%{_initddir}/zabbix_agentd
  243. %endif
  244. %endif
  245. # logrotate
  246. %__mkdir_p %{buildroot}%{_sysconfdir}/logrotate.d
  247. %if %{with server}
  248. %__cp %{SOURCE4} %{buildroot}%{_sysconfdir}/logrotate.d/zabbix_server
  249. %endif
  250. %if %{with proxy}
  251. %__cp %{SOURCE5} %{buildroot}%{_sysconfdir}/logrotate.d/zabbix_proxy
  252. %endif
  253. %if %{with agent}
  254. %__cp %{SOURCE6} %{buildroot}%{_sysconfdir}/logrotate.d/zabbix_agentd
  255. %endif
  256. %if %{with frontend}
  257. # frontend-php
  258. %__mkdir_p %{buildroot}%{_datadir}/zabbix-frontend
  259. %__cp -a ui %{buildroot}%{_datadir}/zabbix-frontend/php
  260. %__rm -f %{buildroot}%{_datadir}/zabbix-frontend/php/assets/fonts/DejaVuSans.ttf
  261. ln -s /usr/share/fonts/TrueType-vlgothic/VL-Gothic-Regular.ttf \
  262. %{buildroot}%{_datadir}/zabbix-frontend/php/assets/fonts/
  263. %endif
  264. %if %{with proxy}
  265. # proxy
  266. mkdir -p %{buildroot}%{_datadir}/zabbix-proxy
  267. ln -sf ../zabbix/mysql %{buildroot}%{_datadir}/zabbix-proxy/
  268. ln -sf ../zabbix/postgresql %{buildroot}%{_datadir}/zabbix-proxy/
  269. %endif
  270. popd
  271. %if %{with server}%{with proxy}
  272. pushd zabbix_pgsql
  273. install -m755 src/zabbix_server/zabbix_server %{buildroot}%{_sbindir}/zabbix_server.pgsql
  274. install -m755 src/zabbix_proxy/zabbix_proxy %{buildroot}%{_sbindir}/zabbix_proxy.pgsql
  275. popd
  276. %endif
  277. %clean
  278. %__rm -rf %{buildroot}
  279. %pre
  280. getent group zabbix >/dev/null || groupadd -r zabbix
  281. getent passwd zabbix >/dev/null || \
  282. useradd -r -g zabbix -d %{_sysconfdir}/zabbix -s /sbin/nologin \
  283. -c "Zabbix Monitoring Solution" zabbix
  284. exit 0
  285. %if %{with server}
  286. %post server-mysql
  287. %if %{with systemd}
  288. %systemd_post zabbix-server-mysql.service
  289. %else
  290. /sbin/update-alternatives --install /usr/sbin/zabbix_server \
  291. zabbix_server /usr/sbin/zabbix_server.mysql 10
  292. %endif
  293. %post server-postgresql
  294. %if %{with systemd}
  295. %systemd_post zabbix-server-pgsql.service
  296. %else
  297. /sbin/update-alternatives --install /usr/sbin/zabbix_server \
  298. zabbix_server /usr/sbin/zabbix_server.pgsql 10
  299. /sbin/chkconfig --add zabbix_server
  300. %endif
  301. %endif
  302. %if %{with proxy}
  303. %post proxy-mysql
  304. %if %{with systemd}
  305. %systemd_post zabbix-proxy-mysql.service
  306. %else
  307. /sbin/update-alternatives --install /usr/sbin/zabbix_proxy \
  308. zabbix_proxy /usr/sbin/zabbix_proxy.mysql 10
  309. /sbin/chkconfig --add zabbix_proxy
  310. %endif
  311. %post proxy-postgresql
  312. %if %{with systemd}
  313. %systemd_post zabbix-proxy-pgsql.service
  314. %else
  315. /sbin/update-alternatives --install /usr/sbin/zabbix_proxy \
  316. zabbix_proxy /usr/sbin/zabbix_proxy.pgsql 10
  317. /sbin/chkconfig --add zabbix_proxy
  318. %endif
  319. %endif
  320. %if %{with agent}
  321. %post agent
  322. %if %{with systemd}
  323. %systemd_post zabbix-agent.service
  324. %else
  325. /sbin/chkconfig --add zabbix_agentd
  326. %endif
  327. %endif
  328. %if %{with server}
  329. %preun server-mysql
  330. %if %{with systemd}
  331. %systemd_preun zabbix-server-mysql.service
  332. %else
  333. if [ "$1" -eq 0 -o -x /bin/systemctl ]; then
  334. /sbin/service zabbix_server stop >/dev/null 2>&1
  335. /sbin/chkconfig --del zabbix_server
  336. /sbin/update-alternatives --remove zabbix_server \
  337. /usr/sbin/zabbix_server.mysql
  338. fi
  339. %endif
  340. %preun server-postgresql
  341. %if %{with systemd}
  342. %systemd_preun zabbix-server-pgysql.service
  343. %else
  344. if [ "$1" -eq 0 -o -x /bin/systemctl ]; then
  345. /sbin/service zabbix_server stop >/dev/null 2>&1
  346. /sbin/chkconfig --del zabbix_server
  347. /sbin/update-alternatives --remove zabbix_server \
  348. /usr/sbin/zabbix_server.pgsql
  349. fi
  350. %endif
  351. %endif
  352. %if %{with proxy}
  353. %preun proxy-mysql
  354. %if %{with systemd}
  355. %systemd_preun zabbix-proxy-mysql.service
  356. %else
  357. if [ "$1" -eq 0 -o -x /bin/systemctl ]; then
  358. /sbin/service zabbix_proxy stop >/dev/null 2>&1
  359. /sbin/chkconfig --del zabbix_proxy
  360. /sbin/update-alternatives --remove zabbix_proxy \
  361. /usr/sbin/zabbix_proxy.mysql
  362. fi
  363. %endif
  364. %preun proxy-postgresql
  365. %if %{with systemd}
  366. %systemd_preun zabbix-proxy-pgsql.service
  367. %else
  368. if [ "$1" -eq 0 -o -x /bin/systemctl ]; then
  369. /sbin/service zabbix_proxy stop >/dev/null 2>&1
  370. /sbin/chkconfig --del zabbix_proxy
  371. /sbin/update-alternatives --remove zabbix_proxy \
  372. /usr/sbin/zabbix_proxy.pgsql
  373. fi
  374. %endif
  375. %endif
  376. %if %{with agent}
  377. %preun agent
  378. %if %{with systemd}
  379. %systemd_preun zabbix-agent.service
  380. %else
  381. if [ "$1" -eq 0 -o -x /bin/systemctl ]; then
  382. /sbin/service zabbix_agentd stop >/dev/null 2>&1
  383. /sbin/chkconfig --del zabbix_agentd
  384. fi
  385. %endif
  386. %endif
  387. %if %{with server}
  388. %postun server-mysql
  389. %if %{with systemd}
  390. %systemd_postun_with_restart zabbix-server-mysql.service
  391. %else
  392. if [ "$1" -ge "1" -a ! -x /bin/systemctl ]; then
  393. /sbin/service zabbix_server condrestart >/dev/null 2>&1 || :
  394. fi
  395. %endif
  396. %postun server-postgresql
  397. %if %{with systemd}
  398. %systemd_postun_with_restart zabbix-server-pgsql.service
  399. %else
  400. if [ "$1" -ge "1" -a ! -x /bin/systemctl ]; then
  401. /sbin/service zabbix_server condrestart >/dev/null 2>&1 || :
  402. fi
  403. %endif
  404. %endif
  405. %if %{with proxy}
  406. %postun proxy-mysql
  407. %if %{with systemd}
  408. %systemd_postun_with_restart zabbix-proxy-mysql.service
  409. %else
  410. if [ "$1" -ge "1" -a ! -x /bin/systemctl ]; then
  411. /sbin/service zabbix_proxy condrestart >/dev/null 2>&1 || :
  412. fi
  413. %endif
  414. %postun proxy-postgresql
  415. %if %{with systemd}
  416. %systemd_postun_with_restart zabbix-proxy-pgsql.service
  417. %else
  418. if [ "$1" -ge "1" -a ! -x /bin/systemctl ]; then
  419. /sbin/service zabbix_proxy condrestart >/dev/null 2>&1 || :
  420. fi
  421. %endif
  422. %postun agent
  423. %if %{with systemd}
  424. %systemd_postun_with_restart zabbix-agent.service
  425. %else
  426. if [ "$1" -ge "1" -a ! -x /bin/systemctl ]; then
  427. /sbin/service zabbix_agentd condrestart >/dev/null 2>&1 || :
  428. fi
  429. %endif
  430. %endif
  431. %files
  432. %defattr(-,root,root,-)
  433. %license zabbix_mysql/COPYING
  434. %doc zabbix_mysql/AUTHORS zabbix_mysql/ChangeLog zabbix_mysql/NEWS zabbix_mysql/README
  435. %attr(0755,zabbix,zabbix) %dir %{_localstatedir}/log/%{name}
  436. %dir %{_datadir}/zabbix
  437. %if %{with server}%{with proxy}
  438. %{_datadir}/zabbix/mysql
  439. %{_datadir}/zabbix/postgresql
  440. %endif
  441. %if %{with systemd}
  442. %{_prefix}/lib/tmpfiles.d/zabbix.conf
  443. %endif
  444. %{_bindir}/zabbix_js
  445. %if %{with server}
  446. %files server-common
  447. %defattr(-,root,root,-)
  448. %dir %{_sysconfdir}/zabbix
  449. %config(noreplace) %{_sysconfdir}/zabbix/zabbix_server.conf
  450. %config(noreplace) %{_sysconfdir}/logrotate.d/zabbix_server
  451. %if !%{with systemd}
  452. %{_initddir}/zabbix_server*
  453. %endif
  454. %{_mandir}/man8/zabbix_server.8*
  455. %files server-mysql
  456. %defattr(-,root,root,-)
  457. %{_sbindir}/zabbix_server.mysql
  458. %if %{with systemd}
  459. %{_unitdir}/zabbix-server-mysql.service
  460. %endif
  461. %files server-postgresql
  462. %defattr(-,root,root,-)
  463. %{_sbindir}/zabbix_server.pgsql
  464. %if %{with systemd}
  465. %{_unitdir}/zabbix-server-pgsql.service
  466. %endif
  467. %endif
  468. %if %{with agent}
  469. %files agent
  470. %defattr(-,root,root,-)
  471. %dir %{_sysconfdir}/zabbix
  472. %config(noreplace) %{_sysconfdir}/zabbix/zabbix_agentd.conf
  473. %config(noreplace) %{_sysconfdir}/logrotate.d/zabbix_agentd
  474. %{_bindir}/zabbix_get
  475. %{_bindir}/zabbix_sender
  476. %{_sbindir}/zabbix_agentd
  477. %if %{with systemd}
  478. %{_unitdir}/zabbix-agent.service
  479. %else
  480. %{_initddir}/zabbix_agentd
  481. %endif
  482. %{_mandir}/man1/zabbix_get.1*
  483. %{_mandir}/man1/zabbix_sender.1*
  484. %{_mandir}/man8/zabbix_agentd.8*
  485. %endif
  486. %if %{with proxy}
  487. %files proxy-common
  488. %defattr(-,root,root,-)
  489. %dir %{_sysconfdir}/zabbix
  490. %config(noreplace) %{_sysconfdir}/zabbix/zabbix_proxy.conf
  491. %config(noreplace) %{_sysconfdir}/logrotate.d/zabbix_proxy
  492. %if !%{with systemd}
  493. %{_initddir}/zabbix_proxy
  494. %endif
  495. %{_mandir}/man8/zabbix_proxy.8*
  496. %{_datadir}/zabbix-proxy
  497. %files proxy-mysql
  498. %defattr(-,root,root,-)
  499. %{_sbindir}/zabbix_proxy.mysql
  500. %if %{with systemd}
  501. %{_unitdir}/zabbix-proxy-mysql.service
  502. %endif
  503. %files proxy-postgresql
  504. %defattr(-,root,root,-)
  505. %{_sbindir}/zabbix_proxy.pgsql
  506. %if %{with systemd}
  507. %{_unitdir}/zabbix-proxy-pgsql.service
  508. %endif
  509. %endif
  510. %if %{with frontend}
  511. %files frontend-php
  512. %defattr(-,root,root,-)
  513. %license zabbix_mysql/COPYING
  514. %doc zabbix_mysql/AUTHORS zabbix_mysql/ChangeLog zabbix_mysql/NEWS zabbix_mysql/README
  515. %dir %{_datadir}/zabbix-frontend
  516. %{_datadir}/zabbix-frontend/php
  517. %files frontend-php-mysql
  518. %files frontend-php-postgresql
  519. %endif
  520. %changelog
  521. * Thu Jul 23 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.2-1
  522. - new upstream release.
  523. - dropped all patches: made to get the same effect by another method.
  524. * Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.19-2
  525. - rebuilt with libevent-2.1.11.
  526. * Mon Apr 06 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.19-1
  527. - new upstream release.
  528. - dropped Patch3: fixed in upstream.
  529. - changed R:php5 to R:php74.
  530. - added systemd support (disabled as default).
  531. * Thu Dec 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.15-1
  532. - new upstream release.
  533. - imported Patch13 from upstream to support php74.
  534. * Thu Oct 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.13-1
  535. - new upstream release.
  536. - updated patches.
  537. * Wed May 08 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-1
  538. - new upstream release.
  539. - switched to 4.0 LTS.
  540. - dropped Patch0: made to get same effect by another method.
  541. - updated Patch1 and 2.
  542. * Wed Nov 07 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.23-1
  543. - new upstream release.
  544. * Tue Jun 12 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 3.0.13-2
  545. - accept building only agent
  546. * Thu Dec 21 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.13-1
  547. - new upstream release.
  548. * Fri Apr 21 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.8-1
  549. - new upstream release.
  550. * Fri Mar 18 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.1-1
  551. - new upstream release.
  552. - disabled jabber support.
  553. * Wed Sep 9 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.6-1
  554. - new upstream release.
  555. * Sat Apr 11 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.9-1
  556. - new upstream release.
  557. * Sun Jul 6 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.4-1
  558. - new upstream release.
  559. - built with both of mysql and postgresql.
  560. * Mon Oct 07 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.8-1
  561. - update to 2.0.8
  562. * Wed Feb 20 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.5-2
  563. - use %%bcond_with mysql to build with mysql
  564. * Tue Feb 19 2013 IWAI, Masaharu <iwai@alib.jp> 2.0.5-1
  565. - update to 2.0.5
  566. - add using MySQL client library switch: default no
  567. - define use_postfix and use_mysql
  568. - add BuildRequires: MySQL-devel
  569. - add configure option: --with-mysql
  570. * Thu Feb 7 2013 IWAI, Masaharu <iwai@alib.jp> 2.0.4-1
  571. - initial build for Vine Linux