polkit-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424
  1. %bcond_with systemd
  2. Summary: PolicyKit Authorization Framework
  3. Summary(ja): PolicyKit 認証フレームワーク
  4. Name: polkit
  5. Version: 0.116
  6. Release: 2%{?_dist_release}%{?with_systemd:.systemd}
  7. Group: System Environment/Libraries
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: LGPLv2+
  11. URL: https://www.freedesktop.org/wiki/Software/polkit
  12. Source0: https://www.freedesktop.org/software/%{name}/releases/%{name}-%{version}.tar.gz
  13. Patch0: polkit-0.115-elogind.patch
  14. Patch1: polkit-0.116-pkttyagent-sigttou-bg-job.patch
  15. Patch2: pkttyagent-tcsaflush-batch-erase.patch
  16. Patch3: jsauthority-memleak.patch
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  18. BuildRequires: elogind-devel
  19. BuildRequires: glib2-devel
  20. BuildRequires: expat-devel
  21. BuildRequires: pam-devel
  22. BuildRequires: mozjs60-devel
  23. BuildRequires: gtk-doc
  24. BuildRequires: intltool
  25. BuildRequires: gobject-introspection-devel
  26. Requires: dbus
  27. Obsoletes: PolicyKit <= 0.10
  28. Provides: PolicyKit = 0.11
  29. Obsoletes: polkit-desktop-policy < 0.103
  30. Provides: polkit-desktop-policy = 0.103
  31. %if %{with systemd}
  32. %{?systemd_requires}
  33. %endif
  34. %description
  35. PolicyKit is a toolkit for defining and handling authorizations.
  36. It is used for allowing unprivileged processes to speak to privileged
  37. processes.
  38. %package devel
  39. Summary: Development files for PolicyKit
  40. Summary(ja): PolicyKit の開発用ファイル
  41. Group: Development/Libraries
  42. Requires: %name = %{version}-%{release}
  43. Requires: %name-docs = %{version}-%{release}
  44. Requires: pkgconfig
  45. Requires: glib2-devel
  46. %description devel
  47. Development files for PolicyKit.
  48. %package docs
  49. Summary: Development documentation for PolicyKit
  50. Summary(ja): PolicyKit の開発用ドキュメント
  51. Group: Development/Libraries
  52. Requires: %name-devel = %{version}-%{release}
  53. Requires: gtk-doc
  54. %description docs
  55. Development documentation for PolicyKit.
  56. %prep
  57. %setup -q
  58. %if !%{with systemd}
  59. %patch0 -p1
  60. %endif
  61. %patch1 -p1
  62. %patch2 -p1
  63. %patch3 -p1
  64. %build
  65. autoreconf -vif
  66. export CXXFLAGS="%{optflags} -std=gnu++11"
  67. %configure \
  68. --with-os-type=redhat \
  69. --enable-gtk-doc \
  70. --disable-static \
  71. --libexecdir=%{_libexecdir}/polkit-1 \
  72. --enable-introspection \
  73. %if %{with systemd}
  74. --enable-libsystemd-login=yes \
  75. %else
  76. --enable-libelogind=yes \
  77. %endif
  78. --enable-examples
  79. make
  80. %install
  81. rm -rf $RPM_BUILD_ROOT
  82. make install DESTDIR=$RPM_BUILD_ROOT
  83. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  84. rm -f $RPM_BUILD_ROOT%{_libdir}/polkit-1/extensions/*.la
  85. %find_lang polkit-1
  86. %clean
  87. rm -rf $RPM_BUILD_ROOT
  88. %pre
  89. groupadd -g 27 -r polkitd 2>&1 > /dev/null || :
  90. useradd -u 27 -g polkitd -r -d '/' -s /sbin/nologin -c "User for polkitd" polkitd 2>&1 > /dev/null || :
  91. exit 0
  92. %post
  93. /sbin/ldconfig
  94. %if %{with systemd}
  95. %systemd_post polkit.service
  96. %endif
  97. %if %{with systemd}
  98. %preun
  99. %systemd_preun polkit.service
  100. %endif
  101. %postun
  102. /sbin/ldconfig
  103. %if %{with systemd}
  104. %systemd_postun_with_restart polkit.service
  105. %endif
  106. %files -f polkit-1.lang
  107. %defattr(-,root,root,-)
  108. %license COPYING
  109. %doc NEWS README
  110. %{_libdir}/lib*.so.*
  111. %{_datadir}/man/man1/*
  112. %{_datadir}/man/man8/*
  113. %{_datadir}/dbus-1/system-services/*
  114. %if %{with systemd}
  115. %{_unitdir}/polkit.service
  116. %endif
  117. %dir %{_datadir}/polkit-1/
  118. %dir %{_datadir}/polkit-1/actions
  119. %attr(0700,polkitd,root) %dir %{_datadir}/polkit-1/rules.d
  120. %{_datadir}/polkit-1/actions/org.freedesktop.policykit.policy
  121. %dir %{_sysconfdir}/polkit-1
  122. %{_sysconfdir}/polkit-1/rules.d/50-default.rules
  123. %attr(0700,polkitd,root) %dir %{_sysconfdir}/polkit-1/rules.d
  124. %{_sysconfdir}/dbus-1/system.d/org.freedesktop.PolicyKit1.conf
  125. %{_sysconfdir}/pam.d/polkit-1
  126. %{_bindir}/pkaction
  127. %{_bindir}/pkcheck
  128. %{_bindir}/pkttyagent
  129. %dir %{_prefix}/lib/polkit-1
  130. %{_prefix}/lib/polkit-1/polkitd
  131. %{_libdir}/girepository-1.0/*.typelib
  132. # see upstream docs for why these permissions are necessary
  133. %attr(4755,root,root) %{_bindir}/pkexec
  134. %attr(4755,root,root) %{_prefix}/lib/polkit-1/polkit-agent-helper-1
  135. %files devel
  136. %defattr(-,root,root,-)
  137. %{_libdir}/lib*.so
  138. %{_libdir}/pkgconfig/*.pc
  139. %{_datadir}/gir-1.0/*.gir
  140. %{_includedir}/*
  141. %{_bindir}/pk-example-frobnicate
  142. %{_datadir}/polkit-1/actions/org.freedesktop.policykit.examples.pkexec.policy
  143. %dir %{_datadir}/gettext
  144. %dir %{_datadir}/gettext/its
  145. %{_datadir}/gettext/its/*
  146. %files docs
  147. %defattr(-,root,root,-)
  148. %{_datadir}/gtk-doc/html/*
  149. %changelog
  150. * Sat Jul 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.116-2
  151. - added systemd support (disabled as default).
  152. - imported Patch1-3 from rawhide.
  153. * Tue Mar 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.116-1
  154. - new upstream release.
  155. * Fri Jan 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.115-2
  156. - really enabled elogind.
  157. * Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.115-1
  158. - new upstream release.
  159. - enabled elogind: ConsoleKit is obsolete.
  160. * Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.112-2
  161. - new upstream release
  162. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.112-1
  163. - new upstream release
  164. * Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.110-1
  165. - new upstream release
  166. * Thu Sep 27 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.107-1
  167. - new upstream release
  168. - add BuildRequires: js-devel
  169. - remove BuildRequires: eggdbus-devel
  170. - remove polkit-desktop-policy subpackage (based on fedora)
  171. - historical changelogs are following:
  172. * Tue May 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.105-1
  173. - new upstream release
  174. * Sat Feb 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.104-1
  175. - new upstream release
  176. * Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.102-1
  177. - new upstream release
  178. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.99-1
  179. - new upstream release
  180. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 0.96-2
  181. - build with rpm-4.8.1-1 for pkg-config file
  182. * Mon Feb 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.96-1
  183. - update to 0.96
  184. - BR: eggdbus-devel >= 0.6
  185. * Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.95-0.2.git20090913
  186. - remove Obsoletes:/Provides: PolicyKit*
  187. * Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.95-0.1.git20090913
  188. - initial build for Vine Linux
  189. * Wed Jul 11 2012 David Zeuthen <davidz@redhat.com> 0.107-1%{?dist}
  190. - Update to upstream release 0.107
  191. * Fri Jun 29 2012 David Zeuthen <davidz@redhat.com> 0.106-2%{?dist}
  192. - Add forgotten Requires(pre): shadow-utils
  193. * Thu Jun 07 2012 David Zeuthen <davidz@redhat.com> 0.106-1%{?dist}
  194. - Update to upstream release 0.106
  195. - Authorizations are no longer controlled by .pkla files - from now
  196. on, use the new .rules files described in the polkit(8) man page
  197. * Tue Apr 24 2012 David Zeuthen <davidz@redhat.com> 0.105-1%{?dist}
  198. - Update to upstream release 0.105
  199. - Nuke patches that are now upstream
  200. - Change 'PolicyKit' to 'polkit' in summary and descriptions
  201. * Thu Mar 08 2012 David Zeuthen <davidz@redhat.com> 0.104-6%{?dist}
  202. - Don't leak file descriptors (bgo #671486)
  203. * Mon Feb 13 2012 Matthias Clasen <mclasen@redhat.com> - 0.104-5%{?dist}
  204. - Make the -docs subpackage noarch
  205. * Mon Feb 06 2012 David Zeuthen <davidz@redhat.com> 0.104-4%{?dist}
  206. - Set error if we cannot obtain a PolkitUnixSession for a given PID (#787222)
  207. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.104-3
  208. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  209. * Tue Jan 03 2012 David Zeuthen <davidz@redhat.com> 0.104-2%{?dist}
  210. - Nuke the ConsoleKit run-time requirement
  211. * Tue Jan 03 2012 David Zeuthen <davidz@redhat.com> 0.104-1%{?dist}
  212. - Update to upstream release 0.104
  213. - Force usage of systemd (instead of ConsoleKit) for session tracking
  214. * Tue Dec 06 2011 David Zeuthen <davidz@redhat.com> 0.103-1%{?dist}
  215. - Update to upstream release 0.103
  216. - Drop upstreamed patch
  217. - Drop Fedora-specific policy, it is now upstream (fdo #41008)
  218. * Wed Oct 26 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.102-3
  219. - Rebuilt for glibc bug#747377
  220. * Tue Oct 18 2011 David Zeuthen <davidz@redhat.com> 0.102-2%{?dist}
  221. - Add patch to neuter the annoying systemd behavior where stdout/stderr
  222. is sent to the system logs
  223. * Thu Aug 04 2011 David Zeuthen <davidz@redhat.com> 0.102-1
  224. - Update to 0.102 release
  225. * Fri May 13 2011 Bastien Nocera <bnocera@redhat.com> 0.101-7
  226. - Allow setting the pretty hostname without a password for wheel,
  227. change matches systemd in git
  228. * Mon May 2 2011 Matthias Clasen <mclasen@redhat.com> - 0.101-6
  229. - Update the action id of the datetime mechanism
  230. * Tue Apr 19 2011 David Zeuthen <davidz@redhat.com> - 0.101-5
  231. - CVE-2011-1485 (#697951)
  232. * Tue Mar 22 2011 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.101-4
  233. - Also allow org.kde.kcontrol.kcmclock.save without password for wheel
  234. * Thu Mar 17 2011 David Zeuthen <davidz@redhat.com> - 0.101-3
  235. - Fix typo in pkla file (thanks notting)
  236. * Thu Mar 17 2011 David Zeuthen <davidz@redhat.com> - 0.101-2
  237. - Nuke desktop_admin_r and desktop_user_r groups - just use the
  238. wheel group instead (#688363)
  239. - Update the set of configuration directives that gives users
  240. in the wheel group extra privileges
  241. * Thu Mar 03 2011 David Zeuthen <davidz@redhat.com> - 0.101-1
  242. - New upstream version
  243. * Mon Feb 21 2011 David Zeuthen <davidz@redhat.com> - 0.100-1
  244. - New upstream version
  245. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.98-7
  246. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  247. * Fri Jan 28 2011 Matthias Clasen <mclasen@redhat.com> - 0.98-6
  248. - Own /usr/libexec/polkit-1
  249. * Sun Nov 14 2010 Matthias Clasen <mclasen@redhat.com> - 0.98-5
  250. - Enable introspection
  251. * Thu Sep 02 2010 David Zeuthen <davidz@redhat.com> - 0.98-4
  252. - Fix #629515 in a way that doesn't require autoreconf
  253. * Thu Sep 02 2010 David Zeuthen <davidz@redhat.com> - 0.98-2
  254. - Include polkitagentenumtypes.h (#629515)
  255. * Mon Aug 23 2010 Matthias Clasen <mclasen@redhat.com> - 0.98-1
  256. - Update to upstream release 0.98
  257. - Co-own /usr/share/gtk-doc (#604410)
  258. * Wed Aug 18 2010 Matthias Clasen <mclasen@redhat.com> - 0.97-5
  259. - Rebuid to work around bodhi limitations
  260. * Wed Aug 18 2010 Matthias Clasen <mclasen@redhat.com> - 0.97-4
  261. - Fix a ConsoleKit interaction bug
  262. * Fri Aug 13 2010 David Zeuthen <davidz@redhat.com> - 0.97-3
  263. - Add a patch to make pkcheck(1) work the way libvirtd uses it (#623257)
  264. - Require GLib >= 2.25.12 instead of 2.25.11
  265. - Ensure polkit-gnome packages earlier than 0.97 are not used with
  266. these packages
  267. * Mon Aug 09 2010 David Zeuthen <davidz@redhat.com> - 0.97-2
  268. - Rebuild
  269. * Mon Aug 09 2010 David Zeuthen <davidz@redhat.com> - 0.97-1
  270. - Update to 0.97. This release contains a port from EggDBus to the
  271. GDBus code available in recent GLib releases.
  272. * Fri Jan 15 2010 David Zeuthen <davidz@redhat.com> - 0.96-1
  273. - Update to 0.96
  274. - Disable introspection support for the time being
  275. * Fri Nov 13 2009 David Zeuthen <davidz@redhat.com> - 0.95-2
  276. - Rebuild
  277. * Fri Nov 13 2009 David Zeuthen <davidz@redhat.com> - 0.95-1
  278. - Update to 0.95
  279. - Drop upstreamed patches
  280. * Tue Oct 20 2009 Matthias Clasen <mclasen@redhat.com> - 0.95-0.git20090913.3
  281. - Fix a typo in pklocalauthority(8)
  282. * Mon Sep 14 2009 David Zeuthen <davidz@redhat.com> - 0.95-0.git20090913.2
  283. - Refine how Obsolete: is used and also add Provides: (thanks Jesse
  284. Keating and nim-nim)
  285. * Mon Sep 14 2009 David Zeuthen <davidz@redhat.com> - 0.95-0.git20090913.1
  286. - Add bugfix for polkit_unix_process_new_full() (thanks Bastien Nocera)
  287. - Obsolete old PolicyKit packages
  288. * Sun Sep 13 2009 David Zeuthen <davidz@redhat.com> - 0.95-0.git20090913
  289. - Update to git snapshot
  290. - Drop upstreamed patches
  291. - Turn on GObject introspection
  292. - Don't delete desktop_admin_r and desktop_user_r groups when
  293. uninstalling polkit-desktop-policy
  294. * Fri Sep 11 2009 David Zeuthen <davidz@redhat.com> - 0.94-4
  295. - Add some patches from git master
  296. - Sort pkaction(1) output
  297. - Bug 23867 – UnixProcess vs. SystemBusName aliasing
  298. * Thu Aug 13 2009 David Zeuthen <davidz@redhat.com> - 0.94-3
  299. - Add desktop_admin_r and desktop_user_r groups along with a first cut
  300. of default authorizations for users in these groups.
  301. * Wed Aug 12 2009 David Zeuthen <davidz@redhat.com> - 0.94-2
  302. - Disable GObject Introspection for now as it breaks the build
  303. * Wed Aug 12 2009 David Zeuthen <davidz@redhat.com> - 0.94-1
  304. - Update to upstream release 0.94
  305. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.93-3
  306. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  307. * Mon Jul 20 2009 David Zeuthen <davidz@redhat.com> - 0.93-2
  308. - Rebuild
  309. * Mon Jul 20 2009 David Zeuthen <davidz@redhat.com> - 0.93-1
  310. - Update to 0.93
  311. * Tue Jun 09 2009 David Zeuthen <davidz@redhat.com> - 0.92-3
  312. - Don't make docs noarch (I *heart* multilib)
  313. - Change license to LGPLv2+
  314. * Mon Jun 08 2009 David Zeuthen <davidz@redhat.com> - 0.92-2
  315. - Rebuild
  316. * Mon Jun 08 2009 David Zeuthen <davidz@redhat.com> - 0.92-1
  317. - Update to 0.92 release
  318. * Wed May 27 2009 David Zeuthen <davidz@redhat.com> - 0.92-0.git20090527
  319. - Update to 0.92 snapshot
  320. * Mon Feb 9 2009 David Zeuthen <davidz@redhat.com> - 0.91-1
  321. - Initial spec file.