libdvdread-vl.spec 5.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203
  1. # -*- coding: utf-8-unix -*-
  2. Name: libdvdread
  3. Summary: A library for reading DVD video discs based on Ogle code
  4. Version: 4.2.0
  5. Release: 1%{?_dist_release}
  6. Group: System Environment/Libraries
  7. License: GPLv2+
  8. Source0: http://dvdnav.mplayerhq.hu/releases/libdvdread-%{version}.tar.bz2
  9. # dvdread-config: use pkg-config instead of hard-coded
  10. # multilib-conflicting values
  11. Patch1: %{name}-multilib.patch
  12. Obsoletes: self-build-libdvdread
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. Packager: munepi
  17. %description
  18. libdvdread provides a simple foundation for reading DVD video disks.
  19. It provides the functionality that is required to access many DVDs.
  20. %package devel
  21. Summary: Development files for libdvdread
  22. Group: Development/Libraries
  23. Requires: %{name} = %{version}-%{release}
  24. Requires: pkgconfig
  25. %description devel
  26. libdvdread provides a simple foundation for reading DVD video disks.
  27. It provides the functionality that is required to access many DVDs.
  28. This package contains development files for libdvdread.
  29. %prep
  30. %setup -q
  31. %patch1 -p1 -b .multilib
  32. %build
  33. ./configure2 \
  34. --disable-opts \
  35. --disable-static \
  36. --disable-strip \
  37. --extra-cflags="%{optflags}" \
  38. --libdir=%{_libdir} \
  39. --prefix=%{_prefix} \
  40. --shlibdir=%{_libdir} \
  41. ;
  42. %{__make} %{?_smp_mflags}
  43. %install
  44. %{__rm} -rf %{buildroot}
  45. %{__make} install DESTDIR=%{buildroot}
  46. %clean
  47. %{__rm} -rf %{buildroot}
  48. %post -p /sbin/ldconfig
  49. %postun -p /sbin/ldconfig
  50. %files
  51. %defattr(-,root,root,-)
  52. %doc AUTHORS COPYING ChangeLog README
  53. %{_libdir}/libdvdread.so.*
  54. %files devel
  55. %defattr(-,root,root,-)
  56. %doc DEVELOPMENT-POLICY.txt TODO
  57. %{_bindir}/dvdread-config
  58. %{_includedir}/dvdread
  59. %{_libdir}/libdvdread.so
  60. %{_libdir}/pkgconfig/dvdread.pc
  61. %changelog
  62. * Wed Nov 2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 4.2.0-1
  63. - updated to 4.2.0 release
  64. - dropped obsolete endianness check patch
  65. - simplified multilib patch from Fedora rawhide
  66. - added some docs
  67. - added Vendor, Distribution, Packager tags
  68. * Sat Sep 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.1.3-4
  69. - rebuilt with rpm-4.8.1 for pkg-config
  70. * Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.1.3-3
  71. - add Patch10: fix DVD playback failure on ppc (big endian, more precisely)
  72. * Fri Nov 07 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.1.3-2
  73. - obsolete self-build-libdvdread
  74. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.1.3-1
  75. - initial bulid based on Fedora package
  76. * Tue Sep 09 2008 Dominik Mierzejewski <rpm@greysector.net> 4.1.3-1
  77. - update to 4.1.3 final
  78. * Sun Aug 31 2008 Dominik Mierzejewski <rpm@greysector.net> 4.1.3-0.3.rc1
  79. - update to 4.1.3rc1
  80. - fix include path
  81. * Thu Jul 17 2008 Dominik Mierzejewski <rpm@greysector.net> 4.1.3-0.2
  82. - resurrect package from new upstream
  83. * Sun Jan 27 2008 Dominik Mierzejewski <rpm@greysector.net> 0.9.7-4
  84. - fix missing <inttypes.h> include (bug 428910)
  85. * Wed Aug 29 2007 Dominik Mierzejewski <rpm@greysector.net> 0.9.7-3
  86. - rebuild for BuildID
  87. - update license tag
  88. * Wed Nov 26 2006 Dominik Mierzejewski <rpm@greysector.net> 0.9.7-2
  89. - Rebuild.
  90. * Fri Oct 6 2006 Dams <anvil[AT]livna.org> - 0.9.7-1
  91. - Updated to 0.9.7
  92. * Wed Sep 20 2006 Ville Skytt霎ー <ville.skytta at iki.fi> - 0.9.6-2
  93. - Rebuild.
  94. * Sun Jul 23 2006 Ville Skytt霎ー <ville.skytta at iki.fi> - 0.9.6-1
  95. - 0.9.6.
  96. - Specfile cleanup.
  97. * Thu Mar 16 2006 Ville Skytt霎ー <ville.skytta at iki.fi> - 0.9.4-4
  98. - Fix linking with libdl on x86_64.
  99. - Don't ship static libs.
  100. - Build with dependency tracking disabled.
  101. - Convert specfile and docs to UTF-8.
  102. - Improve package descriptions.
  103. * Thu Mar 16 2006 Dams <anvil[AT]livna.org> - 0.9.4-3
  104. - We BuildConflicting libdvdcss-devel at build time
  105. * Mon Mar 13 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> 0.9.4-2
  106. - Drop Epoch completely
  107. * Thu Mar 09 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  108. - switch to new release field
  109. - drop Epoch
  110. * Tue Feb 28 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  111. - add dist
  112. * Thu Apr 3 2003 Marius Johndal <mariuslj at ifi.uio.no> 0:0.9.4-0.fdr.1
  113. - Initial Fedora RPM release.
  114. * Mon Mar 31 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
  115. - Rebuilt for Red Hat Linux 9.
  116. - Exclude .la file.
  117. * Sun Feb 16 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
  118. - Update to 0.9.4.
  119. * Thu Sep 26 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
  120. - Updated to the latest cvs release.
  121. - Rebuilt for Red Hat Linux 8.0.
  122. - Updated URLs.
  123. * Mon May 27 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
  124. - Update to 0.9.3.
  125. * Wed May 15 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
  126. - Fixed the libdvdcss.so.0/1/2 problem again.
  127. * Thu May 2 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
  128. - Back to using libdvdcss 1.1.1, now it's all merged and fine.
  129. - Rebuilt against Red Hat Linux 7.3.
  130. - Added the %{?_smp_mflags} expansion.
  131. * Sat Jan 12 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
  132. - Reverted back to using libdvdcss 0.0.3.ogle3 since it works MUCH better
  133. than 1.0.x. Doh!
  134. * Tue Nov 13 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
  135. - Rebuilt against libdvdcss 1.0.0 (added a patch).
  136. * Mon Oct 29 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
  137. - Spec file cleanup and fixes.
  138. * Thu Oct 11 2001 Martin Norb霎ーck <d95mback@dtek.chalmers.se>
  139. - Updated to version 0.9.2
  140. * Tue Sep 25 2001 Martin Norb霎ーck <d95mback@dtek.chalmers.se>
  141. - Added small patch to fix the ldopen of libdvdcss
  142. * Tue Sep 18 2001 Martin Norb霎ーck <d95mback@dtek.chalmers.se>
  143. - Updated to version 0.9.1
  144. * Fri Sep 14 2001 Martin Norb霎ーck <d95mback@dtek.chalmers.se>
  145. - Split into normal and devel package
  146. * Thu Sep 6 2001 Martin Norb霎ーck <d95mback@dtek.chalmers.se>
  147. - Updated to version 0.9.0
  148. * Tue Jul 03 2001 Martin Norb霎ーck <d95mback@dtek.chalmers.se>
  149. - initial version