libotf-vl.spec 3.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123
  1. ## -*- coding: utf-8-unix -*-
  2. Name: libotf
  3. Version: 0.9.12
  4. Release: 1%{?_dist_release}
  5. Summary: A Library for handling OpenType Font
  6. Summary(ja): OpenType フォントを扱うライブラリ
  7. Group: System Environment/Libraries
  8. License: LGPLv2+
  9. URL: http://www.m17n.org/libotf/
  10. Source0: http://www.m17n.org/%{name}/%{name}-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: gcc chrpath freetype2-devel libXaw-devel
  13. Requires: freetype2
  14. %description
  15. The library "libotf" provides the following facilites.
  16. Read Open Type Layout Tables from OTF file. Currently these tables are
  17. supported; head, name, cmap, GDEF, GSUB, and GPOS. Convert a Unicode
  18. character sequence to a glyph code sequence by using the above tables.
  19. The combination of libotf and the FreeType library (Ver.2) realizes
  20. CTL (complex text layout) by OpenType fonts. This library is currently
  21. used by the m17n library. It seems that the probject Free Type Layout
  22. provides the similar (or better) facility as this library, but
  23. currently they have not yet released their library. So, we have
  24. developed this one.
  25. %package devel
  26. Summary: Development files for %{name}
  27. Group: Development/Libraries
  28. Requires: %{name} = %{version}-%{release}, pkgconfig
  29. %description devel
  30. The %{name}-devel package contains libraries and header files for
  31. developing applications that use %{name}.
  32. %prep
  33. %setup -q
  34. %build
  35. %configure --disable-static
  36. %__make %{?_smp_mflags}
  37. %install
  38. %__rm -rf $RPM_BUILD_ROOT
  39. %__make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
  40. find $RPM_BUILD_ROOT -name '*.la' -exec %__rm -f {} ';'
  41. for file in $RPM_BUILD_ROOT/usr/bin/*; do chrpath -d $file || true; done
  42. (cd example && %__make clean && %__rm -rf .deps && rm Makefile)
  43. %__rm $RPM_BUILD_ROOT/usr/bin/libotf-config
  44. %clean
  45. %__rm -rf $RPM_BUILD_ROOT
  46. %post -p /sbin/ldconfig
  47. %postun -p /sbin/ldconfig
  48. %files
  49. %defattr(-,root,root,-)
  50. %doc AUTHORS COPYING README NEWS
  51. %{_libdir}/*.so.*
  52. %{_bindir}/otfdump
  53. %{_bindir}/otflist
  54. %{_bindir}/otftobdf
  55. %{_bindir}/otfview
  56. %files devel
  57. %defattr(-,root,root,-)
  58. %doc example
  59. %{_includedir}/*
  60. %{_libdir}/*.so
  61. %{_libdir}/pkgconfig/*
  62. %changelog
  63. * Tue Feb 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.12-1
  64. - new upstream release
  65. * Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9-1
  66. - built based on Fedora development
  67. - s/freetype/freetype2/ in Requires, BuildRequires tags
  68. * Sat Oct 24 2009 Neal Becker <ndbecker2@gmail.com> - 0.9.9-3
  69. - Add BR libXaw-devel (BR 530586)
  70. * Fri Oct 9 2009 Neal Becker <ndbecker2@gmail.com> - 0.9.9-2
  71. - Remove libotf-config (just just pkg-config instead)
  72. - Remove example/Makefile to fix multilib conflict
  73. * Tue Aug 25 2009 Neal Becker <ndbecker2@gmail.com> - 0.9.9-1
  74. - Update to 0.9.9
  75. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.8-3
  76. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  77. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.8-2
  78. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  79. * Fri Aug 8 2008 Neal Becker <ndbecker2@gmail.com> - 0.9.8-1
  80. - Update to 0.9.8
  81. * Mon Apr 14 2008 Neal Becker <ndbecker2@gmail.com> - 0.9.7-4
  82. - Remove .deps from example
  83. * Fri Mar 28 2008 Neal Becker <ndbecker2@gmail.com> - 0.9.7-3
  84. - Change to LGPLv2+
  85. - Add examples
  86. * Wed Mar 26 2008 Neal Becker <ndbecker2@gmail.com> - 0.9.7-2
  87. - Cleanup suggestions from panemade at gmail dot com
  88. * Tue Mar 25 2008 Neal Becker <ndbecker2@gmail.com> - 0.9.7-1
  89. - Initial