1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071 |
- %define pyver %(python -c 'import sys;print(sys.version[0:3])')
- #%%define pysite %{_libdir}/python%{pyver}/site-packages
- %define pysite %(python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(0)')
- %define pyinc %{_includedir}/python%{pyver}
- %define pkg_release 3%{?_dist_release}
- Summary: The Python X Library
- Summary(ja): Python X ライブラリ
- Name: python-xlib
- Version: 0.14
- Release: %{pkg_release}
- License: GPL
- Group: Development/Languages
- URL: http:
- Source0: http:
- AutoReqProv: no
- Requires: python >= 1.5.2
- BuildRequires: python python-devel
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- BuildArch: noarch
- %description
- python-xlib is a 100% pure Python implementation of the X11 protocol.
- It currently implements client-side X11R6 fully, supports the resource
- database, ICCM, and the Shape extension.
- %description -l ja
- python-xlib は 100% Python 言語で書かれた X11 protocol の実装です。
- 現在はクライアントサイドの X11R6 が全て実装されており、リソース
- データベースや、ICCM、Shape Extension がサポートされています。
- %prep
- %setup -q
- %build
- %{__python} setup.py build
- # create html document
- pushd $docdir doc/html
- %{__make}
- popd
- %install
- %{__rm} -rf ${RPM_BUILD_ROOT}
- %{__python} setup.py install --root=${RPM_BUILD_ROOT}
- %clean
- %{__rm} -rf $}RPM_BUILD_ROOT}
- %files
- %defattr(-, root, root)
- %doc COPYING NEWS README TODO doc/html
|