peco-vl.spec 2.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889
  1. %define pkg_name peco
  2. %define pkg_version 0.3.6
  3. %define pkg_release 1%{?_dist_release}
  4. %global gopath %{_datadir}/gocode
  5. Summary: Simplistic interactive filtering tool
  6. Summary(ja): シンプルな対話式フィルタリングツール
  7. Name: %{pkg_name}
  8. Version: %{pkg_version}
  9. Release: %{pkg_release}
  10. License: MIT License
  11. Group: Applications/Text
  12. URL: https://github.com/peco/peco
  13. Source: https://github.com/peco/peco/archive/v%{version}.tar.gz#/peco-%{version}.tar.gz
  14. BuildRoot: %{_tmppath}/%{pkg_name}-%{version}-root
  15. BuildRequires: golang
  16. BuildRequires: golang(github.com/google/btree)
  17. BuildRequires: golang(github.com/mattn/go-runewidth)
  18. BuildRequires: golang(github.com/jessevdk/go-flags)
  19. BuildRequires: golang(github.com/nsf/termbox-go)
  20. Vendor: Project Vine
  21. Distribution: Vine Linux
  22. Packager: ara_t
  23. %description
  24. peco is a simplistic interactive filtering tool
  25. based on a python tool, percol, and written in Go.
  26. %description -l ja
  27. pecoはシンプルな対話式フィルタリングツールであり、
  28. Pyhon製のpercolをGo言語で実装したプログラムです。
  29. %prep
  30. %{__rm} -rf ${RPM_BUILD_ROOT}
  31. %setup -q
  32. %build
  33. export BUILD_DIR=$(pwd)/.build
  34. export GOPATH=$BUILD_DIR:%{gopath}
  35. %{__mkdir_p} $BUILD_DIR/src/github.com/peco/peco
  36. %{__cp} -r * $BUILD_DIR/src/github.com/peco/peco
  37. go build cmd/peco/peco.go
  38. %install
  39. %{__mkdir_p} ${RPM_BUILD_ROOT}%{_bindir}
  40. %{__install} -m 755 peco ${RPM_BUILD_ROOT}%{_bindir}
  41. %clean
  42. %{__rm} -rf ${RPM_BUILD_ROOT}
  43. %files
  44. %defattr(-, root, root)
  45. %doc LICENSE
  46. %doc README.md Changes
  47. %{_bindir}/
  48. %changelog
  49. * Wed May 11 2016 Toshiaki Ara <ara_t@384.jp> 0.3.6-1
  50. - update to 0.3.6
  51. * Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 0.3.5-5
  52. - correct SPEC file
  53. * Fri Jan 29 2016 Toshiaki Ara <ara_t@384.jp> 0.3.5-4
  54. - defile %%{gopath}
  55. * Mon Jan 25 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.5-3
  56. - using golang-* RPM packages for BuildRequires
  57. - stop 'go get' in build section
  58. - update build section
  59. - add LICENSE, README.md and Changes
  60. * Tue Jan 19 2016 Toshiaki Ara <ara_t@384.jp> 0.3.5-2
  61. - build with Go
  62. - change spec file
  63. * Sun Jan 17 2016 Toshiaki Ara <ara_t@384.jp> 0.3.5-1
  64. - new package