scim-bridge-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define name scim-bridge
  3. %define version 0.4.16
  4. %define release 16%{?_dist_release}
  5. %define qt3_ver 3.3.8
  6. %define qt4_ver 4.8.0
  7. # build qt3 immodule ("--without qt3" to disable qt3)
  8. %bcond_without qt3
  9. %define _qt3_version 3.3.8
  10. %define _qt3_prefix %{_libdir}/qt-%{_qt3_version}
  11. %define _qt3_plugindir %{_qt3_prefix}/plugins
  12. # build qt4 immodule ("--without qt4" to disable qt4)
  13. %bcond_without qt4
  14. # Qt4 version auto-detection -- inagaki
  15. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
  16. %define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
  17. %define _qt4_plugindir %(pkg-config --variable plugindir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
  18. Summary: yet another IM client of SCIM
  19. Summary(ja): もう一つ別の SCIM IM クライアント
  20. Name: %{name}
  21. Version: %{version}
  22. Release: %{release}
  23. Group: System Environment/Libraries
  24. License: GPL/LGPL
  25. URL: http://www.scim-im.org/projects/scim_bridge
  26. Source0: http://1jaist.dl.sourceforge.net/sourceforge/scim/%{name}-%{version}.tar.gz
  27. # Patch from Fedora 10
  28. Patch0: scim-bridge-0.4.15-fix-gdm.patch
  29. Patch1: scim-bridge-0.4.15-bz461373.patch
  30. # Patch from Mandriva 2009
  31. Patch2: bug-351920-should-return-retval.patch
  32. Patch3: scim-bridge-0.4.15.2-linkage.patch
  33. # Patch from Fedora development
  34. Patch4: scim-bridge-0.4.15-EOF.patch
  35. Patch5: scim-bridge-0.4.15-hotkey-help.patch
  36. Patch6: scim-bridge-0.4.16-fix-gtk-key-snooper.patch
  37. Patch7: scim-bridge-0.4.16-fixes-null-imengine.patch
  38. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  39. BuildRequires: scim-devel >= 1.4
  40. BuildRequires: pkgconfig >= 0.9.0
  41. BuildRequires: gtk2-devel >= 2.14.0
  42. Requires: scim >= 1.4
  43. %description
  44. Scim-bridge is yet another IM client of SCIM.
  45. The im-module of scim-bridge communicates with scim via socket.
  46. %description -l ja
  47. scim-bridge は、もう一つ別の SCIM IM クライアントです。
  48. scim-bridge の im-module はソケット経由で SCIM と通信します。
  49. %package gtk
  50. Summary: SCIM Bridge GTK IM Module
  51. Summary(ja): SCIM Bridge GTK IM モジュール
  52. Group: System Environment/Libraries
  53. Requires: %{name} = %{version}-%{release}
  54. Requires: gtk2 >= 2.14.0
  55. Requires(post): gtk2 >= 2.14.0
  56. Requires(postun): gtk2 >= 2.14.0
  57. Obsoletes: %{name} <= 0.1.7
  58. %description gtk
  59. This package provides the SCIM Bridge GTK IM module.
  60. %description -l ja gtk
  61. このパッケージには SCIM Bridge の GTK IM モジュールが含まれています。
  62. %if !%{without qt3}
  63. %package qt
  64. Summary: SCIM Bridge Qt IM Module
  65. Summary(ja): SCIM Bridge Qt IM モジュール
  66. Group: System Environment/Libraries
  67. Requires: %{name} = %{version}-%{release}
  68. Requires: qt = %{_qt3_version}
  69. BuildRequires: qt-devel
  70. BuildRequires: libXmu-devel
  71. %description qt
  72. This package provides the SCIM Bridge Qt IM module.
  73. %description -l ja qt
  74. このパッケージには SCIM Bridge の Qt IM モジュールが含まれています。
  75. %endif
  76. %if !%{without qt4}
  77. %package qt4
  78. Summary: SCIM Bridge Qt4 IM Module
  79. Summary(ja): SCIM Bridge Qt4 IM モジュール
  80. Group: System Environment/Libraries
  81. Requires: %{name} = %{version}-%{release}
  82. Requires: qt4 >= %{_qt4_version}
  83. BuildRequires: qt4-devel
  84. %description qt4
  85. This package provides the SCIM Bridge Qt4 IM module.
  86. %description -l ja qt4
  87. このパッケージには SCIM Bridge の Qt4 IM モジュールが含まれています。
  88. %endif
  89. ## to build compat32 for x86_64 architecture support
  90. %package -n compat32-%{name}-gtk
  91. Summary: SCIM Bridge GTK IM Module
  92. Summary(ja): SCIM Bridge GTK IM モジュール
  93. Group: System Environment/Libraries
  94. Requires: %{name} = %{version}-%{release}
  95. Requires: gtk2 >= 2.14.0
  96. Requires(post): gtk2 >= 2.14.0
  97. Requires(postun): gtk2 >= 2.14.0
  98. %description -n compat32-%{name}-gtk
  99. This package provides the SCIM Bridge GTK IM module.
  100. %description -l ja -n compat32-%{name}-gtk
  101. このパッケージには SCIM Bridge の GTK IM モジュールが含まれています。
  102. %if !%{without qt3}
  103. %package -n compat32-%{name}-qt
  104. Summary: SCIM Bridge Qt IM Module
  105. Summary(ja): SCIM Bridge Qt IM モジュール
  106. Group: System Environment/Libraries
  107. Requires: %{name} = %{version}-%{release}
  108. Requires: qt = %{_qt3_version}
  109. BuildRequires: qt-devel
  110. %description -n compat32-%{name}-qt
  111. This package provides the SCIM Bridge Qt IM module.
  112. %description -l ja -n compat32-%{name}-qt
  113. このパッケージには SCIM Bridge の Qt IM モジュールが含まれています。
  114. %endif
  115. %if !%{without qt4}
  116. %package -n compat32-%{name}-qt4
  117. Summary: SCIM Bridge Qt4 IM Module
  118. Summary(ja): SCIM Bridge Qt4 IM モジュール
  119. Group: System Environment/Libraries
  120. Requires: %{name} = %{version}-%{release}
  121. Requires: qt4 = %{_qt4_version}
  122. BuildRequires: qt4-devel
  123. %description -n compat32-%{name}-qt4
  124. This package provides the SCIM Bridge Qt4 IM module.
  125. %description -l ja -n compat32-%{name}-qt4
  126. このパッケージには SCIM Bridge の Qt4 IM モジュールが含まれています。
  127. %endif
  128. %prep
  129. %setup -q
  130. %patch0 -p1 -b .0-fix-gdm
  131. %patch1 -p1
  132. %patch2 -p1
  133. %patch3
  134. %patch4 -p1
  135. %patch5 -p1
  136. pushd client-gtk
  137. %patch6 -p0
  138. popd
  139. %patch7 -p1
  140. %build
  141. %if !%{without qt3}
  142. export QT3_PREFIX=%{_qt3_prefix}
  143. %endif
  144. %if !%{without qt4}
  145. export QT4_PREFIX=%{_qt4_prefix}
  146. %endif
  147. %configure --disable-static \
  148. %if %{without qt3}
  149. --disable-qt3-immodule \
  150. %else
  151. --enable-qt3-immodule \
  152. %endif
  153. %if %{without qt4}
  154. --disable-qt4-immodule \
  155. %else
  156. --enable-qt4-immodule \
  157. %endif
  158. --enable-gtk2-immodule
  159. %__make %{?_smp_mflags}
  160. %install
  161. %__rm -rf %{buildroot}
  162. #%%makeinstall moduledir=%{buildroot}%{_libdir}/gtk-2.0/immodules
  163. %__make DESTDIR=%{buildroot} install
  164. # remove unneeded files
  165. %__rm -f %{buildroot}%{_libdir}/gtk-2.0/immodules/*.{a,la}
  166. %__rm -f %{buildroot}%{_qt3_plugindir}/inputmethods/*.{a,la}
  167. %__rm -f %{buildroot}%{_qt4_plugindir}/inputmethods/*.{a,la}
  168. %clean
  169. %__rm -rf %{buildroot}
  170. %post gtk
  171. %{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
  172. %postun gtk
  173. %{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
  174. %post -n compat32-%{name}-gtk
  175. %{_bindir}/gtk-query-immodules-2.0-32 > %{_sysconfdir}/gtk-2.0/i386/gtk.immodules
  176. %postun -n compat32-%{name}-gtk
  177. %{_bindir}/gtk-query-immodules-2.0-32 > %{_sysconfdir}/gtk-2.0/i386/gtk.immodules
  178. %files
  179. %defattr(-,root,root)
  180. %doc AUTHORS COPYING ChangeLog NEWS README doc/LICENSE*
  181. %{_bindir}/scim-bridge
  182. %files gtk
  183. %defattr(-,root,root)
  184. %{_libdir}/gtk-2.0/immodules/im-scim-bridge.so
  185. %if !%{without qt3}
  186. %files qt
  187. %defattr(-,root,root)
  188. %{_qt3_plugindir}/inputmethods/*.so
  189. %endif
  190. %if !%{without qt4}
  191. %files qt4
  192. %defattr(-,root,root)
  193. %{_qt4_plugindir}/inputmethods/*.so
  194. %endif
  195. ## to build compat32 for x86_64 architecture support
  196. %if %{build_compat32}
  197. %files -n compat32-%{name}-gtk
  198. %defattr(-,root,root)
  199. %{_libdir}/gtk-2.0/immodules/im-scim-bridge.so
  200. %if !%{without qt3}
  201. %files -n compat32-%{name}-qt
  202. %defattr(-,root,root)
  203. %{_qt3_plugindir}/inputmethods/*.so
  204. %endif
  205. %if !%{without qt4}
  206. %files -n compat32-%{name}-qt4
  207. %defattr(-,root,root)
  208. %{_qt4_plugindir}/inputmethods/*.so
  209. %endif
  210. %endif
  211. %changelog
  212. * Tue Jan 10 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-16
  213. - rebuilt with qt4-4.8.0
  214. * Tue Mar 8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-15
  215. - rebuilt with qt4-4.7.2
  216. * Sat Feb 5 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-14
  217. - added BR: libXmu-devel to qt package
  218. * Sun Jan 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-13
  219. - rebuilt with qt4-4.7.1
  220. * Sat Oct 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.16-12
  221. - added compat32-* packages for x86_64 architecture support
  222. * Thu Jul 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-11
  223. - rebuilt with qt4-4.6.3
  224. * Tue Jun 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-10
  225. - used %{?_smp_mflags} macro on build
  226. - deleted in unused log in changelog
  227. - Patch8 was none, forgot to delete...
  228. * Fri May 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-9
  229. - added Patch6,7 from Fedora development
  230. - to fix Text input in firefox becomes increasingly sluggish (Patch6)
  231. - to fix Process /usr/bin/scim-bridge was killed by signal 11 (Patch7)
  232. - added configure --disable-static option
  233. * Sun Jan 31 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-8
  234. - updated Qt version detection macros to build properly
  235. * Fri Jan 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-7
  236. - rebuilt with qt4-4.6.1
  237. * Sun Nov 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-6
  238. - rebuilt with qt4-4.5.3
  239. * Tue Oct 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-5
  240. - cleaned up spec
  241. - renumbered patch
  242. - added Patch5 from Fedora
  243. * Wed Sep 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.16-4
  244. - rebuild with qt4-4.5.2
  245. * Mon Apr 27 2009 Shu KONNO <owa@bg.wakwak.com> 0.4.16-3
  246. - dropt qt3rel/qt4rel part of Requires in subpackages qt, qt4
  247. * Sun Apr 26 2009 Shu KONNO <owa@bg.wakwak.com> 0.4.16-2
  248. - rebuild with qt-3.3.8-3vl5, because scim-bridge-qt requires "Rq: qt = %{qt3ver}-%{qt3rel}"
  249. * Sun Apr 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-1
  250. - new upstream release
  251. - dropt Pacth3,4,5 (these patches are merged)
  252. * Fri Apr 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.15.2-2
  253. - spec in UTF-8
  254. - fixed description in scim-bridge-qt4
  255. - added patch6,7 (import Fedora, Mandriva patches)
  256. * Mon Feb 2 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.15.2-1
  257. - new upstream release
  258. - added patch0,1,2,3,4,5 (import Fedora, Mandriva, scim-devel patches)
  259. * Wed Oct 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-4
  260. - rebuild with qt4-4.4.2
  261. * Fri Oct 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-3
  262. - add qt4 immodule
  263. - build gtk,qt3,qt4 immodule by default
  264. * Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-2
  265. - rebuild with gtk+-2.14
  266. * Sat Apr 05 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.15-1
  267. - new upstream release
  268. - apply new versioning policy
  269. * Fri Jan 18 2008 IWAI, Masaharu <iwai@alib.jp> 0.4.14-0vl2
  270. - drop unnecessary BuildRequires for qt3-immodule package
  271. - fix typo: 0.4.14-0vl1 changelog <BTS:VineLinux:#592>
  272. * Wed Jan 9 2008 IWAI, Masaharu <iwai@alib.jp> 0.4.14-0vl1
  273. - new upstream release
  274. - drop unnecessary Qt fix patch ( Patch0 ): upstream merged
  275. - update BuildRequires
  276. - drop doxygen
  277. - add XOrg-gl-devel for building qt3-immodule
  278. - move libmng-devel for building qt3-immodule
  279. * Tue Oct 09 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl2
  280. - rebuild for Vine Linux 4.2.
  281. * Tue Oct 09 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl3
  282. - add patch0 to fix symbol lookup error with qt3.
  283. * Wed Sep 26 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl0
  284. - rebuild for Vine Linux 4.2.
  285. * Sat Sep 15 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl1
  286. - new upstrm release
  287. - detect qt version at build time.
  288. - add --disable-qt4-immodule configure option.
  289. - add BuildRequires libmng-devel.
  290. * Thu May 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.12-0vl2
  291. - rebuild with libstdc++34
  292. * Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.12-0vl1
  293. - new upstream release
  294. * Tue Dec 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.4.8-0vl2
  295. - change License to GPL/LGPL
  296. - add doc/LICENSE.* as documents
  297. * Mon Dec 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.4.8-0vl1
  298. - new upstream release
  299. - add BuildRequires: doxygen, qt-devel
  300. - add new sub-packages:
  301. - gtk: GTK IM module (obsoletes: %%{name} <= 0.1.7)
  302. - qt: Qt IM module
  303. * Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.7-0vl1
  304. - new upstream release
  305. - add documents
  306. - running gtk-query-immodules-2.0 in post and postun scripts
  307. - add PreReq: gtk2 > 2.2
  308. * Fri Apr 21 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.6-0vl1
  309. - new upstream release
  310. * Thu Apr 6 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.4-0vl1
  311. - initial release