WebKit-vl.spec 9.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313
  1. %define add_to_doc_files() \
  2. mkdir -p %{buildroot}%{_docdir}/%{name}-%{version}; \
  3. cp -p %1 %{buildroot}%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') \
  4. echo %%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') >> docfiles.list
  5. #define svn_revision 43436
  6. # --with coverage: Enables compile-time checking of code coverage. (default: no)
  7. %bcond_with coverage
  8. # --with jit: Enable JIT ("just-in-time") JavaScript compiling support.
  9. #%bcond_with jit
  10. # --with pango : use pango for font rendering instead of freetype2 (default: use freetype2)
  11. %bcond_with pango
  12. # --with libsoup : use libsoup for HTTP backend instead of cURL (default: no)
  13. %bcond_with libsoup
  14. # --with svg : experimental svg support (default: no)
  15. %bcond_with svg
  16. # --with wml: Build support for WML
  17. %bcond_with wml
  18. Name: WebKit
  19. Version: 1.2.0
  20. Release: 2%{?_dist_release}
  21. Summary: Web content engine library
  22. Summary(ja): ウェブコンテンツエンジンライブラリ
  23. Group: Development/Libraries
  24. License: LGPLv2+ and BSD
  25. URL: http://webkitgtk.org/
  26. Vendor: Project Vine
  27. Distribution: Vine Linux
  28. Packager: yasumichi
  29. Source0: http://www.webkitgtk.org/webkit-%{version}.tar.gz
  30. # upstream patch
  31. Patch100: WebKit-icu44-36381.patch
  32. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  33. BuildRequires: bison
  34. BuildRequires: flex
  35. BuildRequires: gperf
  36. BuildRequires: gtk2-devel
  37. BuildRequires: libicu-devel
  38. BuildRequires: libjpeg-devel
  39. BuildRequires: libtool
  40. BuildRequires: libxslt-devel
  41. BuildRequires: libXt-devel
  42. BuildRequires: pcre-devel
  43. BuildRequires: sqlite3-devel
  44. BuildRequires: geoclue-devel
  45. BuildRequires: gnome-keyring-devel
  46. BuildRequires: gstreamer-devel
  47. BuildRequires: gstreamer-plugins-base-devel
  48. BuildRequires: enchant-devel
  49. %if %{with pango}
  50. BuildRequires: pango-devel
  51. %else
  52. BuildRequires: cairo-devel
  53. BuildRequires: fontconfig-devel
  54. BuildRequires: freetype2-devel
  55. %endif
  56. %if %{with libsoup}
  57. BuildRequires: libsoup-devel >= 2.23
  58. %else
  59. BuildRequires: curl-devel
  60. %endif
  61. %description
  62. WebKit is an open source web browser engine.
  63. %package gtk
  64. Summary: GTK+ port of WebKit
  65. Summary(ja): WebKit の GTK+ ポート
  66. Group: Development/Libraries
  67. %description gtk
  68. %{name} is an open-source Web content engine library. This package contains
  69. the shared libraries for the WebKit GTK+ port as well as the sample
  70. GtkLauncher tool.
  71. %package gtk-devel
  72. Summary: Development package for %{name}
  73. Summary(ja): %{name} の開発パッケージ
  74. Group: Development/Libraries
  75. Requires: %{name}-gtk = %{version}-%{release}
  76. Requires: pkgconfig
  77. Requires: gtk2-devel
  78. %description gtk-devel
  79. The %{name}-gtk-devel package contains libraries, build data, and header
  80. files for developing applications that use %{name}-gtk.
  81. Please note that the WebKit/GTK+ API is not yet stable. This should
  82. only be used as a "preview" rather than a stable platform library.
  83. %package doc
  84. Summary: Documentation for %{name}
  85. Summary(ja): %{name} のドキュメント
  86. Group: Documentation
  87. %description doc
  88. %{name} is an open-source Web content engine library. This package contains
  89. the documentation for %{name}, including various LICENSE, README, and
  90. AUTHORS files.
  91. %prep
  92. %setup -q -n webkit-%{version}
  93. # upstream
  94. %patch100 -p0
  95. %build
  96. %configure \
  97. --enable-icon-database \
  98. --enable-gnome-keyring \
  99. --enable-geolocation \
  100. %{?with_coverage: --enable-coverage } \
  101. %{?with_pango: --with-font-backend=pango } \
  102. %{?with_libsoup: --with-http-backend=soup } \
  103. %{?with_svg: --enable-svg-filters } \
  104. %{?with_wml: --enable-wml }
  105. make %{?_smp_mflags}
  106. # workaround for bug 488112
  107. # Compile libJavaScriptCore.a with -fno-strict-aliasing
  108. touch JavaScriptCore/AllInOneFile.cpp
  109. make %{?_smp_mflags} CXXFLAGS="%{optflags} -fno-strict-aliasing"
  110. %install
  111. rm -rf %{buildroot}
  112. make install DESTDIR=%{buildroot}
  113. install -d -m 755 %{buildroot}%{_libexecdir}/%{name}
  114. install -m 755 Programs/GtkLauncher %{buildroot}%{_libexecdir}/%{name}
  115. ## Finally, copy over and rename the various files for %%doc inclusion.
  116. rm -f docfiles.list
  117. %add_to_doc_files JavaScriptCore/COPYING.LIB
  118. %add_to_doc_files JavaScriptCore/icu/LICENSE
  119. %add_to_doc_files WebKit/LICENSE
  120. %add_to_doc_files WebCore/LICENSE-APPLE
  121. %add_to_doc_files WebCore/LICENSE-LGPL-2
  122. %add_to_doc_files WebCore/LICENSE-LGPL-2.1
  123. %add_to_doc_files WebCore/icu/LICENSE
  124. %add_to_doc_files JavaScriptCore/AUTHORS
  125. %add_to_doc_files JavaScriptCore/pcre/AUTHORS
  126. %add_to_doc_files JavaScriptCore/THANKS
  127. %find_lang webkit
  128. %clean
  129. rm -rf %{buildroot}
  130. %post gtk -p /sbin/ldconfig
  131. %postun gtk -p /sbin/ldconfig
  132. %files -f webkit.lang gtk
  133. %defattr(-,root,root,-)
  134. %doc
  135. %{_libdir}/libwebkit-1.0.so.*
  136. %{_libexecdir}/WebKit/
  137. %{_bindir}/jsc
  138. %files gtk-devel
  139. %defattr(-,root,root,-)
  140. %exclude %{_libdir}/*.la
  141. %{_includedir}/webkit-1.0
  142. %{_datadir}/webkit-1.0
  143. %{_libdir}/libwebkit-1.0.so
  144. %{_libdir}/pkgconfig/webkit-1.0.pc
  145. %files doc -f docfiles.list
  146. %defattr(-,root,root,-)
  147. %changelog
  148. * Wed Apr 14 2010 MATSUBAYASHI Kohji <shaoliN@vinelinux.org> - 1.2.0-2
  149. - rebuilt again on ppc
  150. * Sun Apr 11 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.0-1
  151. - new upstream release
  152. - rebuilt with libicu-4.4
  153. - added Patch100 for compiling with libicu-4.4
  154. - s/sqlite-devel/sqlite3-devel/
  155. - s/freetype-devel/freetype2-devel/
  156. * Mon Jan 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.18-1
  157. - updated to 1.1.18
  158. * Fri Nov 06 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.1.15.3-2
  159. - change BR from libsoup to libsoup-devel
  160. * Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.1.15.3-1
  161. - new upstream release.
  162. - add Vendor, Distribution and Packager.
  163. * Mon Jul 27 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.10-1
  164. - update to webkit-1.1.10 release version
  165. - added BuildRequires: enchant-devel
  166. * Sun May 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.6-1
  167. - update to webkit-1.1.6 release version
  168. * Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-8.svn41944
  169. - update to new upstream snapshot (svn r41944)
  170. * Mon Feb 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-7.svn40471
  171. - update to new upstream snapshot (svn r40471)
  172. * Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-6.svn37056
  173. - update to new upstream snapshot (svn r37056)
  174. - disable html5video by default
  175. * Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-5.svn36882
  176. - update to new upstream snapshot (svn r36882)
  177. - build with gnome-2.24
  178. * Thu Sep 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-4.svn36053
  179. - build without pango by default.
  180. * Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-3.svn36053
  181. - update to new upstream snapshot (svn r36053)
  182. * Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2.svn34655
  183. - update to new upstream snapshot (svn r34655)
  184. * Mon Jun 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1.svn34279
  185. - initial build for Vine Linux
  186. * Tue Jun 3 2008 Caol叩n McNamara <caolanm@redhat.com> - 1.0.0-0.12.svn34279
  187. - rebuild for new icu
  188. * Tue Jun 3 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.0.0-0.11.svn34279
  189. - Update to new upstream snapshot (SVN 34279) anyway
  190. - Add BR: libXt-devel
  191. * Tue Apr 29 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.10.svn32531
  192. - Remove the -Qt subpackage stuff. QtWebKit is now included in Qt proper, as
  193. of qt-4.4.0-0.6.rc1. (We no longer need separate build-qt and build-gtk
  194. subdirectories either.)
  195. - Reference: bug 442200 (RFE: WebKit Migration)
  196. - Add libjpeg dependency (was previously pulled in by the qt4-devel dependency
  197. tree).
  198. * Mon Apr 28 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.0.0-0.9.svn32531
  199. - Update to new upstream snapshot (SVN 32531).
  200. - Fix bug 443048 and hopefully fix bug 444445
  201. - Modify the process of building GTK+ port a bit
  202. - on qt port WebKit/qt/Plugins is not built for qt >= 4.4.0
  203. * Sat Apr 12 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.8.svn31787
  204. - Update to new upstream snapshot (SVN 31787).
  205. - Resolves: CVE-2008-1010 (bug 438532: Arbitrary code execution) and
  206. CVE-2008-1011 (bug 438531: Cross-Site Scripting).
  207. - Switch to using autotools for building the GTK+ port.
  208. * Wed Mar 05 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.7.svn30667
  209. - Fix the WebKitGtk pkgconfig data (should depend on gtk+-2.0). Resolves
  210. bug 436073 (Requires: gtk+-2.0 missing from WebKitGtk.pc).
  211. - Thanks to Mamoru Tasaka for helping find and squash these many bugs.
  212. * Sat Mar 01 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.6.svn30667
  213. - Fix include directory naming. Resolves: bug 435561 (Header file <> header
  214. file location mismatch)
  215. - Remove qt4-devel runtime dependency and .prl file from WebKit-gtk-devel.
  216. Resolves: bug 433138 (WebKit-gtk-devel has a requirement on qt4-devel)
  217. * Fri Feb 29 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.5.svn30667
  218. - Update to new upstream snapshot (SVN 30667)
  219. - Add some build fixes for GCC 4.3:
  220. + gcc43.patch
  221. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.0-0.5.svn29336
  222. - Autorebuild for GCC 4.3
  223. * Wed Jan 09 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.4.svn29336
  224. - Update to new upstream snapshot (SVN 29336).
  225. - Drop TCSpinLock pthread workaround (fixed upstream):
  226. - TCSpinLock-use-pthread-stubs.patch
  227. * Thu Dec 06 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.3.svn28482
  228. - Add proper %%defattr line to qt, qt-devel, and doc subpackages.
  229. - Add patch to forcibly build the TCSpinLock code using the pthread
  230. implementation:
  231. + TCSpinLock-use-pthread-stubs.patch
  232. * Thu Dec 06 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.2.svn28482
  233. - Package renamed from WebKitGtk.
  234. - Update to SVN 28482.
  235. - Build both the GTK and Qt ports, putting each into their own respective
  236. subpackages.
  237. - Invoke qmake-qt4 and make directly (with SMP build flags) instead of using
  238. the build-webkit script from upstream.
  239. - Add various AUTHORS, README, and LICENSE files (via the doc subpackage).
  240. * Tue Dec 04 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.1.svn28383
  241. - Initial packaging for Fedora.