viewnior-vl.spec 3.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120
  1. # We don't build with Gnome support by default to avoid a GConf dependency.
  2. # If you would like to set the Gnome background image with Viewnior, rebuild
  3. # the srpm with:
  4. # rpmbuild --rebuild viewnior-*-src.rpm --with gnome
  5. # or use bcond_without to change the defaul
  6. %bcond_with gnome
  7. Name: viewnior
  8. Version: 1.1
  9. Release: 1%{?_dist_release}
  10. Summary: Elegant image viewer
  11. Summary(ja): エレガントな画像ビューア
  12. Group: Applications/Graphics
  13. License: GPLv3+
  14. URL: http://xsisqox.github.com/Viewnior
  15. Source0: http://cloud.github.com/downloads/xsisqox/Viewnior/%{name}-%{version}.tar.gz
  16. Patch0: viewnior-0.7-dsofix.patch
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. BuildRequires: gdk-pixbuf2-devel >= 2.4.0
  19. BuildRequires: glib2-devel >= 2.24
  20. BuildRequires: gtk2-devel >= 2.20
  21. BuildRequires: desktop-file-utils
  22. BuildRequires: gettext
  23. BuildRequires: intltool >= 0.35.0
  24. BuildRequires: perl-XML-Parser
  25. BuildRequires: shared-mime-info >= 0.20
  26. %if %{with gnome}
  27. BuildRequires: GConf2-devel
  28. %endif
  29. %description
  30. Viewnior is an image viewer program. Created to be simple, fast and elegant.
  31. It's minimalistic interface provides more screen space for your images. Among
  32. its features are:
  33. * Fullscreen & Slideshow
  34. * Rotate, flip, save, delete images
  35. * Animation support
  36. * Browse only selected images
  37. * Navigation window
  38. * Simple interface
  39. * Configurable mouse actions
  40. %prep
  41. %setup -q
  42. %patch0 -p1 -b .dsofix
  43. # fix spurious executable perms
  44. chmod 0644 AUTHORS ChangeLog COPYING NEWS README TODO src/*
  45. %build
  46. %configure \
  47. %if %{with gnome}
  48. --enable-wallpaper
  49. %endif
  50. make %{?_smp_mflags} V=1
  51. %install
  52. rm -rf %{buildroot}
  53. make install DESTDIR=%{buildroot} INSTALL='install -p'
  54. %find_lang %{name}
  55. desktop-file-validate %{buildroot}/%{_datadir}/applications/%{name}.desktop
  56. %clean
  57. rm -rf %{buildroot}
  58. %post
  59. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  60. update-desktop-database &> /dev/null || :
  61. %postun
  62. if [ $1 -eq 0 ] ; then
  63. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  64. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  65. fi
  66. update-desktop-database &> /dev/null || :
  67. %posttrans
  68. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  69. %files -f %{name}.lang
  70. %defattr(-,root,root,-)
  71. %doc AUTHORS ChangeLog COPYING NEWS README TODO
  72. %{_bindir}/%{name}
  73. %{_datadir}/applications/%{name}.desktop
  74. %{_datadir}/icons/hicolor/*/apps/%{name}.*
  75. %{_datadir}/%{name}/
  76. %{_mandir}/man?/
  77. %changelog
  78. * Thu Dec 16 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1-1
  79. - initial build for VineSeed
  80. * Wed Mar 31 2010 Christoph Wickert <cwickert@fedoraproject.org> - 1.0-1
  81. - Update to 1.0
  82. * Tue Feb 16 2010 Christoph Wickert <cwickert@fedoraproject.org> - 0.7-2
  83. - Add patch to fix DSO linking (#565018)
  84. - Switch to %%bcond macro
  85. * Mon Sep 07 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.7-1
  86. - Update to 0.7
  87. * Sat Sep 05 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6-2
  88. - Spec file cleanups from review.
  89. * Mon Aug 01 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6-1
  90. - Initial package