texlive-collection-luatex-vl.spec 9.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271
  1. ## -*- coding: utf-8-unix -*-
  2. ## NOTE: This spec file is generated by tlpdb2rpmspec 2009-3:
  3. ## tlpdb2rpmspec collection-luatex
  4. %bcond_with firstbuild
  5. %define tex_destdir %{_datadir}
  6. %define texmf %{tex_destdir}/texmf
  7. %define texlive_src %{tex_destdir}/texlive-sources
  8. %define build_tex_destdir %{buildroot}%{tex_destdir}
  9. %define build_texmf %{buildroot}%{texmf}
  10. %define exec_mktexlsr [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
  11. %define exec_texhash [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
  12. %define exec_updmap [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
  13. %define exec_fmtutil [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
  14. %define exec_upddeffont [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
  15. %define vartexfonts %{_var}/lib/texmf
  16. %define __find_provides %{nil}
  17. %define __find_requires %{nil}
  18. %define __perl_provides %{nil}
  19. %define __perl_requires %{nil}
  20. Autoreq: 0
  21. Summary: TeX Live: LuaTeX packages
  22. Summary(ja): TeX Live: LuaTeX packages
  23. Name: texlive-collection-luatex
  24. Version: 2009
  25. Release: 3%{?_dist_release}
  26. License: Public Domain, Freely redistributable without restriction
  27. Group: Applications/Publishing
  28. URL:http://www.tug.org/texlive/
  29. Requires: texlive = %{version}
  30. Requires: texlive-collection-basic = %{version}
  31. Requires(post): texlive = %{version}
  32. Requires(postun): texlive = %{version}
  33. BuildRequires: texlive-sources = %{version}
  34. BuildArch: noarch
  35. Buildroot: %{_tmppath}/%{name}-%{version}-root
  36. Vendor: Project Vine
  37. Distribution: Vine Linux
  38. Packager: munepi
  39. %description
  40. The TeX Live software distribution offers a complete TeX system for a
  41. variety of Unix, Macintosh, Windows and other platforms. It
  42. encompasses programs for editing, typesetting, previewing and printing
  43. of TeX documents in many different languages, and a large collection
  44. of TeX macros and font libraries.
  45. The distribution includes extensive general documentation about TeX,
  46. as well as the documentation for the included software packages.
  47. This package is a collection of LuaTeX packages:
  48. Packages for LuaTeX, a Unicode-aware extension of pdfTeX, using
  49. Lua as an embedded scripting and extension language.
  50. http://luatex.org/
  51. This package contains the following CTAN packages:
  52. luainputenc: Replacing inputenc for use in LuaTeX.
  53. luamplib: Use LuaTeX's built-in MetaPost interpreter.
  54. luaotfload: ConTeXt OTF loading system for Plain and LaTeX.
  55. luatextra: Additional macros for Plain TeX and LaTeX in LuaTeX.
  56. %description -l ja
  57. TeX Live ソフトウェアディストリビューションは、
  58. さまざまな Unix, Macintosh, Windows、および
  59. 他のプラットホームに対して完全な TeX システムを提供します。
  60. 多くの異なった言語を含む TeX ドキュメントの
  61. 編集、組版、閲覧、印刷するためのプログラム、
  62. そして、TeX マクロやフォントライブラリの大きなコレクションを
  63. 同梱しています。
  64. このディストリビューションは
  65. 同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
  66. TeX に関するたくさんの一般的なドキュメントを含んでいます。
  67. このパッケージは以下のようなパッケージ集です。
  68. LuaTeX packages:
  69. Packages for LuaTeX, a Unicode-aware extension of pdfTeX, using
  70. Lua as an embedded scripting and extension language.
  71. http://luatex.org/
  72. このパッケージは以下の CTAN パッケージを含んでいます:
  73. luainputenc: Replacing inputenc for use in LuaTeX.
  74. luamplib: Use LuaTeX's built-in MetaPost interpreter.
  75. luaotfload: ConTeXt OTF loading system for Plain and LaTeX.
  76. luatextra: Additional macros for Plain TeX and LaTeX in LuaTeX.
  77. %package doc
  78. Summary: TeX Live: Documentation files of %{name}
  79. Group: Applications/Publishing
  80. Requires: %{name} = %{version}-%{release}
  81. %description doc
  82. This package contains documentation files of %{name}.
  83. %prep
  84. %build
  85. %install
  86. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
  87. PREF=%{buildroot}%{tex_destdir}
  88. manifest=(
  89. texmf-dist/doc/lualatex/luainputenc/README
  90. texmf-dist/doc/lualatex/luainputenc/inputenc.sty.diff
  91. texmf-dist/doc/lualatex/luainputenc/luainputenc.pdf
  92. texmf-dist/source/lualatex/luainputenc/Makefile
  93. texmf-dist/source/lualatex/luainputenc/luainputenc.dtx
  94. texmf-dist/tex/lualatex/luainputenc/eu2enc.def
  95. texmf-dist/tex/lualatex/luainputenc/eu2lmr.fd
  96. texmf-dist/tex/lualatex/luainputenc/luainputenc.lua
  97. texmf-dist/tex/lualatex/luainputenc/luainputenc.sty
  98. texmf-dist/tex/lualatex/luainputenc/lutf8.def
  99. texmf-dist/tex/lualatex/luainputenc/lutf8x.def
  100. texmf-dist/doc/luatex/luamplib/README
  101. texmf-dist/doc/luatex/luamplib/luamplib.pdf
  102. texmf-dist/source/luatex/luamplib/Makefile
  103. texmf-dist/source/luatex/luamplib/luamplib.dtx
  104. texmf-dist/tex/luatex/luamplib/luamplib-createmem.lua
  105. texmf-dist/tex/luatex/luamplib/luamplib.lua
  106. texmf-dist/tex/luatex/luamplib/luamplib.sty
  107. texmf-dist/doc/luatex/luaotfload/README
  108. texmf-dist/doc/luatex/luaotfload/luaotfload.pdf
  109. texmf-dist/source/luatex/luaotfload/Makefile
  110. texmf-dist/source/luatex/luaotfload/luaotfload.dtx
  111. texmf-dist/tex/luatex/luaotfload/luaotfload.lua
  112. texmf-dist/tex/luatex/luaotfload/luaotfload.sty
  113. texmf-dist/tex/luatex/luaotfload/otfl-data-con.lua
  114. texmf-dist/tex/luatex/luaotfload/otfl-font-cid.lua
  115. texmf-dist/tex/luatex/luaotfload/otfl-font-def.lua
  116. texmf-dist/tex/luatex/luaotfload/otfl-font-dum.lua
  117. texmf-dist/tex/luatex/luaotfload/otfl-font-ini.lua
  118. texmf-dist/tex/luatex/luaotfload/otfl-font-map.lua
  119. texmf-dist/tex/luatex/luaotfload/otfl-font-ota.lua
  120. texmf-dist/tex/luatex/luaotfload/otfl-font-otb.lua
  121. texmf-dist/tex/luatex/luaotfload/otfl-font-otc.lua
  122. texmf-dist/tex/luatex/luaotfload/otfl-font-otd.lua
  123. texmf-dist/tex/luatex/luaotfload/otfl-font-otf.lua
  124. texmf-dist/tex/luatex/luaotfload/otfl-font-oti.lua
  125. texmf-dist/tex/luatex/luaotfload/otfl-font-otn.lua
  126. texmf-dist/tex/luatex/luaotfload/otfl-font-ott.lua
  127. texmf-dist/tex/luatex/luaotfload/otfl-font-tfm.lua
  128. texmf-dist/tex/luatex/luaotfload/otfl-font-xtx.lua
  129. texmf-dist/tex/luatex/luaotfload/otfl-luat-dum.lua
  130. texmf-dist/tex/luatex/luaotfload/otfl-node-dum.lua
  131. texmf-dist/tex/luatex/luaotfload/otfl-node-fnt.lua
  132. texmf-dist/tex/luatex/luaotfload/otfl-node-ini.lua
  133. texmf-dist/tex/luatex/luaotfload/otfl-node-inj.lua
  134. texmf-dist/tex/luatex/luaotfload/otfl-node-res.lua
  135. texmf-dist/doc/luatex/luatextra/README
  136. texmf-dist/doc/luatex/luatextra/luaextra.pdf
  137. texmf-dist/doc/luatex/luatextra/luamcallbacks-test.tex
  138. texmf-dist/doc/luatex/luatextra/luamcallbacks.pdf
  139. texmf-dist/doc/luatex/luatextra/luatextra-reference.pdf
  140. texmf-dist/doc/luatex/luatextra/luatextra.pdf
  141. texmf-dist/source/luatex/luatextra/Makefile
  142. texmf-dist/source/luatex/luatextra/luaextra.dtx
  143. texmf-dist/source/luatex/luatextra/luamcallbacks.dtx
  144. texmf-dist/source/luatex/luatextra/luatextra-reference.tex
  145. texmf-dist/source/luatex/luatextra/luatextra.dtx
  146. texmf-dist/tex/luatex/luatextra/luaextra.lua
  147. texmf-dist/tex/luatex/luatextra/luamcallbacks.lua
  148. texmf-dist/tex/luatex/luatextra/luatextra-latex.tex
  149. texmf-dist/tex/luatex/luatextra/luatextra.lua
  150. texmf-dist/tex/luatex/luatextra/luatextra.sty
  151. )
  152. %__mkdir_p ${PREF}/texmf-dist
  153. for i in "${manifest[@]}"; do
  154. %__install -D %{texlive_src}/$i ${PREF}/$i
  155. done
  156. ## info
  157. %__rm -f %{buildroot}%{_infodir}/dir
  158. %__gzip -9nf %{buildroot}%{_infodir}/*info* ||:
  159. ## man
  160. ## man t1* files are provided by t1utils
  161. for i in t1ascii t1asm t1binary t1disasm t1mac t1unmac; do
  162. %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
  163. done
  164. ## man some files are provided by psutils
  165. for i in epsffit extractres fixdlsrps fixfmps fixmacps fixpsditps fixpspps fixscribeps fixtpps fixwfwps fixwpps fixwwps getafm includeres psbook psmerge psnup psresize psselect pstops; do
  166. %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
  167. done
  168. ## fix perl path
  169. for i in source/metapost/expressg/expressg.dtx \
  170. doc/metapost/expressg/n2mpsprl.prl \
  171. doc/latex/songbook/contrib/crd2sb/crd2sb; do
  172. [ -f %{build_texmf}-dist/${i} ] && \
  173. %__sed -i -e "s|^#!/usr/local/bin/perl|#!%{__perl}|" %{build_texmf}-dist/${i}
  174. done
  175. ## remove asymptote directries, which provides asymptote package
  176. find %{buildroot} -regex ".*asymptote.*" | xargs %__rm -rf
  177. # find %{buildroot} -name "Makefile" | xargs %__rm -f
  178. # ## remove xindy
  179. # find %{buildroot} -regex ".*xindy.*" | xargs %__rm -rf
  180. # ## remove tex4ht
  181. # find %{buildroot} -regex ".*tex4ht.*" | xargs %__rm -rf
  182. ## remove arch dependent binaries
  183. %__rm -f %{build_texmf}-dist/source/latex/splitindex/splitindex-{OpenBSD,Linux}-i386
  184. ## remove unpackaging files
  185. find %{buildroot} | %__grep -e "\.\(la\|a\)$" | xargs %__rm -f
  186. find %{buildroot} | %__grep -e "\.\(diff\|patch\)$" | xargs %__rm -f
  187. ## Files list
  188. find %{buildroot} -type f -or -type l | \
  189. %__sed -e "s|%{buildroot}||g" > filelist.full
  190. find %{buildroot}%{texmf}-dist -type d | \
  191. %__sed -e "s|^%{buildroot}|%dir |" \
  192. -e "s|$|/|" >> filelist.full
  193. ## subpackages
  194. grep "/texmf-dist/doc/" filelist.full > filelist.doc
  195. cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
  196. %__mv -f filelist.tmp filelist.full
  197. %clean
  198. %__rm -rf %{buildroot}
  199. %post
  200. %{exec_texhash}
  201. exit 0
  202. %postun
  203. if [ "$1" = 0 ]; then
  204. %{exec_texhash}
  205. fi
  206. exit 0
  207. %files -f filelist.full
  208. %defattr(-,root,root)
  209. %files -f filelist.doc doc
  210. %defattr(-,root,root)
  211. %changelog
  212. * Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
  213. - generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-luatex
  214. - improved %%post
  215. * Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
  216. - generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-luatex
  217. - removed arch dependent binaries (texlive-collection-latexextra)
  218. - fixed perl path
  219. - improved updmap process in %%post and %%postun
  220. * Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
  221. - generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-luatex