texlive-collection-langswedish-vl.spec 6.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212
  1. ## -*- coding: utf-8-unix -*-
  2. ## NOTE: This spec file is generated by tlpdb2rpmspec 2009-3:
  3. ## tlpdb2rpmspec collection-langswedish
  4. %bcond_with firstbuild
  5. %define tex_destdir %{_datadir}
  6. %define texmf %{tex_destdir}/texmf
  7. %define texlive_src %{tex_destdir}/texlive-sources
  8. %define build_tex_destdir %{buildroot}%{tex_destdir}
  9. %define build_texmf %{buildroot}%{texmf}
  10. %define exec_mktexlsr [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
  11. %define exec_texhash [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
  12. %define exec_updmap [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
  13. %define exec_fmtutil [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
  14. %define exec_upddeffont [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
  15. %define vartexfonts %{_var}/lib/texmf
  16. %define __find_provides %{nil}
  17. %define __find_requires %{nil}
  18. %define __perl_provides %{nil}
  19. %define __perl_requires %{nil}
  20. Autoreq: 0
  21. Summary: TeX Live: Swedish
  22. Summary(ja): TeX Live: Swedish
  23. Name: texlive-collection-langswedish
  24. Version: 2009
  25. Release: 3%{?_dist_release}
  26. License: LPPL
  27. Group: Applications/Publishing
  28. URL:http://www.tug.org/texlive/
  29. Requires: texlive = %{version}
  30. Requires: texlive-collection-basic = %{version}
  31. Requires(post): texlive = %{version}
  32. Requires(postun): texlive = %{version}
  33. BuildRequires: texlive-sources = %{version}
  34. BuildArch: noarch
  35. Buildroot: %{_tmppath}/%{name}-%{version}-root
  36. Vendor: Project Vine
  37. Distribution: Vine Linux
  38. Packager: munepi
  39. %description
  40. The TeX Live software distribution offers a complete TeX system for a
  41. variety of Unix, Macintosh, Windows and other platforms. It
  42. encompasses programs for editing, typesetting, previewing and printing
  43. of TeX documents in many different languages, and a large collection
  44. of TeX macros and font libraries.
  45. The distribution includes extensive general documentation about TeX,
  46. as well as the documentation for the included software packages.
  47. This package is a collection of Swedish:
  48. Support for typesetting Swedish.
  49. This package contains the following CTAN packages:
  50. swebib: Swedish bibliography styles.
  51. hyphen-swedish:
  52. %description -l ja
  53. TeX Live ソフトウェアディストリビューションは、
  54. さまざまな Unix, Macintosh, Windows、および
  55. 他のプラットホームに対して完全な TeX システムを提供します。
  56. 多くの異なった言語を含む TeX ドキュメントの
  57. 編集、組版、閲覧、印刷するためのプログラム、
  58. そして、TeX マクロやフォントライブラリの大きなコレクションを
  59. 同梱しています。
  60. このディストリビューションは
  61. 同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
  62. TeX に関するたくさんの一般的なドキュメントを含んでいます。
  63. このパッケージは以下のようなパッケージ集です。
  64. Swedish:
  65. Support for typesetting Swedish.
  66. このパッケージは以下の CTAN パッケージを含んでいます:
  67. swebib: Swedish bibliography styles.
  68. hyphen-swedish:
  69. %package doc
  70. Summary: TeX Live: Documentation files of %{name}
  71. Group: Applications/Publishing
  72. Requires: %{name} = %{version}-%{release}
  73. %description doc
  74. This package contains documentation files of %{name}.
  75. %prep
  76. %build
  77. %install
  78. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
  79. PREF=%{buildroot}%{tex_destdir}
  80. manifest=(
  81. texmf-dist/doc/latex/swebib/README
  82. texmf-dist/bibtex/bst/swebib/sweabbrv.bst
  83. texmf-dist/bibtex/bst/swebib/swealpha.bst
  84. texmf-dist/bibtex/bst/swebib/sweplain.bst
  85. texmf-dist/bibtex/bst/swebib/sweplnat.bst
  86. texmf-dist/bibtex/bst/swebib/sweunsrt.bst
  87. )
  88. %__mkdir_p ${PREF}/texmf-dist
  89. for i in "${manifest[@]}"; do
  90. %__install -D %{texlive_src}/$i ${PREF}/$i
  91. done
  92. ## info
  93. %__rm -f %{buildroot}%{_infodir}/dir
  94. %__gzip -9nf %{buildroot}%{_infodir}/*info* ||:
  95. ## man
  96. ## man t1* files are provided by t1utils
  97. for i in t1ascii t1asm t1binary t1disasm t1mac t1unmac; do
  98. %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
  99. done
  100. ## man some files are provided by psutils
  101. for i in epsffit extractres fixdlsrps fixfmps fixmacps fixpsditps fixpspps fixscribeps fixtpps fixwfwps fixwpps fixwwps getafm includeres psbook psmerge psnup psresize psselect pstops; do
  102. %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
  103. done
  104. ## fix perl path
  105. for i in source/metapost/expressg/expressg.dtx \
  106. doc/metapost/expressg/n2mpsprl.prl \
  107. doc/latex/songbook/contrib/crd2sb/crd2sb; do
  108. [ -f %{build_texmf}-dist/${i} ] && \
  109. %__sed -i -e "s|^#!/usr/local/bin/perl|#!%{__perl}|" %{build_texmf}-dist/${i}
  110. done
  111. ## remove asymptote directries, which provides asymptote package
  112. find %{buildroot} -regex ".*asymptote.*" | xargs %__rm -rf
  113. # find %{buildroot} -name "Makefile" | xargs %__rm -f
  114. # ## remove xindy
  115. # find %{buildroot} -regex ".*xindy.*" | xargs %__rm -rf
  116. # ## remove tex4ht
  117. # find %{buildroot} -regex ".*tex4ht.*" | xargs %__rm -rf
  118. ## remove arch dependent binaries
  119. %__rm -f %{build_texmf}-dist/source/latex/splitindex/splitindex-{OpenBSD,Linux}-i386
  120. ## remove unpackaging files
  121. find %{buildroot} | %__grep -e "\.\(la\|a\)$" | xargs %__rm -f
  122. find %{buildroot} | %__grep -e "\.\(diff\|patch\)$" | xargs %__rm -f
  123. ## Files list
  124. find %{buildroot} -type f -or -type l | \
  125. %__sed -e "s|%{buildroot}||g" > filelist.full
  126. find %{buildroot}%{texmf}-dist -type d | \
  127. %__sed -e "s|^%{buildroot}|%dir |" \
  128. -e "s|$|/|" >> filelist.full
  129. ## subpackages
  130. grep "/texmf-dist/doc/" filelist.full > filelist.doc
  131. cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
  132. %__mv -f filelist.tmp filelist.full
  133. %clean
  134. %__rm -rf %{buildroot}
  135. %post
  136. %{exec_texhash}
  137. rpm -q --quiet texlive-common || exit 0
  138. echo -n " "
  139. echo -n "Running fmtutil ... " && %{exec_fmtutil} && echo "done."
  140. exit 0
  141. %postun
  142. if [ "$1" = 0 ]; then
  143. %{exec_texhash}
  144. fi
  145. exit 0
  146. %files -f filelist.full
  147. %defattr(-,root,root)
  148. %files -f filelist.doc doc
  149. %defattr(-,root,root)
  150. %changelog
  151. * Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
  152. - generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-langswedish
  153. - improved %%post
  154. * Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
  155. - generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-langswedish
  156. - removed arch dependent binaries (texlive-collection-latexextra)
  157. - fixed perl path
  158. - improved updmap process in %%post and %%postun
  159. * Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
  160. - generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-langswedish