texlive-collection-langfinnish-vl.spec 6.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191
  1. ## -*- coding: utf-8-unix -*-
  2. ## NOTE: This spec file is generated by tlpdb2rpmspec 2009-3:
  3. ## tlpdb2rpmspec collection-langfinnish
  4. %bcond_with firstbuild
  5. %define tex_destdir %{_datadir}
  6. %define texmf %{tex_destdir}/texmf
  7. %define texlive_src %{tex_destdir}/texlive-sources
  8. %define build_tex_destdir %{buildroot}%{tex_destdir}
  9. %define build_texmf %{buildroot}%{texmf}
  10. %define exec_mktexlsr [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
  11. %define exec_texhash [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
  12. %define exec_updmap [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
  13. %define exec_fmtutil [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
  14. %define exec_upddeffont [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
  15. %define vartexfonts %{_var}/lib/texmf
  16. %define __find_provides %{nil}
  17. %define __find_requires %{nil}
  18. %define __perl_provides %{nil}
  19. %define __perl_requires %{nil}
  20. Autoreq: 0
  21. Summary: TeX Live: Finnish
  22. Summary(ja): TeX Live: Finnish
  23. Name: texlive-collection-langfinnish
  24. Version: 2009
  25. Release: 3%{?_dist_release}
  26. License: Freely redistributable without restriction, Public Domain
  27. Group: Applications/Publishing
  28. URL:http://www.tug.org/texlive/
  29. Requires: texlive = %{version}
  30. Requires: texlive-collection-basic = %{version}
  31. Requires(post): texlive = %{version}
  32. Requires(postun): texlive = %{version}
  33. BuildRequires: texlive-sources = %{version}
  34. BuildArch: noarch
  35. Buildroot: %{_tmppath}/%{name}-%{version}-root
  36. Vendor: Project Vine
  37. Distribution: Vine Linux
  38. Packager: munepi
  39. %description
  40. The TeX Live software distribution offers a complete TeX system for a
  41. variety of Unix, Macintosh, Windows and other platforms. It
  42. encompasses programs for editing, typesetting, previewing and printing
  43. of TeX documents in many different languages, and a large collection
  44. of TeX macros and font libraries.
  45. The distribution includes extensive general documentation about TeX,
  46. as well as the documentation for the included software packages.
  47. This package is a collection of Finnish:
  48. Support for typesetting Finnish.
  49. This package contains the following CTAN packages:
  50. finbib: A Finnish version of plain.bst.
  51. hyphen-finnish: Hyphenation patterns for Finnish language.
  52. %description -l ja
  53. TeX Live ソフトウェアディストリビューションは、
  54. さまざまな Unix, Macintosh, Windows、および
  55. 他のプラットホームに対して完全な TeX システムを提供します。
  56. 多くの異なった言語を含む TeX ドキュメントの
  57. 編集、組版、閲覧、印刷するためのプログラム、
  58. そして、TeX マクロやフォントライブラリの大きなコレクションを
  59. 同梱しています。
  60. このディストリビューションは
  61. 同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
  62. TeX に関するたくさんの一般的なドキュメントを含んでいます。
  63. このパッケージは以下のようなパッケージ集です。
  64. Finnish:
  65. Support for typesetting Finnish.
  66. このパッケージは以下の CTAN パッケージを含んでいます:
  67. finbib: A Finnish version of plain.bst.
  68. hyphen-finnish: Hyphenation patterns for Finnish language.
  69. %prep
  70. %build
  71. %install
  72. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
  73. PREF=%{buildroot}%{tex_destdir}
  74. manifest=(
  75. texmf-dist/bibtex/bst/finbib/finplain.bst
  76. )
  77. %__mkdir_p ${PREF}/texmf-dist
  78. for i in "${manifest[@]}"; do
  79. %__install -D %{texlive_src}/$i ${PREF}/$i
  80. done
  81. ## info
  82. %__rm -f %{buildroot}%{_infodir}/dir
  83. %__gzip -9nf %{buildroot}%{_infodir}/*info* ||:
  84. ## man
  85. ## man t1* files are provided by t1utils
  86. for i in t1ascii t1asm t1binary t1disasm t1mac t1unmac; do
  87. %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
  88. done
  89. ## man some files are provided by psutils
  90. for i in epsffit extractres fixdlsrps fixfmps fixmacps fixpsditps fixpspps fixscribeps fixtpps fixwfwps fixwpps fixwwps getafm includeres psbook psmerge psnup psresize psselect pstops; do
  91. %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
  92. done
  93. ## fix perl path
  94. for i in source/metapost/expressg/expressg.dtx \
  95. doc/metapost/expressg/n2mpsprl.prl \
  96. doc/latex/songbook/contrib/crd2sb/crd2sb; do
  97. [ -f %{build_texmf}-dist/${i} ] && \
  98. %__sed -i -e "s|^#!/usr/local/bin/perl|#!%{__perl}|" %{build_texmf}-dist/${i}
  99. done
  100. ## remove asymptote directries, which provides asymptote package
  101. find %{buildroot} -regex ".*asymptote.*" | xargs %__rm -rf
  102. # find %{buildroot} -name "Makefile" | xargs %__rm -f
  103. # ## remove xindy
  104. # find %{buildroot} -regex ".*xindy.*" | xargs %__rm -rf
  105. # ## remove tex4ht
  106. # find %{buildroot} -regex ".*tex4ht.*" | xargs %__rm -rf
  107. ## remove arch dependent binaries
  108. %__rm -f %{build_texmf}-dist/source/latex/splitindex/splitindex-{OpenBSD,Linux}-i386
  109. ## remove unpackaging files
  110. find %{buildroot} | %__grep -e "\.\(la\|a\)$" | xargs %__rm -f
  111. find %{buildroot} | %__grep -e "\.\(diff\|patch\)$" | xargs %__rm -f
  112. ## Files list
  113. find %{buildroot} -type f -or -type l | \
  114. %__sed -e "s|%{buildroot}||g" > filelist.full
  115. find %{buildroot}%{texmf}-dist -type d | \
  116. %__sed -e "s|^%{buildroot}|%dir |" \
  117. -e "s|$|/|" >> filelist.full
  118. %clean
  119. %__rm -rf %{buildroot}
  120. %post
  121. %{exec_texhash}
  122. rpm -q --quiet texlive-common || exit 0
  123. echo -n " "
  124. echo -n "Running fmtutil ... " && %{exec_fmtutil} && echo "done."
  125. exit 0
  126. %postun
  127. if [ "$1" = 0 ]; then
  128. %{exec_texhash}
  129. fi
  130. exit 0
  131. %files -f filelist.full
  132. %defattr(-,root,root)
  133. %changelog
  134. * Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
  135. - generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-langfinnish
  136. - improved %%post
  137. * Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
  138. - generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-langfinnish
  139. - removed arch dependent binaries (texlive-collection-latexextra)
  140. - fixed perl path
  141. - improved updmap process in %%post and %%postun
  142. * Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
  143. - generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-langfinnish