texlive-collection-documentation-ukrainian-vl.spec 6.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185
  1. ## -*- coding: utf-8-unix -*-
  2. ## NOTE: This spec file is generated by tlpdb2rpmspec 2009-3:
  3. ## tlpdb2rpmspec collection-documentation-ukrainian
  4. %bcond_with firstbuild
  5. %define tex_destdir %{_datadir}
  6. %define texmf %{tex_destdir}/texmf
  7. %define texlive_src %{tex_destdir}/texlive-sources
  8. %define build_tex_destdir %{buildroot}%{tex_destdir}
  9. %define build_texmf %{buildroot}%{texmf}
  10. %define exec_mktexlsr [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
  11. %define exec_texhash [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
  12. %define exec_updmap [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
  13. %define exec_fmtutil [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
  14. %define exec_upddeffont [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
  15. %define vartexfonts %{_var}/lib/texmf
  16. %define __find_provides %{nil}
  17. %define __find_requires %{nil}
  18. %define __perl_provides %{nil}
  19. %define __perl_requires %{nil}
  20. Autoreq: 0
  21. Summary: TeX Live: Ukrainian documentation
  22. Summary(ja): TeX Live: Ukrainian documentation
  23. Name: texlive-collection-documentation-ukrainian
  24. Version: 2009
  25. Release: 3%{?_dist_release}
  26. License: Freely redistributable without restriction
  27. Group: Applications/Publishing
  28. URL:http://www.tug.org/texlive/
  29. Requires: texlive = %{version}
  30. Requires(post): texlive = %{version}
  31. Requires(postun): texlive = %{version}
  32. BuildRequires: texlive-sources = %{version}
  33. BuildArch: noarch
  34. Buildroot: %{_tmppath}/%{name}-%{version}-root
  35. Vendor: Project Vine
  36. Distribution: Vine Linux
  37. Packager: munepi
  38. %description
  39. The TeX Live software distribution offers a complete TeX system for a
  40. variety of Unix, Macintosh, Windows and other platforms. It
  41. encompasses programs for editing, typesetting, previewing and printing
  42. of TeX documents in many different languages, and a large collection
  43. of TeX macros and font libraries.
  44. The distribution includes extensive general documentation about TeX,
  45. as well as the documentation for the included software packages.
  46. This package is a collection of Ukrainian documentation:
  47. This package contains the following CTAN packages:
  48. lshort-ukr: Ukrainian version of the LaTeX introduction.
  49. %description -l ja
  50. TeX Live ソフトウェアディストリビューションは、
  51. さまざまな Unix, Macintosh, Windows、および
  52. 他のプラットホームに対して完全な TeX システムを提供します。
  53. 多くの異なった言語を含む TeX ドキュメントの
  54. 編集、組版、閲覧、印刷するためのプログラム、
  55. そして、TeX マクロやフォントライブラリの大きなコレクションを
  56. 同梱しています。
  57. このディストリビューションは
  58. 同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
  59. TeX に関するたくさんの一般的なドキュメントを含んでいます。
  60. このパッケージは以下のようなパッケージ集です。
  61. Ukrainian documentation:
  62. このパッケージは以下の CTAN パッケージを含んでいます:
  63. lshort-ukr: Ukrainian version of the LaTeX introduction.
  64. %prep
  65. %build
  66. %install
  67. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
  68. PREF=%{buildroot}%{tex_destdir}
  69. manifest=(
  70. texmf-dist/doc/latex/lshort-ukr/lshort-ukr-4.12.src.tar.gz
  71. texmf-dist/doc/latex/lshort-ukr/lshort-ukr.pdf
  72. )
  73. %__mkdir_p ${PREF}/texmf-dist
  74. for i in "${manifest[@]}"; do
  75. %__install -D %{texlive_src}/$i ${PREF}/$i
  76. done
  77. ## info
  78. %__rm -f %{buildroot}%{_infodir}/dir
  79. %__gzip -9nf %{buildroot}%{_infodir}/*info* ||:
  80. ## man
  81. ## man t1* files are provided by t1utils
  82. for i in t1ascii t1asm t1binary t1disasm t1mac t1unmac; do
  83. %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
  84. done
  85. ## man some files are provided by psutils
  86. for i in epsffit extractres fixdlsrps fixfmps fixmacps fixpsditps fixpspps fixscribeps fixtpps fixwfwps fixwpps fixwwps getafm includeres psbook psmerge psnup psresize psselect pstops; do
  87. %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
  88. done
  89. ## fix perl path
  90. for i in source/metapost/expressg/expressg.dtx \
  91. doc/metapost/expressg/n2mpsprl.prl \
  92. doc/latex/songbook/contrib/crd2sb/crd2sb; do
  93. [ -f %{build_texmf}-dist/${i} ] && \
  94. %__sed -i -e "s|^#!/usr/local/bin/perl|#!%{__perl}|" %{build_texmf}-dist/${i}
  95. done
  96. ## remove asymptote directries, which provides asymptote package
  97. find %{buildroot} -regex ".*asymptote.*" | xargs %__rm -rf
  98. # find %{buildroot} -name "Makefile" | xargs %__rm -f
  99. # ## remove xindy
  100. # find %{buildroot} -regex ".*xindy.*" | xargs %__rm -rf
  101. # ## remove tex4ht
  102. # find %{buildroot} -regex ".*tex4ht.*" | xargs %__rm -rf
  103. ## remove arch dependent binaries
  104. %__rm -f %{build_texmf}-dist/source/latex/splitindex/splitindex-{OpenBSD,Linux}-i386
  105. ## remove unpackaging files
  106. find %{buildroot} | %__grep -e "\.\(la\|a\)$" | xargs %__rm -f
  107. find %{buildroot} | %__grep -e "\.\(diff\|patch\)$" | xargs %__rm -f
  108. ## Files list
  109. find %{buildroot} -type f -or -type l | \
  110. %__sed -e "s|%{buildroot}||g" > filelist.full
  111. find %{buildroot}%{texmf}-dist -type d | \
  112. %__sed -e "s|^%{buildroot}|%dir |" \
  113. -e "s|$|/|" >> filelist.full
  114. %clean
  115. %__rm -rf %{buildroot}
  116. %post
  117. %{exec_texhash}
  118. exit 0
  119. %postun
  120. if [ "$1" = 0 ]; then
  121. %{exec_texhash}
  122. fi
  123. exit 0
  124. %files -f filelist.full
  125. %defattr(-,root,root)
  126. %changelog
  127. * Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
  128. - generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-documentation-ukrainian
  129. - improved %%post
  130. * Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
  131. - generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-documentation-ukrainian
  132. - removed arch dependent binaries (texlive-collection-latexextra)
  133. - fixed perl path
  134. - improved updmap process in %%post and %%postun
  135. * Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
  136. - generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-documentation-ukrainian