tcsh-vl.spec 7.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262
  1. %define _bindir /bin
  2. Summary: An enhanced version of csh, the C shell
  3. Summary(ja): csh, Cシェルの進化バージョン
  4. Name: tcsh
  5. Version: 6.16
  6. Release: 2%{?_dist_release}
  7. License: BSD
  8. URL: http://www.tcsh.org/
  9. Group: System Environment/Shells
  10. Source: ftp://ftp.astron.com/pub/tcsh/%{name}-%{version}.00.tar.gz
  11. Patch1: tcsh-6.15.00-closem.patch
  12. Patch2: tcsh-6.14.00-tinfo.patch
  13. Patch3: tcsh-6.14.00-unprintable.patch
  14. Patch4: tcsh-6.15.00-hist-sub.patch
  15. Patch6: tcsh-6.15.00-ca-color.patch
  16. Patch7: tcsh-6.14.00-set.patch
  17. Patch8: tcsh-6.14.00-syntax.patch
  18. Patch9: tcsh-6.13.00-memoryuse.patch
  19. Patch11: tcsh-6.14.00-order.patch
  20. Patch12: tcsh-6.15.00-wide-str.patch
  21. Patch13: tcsh-6.15.00-rs-color.patch
  22. Provides: csh = %{version}
  23. Requires(post): grep
  24. Requires(postun): coreutils, grep
  25. Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
  26. BuildRequires: autoconf, automake, ncurses-devel, gettext-devel
  27. %description
  28. Tcsh is an enhanced but completely compatible version of csh, the C
  29. shell. Tcsh is a command language interpreter which can be used both
  30. as an interactive login shell and as a shell script command processor.
  31. Tcsh includes a command line editor, programmable word completion,
  32. spelling correction, a history mechanism, job control and a C language
  33. like syntax.
  34. %description -l ja
  35. tcsh は、バークレイ版 UNIX の C シェル csh と完全に互換性があり、
  36. さらに機能強化したシェルです。対話的なログインシェル、またシェルス
  37. クリプトのコマンドプロセッサの両方の用途で使われるコマンドインタプ
  38. リタです。
  39. tcsh には、コマンド行編集機能や、プログラム可能な単語の補完機能、
  40. スペル訂正、履歴、ジョブ制御、C 言語風の文法等が含まれます。
  41. %prep
  42. %setup -q -n %{name}-%{version}.00
  43. %patch1 -p1 -b .closem
  44. %patch2 -p1 -b .tinfo
  45. %patch3 -p1 -b .unprintable
  46. %patch4 -p1 -b .hist-sub
  47. %patch6 -p1 -b .ca-color
  48. %patch7 -p1 -b .set
  49. %patch8 -p1 -b .syntax
  50. %patch9 -p1 -b .memoryuse
  51. %patch11 -p1 -b .order
  52. %patch12 -p1 -b .wide-str
  53. %patch13 -p1 -b .rs-color
  54. for i in Fixes WishList; do
  55. iconv -f iso-8859-1 -t utf-8 "$i" > "${i}_" && \
  56. touch -r "$i" "${i}_" && \
  57. mv "${i}_" "$i"
  58. done
  59. %build
  60. # For tcsh-6.14.00-tinfo.patch
  61. autoreconf
  62. %configure --without-hesiod
  63. make %{?_smp_mflags} all
  64. make %{?_smp_mflags} -C nls catalogs
  65. %install
  66. rm -rf $RPM_BUILD_ROOT
  67. mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man1 ${RPM_BUILD_ROOT}%{_bindir}
  68. install -p -m 755 tcsh ${RPM_BUILD_ROOT}%{_bindir}/tcsh
  69. install -p -m 644 tcsh.man ${RPM_BUILD_ROOT}%{_mandir}/man1/tcsh.1
  70. ln -sf tcsh ${RPM_BUILD_ROOT}%{_bindir}/csh
  71. ln -sf tcsh.1 ${RPM_BUILD_ROOT}%{_mandir}/man1/csh.1
  72. while read lang language ; do
  73. dest=${RPM_BUILD_ROOT}%{_datadir}/locale/$lang/LC_MESSAGES
  74. if test -f tcsh.$language.cat ; then
  75. mkdir -p $dest
  76. install -p -m 644 tcsh.$language.cat $dest/tcsh
  77. echo "%lang($lang) %{_datadir}/locale/$lang/LC_MESSAGES/tcsh"
  78. fi
  79. done > tcsh.lang << _EOF
  80. de german
  81. el greek
  82. en C
  83. es spanish
  84. et et
  85. fi finnish
  86. fr french
  87. it italian
  88. ja ja
  89. pl pl
  90. ru russian
  91. uk ukrainian
  92. _EOF
  93. %clean
  94. rm -rf $RPM_BUILD_ROOT
  95. %post
  96. if [ ! -f /etc/shells ]; then
  97. echo "%{_bindir}/tcsh" >> /etc/shells
  98. echo "%{_bindir}/csh" >> /etc/shells
  99. else
  100. grep -q '^%{_bindir}/tcsh$' /etc/shells || \
  101. echo "%{_bindir}/tcsh" >> /etc/shells
  102. grep -q '^%{_bindir}/csh$' /etc/shells || \
  103. echo "%{_bindir}/csh" >> /etc/shells
  104. fi
  105. %postun
  106. if [ ! -x %{_bindir}/tcsh ]; then
  107. grep -v '^%{_bindir}/tcsh$' /etc/shells | \
  108. grep -v '^%{_bindir}/csh$' > /etc/shells.rpm && \
  109. mv /etc/shells.rpm /etc/shells
  110. fi
  111. %files -f tcsh.lang
  112. %defattr(-,root,root,-)
  113. %doc BUGS FAQ Fixes NewThings WishList complete.tcsh
  114. %{_bindir}/tcsh
  115. %{_bindir}/csh
  116. %{_mandir}/man1/*.1*
  117. %changelog
  118. * Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.16-2
  119. - rebuilt with current VineSeed
  120. * Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 6.16-1
  121. - new upstream release
  122. - resync with 6.16-1(fc12)
  123. - drop vine patch
  124. * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 6.12-1vl5
  125. - applied new versioning policy, spec in utf-8
  126. * Wed Oct 18 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 6.12-0vl6
  127. - added patch11 from fedora
  128. * Thu Mar 23 2006 Miloslav Trmac <mitr@redhat.com> - 6.14-8
  129. - Backport a patch to ignore LS_COLOR codes introduced in newer coreutils
  130. (#186037)
  131. - added japanese description
  132. * Thu Apr 02 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 6.12-0vl5
  133. - added patch from fedora
  134. * Tue Feb 10 2004 Nalin Dahyabhai <nalin@redhat.com> 6.12-7
  135. - remove declaration of setpgrp() which conflicts with libc's (#115185)
  136. * Fri Nov 21 2003 Nalin Dahyabhai <nalin@redhat.com> 6.12-6
  137. - add missing buildprereqs on groff, libtermcap-devel (#110599)
  138. * Mon Oct 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.12-0vl4
  139. - rebuild with new toolchains
  140. - s/Copyright/License/
  141. - fix spec file to build correctly (based on Rawhide spec file)
  142. * Tue Aug 06 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 6.12-0vl3
  143. - "Re"-changed the way of fixing check locale from Patch8 to Patch9
  144. on ppc strlen() can not deal with 'short' variables
  145. * Sat Aug 03 2002 Satoshi MACHINO <machino@vinelinux.org> 6.12-0vl2
  146. - fixed changelog
  147. * Thu Jul 25 2002 K. Nagasaka <nagasaka@math.tsukuba.ac.jp> 6.12-0vl1
  148. - update
  149. * Sun Apr 28 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 6.11-0vl4
  150. - change limit.patch
  151. * Fri Apr 26 2002 Kosaku Nagasaka <nagasaka@math.tsukuba.ac.jp> 6.11-0vl3
  152. - fixed limit by Patch10
  153. * Sun Jan 27 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 6.11-0vl2
  154. - changed the way of fixing check locale from Patch8 to Patch9
  155. on ppc strlen() can not deal with 'short' variables
  156. * Mon Jan 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 6.11-0vl1
  157. - update
  158. * Thu Dec 28 2001 Satoshi MACHINO <machino@vinelinux.org> 6.10.02-0vl2
  159. - fixed check locale
  160. - merged some patches from RHL-7.2
  161. * Thu Aug 09 2001 <sagami@vinelinux.org>
  162. - 6.10.02-0vl1
  163. * Sun Jan 7 2001 Jun Nishii <jun@vinelinux.org>
  164. - 6.10-1vl2
  165. - build with gcc
  166. * Mon Dec 11 2000 Yasuhide OOMORI <dasen@icntv.ne.jp>
  167. - syncronized release tcsh based on a securty fix for RH6.2.
  168. * Thu Nov 30 2000 Nalin Dahyabhai <nalin@redhat.com>
  169. - update to 6.10.00 to fix here-script vulnerability
  170. * Wed Sep 18 2000 Adrian Havill <havill@redhat.com>
  171. - fix catalog locale dirname for Japanese
  172. * Thu Jun 15 2000 Jeff Johnson <jbj@redhat.com>
  173. - FHS packaging.
  174. - add locale support (#10345).
  175. * Tue Mar 7 2000 Jeff Johnson <jbj@redhat.com>
  176. - rebuild for sparc baud rates > 38400.
  177. * Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
  178. - rebuild to fix dependencies
  179. * Thu Jan 27 2000 Jeff Johnson <jbj@redhat.com>
  180. - append entries to spanking new /etc/shells.
  181. * Mon Jan 10 2000 Jeff Johnson <jbj@redhat.com>
  182. - update to 6.09.
  183. - fix strcoll oddness (#6000, #6244, #6398).
  184. * Sat Sep 25 1999 Michael K. Johnson <johnsonm@redhat.com>
  185. - fix $shell by using --bindir
  186. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  187. - auto rebuild in the new build environment (release 5)
  188. * Wed Feb 24 1999 Cristian Gafton <gafton@redhat.com>
  189. - patch for using PATH_MAX instead of some silly internal #defines for
  190. variables that handle filenames.
  191. * Fri Nov 6 1998 Jeff Johnson <jbj@redhat.com>
  192. - update to 6.08.00.
  193. * Fri Oct 02 1998 Cristian Gafton <gafton@redhat.com>
  194. - upgraded to 6.07.09 from the freebsd
  195. - security fix
  196. * Wed Aug 5 1998 Jeff Johnson <jbj@redhat.com>
  197. - use -ltermcap so that /bin/tcsh can be used in single user mode w/o /usr.
  198. - update url's
  199. * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
  200. - translations modified for de, fr, tr
  201. * Thu Oct 21 1997 Cristian Gafton <gafton@redhat.com>
  202. - updated to 6.07; added BuildRoot
  203. - cleaned up the spec file; fixed source url
  204. * Wed Sep 03 1997 Erik Troan <ewt@redhat.com>
  205. - added termios hacks for new glibc
  206. - added /bin/csh to file list
  207. * Fri Jun 13 1997 Erik Troan <ewt@redhat.com>
  208. - built against glibc
  209. * Fri Feb 07 1997 Erik Troan <ewt@redhat.com>
  210. - Provides csh, adds and removes /bin/csh from /etc/shells if csh package
  211. isn't installed.