rhpl-vl.spec 23 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710
  1. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. Summary: Library of python code used by programs in Vine Linux
  3. Summary(ja): Vine Linux で利用する python コードライブラリ
  4. Name: rhpl
  5. Version: 0.216
  6. Release: 7%{?_dist_release}
  7. Source0: %{name}-%{version}.tar.bz2
  8. Patch0: %{name}-0.216-compat.patch
  9. Patch1: %{name}-0.216-pmac.patch
  10. License: GPL
  11. Group: System Environment/Libraries
  12. BuildRoot: %{_tmppath}/%{name}-root
  13. BuildRequires: python-devel, gettext
  14. BuildRequires: wireless-tools-devel
  15. Requires: python >= %(%{__python} -c "import sys; print sys.version[:3]")
  16. Requires: pyxf86config >= 0.3.2
  17. %description
  18. The rhpl package contains Python code used by programs in Vine Linux.
  19. Vendor: Project Vine
  20. Distribution: Vine Linux
  21. Packager: daisuke
  22. %prep
  23. %setup -q
  24. %patch0 -p1 -b .compat
  25. %patch1 -p1 -b .pmac
  26. # this line is no more need?
  27. perl -pi -e 's/python2.3/python2.4/g' Makefile.inc src/*
  28. perl -pi -e 's/xgettext /xgettext --from-code=UTF-8 /g' po/Makefile
  29. %build
  30. %__make
  31. %install
  32. rm -rf $RPM_BUILD_ROOT
  33. make DESTDIR=${RPM_BUILD_ROOT} install
  34. %find_lang %name
  35. %clean
  36. rm -rf $RPM_BUILD_ROOT
  37. %files -f %{name}.lang
  38. %defattr(-,root,root)
  39. %doc README COPYING
  40. %{python_sitearch}/rhpl
  41. %changelog
  42. * Wed Apr 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.216-7
  43. - rebuild for Vine 6
  44. * Wed Mar 31 2010 Shu KONNO <owa@bg.wakwak.com> 0.216-6
  45. - updated release number
  46. - import Vine5.1 changes
  47. * Wed Jan 27 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.216-5
  48. - add BuildRequires: wireless-tools-devel
  49. * Wed Sep 9 2009 MATSUBAYSHI Kohji <shaolin@vinelinux.org> 0.216-4
  50. - add Patch1: implement getPPCMachineName()
  51. * Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.216-4
  52. - rebuild with python-2.6
  53. * Wed Mar 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.216-3
  54. - disable deprecate warning in log.py
  55. * Tue Feb 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.216-2
  56. - add comps.py from rhpl-0.146.3
  57. * Mon Aug 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.216-1
  58. - new upstream release
  59. * Tue May 22 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl17
  60. - add "--from-code" option to xgettext
  61. * Thu Nov 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl16
  62. - update vine patch
  63. - add some fontpath (<BTS:371>)
  64. - add nv panel size detection code.
  65. * Wed Nov 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl15
  66. - update vine patch
  67. - remove unsupported (larger) display from Modes list.
  68. * Tue Oct 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl14
  69. - update vine patch
  70. - set desired_resolution from LCD panel resolution.
  71. * Wed Oct 25 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl13
  72. - apply new compare_resolution algorism for all arch. (<BTS:301>)
  73. * Sun Oct 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl12
  74. - update vine patch
  75. - fix radeon panel size detection code.
  76. * Wed Sep 20 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.148.3-0vl11
  77. - don't apply Patch60 on ppc
  78. * Wed Sep 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl10
  79. - add more extra modelines
  80. * Wed Sep 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl9
  81. - add extra modeline to extramodes
  82. * Thu Sep 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl8
  83. - add Patch50 to guess unprobed mouse as generic mouse.
  84. * Fri Sep 08 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.148.3-0vl7
  85. - add Patch40 for ppc
  86. * Sat Sep 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl6
  87. - add Patch30 to modifiy keyboard_models
  88. * Thu Aug 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl5
  89. - update vine patch
  90. - detect i810 panel size
  91. * Tue Aug 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl4
  92. - update vine patch
  93. - add more display resolutions
  94. * Thu Aug 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl3
  95. - replace obsolete gtk.{TRUE,FALSE} with {True,False}
  96. * Tue Aug 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl2
  97. - fix default X settings
  98. - add VMWare monitor hacks
  99. * Wed Aug 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl1
  100. - initial build for Vine Linux
  101. * Fri Jul 8 2005 Jeremy Katz <katzj@redhat.com> - 0.148.3-1
  102. - fix indic keyboards (#158139)
  103. * Wed Nov 17 2004 Jeremy Katz <katzj@redhat.com> - 0.148.2-1
  104. - add patch from Jim Parsons to add executil.execWithCaptureErrorStatus as
  105. needed by system-config-lvm
  106. * Tue Nov 16 2004 Paul Nasrat <pnasrat@redhat.com> - 0.148.1-1
  107. - RHEL4 remove synaptics
  108. * Wed Oct 13 2004 Paul Nasrat <pnasrat@redhat.com> - 0.148-1
  109. - Indic keyboard fixups
  110. - Multi-input synaptics
  111. - require synaptics
  112. - Less verbose ddcprobe
  113. * Thu Sep 30 2004 Harald Hoyer <harald@redhat.com> - 0.147-1
  114. - let Conf.ConfModules use modprobe.conf name and format (bug 131952)
  115. - use network script resolv.conf merger/changer (bug 132485)
  116. * Fri Sep 24 2004 Jeremy Katz <katzj@redhat.com>
  117. - require python (#133462)
  118. * Wed Sep 22 2004 Jeremy Katz <katzj@redhat.com> - 0.146-1
  119. - add synaptics support (pnasrat)
  120. - add arabic and indic keyboards (pnasrat)
  121. * Fri Jun 18 2004 Jeremy Katz <katzj@redhat.com> - 0.145-1
  122. - improved lib64 detection, rebuild with gcc 3.4
  123. * Wed May 5 2004 Jeremy Katz <katzj@redhat.com> - 0.144-1
  124. - open cd device with O_NONBLOCK so eject ioctl works (#122524)
  125. * Tue Apr 20 2004 Brent Fox <bfox@redhat.com> 0.143-1
  126. - Do not write out XkbRules line to config file, as it is unnecessary to hard
  127. code the rules file, which has a built in default which should always
  128. work. (#120858)
  129. * Fri Apr 16 2004 Jeremy Katz <katzj@redhat.com> - 0.142-1
  130. - more XFree86->xorg
  131. * Thu Apr 15 2004 Jeremy Katz <katzj@redhat.com> - 0.141-1
  132. - xserver.py: workaround libxf86config not writing out the monitor stuff
  133. we tell it to (#120950)
  134. * Wed Apr 14 2004 Jeremy Katz <katzj@redhat.com> - 0.140-1
  135. - translate.py: one more try at string encoding madness (#119391)
  136. * Tue Apr 13 2004 Jeremy Katz <katzj@redhat.com> - 0.139-1
  137. - videocard.py: fixups for VESA handling on x86_64
  138. - videocard.py, xserver.py: XFree86 -> Xorg changes
  139. * Wed Mar 17 2004 Bill Nottingham <notting@redhat.com> 0.138-1
  140. - mouse.py cleanups
  141. * Tue Mar 16 2004 Bill Nottingham <notting@redhat.com> 0.135-1
  142. - remove old default keymap when writing config (#116852)
  143. * Tue Mar 9 2004 Brent Fox <bfox@redhat.com> 0.134-1
  144. - user fr-latin9 for the X keymap too (bug #113672)
  145. * Tue Mar 9 2004 Jeremy Katz <katzj@redhat.com> - 0.133-1
  146. - use vesa for unknown cards on x86_64
  147. * Fri Mar 5 2004 Brent Fox <bfox@redhat.com> 0.132-1
  148. - use fr-latin9 instead of fr-latin0 (bug #113672)
  149. * Thu Mar 4 2004 Jeremy Katz <katzj@redhat.com> - 0.131-1
  150. - switch some default keyboard layouts (#117007)
  151. * Thu Mar 4 2004 Brent Fox <bfox@redhat.com> 0.130-1
  152. - strip out refresh rate data (bug #117327)
  153. * Wed Mar 3 2004 Brent Fox <bfox@redhat.com> 0.129-1
  154. - enable DRI extentions for all i386, x86_64, and ia64 systems (bug #115672)
  155. - vmware doesn't do 24bpp (#117375)
  156. - fix for savage + lcds (#117079)
  157. * Thu Feb 26 2004 Brent Fox <bfox@redhat.com> 0.128-1
  158. - add some hooks to xhwstate.py to get PCI bus ID info
  159. * Fri Feb 20 2004 Brent Fox <bfox@redhat.com> 0.127-2
  160. - correct a typo
  161. * Fri Feb 20 2004 Brent Fox <bfox@redhat.com> 0.127-1
  162. - changes to mouse handling in xhwstate.py
  163. * Wed Feb 18 2004 Jeremy Katz <katzj@redhat.com> 0.126-1
  164. - minor tweak for mouse stuff
  165. * Fri Feb 13 2004 Brent Fox <bfox@redhat.com> 0.125.1-1
  166. - use hu_qwerty for Hungarian (101 key) (bug #114629)
  167. * Thu Jan 22 2004 Jeremy Katz <katzj@redhat.com> 0.124.1-1
  168. - translate.py: minor tweaks
  169. * Tue Jan 20 2004 Jeremy Katz <katzj@redhat.com> 0.124-1
  170. - translate.py: return UTF-8 encoded strings (#113202)
  171. * Thu Jan 8 2004 Brent Fox <bfox@redhat.com> 0.123.1-1
  172. - add an entry for Korean keyboards (bug #112024)
  173. * Tue Jan 6 2004 Jeremy Katz <katzj@redhat.com>
  174. - mark keyboard model names as keyboard|name to make them differ
  175. from language names (#84969)
  176. * Tue Dec 16 2003 Jeremy Katz <katzj@redhat.com>
  177. - use EISA if name doesn't exist in ddc data (#112281)
  178. * Fri Nov 14 2003 Jeremy Katz <katzj@redhat.com> 0.122.2-1
  179. - more python2.3
  180. * Sat Nov 8 2003 Jeremy Katz <katzj@redhat.com> 0.122.1-1
  181. - more python 2.3 fixups
  182. * Thu Nov 6 2003 Jeremy Katz <katzj@redhat.com> 0.122-1
  183. - python 2.3
  184. * Tue Oct 21 2003 Jeremy Katz <katzj@redhat.com> 0.121-1
  185. - don't try to use 24bpp on old hardware (#105713)
  186. * Thu Oct 16 2003 Brent Fox <bfox@redhat.com> 0.120-1
  187. - mouse.py - add two entries for optical mice
  188. * Thu Oct 16 2003 Jeremy Katz <katzj@redhat.com> 0.119-1
  189. - keyboard_models.py: fix greek keyboard layout (#100773)
  190. * Wed Oct 15 2003 Jeremy Katz <katzj@redhat.com> 0.118-1
  191. - translate.py: assume UTF-8 if we can't figure out the encoding of a mofile
  192. * Thu Oct 8 2003 Michael Fulbright <msf@redhat.com> 0.117-1
  193. - xhwstate.py - dont write out video ram option to XF86Config
  194. * Thu Oct 2 2003 Brent Fox <bfox@redhat.com> 0.116-1
  195. - videocard.py: added pci busID functions
  196. * Tue Sep 30 2003 Jeremy Katz <katzj@redhat.com> 0.115-1
  197. - mouse.py: add new API and make sane to use for translation
  198. * Thu Sep 25 2003 Harald Hoyer <harald@redhat.de> 0.114-1
  199. - preserve comments in modules.conf #76640
  200. * Tue Sep 23 2003 Michael Fulbright <msf@redhat.com>
  201. - fix bug dealing with determining video modes supported by a monitor
  202. * Mon Sep 8 2003 Jeremy Katz <katzj@redhat.com>
  203. - use RPM_OPT_FLAGS (#103970)
  204. * Thu Sep 04 2003 Harald Hoyer <harald@redhat.de> 0.112-1
  205. - fixed ConfPAP.getfields()
  206. * Thu Sep 04 2003 Michael Fulbright <msf@redhat.com> 0.111-1
  207. - fixes for bugzilla #103353
  208. * Tue Sep 02 2003 Michael Fulbright <msf@redhat.com> 0.111-1
  209. - fixes to X setup code
  210. * Fri Aug 29 2003 Harald Hoyer <harald@redhat.de> 0.110-1
  211. - removed memory leak
  212. * Wed Jul 16 2003 Jeremy Katz <katzj@redhat.com> 0.110-1
  213. - add an interface for adding packages to groups
  214. * Mon Jul 14 2003 Jeremy Katz <katzj@redhat.com> 0.109-1
  215. - multilib on ia64
  216. * Wed Jul 09 2003 Harald Hoyer <harald@redhat.de> 0.108-3
  217. - rebuilt with all files updated from cvs
  218. * Tue Jul 8 2003 Jeremy Katz <katzj@redhat.com> 0.108-1
  219. - comps.py: preserve xml doc/nodes
  220. - translate.py: make it so we can use translations from update disks in
  221. anaconda
  222. * Thu Jun 12 2003 Brent Fox <bfox@redhat.com> 0.107-1
  223. - add a get_xconfig() method to xhwstate.py
  224. * Tue Jun 10 2003 Harald Hoyer <harald@redhat.de> 0.106-1
  225. - better regexp in Conf.py
  226. - strip filename from subject
  227. * Fri Jun 6 2003 Jeremy Katz <katzj@redhat.com> 0.105-1
  228. - more biarch fun
  229. * Wed Jun 4 2003 Jeremy Katz <katzj@redhat.com> 0.104-1
  230. - add ppc64[ip]series
  231. * Wed Jun 4 2003 Jeremy Katz <katzj@redhat.com> 0.103.1-1
  232. - arch.py tweaks
  233. * Fri May 30 2003 Jeremy Katz <katzj@redhat.com> 0.103-1
  234. - comps.py extensions for biarch
  235. * Fri May 23 2003 Jeremy Katz <katzj@redhat.com> 0.102.1-1
  236. - fix tyop
  237. * Fri May 23 2003 Jeremy Katz <katzj@redhat.com> 0.102-1
  238. - add arch.py
  239. * Wed May 21 2003 Harald Hoyer <harald@redhat.de> 0.101.1-1
  240. - strip quotes from PAP/CHAP server also
  241. - Conf.py, cope with lines at the end of the file, that have no newline
  242. - speedup some things
  243. * Wed May 07 2003 Michael Fulbright <msf@redhat.com> 0.100.1-1
  244. - fixed simpleconfig.py and how it uppercases keys
  245. * Tue Apr 29 2003 Harald Hoyer <harald@redhat.com> 0.99.1-1
  246. - genClass and ethtool updates
  247. * Thu Apr 24 2003 Brent Fox <bfox@redhat.com> 0.98.1-2
  248. - strip an invalid char from monitor name (bug #87588)
  249. * Wed Apr 23 2003 Jeremy Katz <katzj@redhat.com> 0.98.1-1
  250. - revert broken part of pseries fb change
  251. * Mon Apr 21 2003 Jeremy Katz <katzj@redhat.com> 0.98-1
  252. - handle headless case better
  253. * Fri Apr 18 2003 Jeremy Katz <katzj@redhat.com> 0.97-1
  254. - fixes so that framebuffer can work for use on ppc machines
  255. * Thu Apr 3 2003 Brent Fox <bfox@redhat.com> 0.96-2
  256. - update the list of dri drivers from mharris
  257. * Thu Apr 3 2003 Brent Fox <bfox@redhat.com> 0.96-1
  258. - add ati and i810 to dri supported list in xhwstate.py
  259. * Wed Apr 2 2003 Brent Fox <bfox@redhat.com> 0.95-1
  260. - allow dialog size to be passed into firstboot_gui_window
  261. * Thu Feb 27 2003 Bill Nottingham <notting@redhat.com> 0.94-1
  262. - make py_bind_textdomain_codeset not segfault on ia64 (#85334)
  263. * Mon Feb 24 2003 Jeremy Katz <katzj@redhat.com> 0.93-1
  264. - mouse.py (mouseWindow): try to ensure we have a locale that
  265. we can do linedrawing chars for (#84908)
  266. * Wed Feb 12 2003 Brent Fox <bfox@redhat.com> 0.92-1
  267. - add grp_led:scroll to all lines with XkbOptions (bug #82096)
  268. * Tue Feb 11 2003 Brent Fox <bfox@redhat.com> 0.91-1
  269. - convert all toggles to grp:shift_toggle (bug #79287)
  270. * Fri Feb 7 2003 Brent Fox <bfox@redhat.com> 0.90-1
  271. - add grp_led:scroll to all Russian keyboards
  272. * Fri Feb 7 2003 Brent Fox <bfox@redhat.com> 0.89-1
  273. - add translate.textdomain('rhpl') to fix bug #69760
  274. * Thu Feb 6 2003 Matt Wilson <msw@redhat.com> 0.88-1
  275. - only reset the mouse if you have to
  276. * Thu Feb 6 2003 Brent Fox <bfox@redhat.com> 0.87-1
  277. - load additional us keymap for all ru keyboards in keyboard_models.py
  278. - make sure the kbd option gets set in keyboard.py
  279. * Thu Feb 6 2003 Brent Fox <bfox@redhat.com> 0.86-1
  280. - use sv-latin1 for swedish keyboards (bug #80508)
  281. * Wed Feb 5 2003 Matt Wilson <msw@redhat.com> 0.85-1
  282. - autodetect ps/2 wheel mice (#81902)
  283. * Wed Feb 5 2003 Brent Fox <bfox@redhat.com> 0.84-1
  284. - if there are no display Modes in the XF86Config file, create one and default to 800x600 (bug #83314)
  285. * Tue Feb 04 2003 Harald Hoyer <harald@redhat.de> 0.83-1
  286. - ConfPAP fix for quotation
  287. * Fri Jan 31 2003 Jeremy Katz <katzj@redhat.com> 0.81-2
  288. - fix typo
  289. * Fri Jan 31 2003 Adrian Likins <alikins@redhat.com>
  290. - added get_ipaddr, get_netmask, get_broadcast
  291. to ethtool module
  292. * Fri Jan 31 2003 Harald Hoyer <harald@redhat.de>
  293. - added some BuildRequires
  294. * Thu Jan 30 2003 Jeremy Katz <katzj@redhat.com> 0.80-1
  295. - default non-i386 arches to 8 megs of videoram
  296. * Wed Jan 22 2003 Brent Fox <bfox@redhat.com> 0.79-1
  297. - add us keymap and XkbOptions to non-latin keymaps in keyboard_models.py
  298. - change keyboard.py to handle the XkbOptions field
  299. * Mon Jan 20 2003 Michael Fulbright <msf@redhat.com> 0.78-1
  300. - improved code for LCD guessing
  301. * Fri Jan 17 2003 Michael Fulbright <msf@redhat.com> 0.77-1
  302. - added code to xserver.py to guess LCD size using guesslcd.py
  303. * Fri Jan 17 2003 Brent Fox <bfox@redhat.com> 0.76-1
  304. - changes to firstbootGuiWindow.py for new firstboot look
  305. * Tue Jan 14 2003 Michal Fulbright <msf@redhat.com> 0.75-1
  306. - fix xserver.py to include keyboard import
  307. * Fri Jan 10 2003 Brent Fox <bfox@redhat.com> 0.74-2
  308. - change se-latin1 kbd to se-fi-lat6 according to bug #80508
  309. * Fri Jan 3 2003 Brent Fox <bfox@redhat.com> 0.74-1
  310. - default to pc105 for most keyboards
  311. * Thu Jan 2 2003 Jeremy Katz <katzj@redhat.com> 0.73-3
  312. - make the translate.py change less noisy
  313. * Thu Jan 2 2003 Jeremy Katz <katzj@redhat.com> 0.73-2
  314. - typo fix
  315. * Wed Jan 1 2003 Jeremy Katz <katzj@redhat.com> 0.73-1
  316. - discid.py: add readFromBuffer
  317. * Sun Dec 29 2002 Jeremy Katz <katzj@redhat.com>
  318. - translate.py: if we fail, at least gracefully fall back instead of
  319. causing a traceback (#76104)
  320. * Thu Dec 19 2002 Harald Hoyer <harald@redhat.de> 0.72-1
  321. - added exception.py
  322. * Tue Dec 17 2002 Jeremy Katz <katzj@redhat.com> 0.71-2
  323. - fix silly typo
  324. * Tue Dec 17 2002 Jeremy Katz <katzj@redhat.com> 0.71-1
  325. - simpleconfig.py: gracefully handle non-existent config files
  326. * Mon Dec 16 2002 Harald Hoyer <harald@redhat.de> 0.70-1
  327. - _setParent() in GenClass::__setitem__
  328. * Fri Dec 13 2002 Jeremy Katz <katzj@redhat.com> 0.69-1
  329. - only probe for the mouse once to fix mouse probing problems
  330. - make keyboard names more consistent (#79354)
  331. * Thu Dec 12 2002 Harald Hoyer <harald@redhat.de> 0.68-1
  332. - genClass: slicing of anonymous lists
  333. - executil: dup2 more output redirectors
  334. * Tue Nov 26 2002 Michael Fulbright <msf@redhat.com> 0.67-1
  335. - Fixed issue related to not defaulting to sane monitor values if monitor
  336. was not probed.
  337. * Tue Nov 26 2002 Phil Knirsch <pknirsch@redhat.com> 0.66-1
  338. - Fixed -fpic handling for s390 and s390x.
  339. * Thu Nov 21 2002 Michael Fulbright <msf@redhat.com> 0.65-1
  340. - added some code to handle the no mouse setup better
  341. * Thu Nov 21 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  342. - do not require pyxf86config for mainframe
  343. * Tue Nov 19 2002 Michael Fulbright <msf@redhat.com> 0.64-1
  344. - Added new xserver.py which has code to help get X up and running from scratch
  345. * Tue Nov 19 2002 Jeremy Katz <katzj@redhat.com> 0.63-2
  346. - rebuild for all arches
  347. * Fri Nov 15 2002 Brent Fox <bfox@redhat.com> 0.63-1
  348. - Added Latin American (la-latin1) keyboard
  349. * Thu Nov 14 2002 Harald Hoyer <harald@redhat.de> 0.62-1
  350. - removed Alchemist dependency from genClass
  351. - executil extended
  352. * Tue Nov 12 2002 Michael Fulbright <msf@redhat.com> 0.61-1
  353. - big changes as we moved alot of code from redhat-config-xfree86 into xhwstate.py
  354. * Tue Nov 5 2002 Jeremy Katz <katzj@redhat.com> 0.59-1
  355. - access Cards database in /usr/share/hwdata instead of
  356. /usr/X11R6/lib/X11 (#73899)
  357. - excludearch x86_64 until python is fixed
  358. * Fri Nov 1 2002 Jeremy Katz <katzj@redhat.com> 0.58-1
  359. - add macedonian keyboard (#76902)
  360. - find loadkeys for anaconda (#75329)
  361. * Thu Oct 31 2002 Brent Fox <bfox@redhat.com> 0.57-1
  362. - Mark keyboard names for translations
  363. * Mon Oct 21 2002 Brent Fox <bfox@redhat.com> 0.56-1
  364. - Use cz_qwerty keymap for Czech qwerty keyboards
  365. * Thu Oct 10 2002 Jeremy Katz <katzj@redhat.com> 0.55-2
  366. - rebuild so that we actually get object files for the correct architectures
  367. * Wed Oct 9 2002 Dan Walsh <dwalsh@redhat.de> 0.55-1
  368. - removed chmod from ConfSMB.py file protection should remain the same
  369. * Tue Oct 8 2002 Harald Hoyer <harald@redhat.de> 0.54-1
  370. - removed fd/socket leaking
  371. * Tue Oct 08 2002 Phil Knirsch <pknirsch@redhat.com> 0.53-2
  372. - Integreated Karsten Hopp's 64bit bigendian patch for s390x.
  373. * Fri Oct 4 2002 Brent Fox <bfox@redhat.com> 0.53-1
  374. - Allow window icon to be passed into stand_alone in firstboot_gui_window.py
  375. * Thu Oct 3 2002 Jeremy Katz <katzj@redhat.com> 0.52-2
  376. - fixup installation into %%{_libdir}/python2.2/
  377. * Thu Oct 3 2002 Jeremy Katz <katzj@redhat.com> 0.52-1
  378. - iconvmodule.c: PyObject_asReadBuffer() expects *int while iconv()
  379. expects size_t.
  380. * Thu Aug 29 2002 Jeremy Katz <katzj@redhat.com> 0.51-1
  381. - src/keyboard_models.py: fix romanian console keymap (#72952)
  382. * Wed Aug 28 2002 Jeremy Katz <katzj@redhat.com> 0.50-1
  383. - diskutil.py: update /etc/mtab
  384. * Fri Aug 23 2002 Michael Fulbright <msf@redhat.com> 0.49-1
  385. - videocard.py: Use unsupported VGA compatible card entry if card unknown
  386. * Thu Aug 22 2002 Brent Fox <bfox@redhat.com> 0.48-1
  387. - translate.py: add ability to set codeset for textdomains not pulled in by us
  388. * Thu Aug 22 2002 Brent Fox <bfox@redhat.com> 0.47-1
  389. - fix another typo in translate.py
  390. * Thu Aug 22 2002 Jeremy Katz <katzj@redhat.com> 0.46-1
  391. - fix a typo in translate.py
  392. * Thu Aug 22 2002 Jeremy Katz <katzj@redhat.com> 0.45-1
  393. - minor mouse fixups (#70289, #71893)
  394. * Wed Aug 21 2002 Michael Fulbright <msf@redhat.com> 0.44-1
  395. - added sanity check to ddcprobe'd range values
  396. * Tue Aug 20 2002 Harald Hoyer <harald@redhat.de> 0.43-1
  397. - fixed genClass.py:toContext()
  398. - ValueError -> TypeError in checkType
  399. * Fri Aug 16 2002 Brent Fox <bfox@redhat.com> 0.42-1
  400. - Mark window title for translations in firstboot_gui_window
  401. * Fri Aug 16 2002 Jeremy Katz <katzj@redhat.com> 0.41-1
  402. - translate.py fixes
  403. - "None - None" is back, but as "No mouse"
  404. * Thu Aug 15 2002 Jeremy Katz <katzj@redhat.com> 0.40-1
  405. - comps.py: handle translated category names
  406. * Wed Aug 14 2002 Harald Hoyer <harald@redhat.de>
  407. - added iwconfig-support to ethtool
  408. * Wed Aug 14 2002 Brent Fox <bfox@redhat.com> 0.37-1
  409. - Call destroy() when a firstboot window exits
  410. * Mon Aug 12 2002 Jeremy Katz <katzj@redhat.com> 0.36-1
  411. - add generic wheel mouse types
  412. - add bad hack to handle packages which should only be installed
  413. if another package is installed
  414. * Sun Aug 11 2002 Brent Fox <bfox@redhat.com> 0.35-1
  415. - Create US International keymap line for bug 71105
  416. * Sun Aug 11 2002 Brent Fox <bfox@redhat.com> 0.34-2
  417. - Fix typo that I made with the last build
  418. * Sun Aug 11 2002 Brent Fox <bfox@redhat.com> 0.34-1
  419. - Fix Brazilian abnt2 keyboard map for bug 70351
  420. * Tue Aug 6 2002 Michael Fulbright <msf@redhat.com>
  421. - added sanity checks for sync rates
  422. * Fri Aug 2 2002 Jeremy Katz <katzj@redhat.com>
  423. - keyboard_models.py: be-latin2 isn't a valid keymap
  424. * Wed Jul 31 2002 Jeremy Katz <katzj@redhat.com> 0.32-1
  425. - add losetup, unlosetup, and getUnusedLoop to diskutil
  426. * Tue Jul 30 2002 Brent Fox <bfox@redhat.com> 0.31-1
  427. - remove some dead code
  428. - make the font big for firstboot_gui_window titles
  429. * Thu Jul 25 2002 Jeremy Katz <katzj@redhat.com> 0.30-1
  430. - mouse.py: don't enable emulate three buttons on the fly (#68129)
  431. * Thu Jul 25 2002 Jeremy Katz <katzj@redhat.com> 0.29-1
  432. - translate.py: set up default langs based on environment
  433. * Wed Jul 24 2002 Jonathan Blandford <jrb@redhat.com> 0.28-1
  434. * add GenericError.py
  435. * Wed Jul 24 2002 Jeremy Katz <katzj@redhat.com> 0.27-2
  436. - actually install _diskutil.so
  437. * Wed Jul 24 2002 Jeremy Katz <katzj@redhat.com> 0.27-1
  438. - diskutil.py, diskutil.c: add some simple disk utility methods (mount,
  439. umount, sync, ejectCdrom)
  440. * Mon Jul 22 2002 Jeremy Katz <katzj@redhat.com> 0.26-1
  441. - comps.py: add support for reading group hierarchy
  442. * Thu Jul 17 2002 Brent Fox <bfox@redhat.com> 0.25-1
  443. - Make firstboot windows use GtkDialog instead of GtkWindow
  444. * Wed Jul 17 2002 Brent Fox <bfox@redhat.com> 0.24-3
  445. - Change Poland keyboard to Polish. Bug #68520
  446. * Wed Jul 17 2002 Michael Fulbright <msf@redhat.com> 0.24-2
  447. - minor typo fix
  448. * Wed Jul 17 2002 Michael Fulbright <msf@redhat.com> 0.24-1
  449. - executil.py: add getfd() function
  450. * Tue Jul 16 2002 Jeremy Katz <katzj@redhat.com> 0.23-1
  451. - comps.py: add metapkg support
  452. * Tue Jul 16 2002 Brent Fox <bfox@redhat.com> 0.22-2
  453. - Call loadkeys if the binary exists when changing keymaps
  454. * Mon Jul 15 2002 Jeremy Katz <katzj@redhat.com> 0.21-1
  455. - fix jp106 entry in keyboard_models
  456. - add method to get list of supported keyboard maps
  457. * Sat Jul 13 2002 Brent Fox <bfox@redhat.com> 0.20-1
  458. - Small change in firstboot_gui_window.py to center popup windows
  459. * Wed Jul 10 2002 Brent Fox <bfox@redhat.com> 0.19-1
  460. - Added a Greek keyboard to keyboard_models.py
  461. * Wed Jul 10 2002 Alexander Larsson <alexl@redhat.com> 0.18-1
  462. - Fixed bug in monitor resoultion support code
  463. * Mon Jul 1 2002 Harald Hoyer <harald@redhat.de> 0.16-1
  464. - updated Conf*.py
  465. - updated genClass
  466. - added ethtool
  467. * Fri Jun 28 2002 Jeremy Katz <katzj@redhat.com> 0.15-1
  468. - comps.py: use libxml2 for xml parsing instead of expat
  469. * Fri Jun 28 2002 Jeremy Katz <katzj@redhat.com> 0.14-1
  470. - only setxkbmap if $DISPLAY is set
  471. * Thu Jun 27 2002 Jeremy Katz <katzj@redhat.com> 0.13-1
  472. - add parser for new comps file
  473. * Wed Jun 26 2002 Michael Fulbright <msf@redhat.com> 0.12-1
  474. - Fix bug of uninitialized data in Mouse class
  475. * Tue Jun 25 2002 Brent Fox <bfox@redhat.com> 0.11-3
  476. - Allow a window title to be passed in
  477. * Wed Jun 19 2002 Brent Fox <bfox@redhat.com> 0.9-4
  478. - Fixed line for German keyboards in keyboard_models.py
  479. * Tue Jun 18 2002 Brent Fox <bfox@redhat.com> 0.9-3
  480. - Remove cancel button from firstboot_gui_window
  481. * Tue Jun 18 2002 Brent Fox <bfox@redhat.com> 0.9-2
  482. - Provide a way to pass keymap name back to firstboot
  483. - Fix error in Slovakian keymap line in keyboard_models.py
  484. * Wed Jun 12 2002 Jeremy Katz <katzj@redhat.com>
  485. - use cz-lat2 for Czechoslovakian keybaord map (#66354)
  486. * Tue Jun 04 2002 Michael Fulbright <msf@redhat.com>
  487. - fixed bug referencing ddcDevice and videoram in card.
  488. * Tue May 28 2002 Jeremy Katz <katzj@redhat.com>
  489. - removed kbd.py, added keyboard.py
  490. * Fri May 24 2002 Michael Fulbright <msf@redhat.com>
  491. - Added kbd.py
  492. * Thu May 23 2002 Alex Larsson <alexl@redhat.com>
  493. - Added /usr/share/rhpl to files list
  494. * Thu May 23 2002 Michael Fulbright <msf@redhat.com>
  495. - added log.py, videocard.py, mouse.py, monitor.py, simpleconfig.py
  496. * Wed May 22 2002 Jeremy Katz <katzj@redhat.com>
  497. - Initial build.