libsigc++10-vl.spec 5.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188
  1. %define name libsigc++10
  2. %define version 1.0.4
  3. %define release 1%{?_dist_release}
  4. %define lib_name sigc++-1.0
  5. Summary: The Typesafe Signal Framework for C++
  6. Summary(ja): C++ 用の型安全なシグナルフレームワーク
  7. Name: %{name}
  8. Version: %{version}
  9. Release: %{release}
  10. Source: ftp://download.sourceforge.net/pub/sourceforge/libsigc/libsigc++-%{version}.tar.gz
  11. License: LGPL
  12. Group: System Environment/Libraries
  13. URL: http://libsigc.sourceforge.net/
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. Buildroot: %{_tmppath}/%{name}-%{version}-root
  17. %description
  18. This library implements a full callback system for use in widget libraries,
  19. abstract interfaces, and general programming. Originally part of the Gtk--
  20. widget set, %{name} is now a seperate library to provide for more general
  21. use. It is the most complete library of its kind with the ablity to connect
  22. an abstract callback to a class method, function, or function object. It
  23. contains adaptor classes for connection of dissimilar callbacks and has an
  24. ease of use unmatched by other C++ callback libraries.
  25. Package GTK-- (gtkmm), which is a C++ binding to the GTK+ library,
  26. starting with version 1.1.2, uses %{name}.
  27. %package devel
  28. Summary: development tools for the Typesafe Signal Framework for C++
  29. Group: Development/Libraries
  30. Requires: %{name} = %{version}-%{release}
  31. %description devel
  32. The %{name}-devel package contains the static libraries and header files
  33. needed for development with %{name}.
  34. %package examples
  35. Summary: examples and tests for the Typesafe Signal Framework for C++
  36. Group: Development/Libraries
  37. Requires: %{name}-devel = %{version}-%{release}
  38. %description examples
  39. The %{name}-examples package contains source code of example and test
  40. programs for %{name}.
  41. %prep
  42. %setup -q -n libsigc++-%{version}
  43. %build
  44. %configure
  45. export tagname=CC
  46. make %{_smp_mflags} LIBTOOL=/usr/bin/libtool
  47. %install
  48. rm -rf $RPM_BUILD_ROOT
  49. export tagname=CC
  50. %makeinstall LIBTOOL=/usr/bin/libtool
  51. mkdir -p $RPM_BUILD_ROOT%{_libdir}/%{lib_name}
  52. cp -a examples tests $RPM_BUILD_ROOT%{_libdir}/%{lib_name}
  53. find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type d -name .libs |xargs -r rm -rf
  54. find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type f |xargs file |
  55. grep -E '(relocatable|executable|shell script)' |cut -d: -f1 |xargs -r rm -f
  56. for i in $RPM_BUILD_ROOT%{_libdir}/%{lib_name}/examples/Makefile; do
  57. rm -f $i.*
  58. cp -p scripts/examples.Makefile $i
  59. done
  60. for i in $RPM_BUILD_ROOT%{_libdir}/%{lib_name}/tests/Makefile; do
  61. rm -f $i.*
  62. cp -p scripts/tests.Makefile $i
  63. done
  64. ## remove unuse files
  65. rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
  66. %post -p /sbin/ldconfig
  67. %postun -p /sbin/ldconfig
  68. %clean
  69. rm -rf $RPM_BUILD_ROOT
  70. %files
  71. %defattr(-,root,root,755)
  72. %attr(755,root,root) %{_libdir}/lib*.so.*
  73. %doc AUTHORS COPYING.LIB README IDEAS NEWS ChangeLog TODO
  74. %files devel
  75. %defattr(-,root,root,755)
  76. %doc doc/*
  77. %{_bindir}/*
  78. %{_includedir}/*
  79. %attr(755,root,root) %{_libdir}/lib*.so
  80. %attr(644,root,root) %{_libdir}/*.a
  81. %{_datadir}/aclocal/*
  82. %files examples
  83. %defattr(-,root,root,755)
  84. %{_libdir}/%{lib_name}/examples
  85. %{_libdir}/%{lib_name}/tests
  86. %changelog
  87. * Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.4-1vl5
  88. - applied new versioning policy, spec in utf-8
  89. - removed *.la
  90. * Sun Jun 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.4-0vl5
  91. - rebuilt with new toolchain
  92. * Sun Dec 14 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.4-0vl4
  93. - renamed libsigc++10 in order to allow 1.2 installation
  94. * Sat Oct 4 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.4-0vl3
  95. - rebuild to remove dependance <5371>
  96. - add Japanese summary
  97. - use better macros
  98. - s/Copyright/License/
  99. * Mon Nov 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl2
  100. - rebuild with new toolchain
  101. * Wed Feb 06 2002 Satoshi IWMAOTO <satoshi.iwamoto@nifty.ne.jp>
  102. - 1.0.4-0vl1
  103. - Build for Vine Linux 2.5
  104. * Wed Feb 21 2001 yoneda kenji <yoneda@n.isl.titech.ac.jp>
  105. - packaged for Vine Linux 2.1
  106. * Sat Apr 15 2000 Dmitry V. Levin <ldv@fandra.org>
  107. - updated Url and Source fileds
  108. - 1.0.0 stable release
  109. * Sat Jan 22 2000 Dmitry V. Levin <ldv@fandra.org>
  110. - filtering out -fno-rtti and -fno-exceptions options from $RPM_OPT_FLAGS
  111. - minor install section cleanup
  112. * Wed Jan 19 2000 Allan Rae <rae@lyx.org>
  113. - autogen just creates configure, not runs it, so cleaned that up too.
  114. * Wed Jan 19 2000 Dmitry V. Levin <ldv@fandra.org>
  115. - minor attr fix
  116. - removed unnecessary curly braces
  117. - fixed Herbert's adjustement
  118. * Sat Jan 15 2000 Dmitry V. Levin <ldv@fandra.org>
  119. - minor package dependence fix
  120. * Sat Dec 25 1999 Herbert Valerio Riedel <hvr@gnu.org>
  121. - fixed typo of mine
  122. - added traditional CUSTOM_RELEASE stuff
  123. - added SMP support
  124. * Thu Dec 23 1999 Herbert Valerio Riedel <hvr@gnu.org>
  125. - adjusted spec file to get tests.Makefile and examples.Makefile from scripts/
  126. * Fri Oct 22 1999 Dmitry V. Levin <ldv@fandra.org>
  127. - split into three packages: %name, %name-devel and %name-examples
  128. * Thu Aug 12 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
  129. - updated source field and merged conflicts between revisions.
  130. * Tue Aug 10 1999 Dmitry V. Levin <ldv@fandra.org>
  131. - updated Prefix and BuildRoot fields
  132. * Thu Aug 5 1999 Herbert Valerio Riedel <hvr@hvrlab.dhs.org>
  133. - made sure configure works on all alphas
  134. * Wed Jul 7 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
  135. - Added autoconf macro for sigc.
  136. * Fri Jun 11 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
  137. - Made into a .in to keep version field up to date
  138. - Still need to do release by hand
  139. * Mon Jun 7 1999 Dmitry V. Levin <ldv@fandra.org>
  140. - added Vendor and Packager fields
  141. * Sat Jun 5 1999 Dmitry V. Levin <ldv@fandra.org>
  142. - updated to 0.8.0
  143. * Tue Jun 1 1999 Dmitry V. Levin <ldv@fandra.org>
  144. - initial revision