jam-vl.spec 1.8 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768
  1. %define name jam
  2. %define version 2.5
  3. %define release 1%{?_dist_release}
  4. Summary: Program construction tool, similar to make
  5. Name: %{name}
  6. Version: %{version}
  7. Release: %{release}
  8. Source0: ftp://ftp.perforce.com/pub/jam/%{name}-%{version}.tar
  9. License: Distributable
  10. Group: Development/Tools
  11. URL: http://www.perforce.com/jam/jam.html
  12. #Requires: byacc
  13. BuildRequires: byacc
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. %description
  16. Jam is a program construction tool, like make.
  17. Jam recursively builds target files from source files,
  18. using dependency information and updating actions expressed in
  19. the Jambase file, which is written in jam's own interpreted
  20. language. The default Jambase is compiled into jam and
  21. provides a boilerplate for common use, relying on a user-provide
  22. file "Jamfile" to enumerate actual targets and sources.
  23. The Jambase is described in the Jambase
  24. Reference and the document Using Jamfiles and Jambase.
  25. # '
  26. %prep
  27. %setup -q
  28. %build
  29. export CFLAGS="$RPM_OPT_FLAGS" CCFLAGS="$RPM_OPT_FLAGS"
  30. make %{?_smp_mflags}
  31. %install
  32. %{__rm} -rf ${RPM_BUILD_ROOT}
  33. mkdir -p ${RPM_BUILD_ROOT}/%{_bindir}
  34. install -m0755 bin.linux*/jam ${RPM_BUILD_ROOT}/%{_bindir}
  35. install -m0755 bin.linux*/mkjambase ${RPM_BUILD_ROOT}/%{_bindir}
  36. %clean
  37. %{__rm} -rf ${RPM_BUILD_ROOT}
  38. %files
  39. %defattr(-,root,root)
  40. %doc README RELNOTES *.html
  41. %{_bindir}/jam
  42. %{_bindir}/mkjambase
  43. %changelog
  44. * Sun Sep 28 2008 Shu KONNO <owa@bg.wakwak.com> 2.5-1vl5
  45. - applied new versioning policy
  46. * Mon Sep 3 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 2.5-0vl2
  47. - rebuild for VineSeed
  48. * Mon Sep 3 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 2.5-0vl1
  49. - initial build for Vine Linux 4.1
  50. * Fri Jun 24 2005 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 2.5-0vlmp1
  51. - initial build for Vine Linux 3.2
  52. # end of file