gnuplot-vl.spec 6.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216
  1. %define gpmainver 4.2
  2. %define gpver %{gpmainver}.5
  3. Summary: A program for plotting mathematical expressions and data.
  4. Summary(ja): 数学系の関数やデータのプロット・プログラム
  5. Name: gnuplot
  6. Version: %{gpver}
  7. Release: 1%{?_dist_release}
  8. License: gnuplot and GPLv2
  9. Group: Applications/Engineering
  10. URL: http://gnuplot.sourceforge.net/
  11. Source: http://prdownloads.sourceforge.net/gnuplot/gnuplot-%{version}.tar.gz
  12. BuildRoot: %{_tmppath}/%{name}-root
  13. BuildRequires: gd-devel >= 2.0.27, libpng-devel, tetex, zlib-devel
  14. BuildRequires: libX11-devel, libXt-devel, wx-gtk2-devel
  15. BuildRequires: readline-devel
  16. BuildRequires: autoconf, automake
  17. BuildRequires: texinfo, emacsen
  18. Requires(post): install-info
  19. Requires(preun): install-info
  20. Vendor: Project Vine
  21. Distribution: Vine Linux
  22. Packager: daisuke
  23. %description
  24. Gnuplot is a command-line driven, interactive function plotting
  25. program especially suited for scientific data representation. Gnuplot
  26. can be used to plot functions and data points in both two and three
  27. dimensions and in many different formats.
  28. Install gnuplot if you need a graphics package for scientific data
  29. representation.
  30. %description -l ja
  31. Gnuplotはとりわけ科学データ・プレゼンテーションに適した、コマンド
  32. 操作によるインタラクティブな関数プロット・プログラムです。
  33. Gnuplotは関数や座標データを同時にプロットしたり、3次元化やさまざ
  34. まな形式で表現するのに利用することができます。
  35. 科学データプレゼンテーション用のグラフィック・パッケージが必要な
  36. 場合、gnuplotをインストールしてください。
  37. %prep
  38. %setup -q
  39. %build
  40. autoreconf -f -i
  41. %ifarch alpha
  42. %define optflags -O0
  43. %endif
  44. %configure --with-readline=gnu --with-png --without-linux-vga --enable-history-file
  45. make %{?_smp_mflags}
  46. %install
  47. rm -rf $RPM_BUILD_ROOT
  48. make install DESTDIR=$RPM_BUILD_ROOT
  49. rm -f demo/Makefile* tutorial/Makefile*
  50. # move app-dafaults to %%_datadir
  51. mv $RPM_BUILD_ROOT%{_libdir}/X11 $RPM_BUILD_ROOT%{_datadir}/
  52. # move texmf config
  53. mv $RPM_BUILD_ROOT%{_datadir}/texmf-local $RPM_BUILD_ROOT%{_datadir}/texmf
  54. # remove unneeded files
  55. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  56. %clean
  57. rm -rf $RPM_BUILD_ROOT
  58. %post
  59. /sbin/install-info --quiet --info-dir=%{_infodir} %{_infodir}/gnuplot.info.gz
  60. %preun
  61. if [ $1 = 0 ]; then
  62. /sbin/install-info --quiet --info-dir=%{_infodir} --delete %{_infodir}/gnuplot.info.gz
  63. fi
  64. %files
  65. %defattr(-,root,root)
  66. %doc demo tutorial
  67. %doc README README.1ST README.exp INSTALL Copyright TODO
  68. %doc PATCHLEVEL VERSION BUGS ChangeLog FAQ
  69. %{_bindir}/gnuplot
  70. %{_libexecdir}/gnuplot/%{gpmainver}/*
  71. %{_datadir}/gnuplot/%{gpmainver}/*
  72. %{_datadir}/X11/app-defaults/Gnuplot
  73. %{_datadir}/texmf/tex/latex/gnuplot
  74. %{_datadir}/emacs/site-lisp/*
  75. %{_infodir}/gnuplot.info*
  76. %{_mandir}/man1/gnuplot.*
  77. %changelog
  78. * Sun May 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.5-1
  79. - update to gnuplot-4.2.5
  80. - drop plus patch (merged in upstream)
  81. - update URL: to new upstream homepage
  82. - fix License:
  83. - build with wxGTK
  84. - add BR: libX11-devel, libXt-devel, wx-gtk2-devel
  85. * Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 4.0.0-1vl5
  86. - applied new versioning policy, spec in utf-8
  87. * Tue Aug 22 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.0.0-0vl6
  88. - add BuildRequires: texinfo, emacsen
  89. * Sun Mar 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.0.0-0vl5
  90. - rebuild with readline-5.1
  91. * Wed Jun 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.0-0vl4
  92. - update Patch0 to fix 'Invalid char in eps file'
  93. (thanks to HANAWA Toshihiro)
  94. - add BuildRequires: autoconf, automake
  95. * Sat Nov 20 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.0-0vl2
  96. - enabled history-file
  97. * Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.0-0vl1
  98. - source update
  99. * Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.8k.3-0vl1
  100. - source update
  101. - patch update and modified
  102. - add info
  103. * Wed Mar 10 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.7.3-2vl3
  104. - rebuild
  105. - fix license
  106. - remove -DUSE_SYSTEM_TIME ([VinePlus:01805])
  107. * Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.7.3-2vl2
  108. - rebuild with readline-4.3
  109. * Thu Feb 20 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.7.3-2vl1
  110. - syncd with RH 3.7.3-2
  111. - modified Yamaga-san's gnuplot3.7.2+1.2.0rc2.patch for 3.7.3
  112. * Fri Jan 25 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 16vl1
  113. - added pathes (patch1,2) from RH
  114. * Sat Aug 25 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 12vl1
  115. - syncd rawhide
  116. - updated to 3.7.1-1.2.0
  117. * Mon Jun 5 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  118. - updated to 3.7.1
  119. - updated gnuplot+ patch to 1.1.9 for gnuplot 3.7.1.
  120. - remake SPEC from rawhide.
  121. * Fri May 19 2000 Nalin Dahyabhai <nalin@redhat.com>
  122. - rebuild with new gd, changing gif terminal to jpeg terminal (release 7)
  123. * Mon May 08 2000 Preston Brown <pbrown@redhat.com>
  124. - build for 7.0
  125. * Thu Apr 6 2000 Bill Nottingham <notting@redhat.com>
  126. - use gnu readline, not built-in version
  127. * Mon Apr 3 2000 Bill Nottingham <notting@redhat.com>
  128. - add latex tutorial, demo files, other docs (#10508)
  129. * Wed Mar 1 2000 Bill Nottingham <notting@redhat.com>
  130. - update to 3.7.1. Oops.
  131. * Thu Feb 3 2000 Bill Nottingham <notting@redhat.com>
  132. - handle compressed man pages
  133. * Thu Nov 4 1999 Bill Nottingham <notting@redhat.com>
  134. - update to 3.7.1
  135. * Mon Oct 11 1999 Bill Nottingham <notting@redhat.com>
  136. - ship some docs.
  137. * Wed Aug 18 1999 Bill Nottingham <notting@redhat.com>
  138. - add a patch to fix postscript output from Bernd Kischnick
  139. (kisch@die-herrmanns.de)
  140. * Fri Jul 30 1999 Bill Nottingham <notting@redhat.com>
  141. - fix license
  142. * Thu Jul 15 1999 Bill Nottingham <notting@redhat.com>
  143. - rebuild without svgalib
  144. * Tue Jun 15 1999 Bill Nottingham <notting@redhat.com>
  145. - update to 3.7.0.1
  146. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  147. - auto rebuild in the new build environment (release 2)
  148. * Tue Feb 2 1999 Jeff Johnson <jbj@redhat.com>
  149. - update to 3.7.
  150. * Thu Dec 17 1998 Michael Maher <mike@redhat.com>
  151. - built package for 6.0
  152. * Fri Sep 11 1998 Jeff Johnson <jbj@redhat.com>
  153. - update to 2.6beta347
  154. * Sat Aug 15 1998 Jeff Johnson <jbj@redhat.com>
  155. - build root
  156. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  157. - translations modified for de, fr, tr
  158. * Mon Oct 20 1997 Donnie Barnes <djb@redhat.com>
  159. - spec file cleanups
  160. * Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
  161. - built against glibc