flex-vl.spec 6.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200
  1. Summary: A tool for creating scanners (text pattern recognizers).
  2. Summary(ja): スキャナ (テキストパターン認識器) 作成ツール
  3. Name: flex
  4. Version: 2.5.35
  5. Release: 3%{?_dist_release}
  6. Group: Development/Tools
  7. License: BSD
  8. URL: http://flex.sourceforge.net/
  9. Source: flex-%{version}.tar.bz2
  10. Patch0: flex-2.5.35-sign.patch
  11. Patch1: flex-2.5.35-hardening.patch
  12. Patch2: flex-2.5.35-gcc44.patch
  13. Patch3: flex-2.5.35-missing-prototypes.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: gettext bison m4
  16. Requires: m4
  17. Requires(post): /sbin/install-info
  18. Requires(preun): /sbin/install-info
  19. %description
  20. The flex program generates scanners. Scanners are programs which can
  21. recognize lexical patterns in text. Flex takes pairs of regular
  22. expressions and C code as input and generates a C source file as
  23. output. The output file is compiled and linked with a library to
  24. produce an executable. The executable searches through its input for
  25. occurrences of the regular expressions. When a match is found, it
  26. executes the corresponding C code. Flex was designed to work with
  27. both Yacc and Bison, and is used by many programs as part of their
  28. build process.
  29. You should install flex if you are going to use your system for
  30. application development.
  31. %description -l ja
  32. flex はスキャナを生成するプログラムです.スキャナとは,
  33. テキストの語彙を認識するプログラムです.flex は正規表現と
  34. C のコードを入力とし,C のソースファイルを出力します.
  35. 出力されたファイルはコンパイルされ,ライブラリとリンクされて
  36. 実行ファイルが作られます.この実行ファイルは入力を調べ,正規表現に
  37. マッチするものがないか探します.もしマッチするものが見付かれば,
  38. 対応する C コードが実行されます.flex は yacc と bison と共に
  39. 動作する様設計されており,多くのプログラムを作成する際に使われます.
  40. アプリケーション開発を行う場合は flex をインストールして下さい.
  41. %prep
  42. %setup -q
  43. %patch0 -p1
  44. %patch1 -p1
  45. %patch2 -p1
  46. %patch3 -p1
  47. %build
  48. %configure --disable-dependency-tracking CFLAGS="-fPIC $RPM_OPT_FLAGS"
  49. make %{?_smp_mflags}
  50. %install
  51. rm -rf $RPM_BUILD_ROOT
  52. make DESTDIR=$RPM_BUILD_ROOT install
  53. rm -f $RPM_BUILD_ROOT/%{_infodir}/dir
  54. ( cd ${RPM_BUILD_ROOT}
  55. strip .%{_bindir}/flex
  56. ln -sf flex .%{_bindir}/lex
  57. ln -s flex.1 .%{_mandir}/man1/lex.1
  58. ln -s flex.1 .%{_mandir}/man1/flex++.1
  59. ln -s libfl.a .%{_libdir}/libl.a
  60. )
  61. %find_lang %{name}
  62. %check
  63. echo ============TESTING===============
  64. make check
  65. echo ============END TESTING===========
  66. %clean
  67. rm -rf $RPM_BUILD_ROOT
  68. %post
  69. /sbin/install-info %{_infodir}/flex.info.gz --dir-file=%{_infodir}/dir ||:
  70. %preun
  71. if [ $1 = 0 ]; then
  72. /sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir ||:
  73. fi
  74. %files -f %{name}.lang
  75. %defattr(-,root,root)
  76. %doc COPYING NEWS README
  77. %{_bindir}/*
  78. %{_mandir}/man1/*
  79. %{_libdir}/*.a
  80. %{_includedir}/FlexLexer.h
  81. %{_infodir}/flex.info*
  82. %changelog
  83. * Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.35-3
  84. - rebuilt with current VineSeed
  85. - inserted the "-fPIC" on configure command-line and dropt the -fPIC patch.
  86. - removed BR: info
  87. - added Patch0-3 from Fedora
  88. * Tue Jul 13 2010 Petr Machata <pmachata@redhat.com> - 2.5.35-10
  89. - Declare yyget_column and yyset_column in reentrant mode.
  90. - Resolves: #612465
  91. * Mon Apr 20 2009 Debarshi Ray <rishi@fedoraproject.org> - 2.5.35-5
  92. - Resolves: #496548.
  93. * Mon Apr 20 2009 Petr Machata <pmachata@redhat.com> - 2.5.35-4
  94. - Get rid of warning caused by ignoring return value of fwrite() in
  95. ECHO macro. Debian patch.
  96. - Resolves: #484961
  97. * Mon May 12 2008 Petr Machata <pmachata@redhat.com> - 2.5.35-2
  98. - Resolves: #445950
  99. * Wed Apr 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.35-2
  100. - spec in utf-8
  101. * Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.35-1
  102. - new upstream release
  103. - updated Patch0, dropped Patch1
  104. * Tue Nov 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.33-5vl1
  105. - rebuilt with new toolchains
  106. - updated to 2.5.33 based on Fedora packages
  107. * Fri Mar 30 2007 Petr Machata <pmachata@redhat.com> - 2.5.33-5
  108. - Make yy-prefixed variables available to scanner even with -P.
  109. * Fri Feb 2 2007 Petr Machata <pmachata@redhat.com> - 2.5.33-4
  110. - Use %%find_lang to package locale files.
  111. * Wed Jan 31 2007 Petr Machata <pmachata@redhat.com> - 2.5.33-3
  112. - Compile with -fPIC.
  113. * Fri Jan 19 2007 Petr Machata <pmachata@redhat.com> - 2.5.33-1
  114. - Rebase to 2.5.33
  115. * Sat Jan 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.4a-30vl2
  116. - rebuild with gcc 3.3.6
  117. * Sun Jul 6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.4a-30vl1
  118. - rebuild with new toolchains
  119. - based on Redhat Rawhide 2.5.4-30
  120. - Mon Nov 4 2002 Than Ngo <than@redhat.com> 2.5.4a-27
  121. - YY_NO_INPUT patch from Jean Marie
  122. - Tue Apr 2 2002 Than Ngo <than@redhat.com> 2.5.4a-23
  123. - More ISO C++ 98 fixes (#59670)
  124. - Wed Feb 20 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.5.4a-21
  125. - More ISO C++ 98 fixes (#59670)
  126. - s/Copyright/License/
  127. * Mon Feb 12 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  128. - 2.5.4a-13vl1
  129. - based on 2.5.4a-13 from Rawhide
  130. - use better macros (%%{_tmppath})
  131. - added Japanese summary and description
  132. * Sat Sep 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  133. - Fix generation of broken code (conflicting isatty() prototype w/ glibc 2.2)
  134. This broke, among other things, the kdelibs 2.0 build
  135. - Fix source URL
  136. * Thu Sep 7 2000 Jeff Johnson <jbj@redhat.com>
  137. - FHS packaging (64bit systems need to use libdir).
  138. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  139. - automatic rebuild
  140. * Tue Jun 6 2000 Bill Nottingham <notting@redhat.com>
  141. - rebuild, FHS stuff.
  142. * Thu Feb 3 2000 Bill Nottingham <notting@redhat.com>
  143. - handle compressed man pages
  144. * Fri Jan 28 2000 Bill Nottingham <notting@redhat.com>
  145. - add a libl.a link to libfl.a
  146. * Wed Aug 25 1999 Jeff Johnson <jbj@redhat.com>
  147. - avoid uninitialized variable warning (Erez Zadok).
  148. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  149. - auto rebuild in the new build environment (release 6)
  150. * Fri Dec 18 1998 Bill Nottingham <notting@redhat.com>
  151. - build for 6.0 tree
  152. * Mon Aug 10 1998 Jeff Johnson <jbj@redhat.com>
  153. - build root
  154. * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
  155. - translations modified for de, fr, tr
  156. * Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
  157. - updated from 2.5.4 to 2.5.4a
  158. * Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
  159. - built against glibc
  160. * Thu Mar 20 1997 Michael Fulbright <msf@redhat.com>
  161. - Updated to v. 2.5.4