123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266 |
- # Copyright (c) 2000-2005, JPackage Project
- # All rights reserved.
- #
- # Redistribution and use in source and binary forms, with or without
- # modification, are permitted provided that the following conditions
- # are met:
- #
- # 1. Redistributions of source code must retain the above copyright
- # notice, this list of conditions and the following disclaimer.
- # 2. Redistributions in binary form must reproduce the above copyright
- # notice, this list of conditions and the following disclaimer in the
- # documentation and/or other materials provided with the
- # distribution.
- # 3. Neither the name of the JPackage Project nor the names of its
- # contributors may be used to endorse or promote products derived
- # from this software without specific prior written permission.
- #
- # THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
- # "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
- # LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
- # A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
- # OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
- # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
- # LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
- # DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
- # THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
- # (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
- # OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- #
- %define _with_gcj_support 1
- %define gcj_support %{?_with_gcj_support:1}%{!?_with_gcj_support:%{?_without_gcj_support:0}%{!?_without_gcj_support:%{?_gcj_support:%{_gcj_support}}%{!?_gcj_support:0}}}
- Name: junit
- Summary: Java regression test package
- Version: 3.8.2
- Release: 7%{?dist}
- License: CPL
- URL: http://www.junit.org/
- Group: Development/Tools
- # http://osdn.dl.sourceforge.net/junit/junit3.8.2.zip
- Source0: junit3.8.2.zip
- Source1: junit3.8.2-build.xml
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- BuildRequires: ant
- BuildRequires: jpackage-utils >= 0:1.6
- %if ! %{gcj_support}
- Buildarch: noarch
- %endif
- %if %{gcj_support}
- BuildRequires: java-gcj-compat-devel
- Requires(post): java-gcj-compat
- Requires(postun): java-gcj-compat
- %endif
- %description
- JUnit is a regression testing framework written by Erich Gamma and Kent
- Beck. It is used by the developer who implements unit tests in Java.
- JUnit is Open Source Software, released under the IBM Public License and
- hosted on SourceForge.
- %package manual
- Group: Documentation
- Summary: Manual for %{name}
- %description manual
- Documentation for %{name}.
- #%package javadoc
- #Group: Documentation
- #Summary: Javadoc for %{name}
- #
- #%description javadoc
- #Javadoc for %{name}.
- %package demo
- Group: Development/Libraries
- Summary: Demos for %{name}
- Requires: %{name} = %{version}-%{release}
- %if %{gcj_support}
- BuildRequires: java-gcj-compat-devel
- Requires(post): java-gcj-compat
- Requires(postun): java-gcj-compat
- %endif
- %description demo
- Demonstrations and samples for %{name}.
- %prep
- %setup -q -n %{name}%{version}
- # extract sources
- #jar xf src.jar
- #rm -f src.jar
- #cp %{SOURCE1} build.xml
- %build
- #ant dist
- %install
- rm -rf $RPM_BUILD_ROOT
- # jars
- install -d -m 755 $RPM_BUILD_ROOT%{_javadir}
- install -m 644 %{name}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}-%{version}.jar
- (cd $RPM_BUILD_ROOT%{_javadir} && for jar in *-%{version}*; do ln -sf ${jar} ${jar/-%{version}/}; done)
- # javadoc
- #install -d -m 755 $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
- #cp -pr %{name}%{version}/javadoc/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
- # demo
- install -d -m 755 $RPM_BUILD_ROOT%{_datadir}/%{name}/demo/junit # Not using %name for last part because it is
- # part of package name
- cp -pr %{name}/* $RPM_BUILD_ROOT%{_datadir}/%{name}/demo/junit
- %if %{gcj_support}
- rm -rf aot-compile-rpm
- # these --exclude options work around an aot-compile-rpm problem with test.jar
- %{_bindir}/aot-compile-rpm --exclude usr/share/junit/demo --exclude usr/share/junit/demo/junit/tests/runner/test.jar
- %endif
- #ln -s %{name}-%{version} $RPM_BUILD_ROOT%{_javadocdir}/%{name}
- %clean
- rm -rf $RPM_BUILD_ROOT
- %post
- %if %{gcj_support}
- if [ -x %{_bindir}/rebuild-gcj-db ]
- then
- %{_bindir}/rebuild-gcj-db
- fi
- %endif
- %postun
- %if %{gcj_support}
- if [ -x %{_bindir}/rebuild-gcj-db ]
- then
- %{_bindir}/rebuild-gcj-db
- fi
- %endif
- %files
- %defattr(0644,root,root,0755)
- %doc README.html
- %{_javadir}/*
- %if %{gcj_support}
- %dir %{_libdir}/gcj/%{name}
- %attr(-,root,root) %{_libdir}/gcj/%{name}/junit-3.8.2.jar.*
- %endif
- %files manual
- %defattr(0644,root,root,0755)
- %doc doc/*
- #files javadoc
- #defattr(0644,root,root,0755)
- #doc %{_javadocdir}/%{name}-%{version}
- #doc %{_javadocdir}/%{name}
- %files demo
- %defattr(0644,root,root,0755)
- %{_datadir}/%{name}
- %changelog
- * Wed Sep 1 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.8.2-7
- - Initial build for Vine Linux
- * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.8.2-6.4
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
- * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.8.2-5.4
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
- * Wed Jul 9 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 3.8.2-4.4
- - drop repotag
- * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 3.8.2-4jpp.3
- - Autorebuild for GCC 4.3
- * Thu Sep 20 2007 Deepak Bhole <dbhole@redhat.com> - 3.8.2-3jpp.3
- - Fix location of stylesheet for javadocs
- * Thu Sep 20 2007 Deepak Bhole <dbhole@redhat.com> - 3.8.2-3jpp.2
- - Rebuild for ppc32 execmem issue and new build-id
- * Mon Feb 12 2007 Thomas Fitzsimmons <fitzsim@redhat.com> - 3.8.2-3jpp.1.fc7
- - Add dist tag
- * Mon Feb 12 2007 Thomas Fitzsimmons <fitzsim@redhat.com> - 3.8.2-3jpp.1
- - Committed on behalf of Tania Bento <tbento@redhat.com>
- - Update per Fedora review process
- - Resolves rhbz#225954
- * Thu Aug 10 2006 Deepak Bhole <dbhole@redhat.com> - 0:3.8.2-3jpp.1
- - Added missing requirements.
- * Thu Aug 10 2006 Karsten Hopp <karsten@redhat.de> 0:3.8.2-2jpp_3fc
- - Require(post/postun): coreutils
- * Sun Jun 23 2006 Deepak Bhole <dbhole@redhat.com> - 0:3.8.2-2jpp_2fc
- - Rebuilt.
- * Sat Jun 22 2006 Deepak Bhole <dbhole@redhat.com> - 0:3.8.2-2jpp_1fc
- - Upgrade to 3.8.2
- - Added conditional native compilation.
- - Fix path where demo is located.
- * Mon Mar 03 2006 Ralph Apel <r.apel at r-apel.de> - 0:3.8.2-1jpp
- - First JPP-1.7 release
- * Sun Aug 23 2004 Randy Watler <rwatler at finali.com> - 0:3.8.1-4jpp
- - Rebuild with ant-1.6.2
- * Fri May 09 2003 David Walluck <david@anti-microsoft.org> 0:3.8.1-3jpp
- - update for JPackage 1.5
- * Fri Mar 21 2003 Nicolas Mailhot <Nicolas.Mailhot (at) JPackage.org> 3.8.1-2jpp
- - For jpackage-utils 1.5
- * Fri Sep 06 2002 Henri Gomez <hgomez@users.sourceforge.net> 3.8.1-1jpp
- - 3.8.1
- * Sun Sep 01 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 3.8-2jpp
- - used original zip file
- * Thu Aug 29 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 3.8-1jpp
- - 3.8
- - group, vendor and distribution tags
- * Sat Jan 19 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 3.7-6jpp
- - versioned dir for javadoc
- - no dependencies for manual and javadoc packages
- - stricter dependency for demo package
- - additional sources in individual archives
- - section macro
- * Sat Dec 1 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 3.7-5jpp
- - javadoc in javadoc package
- * Wed Nov 21 2001 Christian Zoffoli <czoffoli@littlepenguin.org> 3.7-4jpp
- - fixed previous releases ...grrr
- * Wed Nov 21 2001 Christian Zoffoli <czoffoli@littlepenguin.org> 3.7-3jpp
- - added jpp extension
- - removed packager tag
- * Sun Sep 30 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 3.7-2jpp
- - first unified release
- - s/jPackage/JPackage
- * Mon Sep 17 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 3.7-1mdk
- - 3.7
- - vendor tag
- - packager tag
- - s/Copyright/License/
- - truncated description to 72 columns in spec
- - spec cleanup
- - used versioned jar
- - moved demo files to %%{_datadir}/%%{name}
- * Sat Feb 17 2001 Guillaume Rousse <g.rousse@linux-mandrake.com> 3.5-1mdk
- - first Mandrake release
|