123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238 |
- %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
- Name: jasper
- Summary: implementation of the JPEG-2000 standard, Part 1
- Version: 1.900.1
- Release: 10%{?_dist_release}
- Group: Applications/Graphics
- License: Modified BSD (see LICENSE)
- URL: http://www.ece.uvic.ca/~mdadams/jasper/
- Source: %{name}-%{version}.zip
- Patch1: jasper-1.701.0-GL.patch
- # autoconf/automake bits of patch1
- Patch2: jasper-1.701.0-GL-ac.patch
- # CVE-2007-2721 (bug #240397)
- # borrowed from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=413041;msg=88
- Patch3: patch-libjasper-stepsizes-overflow.diff
- # borrowed from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=469786
- Patch4: jpc_dec.c.patch
- # OpenBSD hardening patches addressing couple of possible integer overflows
- # during the memory allocations
- # https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2008-3520
- Patch5: jasper-1.900.1-CVE-2008-3520.patch
- # https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2008-3522
- Patch6: jasper-1.900.1-CVE-2008-3522.patch
- # add pkg-config support
- Patch7: jasper-pkgconfig.patch
- Patch8: jasper-1.900.1-CVE-2011-4516-CVE-2011-4517-CERT-VU-887409.patch
- Patch9: jasper-CVE-2014-9029.patch
- Patch10: jasper-CVE-2014-8137.patch
- Patch11: jasper-CVE-2014-8138.patch
- # Issues found by static analysis of code
- Patch110: jasper-1.900.1-Coverity-BAD_SIZEOF.patch
- Patch111: jasper-1.900.1-Coverity-CHECKED_RETURN.patch
- Patch112: jasper-1.900.1-Coverity-FORWARD_NULL.patch
- Patch113: jasper-1.900.1-Coverity-NULL_RETURNS.patch
- Patch114: jasper-1.900.1-Coverity-RESOURCE_LEAK.patch
- Patch115: jasper-1.900.1-Coverity-UNREACHABLE.patch
- Patch116: jasper-1.900.1-Coverity-UNUSED_VALUE.patch
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- BuildRequires: autoconf automake libtool
- BuildRequires: freeglut-devel
- BuildRequires: libGLU-devel
- BuildRequires: libjpeg-devel
- BuildRequires: pkgconfig
- Requires: %{name}-libs = %{version}-%{release}
- Vendor: Project Vine
- Distribution: Vine Linux
- %description
- JasPer is a collection of software (i.e., a library and application
- programs) for the coding and manipulation of images. This software
- can handle image data in a variety of formats. One such format
- supported by JasPer is the JPEG-2000 format defined in ISO/IEC 15444-1.
- %package devel
- Summary: Include Files and Documentation for jasper
- Group: Development/Libraries
- Requires: %{name}-libs = %{version}-%{release}
- Requires: libjpeg-devel
- %description devel
- This package contains libjasper, a library implementing the JPEG-2000
- image compression standard Part 1.
- %package libs
- Summary: Runtime libraries for %{name}
- Group: System Environment/Libraries
- %description libs
- This package contains runtime libraries for JasPer.
- # compat32
- %package -n compat32-%{name}-devel
- Summary: Include Files and Documentation for jasper
- Group: Development/Libraries
- Requires: %{name}-libs = %{version}-%{release}
- Requires: compat32-libjpeg-devel
- %description -n compat32-%{name}-devel
- This package contains libjasper, a library implementing the JPEG-2000
- image compression standard Part 1.
- %package -n compat32-%{name}-libs
- Summary: Runtime libraries for %{name}
- Group: System Environment/Libraries
- %description -n compat32-%{name}-libs
- This package contains runtime libraries for JasPer.
- %prep
- %setup -q -n %{name}-%{version}
- %patch1 -p1 -b .GL
- %patch2 -p1 -b .GL-ac
- %patch3 -p1 -b .CVE-2007-2721
- %patch4 -p1 -b .jpc_dec_assertion
- %patch5 -p1 -b .CVE-2008-3520
- %patch6 -p1 -b .CVE-2008-3522
- %patch7 -p1 -b .pkgconfig
- %patch8 -p1 -b .CVE-2011-4516-4517
- %patch9 -p1 -b .CVE-2014-9029
- %patch10 -p1 -b .CVE-2014-8137-variant2
- %patch11 -p1 -b .CVE-2014-8138
- %patch110 -p1 -b .BAD_SIZEOF
- %patch111 -p1 -b .CHECKED_RETURN
- %patch112 -p1 -b .FORWARD_NULL
- %patch113 -p1 -b .NULL_RETURNS
- %patch114 -p1 -b .RESOURCE_LEAK
- %patch115 -p1 -b .UNREACHABLE
- %patch116 -p1 -b .UNUSED_VALUE
- autoreconf --verbose --force --install
- %build
- CFLAGS="%{optflags} -fno-strict-overflow" \
- %configure --enable-shared --disable-static
- make %{?_smp_mflags}
- %install
- [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
- make install DESTDIR=$RPM_BUILD_ROOT
- # remove .la
- rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
- %clean
- [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
- %post libs -p /sbin/ldconfig
- %postun libs -p /sbin/ldconfig
- %post -n compat32-%{name}-libs -p /sbin/ldconfig
- %postun -n compat32-%{name}-libs -p /sbin/ldconfig
- %files
- %defattr(-,root,root)
- %doc COPYRIGHT ChangeLog INSTALL LICENSE NEWS README doc
- %{_bindir}/*
- %{_mandir}/man1/*
- %files libs
- %defattr(-,root,root)
- %{_libdir}/libjasper*.so.*
- %files devel
- %defattr(-,root,root)
- %{_includedir}/jasper
- %{_libdir}/libjasper*.so
- %{_libdir}/pkgconfig/jasper.pc
- # compat32
- %if %{build_compat32}
- %files -n compat32-%{name}-libs
- %defattr(-,root,root)
- %{_libdir}/libjasper*.so.*
- %files -n compat32-%{name}-devel
- %defattr(-,root,root)
- %{_libdir}/libjasper*.so
- %{_libdir}/pkgconfig/jasper.pc
- %endif
- %changelog
- * Wed Dec 24 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.900.1-10
- - imported all patches from RawHide.
- * Tue Jul 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.900.1-9
- - rebuild with libpng-1.6.12
- * Thu Apr 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-8
- - rebuilt with current VineSeed
- * Sat May 02 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.900.1-7
- - added compat32 subpackage for x86_64 arch support.
- * Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.900.1-6
- - splited out runtime library to sub package
- - enable opengl again, add BuildRequires: freeglut-devel
- * Wed Jun 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.900.1-5
- - remove .la
- - add --disable-static to configure option
- * Sun Jun 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-0vl4
- - added Patch0 from VinePlus/4.0
- * Thu Jun 21 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.900.1-0vl2.1
- - add patch100 for fix CVE-2007-2721
- - add Vendor/Distributin Tag
- * Fri May 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.900.1-0vl3
- - remove BuildPrereq: freeglut-devel and Requires freeglut
- - add --disable-opengl to configure option
- * Fri Mar 16 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.900.1-0vl2
- - add BuildPreReq: unzip (used in the %%pre section)
- * Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-0vl1
- - new upstream release
- * Tue Jan 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.0-0vl1
- - new upstream release
- - changed Group to System Environment/Libraries
- - added --mandir=%{_mandir}
- - added %post and %postun section
- * Thu Sep 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.701.0-0vl3
- - added --libdir=%{_libdir} configure option
- * Tue Sep 5 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.701.0-0vl2
- - build with freeglut
- - change BuildPrereq and Requires
- * Tue Dec 14 2004 Satoshi MACHINO <machino@vinelinux.org> 1.701.0-0vl1
- - new upstream version (jasper-1.701.0)
- * Sat Nov 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.700.5-0vl2
- - rebuild for VineSeedPlus
- * Sat Nov 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.700.5-0vl1
- - source upgrade
- - change spec to build for VineLinux
- * Fri Oct 25 2002 Alexander D. Karaivanov <adk@medical-insight.com>
- - spec file created
|