libatomic_ops-vl.spec 6.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: libatomic_ops
  3. Summary: Atomic memory update operations
  4. Version: 7.6.10
  5. Release: 1%{?_dist_release}
  6. # libatomic_ops MIT, libatomic_ops_gpl GPLv2
  7. License: GPLv2 and MIT
  8. URL: https://www.hboehm.info/gc/
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. Source0: https://www.hboehm.info/gc/gc_source/libatomic_ops-%{version}.tar.gz
  12. # updated GPLv2 license text
  13. Source1: http://www.gnu.org/licenses/old-licenses/gpl-2.0.txt
  14. %description
  15. Provides implementations for atomic memory update operations on a
  16. number of architectures. This allows direct use of these in reasonably
  17. portable code. Unlike earlier similar packages, this one explicitly
  18. considers memory barrier semantics, and allows the construction of code
  19. that involves minimum overhead across a variety of architectures.
  20. %package devel
  21. Summary: Development files for %{name}
  22. Requires: %{name}%{?_isa} = %{version}-%{release}
  23. %description devel
  24. Files for developing with %{name}.
  25. %package static
  26. Summary: Static library files for %{name}
  27. Requires: %{name}-devel%{?_isa} = %{version}-%{release}
  28. %description static
  29. Files for developing with %{name} and linking statically.
  30. %package -n compat32-%{name}
  31. Summary: Atomic memory update operations
  32. Group: System Environment/Libraries
  33. Requires: %{name} = %{version}-%{release}
  34. %description -n compat32-%{name}
  35. Provides implementations for atomic memory update operations on a
  36. number of architectures. This allows direct use of these in reasonably
  37. portable code. Unlike earlier similar packages, this one explicitly
  38. considers memory barrier semantics, and allows the construction of code
  39. that involves minimum overhead across a variety of architectures.
  40. %package -n compat32-%{name}-devel
  41. Summary: Development files for %{name}
  42. Group: Development/Libraries
  43. Requires: compat32-%{name} = %{version}-%{release}
  44. Requires: %{name}-devel = %{version}-%{release}
  45. %description -n compat32-%{name}-devel
  46. Files for developing with %{name}.
  47. %prep
  48. %autosetup -p1
  49. install -m644 -p %{SOURCE1} ./COPYING
  50. %build
  51. %configure \
  52. --enable-shared \
  53. --disable-silent-rules
  54. make %{?_smp_mflags}
  55. %install
  56. make install DESTDIR=%{buildroot}
  57. ## unpackaged files
  58. rm -fv %{buildroot}%{_libdir}/lib*.la
  59. # omit dup'd docs
  60. rm -fv %{buildroot}%{_datadir}/libatomic_ops/{COPYING,README*,*.txt}
  61. rm -rf %{buildroot}%{_docdir}/libatomic_ops
  62. %check
  63. ## ignore failures on powerpc, atomic stack feature not working (#883748)
  64. #ifarch ppc ppc64 ppc64le aarch64
  65. #global arch_ignore ||:
  66. #endif
  67. make check %{?arch_ignore}
  68. %post -p /sbin/ldconfig
  69. %postun -p /sbin/ldconfig
  70. %files
  71. %license COPYING doc/LICENSING.txt
  72. %doc AUTHORS ChangeLog README.md
  73. %{_libdir}/libatomic_ops.so.1*
  74. %{_libdir}/libatomic_ops_gpl.so.1*
  75. %files devel
  76. %doc doc/README*
  77. %{_includedir}/atomic_ops.h
  78. %{_includedir}/atomic_ops_malloc.h
  79. %{_includedir}/atomic_ops_stack.h
  80. %{_includedir}/atomic_ops/
  81. %{_libdir}/libatomic_ops.so
  82. %{_libdir}/libatomic_ops_gpl.so
  83. %{_libdir}/pkgconfig/atomic_ops.pc
  84. %files static
  85. %{_libdir}/libatomic_ops.a
  86. %{_libdir}/libatomic_ops_gpl.a
  87. %if %{build_compat32}
  88. %files -n compat32-%{name}
  89. %defattr(-,root,root)
  90. %{_libdir}/libatomic_ops.so.1*
  91. %{_libdir}/libatomic_ops_gpl.so.1*
  92. %files -n compat32-%{name}-devel
  93. %defattr(-,root,root)
  94. %{_libdir}/libatomic_ops.so
  95. %{_libdir}/libatomic_ops_gpl.so
  96. %{_libdir}/pkgconfig/atomic_ops.pc
  97. %endif
  98. %changelog
  99. * Tue Sep 10 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 7.6.10-1
  100. - new upstream release.
  101. - dropped all patches.
  102. * Sat Jul 2 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 7.4.4-4
  103. - added compat32 packages.
  104. * Sat Jul 2 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 7.4.4-3
  105. - fixed %%changelog.
  106. * Fri Jul 1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 7.4.4-2
  107. - imported all stuff from rawhide.
  108. * Fri Jun 17 2016 Rex Dieter <rdieter@fedoraproject.org> - 7.4.4-1
  109. - libatomic_ops-7.4.4 (#1346524)
  110. * Mon Mar 28 2016 Rex Dieter <rdieter@fedoraproject.org> 7.4.2-9
  111. - make check fails on test_stack for ppc64le arch (#1096574), drop reference to 0032.patch
  112. * Mon Mar 28 2016 Rex Dieter <rdieter@fedoraproject.org> - 7.4.2-8
  113. - pull in upstream (7.4 branch) fixes
  114. - Add support for 64-bit MIPS (#1317509)
  115. - use %%license
  116. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 7.4.2-7
  117. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  118. * Tue Jul 7 2015 Peter Robinson <pbrobinson@fedoraproject.org> 7.4.2-6
  119. - Don't fail check on aarch64
  120. * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.4.2-5
  121. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  122. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.4.2-4
  123. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  124. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.4.2-3
  125. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  126. * Tue May 13 2014 Rex Dieter <rdieter@fedoraproject.org> 7.4.2-2
  127. - link libatomic_ops_gpl against libatomic_ops for missing symbol(s)
  128. * Tue May 13 2014 Rex Dieter <rdieter@fedoraproject.org> 7.4.2-1
  129. - libatomic_opts-7.4.2
  130. - new upstream/source URLs
  131. - %%check: skip ppc64le too
  132. - License: MIT and GPLv2
  133. - update/longer %%description
  134. - updated GPLv2 license text (with correct address)
  135. * Wed Dec 04 2013 Rex Dieter <rdieter@fedoraproject.org> 7.4.0-1
  136. - separate libatomic_ops lives again!
  137. * Fri Jul 24 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.2-8.gc
  138. - use gc tarball, tag gc release
  139. * Thu Jul 23 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.2-7
  140. - devel: Provides: %%name-static ...
  141. - consolidate %%doc's
  142. - %%files: track libs
  143. * Wed May 20 2009 Dan Horak <dan[t]danny.cz> - 1.2-6
  144. - added fix for s390
  145. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2-5
  146. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  147. * Thu May 22 2008 Jon Stanley <jonstanley@gmail.com> - 1.2-4
  148. - Fix license tag
  149. * Thu Jul 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-1
  150. - initial build for Vine Linux
  151. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2-3
  152. - Autorebuild for GCC 4.3
  153. * Tue May 29 2007 Pierre Ossman <drzeus@drzeus.cx> 1.2-2
  154. - Added fix for PPC AO_load_acquire.
  155. * Fri Nov 10 2006 Pierre Ossman <drzeus@drzeus.cx> 1.2-1
  156. - Update to 1.2.
  157. * Sat Sep 9 2006 Pierre Ossman <drzeus@drzeus.cx> 1.1-2
  158. - Fix naming of package.
  159. - General cleanup of spec file.
  160. * Wed Aug 30 2006 Pierre Ossman <drzeus@drzeus.cx> 1.1-1
  161. - Initial package for Fedora Extras.