wxGTK3-vl.spec 7.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229
  1. %global srcname wxWidgets
  2. %global wxgtkname wxGTK3
  3. %global wxbasename wxBase3
  4. %global gtkver 3
  5. Name: %{wxgtkname}
  6. Version: 3.0.2
  7. Release: 1%{?_dist_release}
  8. Summary: GTK port of the wxWidgets GUI library
  9. License: wxWidgets
  10. Group: System Environment/Libraries
  11. URL: http://www.wxwidgets.org/
  12. Source0: http://downloads.sf.net/wxwindows/%{srcname}-%{version}.tar.bz2
  13. ##Source1: http://downloads.sf.net/wxwindows/%{srcname}-%{version}-docs-html.tar.bz2
  14. Source10: wx-config
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: gtk%{gtkver}-devel
  17. #Note webkitgtk (GTK2) does not appear to be supported
  18. BuildRequires: WebKit3-gtk-devel
  19. BuildRequires: zlib-devel
  20. BuildRequires: libpng-devel
  21. BuildRequires: libjpeg-turbo-devel
  22. BuildRequires: libtiff-devel
  23. BuildRequires: expat-devel
  24. BuildRequires: SDL-devel
  25. BuildRequires: libgnomeprintui-devel
  26. BuildRequires: libGLU-devel
  27. BuildRequires: libSM-devel
  28. BuildRequires: gstreamer-plugins-base-devel
  29. BuildRequires: GConf2-devel
  30. BuildRequires: gettext
  31. BuildRequires: cppunit-devel
  32. BuildRequires: libmspack-devel
  33. Provides: %{srcname} = %{version}-%{release}
  34. Requires: %{wxbasename}%{?_isa} = %{version}-%{release}
  35. %description
  36. wxWidgets is the GTK port of the C++ cross-platform wxWidgets
  37. GUI library, offering classes for all common GUI controls as well as a
  38. comprehensive set of helper classes for most common application tasks,
  39. ranging from networking to HTML display and image manipulation.
  40. %package devel
  41. Group: Development/Libraries
  42. Summary: Development files for the wxGTK3 library
  43. Requires: %{name}%{?_isa} = %{version}-%{release}
  44. Requires: %{wxbasename} = %{version}-%{release}
  45. Requires: gtk%{gtkver}-devel
  46. Requires: libGLU-devel
  47. Provides: %{srcname}-devel = %{version}-%{release}
  48. %description devel
  49. This package include files needed to link with the wxGTK3 library.
  50. wxWidgets is the GTK port of the C++ cross-platform wxWidgets
  51. GUI library, offering classes for all common GUI controls as well as a
  52. comprehensive set of helper classes for most common application tasks,
  53. ranging from networking to HTML display and image manipulation.
  54. %package -n %{wxbasename}
  55. Summary: Non-GUI support classes from the wxWidgets library
  56. Group: System Environment/Libraries
  57. %description -n %{wxbasename}
  58. Every wxWidgets application must link against this library. It contains
  59. mandatory classes that any wxWidgets code depends on (like wxString) and
  60. portability classes that abstract differences between platforms. wxBase can
  61. be used to develop console mode applications -- it does not require any GUI
  62. libraries or the X Window System.
  63. #%package docs
  64. #Group: Development/Libraries
  65. #Summary: Documentation for the wxGTK3 library
  66. #Requires: %{name} = %{version}-%{release}
  67. #Provides: %{srcname}-docs = %{version}-%{release}
  68. #BuildArch: noarch
  69. #%description docs
  70. #This package provides documentation for the %{srcname} library.
  71. %prep
  72. %setup -q -n %{srcname}-%{version}
  73. # in case of gtk3
  74. %if %{gtkver} == 3
  75. sed -i -e 's|gtk2|gtk3|' %{SOURCE10}
  76. %endif
  77. # patch some installed files to avoid conflicts with 2.8.*
  78. sed -i -e 's|aclocal)|aclocal/wxwin3.m4)|' Makefile.in
  79. sed -i -e 's|wxstd.mo|wxstd3.mo|' Makefile.in
  80. sed -i -e 's|wxmsw.mo|wxmsw3.mo|' Makefile.in
  81. # rename docs directory
  82. #mv %{srcname}-%{version} html
  83. sed -i -e 's|/usr/lib\b|%{_libdir}|' wx-config.in configure
  84. # fix plugin dir for 64-bit
  85. sed -i -e 's|/lib|/%{_lib}|' src/unix/stdpaths.cpp
  86. %build
  87. # likely still dereferences type-punned pointers
  88. CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
  89. CXXFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
  90. # fix unused-direct-shlib-dependency error:
  91. export LDFLAGS="-Wl,--as-needed"
  92. %configure \
  93. --with-gtk=%{gtkver} \
  94. --with-opengl \
  95. --with-sdl \
  96. --with-gnomeprint \
  97. --with-libmspack \
  98. --enable-intl \
  99. --enable-no_deps \
  100. --disable-rpath \
  101. --enable-ipv6 \
  102. --enable-utf8 \
  103. make %{?_smp_mflags}
  104. %install
  105. %makeinstall
  106. # install our multilib-aware wrapper
  107. rm %{buildroot}%{_bindir}/wx-config
  108. rm %{buildroot}%{_bindir}/wxrc
  109. install -p -m 755 %{SOURCE10} %{buildroot}%{_bindir}/wx-config-3.0
  110. # move bakefiles to avoid conflicts with 2.8.*
  111. mkdir %{buildroot}%{_datadir}/bakefile/presets/wx3
  112. mv %{buildroot}%{_datadir}/bakefile/presets/*.* %{buildroot}%{_datadir}/bakefile/presets/wx3
  113. %find_lang wxstd3
  114. %find_lang wxmsw3
  115. cat wxmsw3.lang >> wxstd3.lang
  116. %check
  117. pushd tests
  118. make %{?_smp_mflags} test
  119. popd
  120. %post -p /sbin/ldconfig
  121. %postun -p /sbin/ldconfig
  122. %post -n %{wxbasename} -p /sbin/ldconfig
  123. %postun -n %{wxbasename} -p /sbin/ldconfig
  124. %files -f wxstd3.lang
  125. %doc docs/changes.txt docs/gpl.txt docs/lgpl.txt docs/licence.txt
  126. %doc docs/licendoc.txt docs/preamble.txt docs/readme.txt
  127. %{_libdir}/libwx_gtk%{gtkver}u_adv-*.so.*
  128. %{_libdir}/libwx_gtk%{gtkver}u_aui-*.so.*
  129. %{_libdir}/libwx_gtk%{gtkver}u_core-*.so.*
  130. %{_libdir}/libwx_gtk%{gtkver}u_html-*.so.*
  131. %{_libdir}/libwx_gtk%{gtkver}u_gl-*.so.*
  132. %{_libdir}/libwx_gtk%{gtkver}u_media-*.so.*
  133. %{_libdir}/libwx_gtk%{gtkver}u_propgrid-*.so.*
  134. %{_libdir}/libwx_gtk%{gtkver}u_qa-*.so.*
  135. %{_libdir}/libwx_gtk%{gtkver}u_ribbon-*.so.*
  136. %{_libdir}/libwx_gtk%{gtkver}u_richtext-*.so.*
  137. %{_libdir}/libwx_gtk%{gtkver}u_stc-*.so.*
  138. %if %{gtkver} == 3
  139. %{_libdir}/libwx_gtk%{gtkver}u_webview-*.so.*
  140. %endif
  141. %{_libdir}/libwx_gtk%{gtkver}u_xrc-*.so.*
  142. %files devel
  143. %{_bindir}/wx-config*
  144. %{_bindir}/wxrc-3.0
  145. %{_includedir}/wx-3.0
  146. %{_libdir}/libwx_*.so
  147. %{_libdir}/wx
  148. %{_datadir}/aclocal/wxwin3.m4
  149. %{_datadir}/bakefile/presets/wx3/
  150. %files -n %{wxbasename}
  151. %doc docs/changes.txt docs/gpl.txt docs/lgpl.txt docs/licence.txt
  152. %doc docs/licendoc.txt docs/preamble.txt docs/readme.txt
  153. %{_libdir}/libwx_baseu-*.so.*
  154. %{_libdir}/libwx_baseu_net-*.so.*
  155. %{_libdir}/libwx_baseu_xml-*.so.*
  156. #%files docs
  157. #%doc html
  158. %changelog
  159. * Sat Nov 29 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.0.2-1
  160. - new upstream release
  161. * Fri Sep 05 2014 Toshiharu Kudoh <kudoh@vinelinux.org> - 3.0.1-1
  162. - initial build for Vine Linux
  163. * Sat Jul 5 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.1-1
  164. - Bump to 3.0.1 RH#1076617
  165. * Tue Mar 18 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-6
  166. - Removed disable-catch_segvs, see RH#1076617
  167. * Mon Mar 17 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-5
  168. - Renable combat28 - without it causes bugs RH#1076617 and a few others
  169. * Wed Feb 19 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-4
  170. - Fixed GTK3 bug with wx-config
  171. - Fixed a unused-direct-shlib-dependency error
  172. * Mon Feb 17 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-3
  173. - Added patch to avoid build fail on gtk 3.10+
  174. - Reverted patching to make devel package compatible with wxGTK-devel
  175. - Added combatibility for RHEL 6+
  176. - Changed all mention of GTK3 and GTK2 to GTK for consistency
  177. * Mon Feb 10 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-2
  178. - Changed to build against gtk3
  179. - Add webkit to build requires
  180. - Removed patching to make devel package compatible with wxGTK-devel
  181. - Disable 2.8.* combatibility (redundant functionality)
  182. * Sat Jan 4 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-1
  183. - Initial build of wxwidgets version 3, mostly based on wxGTK spec