nghttp2-vl.spec 9.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %bcond_with test
  3. %bcond_without app
  4. %define _unpackaged_files_terminate_build 1
  5. Summary: Experimental HTTP/2 client, server and proxy
  6. Summary(ja): HTTP/2クライアント・サーバ・プロキシの実験的実装
  7. Name: nghttp2
  8. Version: 1.42.0
  9. Release: 1%{?_dist_release}
  10. Group: internet
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. License: MIT
  14. URL: https://nghttp2.org/
  15. Source0: https://github.com/tatsuhiro-t/nghttp2/releases/download/v%{version}/nghttp2-%{version}.tar.xz
  16. %if %{with test}
  17. BuildRequires: CUnit-devel
  18. %endif
  19. BuildRequires: jemalloc-devel
  20. BuildRequires: libboost-devel
  21. BuildRequires: libboost-thread
  22. BuildRequires: libev-devel
  23. BuildRequires: openssl-devel
  24. BuildRequires: zlib-devel
  25. %if %{with app}
  26. Requires: libnghttp2 = %{version}-%{release}
  27. BuildRequires: c-ares-devel
  28. BuildRequires: jansson-devel
  29. BuildRequires: libxml2-devel
  30. %endif
  31. %description
  32. This package contains the HTTP/2 client, server and proxy programs.
  33. %description -l ja
  34. This package contains the HTTP/2 client, server and proxy programs.
  35.  このパッケージにはHTTP/2クライアント・サーバ。プロキシのプログラム
  36. が含まれています。
  37. %package -n libnghttp2
  38. Summary: A library implementing the HTTP/2 protocol
  39. Summary(ja): HTTP/2ライブラリ
  40. Group: system
  41. %description -n libnghttp2
  42. libnghttp2 is a library implementing the Hypertext Transfer Protocol
  43. version 2 (HTTP/2) protocol in C.
  44. %description -l ja -n libnghttp2
  45.  libnghttp2はHypertext Transfer Protocol version 2 (HTTP/2)をC言語で
  46. 実装したライブラリです。
  47. %package -n libnghttp2-devel
  48. Summary: Files needed for building applications with libnghttp2
  49. Summary(ja): libnghttp2を利用するアプリケーションをビルドするために必要なファイル
  50. Group: programming
  51. Requires: libnghttp2%{?_isa} = %{version}-%{release}
  52. Requires: pkgconfig
  53. %description -n libnghttp2-devel
  54. The libnghttp2-devel package includes libraries and header files needed
  55. for building applications with libnghttp2.
  56. %description -l ja -n libnghttp2-devel
  57.  libnghttp2-develパッケージにはlibnghttp2を利用するアプリケーション
  58. をビルドするために必要となるライブラリ・ヘッダファイルが含まれていま
  59. す。
  60. %package -n compat32-libnghttp2
  61. Summary: A library implementing the HTTP/2 protocol
  62. Summary(ja): HTTP/2ライブラリ
  63. Group: system
  64. %description -n compat32-libnghttp2
  65. libnghttp2 is a library implementing the Hypertext Transfer Protocol
  66. version 2 (HTTP/2) protocol in C.
  67. %description -l ja -n compat32-libnghttp2
  68.  libnghttp2はHypertext Transfer Protocol version 2 (HTTP/2)をC言語で
  69. 実装したライブラリです。
  70. %package -n compat32-libnghttp2-devel
  71. Summary: Files needed for building applications with libnghttp2
  72. Summary(ja): libnghttp2を利用するアプリケーションをビルドするために必要なファイル
  73. Group: programming
  74. Requires: compat32-libnghttp2%{?_isa} = %{version}-%{release}
  75. Requires: pkgconfig
  76. %description -n compat32-libnghttp2-devel
  77. The libnghttp2-devel package includes libraries and header files needed
  78. for building applications with libnghttp2.
  79. %description -l ja -n compat32-libnghttp2-devel
  80.  libnghttp2-develパッケージにはlibnghttp2を利用するアプリケーション
  81. をビルドするために必要となるライブラリ・ヘッダファイルが含まれていま
  82. す。
  83. %debug_package
  84. %prep
  85. %setup -q
  86. %build
  87. CFLAGS="%{optflags} -fPIC $LIBEV_CFLAGS" \
  88. CXXFLAGS="%{optflags} -fPIC $LIBEV_CFLAGS" \
  89. %configure \
  90. %if %{with app}
  91. --enable-app \
  92. %endif
  93. --enable-asio-lib \
  94. --with-pic \
  95. --with-boost \
  96. --with-boost-asio \
  97. --with-boost-system \
  98. --with-boost-thread \
  99. --disable-python-bindings \
  100. --disable-static \
  101. --without-libxml2 \
  102. --without-spdylay
  103. # avoid using rpath
  104. sed -i libtool \
  105. -e 's/^runpath_var=.*/runpath_var=/' \
  106. -e 's/^hardcode_libdir_flag_spec=".*"$/hardcode_libdir_flag_spec=""/'
  107. make %{?_smp_mflags} V=1
  108. %install
  109. %make_install
  110. # not needed on Fedora/RHEL
  111. rm -f %{buildroot}%{_libdir}/libnghttp2*.la
  112. # will be installed via %%doc
  113. rm -f "%{buildroot}%{_datadir}/doc/nghttp2/README.rst"
  114. %if ! %{with app}
  115. rm -f %{buildroot}%{_mandir}/man1/*
  116. %endif
  117. %post -n libnghttp2
  118. /sbin/ldconfig
  119. %postun -n libnghttp2
  120. /sbin/ldconfig
  121. %post -n compat32-libnghttp2
  122. /sbin/ldconfig
  123. %postun -n compat32-libnghttp2
  124. /sbin/ldconfig
  125. %check
  126. %if %{with test}
  127. # test the just built library instead of the system one, without using rpath
  128. export "LD_LIBRARY_PATH=%{buildroot}%{_libdir}:$LD_LIBRARY_PATH"
  129. make %{?_smp_mflags} check
  130. %endif
  131. %if %{with app}
  132. %files
  133. %{_bindir}/h2load
  134. %{_bindir}/nghttp
  135. %{_bindir}/nghttpd
  136. %{_bindir}/nghttpx
  137. %{_bindir}/deflatehd
  138. %{_bindir}/inflatehd
  139. %{_datadir}/nghttp2
  140. %{_mandir}/man1/h2load.1*
  141. %{_mandir}/man1/nghttp.1*
  142. %{_mandir}/man1/nghttpd.1*
  143. %{_mandir}/man1/nghttpx.1*
  144. %endif
  145. %files -n libnghttp2
  146. %{_libdir}/libnghttp2*.so.*
  147. %{_datadir}/%{name}/fetch-ocsp-response
  148. %{!?_licensedir:%global license %%doc}
  149. %license COPYING
  150. %files -n libnghttp2-devel
  151. %{_includedir}/nghttp2
  152. %{_libdir}/pkgconfig/libnghttp2*.pc
  153. %{_libdir}/libnghttp2*.so
  154. %doc README.rst
  155. %if %{build_compat32}
  156. %files -n compat32-libnghttp2
  157. %{_libdir}/libnghttp2*.so.*
  158. %{!?_licensedir:%global license %%doc}
  159. %license COPYING
  160. %files -n compat32-libnghttp2-devel
  161. %{_includedir}/nghttp2
  162. %{_libdir}/pkgconfig/libnghttp2*.pc
  163. %{_libdir}/libnghttp2*.so
  164. %doc README.rst
  165. %endif
  166. %changelog
  167. * Wed Dec 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.42.0-1
  168. - new upstream release.
  169. * Tue Jun 09 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.41.0-1
  170. - new upstream release.
  171. * Sat Apr 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.40.0-2
  172. - rebuilt with boost-1.72.0.
  173. * Sun Feb 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.40.0-1
  174. - new upstream release.
  175. * Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.39.2-1
  176. - new upstream release.
  177. * Sat Nov 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.34.0-1
  178. - new upstream release.
  179. * Fri Mar 30 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.31.0-1
  180. - new upstream release.
  181. * Sun Jan 07 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.29.0-2
  182. - rebuilt with libboost-1.66.0.
  183. * Sun Dec 24 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.29.0-1
  184. - new upstream release.
  185. - enabled to build apps as default.
  186. * Mon May 1 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.22.0-1
  187. - new upstream release.
  188. * Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.20.0-1
  189. - new upstream release.
  190. - disabled to build apps as default.
  191. * Wed Dec 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.17.0-1
  192. - new upstream release.
  193. * Sat Jul 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.0-2
  194. - added compat32-* packages.
  195. * Thu Jul 7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.0-1
  196. - new upstream release.
  197. * Tue Jun 7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.11.1-2
  198. - initial build for Vne Linux.
  199. * Sun May 29 2016 Kamil Dudka <kdudka@redhat.com> 1.11.1-1
  200. - update to the latest upstream release
  201. * Thu May 26 2016 Kamil Dudka <kdudka@redhat.com> 1.11.0-1
  202. - update to the latest upstream release
  203. * Mon Apr 25 2016 Kamil Dudka <kdudka@redhat.com> 1.10.0-1
  204. - update to the latest upstream release
  205. * Sun Apr 03 2016 Kamil Dudka <kdudka@redhat.com> 1.9.2-1
  206. - update to the latest upstream release
  207. * Tue Mar 29 2016 Kamil Dudka <kdudka@redhat.com> 1.9.1-1
  208. - update to the latest upstream release
  209. * Thu Feb 25 2016 Kamil Dudka <kdudka@redhat.com> 1.8.0-1
  210. - update to the latest upstream release
  211. * Thu Feb 11 2016 Kamil Dudka <kdudka@redhat.com> 1.7.1-1
  212. - update to the latest upstream release (fixes CVE-2016-1544)
  213. * Fri Feb 05 2016 Kamil Dudka <kdudka@redhat.com> 1.7.0-3
  214. - make the package compile with gcc-6
  215. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.0-2
  216. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  217. * Mon Jan 25 2016 Kamil Dudka <kdudka@redhat.com> 1.7.0-1
  218. - update to the latest upstream release
  219. * Fri Dec 25 2015 Kamil Dudka <kdudka@redhat.com> 1.6.0-1
  220. - update to the latest upstream release (fixes CVE-2015-8659)
  221. * Thu Nov 26 2015 Kamil Dudka <kdudka@redhat.com> 1.5.0-1
  222. - update to the latest upstream release
  223. * Mon Oct 26 2015 Kamil Dudka <kdudka@redhat.com> 1.4.0-1
  224. - update to the latest upstream release
  225. * Thu Sep 24 2015 Kamil Dudka <kdudka@redhat.com> 1.3.4-1
  226. - update to the latest upstream release
  227. * Wed Sep 23 2015 Kamil Dudka <kdudka@redhat.com> 1.3.3-1
  228. - update to the latest upstream release
  229. * Wed Sep 16 2015 Kamil Dudka <kdudka@redhat.com> 1.3.2-1
  230. - update to the latest upstream release
  231. * Mon Sep 14 2015 Kamil Dudka <kdudka@redhat.com> 1.3.1-1
  232. - update to the latest upstream release
  233. * Mon Aug 31 2015 Kamil Dudka <kdudka@redhat.com> 1.3.0-1
  234. - update to the latest upstream release
  235. * Mon Aug 17 2015 Kamil Dudka <kdudka@redhat.com> 1.2.1-1
  236. - update to the latest upstream release
  237. * Sun Aug 09 2015 Kamil Dudka <kdudka@redhat.com> 1.2.0-1
  238. - update to the latest upstream release
  239. * Wed Jul 15 2015 Kamil Dudka <kdudka@redhat.com> 1.1.1-1
  240. - update to the latest upstream release
  241. * Tue Jun 30 2015 Kamil Dudka <kdudka@redhat.com> 1.0.5-1
  242. - packaged for Fedora (#1237247)