jasper-vl.spec 6.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: jasper
  3. Summary: implementation of the JPEG-2000 standard, Part 1
  4. Version: 2.0.23
  5. Release: 1%{?_dist_release}
  6. Group: graphics
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: Modified BSD (see LICENSE)
  10. URL: https://www.ece.uvic.ca/~frodo/jasper/
  11. Source: https://github.com/mdadams/jasper/archive/version-%{version}.tar.gz#/%{name}-version-%{version}.tar.gz
  12. # skip hard-coded prefix/lib rpath
  13. Patch1: jasper-2.0.14-rpath.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: autoconf automake libtool
  16. BuildRequires: freeglut-devel
  17. BuildRequires: libGLU-devel
  18. BuildRequires: libjpeg-devel
  19. BuildRequires: pkgconfig
  20. BuildRequires: cmake
  21. Requires: %{name}-libs = %{version}-%{release}
  22. %description
  23. JasPer is a collection of software (i.e., a library and application
  24. programs) for the coding and manipulation of images. This software
  25. can handle image data in a variety of formats. One such format
  26. supported by JasPer is the JPEG-2000 format defined in ISO/IEC 15444-1.
  27. %package devel
  28. Summary: Include Files and Documentation for jasper
  29. Group: programming
  30. Requires: %{name}-libs = %{version}-%{release}
  31. Requires: libjpeg-devel
  32. %description devel
  33. This package contains libjasper, a library implementing the JPEG-2000
  34. image compression standard Part 1.
  35. %package libs
  36. Summary: Runtime libraries for %{name}
  37. Group: system
  38. %description libs
  39. This package contains runtime libraries for JasPer.
  40. # compat32
  41. %package -n compat32-%{name}-devel
  42. Summary: Include Files and Documentation for jasper
  43. Group: programming
  44. Requires: %{name}-libs = %{version}-%{release}
  45. Requires: compat32-libjpeg-devel
  46. %description -n compat32-%{name}-devel
  47. This package contains libjasper, a library implementing the JPEG-2000
  48. image compression standard Part 1.
  49. %package -n compat32-%{name}-libs
  50. Summary: Runtime libraries for %{name}
  51. Group: system
  52. %description -n compat32-%{name}-libs
  53. This package contains runtime libraries for JasPer.
  54. %debug_package
  55. %prep
  56. %setup -q -n %{name}-version-%{version}
  57. %patch1 -p1 -b .rpath
  58. %build
  59. mkdir -p builder
  60. pushd builder
  61. %cmake -DJAS_ENABLE_DOC:BOOL=OFF ..
  62. popd
  63. %make_build -C builder
  64. %install
  65. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
  66. make install/fast DESTDIR=%{buildroot} -C builder
  67. # Unpackaged files
  68. rm -f doc/README
  69. rm -f %{buildroot}%{_libdir}/lib*.la
  70. rm -rf %{buildroot}%{_docdir}/JasPer
  71. %check
  72. make test -C builder
  73. %clean
  74. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
  75. %post libs -p /sbin/ldconfig
  76. %postun libs -p /sbin/ldconfig
  77. %post -n compat32-%{name}-libs -p /sbin/ldconfig
  78. %postun -n compat32-%{name}-libs -p /sbin/ldconfig
  79. %files
  80. %defattr(-,root,root)
  81. %{!?_licensedir:%global license %%doc}
  82. %{_bindir}/*
  83. %{_mandir}/man1/*
  84. %files libs
  85. %license COPYRIGHT LICENSE
  86. %doc INSTALL README doc/README doc/jasper.pdf doc/jpeg2000.pdf
  87. %defattr(-,root,root)
  88. %{_libdir}/libjasper*.so.*
  89. %files devel
  90. %defattr(-,root,root)
  91. %{_includedir}/jasper
  92. %{_libdir}/libjasper*.so
  93. %{_libdir}/pkgconfig/jasper.pc
  94. # compat32
  95. %if %{build_compat32}
  96. %files -n compat32-%{name}-libs
  97. %defattr(-,root,root)
  98. %{_libdir}/libjasper*.so.*
  99. %files -n compat32-%{name}-devel
  100. %defattr(-,root,root)
  101. %{_libdir}/libjasper*.so
  102. %{_libdir}/pkgconfig/jasper.pc
  103. %endif
  104. %changelog
  105. * Wed Dec 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.23-1
  106. - new upstream release.
  107. * Fri Sep 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.19-1
  108. - new upstream release.
  109. * Sun Sep 08 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.16-1
  110. - new upstream release.
  111. - dropped Patch1: fixed in upstream.
  112. - imported Patch1 from rawhide.
  113. * Mon Mar 20 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.12-1
  114. - new upstream release.
  115. - dropped all patches.
  116. - imported patch1 from rawhide.
  117. * Tue Jul 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.900.1-11
  118. - added Patch1000-1002 to fix CVE-2016-{1577,2089,2116}.
  119. * Wed Dec 24 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.900.1-10
  120. - imported all patches from RawHide.
  121. * Tue Jul 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.900.1-9
  122. - rebuild with libpng-1.6.12
  123. * Thu Apr 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-8
  124. - rebuilt with current VineSeed
  125. * Sat May 02 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.900.1-7
  126. - added compat32 subpackage for x86_64 arch support.
  127. * Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.900.1-6
  128. - splited out runtime library to sub package
  129. - enable opengl again, add BuildRequires: freeglut-devel
  130. * Wed Jun 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.900.1-5
  131. - remove .la
  132. - add --disable-static to configure option
  133. * Sun Jun 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-0vl4
  134. - added Patch0 from VinePlus/4.0
  135. * Thu Jun 21 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.900.1-0vl2.1
  136. - add patch100 for fix CVE-2007-2721
  137. - add Vendor/Distributin Tag
  138. * Fri May 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.900.1-0vl3
  139. - remove BuildPrereq: freeglut-devel and Requires freeglut
  140. - add --disable-opengl to configure option
  141. * Fri Mar 16 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.900.1-0vl2
  142. - add BuildPreReq: unzip (used in the %%pre section)
  143. * Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-0vl1
  144. - new upstream release
  145. * Tue Jan 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.0-0vl1
  146. - new upstream release
  147. - changed Group to System Environment/Libraries
  148. - added --mandir=%{_mandir}
  149. - added %post and %postun section
  150. * Thu Sep 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.701.0-0vl3
  151. - added --libdir=%{_libdir} configure option
  152. * Tue Sep 5 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.701.0-0vl2
  153. - build with freeglut
  154. - change BuildPrereq and Requires
  155. * Tue Dec 14 2004 Satoshi MACHINO <machino@vinelinux.org> 1.701.0-0vl1
  156. - new upstream version (jasper-1.701.0)
  157. * Sat Nov 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.700.5-0vl2
  158. - rebuild for VineSeedPlus
  159. * Sat Nov 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.700.5-0vl1
  160. - source upgrade
  161. - change spec to build for VineLinux
  162. * Fri Oct 25 2002 Alexander D. Karaivanov <adk@medical-insight.com>
  163. - spec file created