systemtap-vl.spec 25 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772
  1. %{!?with_sqlite: %global with_sqlite 1}
  2. %{!?with_docs: %global with_docs 0}
  3. # crash is not available
  4. %ifarch ppc ppc64 %{sparc}
  5. %{!?with_crash: %global with_crash 0}
  6. %else
  7. %{!?with_crash: %global with_crash 1}
  8. %endif
  9. %{!?with_rpm: %global with_rpm 1}
  10. %{!?with_bundled_elfutils: %global with_bundled_elfutils 0}
  11. %{!?elfutils_version: %global elfutils_version 0.142}
  12. %{!?pie_supported: %global pie_supported 1}
  13. %{!?with_boost: %global with_boost 0}
  14. %{!?with_publican: %global with_publican 0}
  15. %{!?publican_brand: %global publican_brand fedora}
  16. Name: systemtap
  17. Version: 2.0
  18. Release: 1%{?_dist_release}
  19. # for version, see also configure.ac
  20. # Packaging abstract:
  21. #
  22. # systemtap empty req:-client req:-devel
  23. # systemtap-server /usr/bin/stap-server*, req:-devel
  24. # systemtap-devel /usr/bin/stap, runtime, tapset, req:kernel-devel
  25. # systemtap-runtime /usr/bin/staprun, /usr/bin/stapsh
  26. # systemtap-client /usr/bin/stap, samples, docs, tapset(bonus), req:-runtime
  27. # systemtap-initscript /etc/init.d/systemtap, req:systemtap
  28. # systemtap-sdt-devel /usr/include/sys/sdt.h /usr/bin/dtrace
  29. # systemtap-testsuite /usr/share/systemtap/testsuite*, req:systemtap, req:sdt-devel
  30. #
  31. # Typical scenarios:
  32. #
  33. # stap-client: systemtap-client
  34. # stap-server: systemtap-server
  35. # local user: systemtap
  36. #
  37. # Unusual scenarios:
  38. #
  39. # intermediary stap-client for --remote: systemtap-client (-runtime unused)
  40. # intermediary stap-server for --use-server: systemtap-server (-devel unused)
  41. Summary: Programmable system-wide instrumentation system
  42. Group: Development/System
  43. License: GPLv2+
  44. URL: http://sourceware.org/systemtap/
  45. Source: ftp://sourceware.org/pub/%{name}/releases/%{name}-%{version}.tar.gz
  46. # Build*
  47. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  48. BuildRequires: gcc-c++
  49. BuildRequires: gettext-devel
  50. BuildRequires: nss-devel avahi-devel pkgconfig
  51. %if %{with_sqlite}
  52. BuildRequires: sqlite-devel
  53. %endif
  54. # Needed for libstd++ < 4.0, without <tr1/memory>
  55. %if %{with_boost}
  56. BuildRequires: boost-devel
  57. %endif
  58. %if %{with_crash}
  59. BuildRequires: crash-devel zlib-devel
  60. %endif
  61. %if %{with_rpm}
  62. BuildRequires: rpm-devel glibc-headers
  63. %endif
  64. %if %{with_bundled_elfutils}
  65. Source1: elfutils-%{elfutils_version}.tar.gz
  66. Patch1: elfutils-portability.patch
  67. BuildRequires: m4
  68. %global setup_elfutils -a1
  69. %else
  70. BuildRequires: elfutils-devel >= %{elfutils_version}
  71. %endif
  72. %if %{with_docs}
  73. BuildRequires: texlive-common
  74. BuildRequires: latex2html
  75. %if %{with_publican}
  76. BuildRequires: publican
  77. BuildRequires: /usr/share/publican/Common_Content/%{publican_brand}/defaults.cfg
  78. %endif
  79. %endif
  80. # Install requirements
  81. Requires: systemtap-client = %{version}-%{release}
  82. Requires: systemtap-devel = %{version}-%{release}
  83. %description
  84. SystemTap is an instrumentation system for systems running Linux.
  85. Developers can write instrumentation scripts to collect data on
  86. the operation of the system. The base systemtap package contains/requires
  87. the components needed to locally develop and execute systemtap scripts.
  88. # ------------------------------------------------------------------------
  89. %package server
  90. Summary: Instrumentation System Server
  91. Group: Development/System
  92. License: GPLv2+
  93. URL: http://sourceware.org/systemtap/
  94. Requires: systemtap-devel = %{version}-%{release}
  95. # On RHEL[45], /bin/mktemp comes from the 'mktemp' package. On newer
  96. # distributions, /bin/mktemp comes from the 'coreutils' package. To
  97. # avoid a specific RHEL[45] Requires, we'll do a file-based require.
  98. Requires: nss /bin/mktemp
  99. Requires: zip unzip
  100. Requires(pre): shadow-utils
  101. Requires(post): chkconfig
  102. Requires(preun): chkconfig
  103. Requires(preun): initscripts
  104. Requires(postun): initscripts
  105. Requires(post): %{name}-runtime
  106. BuildRequires: nss-devel avahi-devel
  107. %description server
  108. This is the remote script compilation server component of systemtap.
  109. It announces itself to nearby clients with avahi (if available), and
  110. compiles systemtap scripts to kernel objects on their demand.
  111. %package devel
  112. Summary: Programmable system-wide instrumentation system - development headers, tools
  113. Group: Development/System
  114. License: GPLv2+
  115. URL: http://sourceware.org/systemtap/
  116. Requires: kernel >= 2.6.9-11
  117. # Alternate kernel packages kernel-PAE-devel et al. have a virtual
  118. # provide for kernel-devel, so this requirement does the right thing,
  119. # at least past RHEL4.
  120. Requires: kernel-devel
  121. Requires: gcc make
  122. # Suggest: kernel-debuginfo
  123. %description devel
  124. This package contains the components needed to compile a systemtap
  125. script from source form into executable (.ko) forms. It may be
  126. installed on a self-contained developer workstation (along with the
  127. systemtap-client and systemtap-runtime packages), or on a dedicated
  128. remote server (alongside the systemtap-server package). It includes
  129. a copy of the standard tapset library and the runtime library C files.
  130. %package runtime
  131. Summary: Programmable system-wide instrumentation system - runtime
  132. Group: Development/System
  133. License: GPLv2+
  134. URL: http://sourceware.org/systemtap/
  135. Requires: kernel >= 2.6.9-11
  136. Requires(pre): shadow-utils
  137. %description runtime
  138. SystemTap runtime contains the components needed to execute
  139. a systemtap script that was already compiled into a module
  140. using a local or remote systemtap-devel installation.
  141. %package client
  142. Summary: Programmable system-wide instrumentation system - client
  143. Group: Development/System
  144. License: GPLv2+
  145. URL: http://sourceware.org/systemtap/
  146. Requires: zip unzip
  147. Requires: systemtap-runtime = %{version}-%{release}
  148. Requires: coreutils grep sed unzip zip
  149. Requires: openssh-clients
  150. %description client
  151. This package contains/requires the components needed to develop
  152. systemtap scripts, and compile them using a local systemtap-devel
  153. or a remote systemtap-server installation, then run them using a
  154. local or remote systemtap-runtime. It includes script samples and
  155. documentation, and a copy of the tapset library for reference.
  156. %package initscript
  157. Summary: Systemtap Initscripts
  158. Group: Development/System
  159. License: GPLv2+
  160. URL: http://sourceware.org/systemtap/
  161. Requires: systemtap = %{version}-%{release}
  162. Requires(post): chkconfig
  163. Requires(preun): chkconfig
  164. Requires(preun): initscripts
  165. Requires(postun): initscripts
  166. %description initscript
  167. Sysvinit scripts to launch selected systemtap scripts at system startup.
  168. %package sdt-devel
  169. Summary: Static probe support tools
  170. Group: Development/System
  171. License: GPLv2+ and Public Domain
  172. URL: http://sourceware.org/systemtap/
  173. %description sdt-devel
  174. This package includes the <sys/sdt.h> header file used for static
  175. instrumentation compiled into userspace programs and libraries, along
  176. with the optional dtrace-compatibility preprocessor to process related
  177. .d files into tracing-macro-laden .h headers.
  178. %package testsuite
  179. Summary: Instrumentation System Testsuite
  180. Group: Development/System
  181. License: GPLv2+
  182. URL: http://sourceware.org/systemtap/
  183. Requires: systemtap = %{version}-%{release}
  184. Requires: systemtap-sdt-devel = %{version}-%{release}
  185. Requires: systemtap-server = %{version}-%{release}
  186. Requires: dejagnu which prelink elfutils grep
  187. Requires: gcc gcc-c++ make glibc-devel
  188. # testsuite/systemtap.server/client.exp needs avahi
  189. Requires: avahi
  190. %if %{with_crash}
  191. # testsuite/systemtap.base/crash.exp needs crash
  192. Requires: crash
  193. %endif
  194. %ifarch x86_64
  195. Requires: compat32-glibc-devel
  196. %endif
  197. %description testsuite
  198. This package includes the dejagnu-based systemtap stress self-testing
  199. suite. This may be used by system administrators to thoroughly check
  200. systemtap on the current system.
  201. # ------------------------------------------------------------------------
  202. %prep
  203. %setup -q %{?setup_elfutils}
  204. %if %{with_bundled_elfutils}
  205. cd elfutils-%{elfutils_version}
  206. %patch1 -p1
  207. sleep 1
  208. find . \( -name Makefile.in -o -name aclocal.m4 \) -print | xargs touch
  209. sleep 1
  210. find . \( -name configure -o -name config.h.in \) -print | xargs touch
  211. cd ..
  212. %endif
  213. %build
  214. %if %{with_bundled_elfutils}
  215. # Build our own copy of elfutils.
  216. %global elfutils_config --with-elfutils=elfutils-%{elfutils_version}
  217. # We have to prevent the standard dependency generation from identifying
  218. # our private elfutils libraries in our provides and requires.
  219. %global _use_internal_dependency_generator 0
  220. %global filter_eulibs() /bin/sh -c "%{1} | sed '/libelf/d;/libdw/d;/libebl/d'"
  221. %global __find_provides %{filter_eulibs /usr/lib/rpm/find-provides}
  222. %global __find_requires %{filter_eulibs /usr/lib/rpm/find-requires}
  223. # This will be needed for running stap when not installed, for the test suite.
  224. %global elfutils_mflags LD_LIBRARY_PATH=`pwd`/lib-elfutils
  225. %endif
  226. # Enable/disable the sqlite coverage testing support
  227. %if %{with_sqlite}
  228. %global sqlite_config --enable-sqlite
  229. %else
  230. %global sqlite_config --disable-sqlite
  231. %endif
  232. # Enable/disable the crash extension
  233. %if %{with_crash}
  234. %global crash_config --enable-crash
  235. %else
  236. %global crash_config --disable-crash
  237. %endif
  238. # Enable/disable the code to find and suggest needed rpms
  239. %if %{with_rpm}
  240. %global rpm_config --with-rpm
  241. %else
  242. %global rpm_config --without-rpm
  243. %endif
  244. %if %{with_docs}
  245. %global docs_config --enable-docs
  246. %else
  247. %global docs_config --disable-docs
  248. %endif
  249. # Enable pie as configure defaults to disabling it
  250. %if %{pie_supported}
  251. %global pie_config --enable-pie
  252. %else
  253. %global pie_config --disable-pie
  254. %endif
  255. %if %{with_publican}
  256. %global publican_config --enable-publican --with-publican-brand=%{publican_brand}
  257. %else
  258. %global publican_config --disable-publican
  259. %endif
  260. %configure %{?elfutils_config} %{sqlite_config} %{crash_config} %{docs_config} %{pie_config} %{publican_config} %{rpm_config} --disable-silent-rules
  261. make %{?_smp_mflags}
  262. %install
  263. rm -rf ${RPM_BUILD_ROOT}
  264. make DESTDIR=$RPM_BUILD_ROOT install
  265. %find_lang %{name}
  266. # We want the examples in the special doc dir, not the build install dir.
  267. # We build it in place and then move it away so it doesn't get installed
  268. # twice. rpm can specify itself where the (versioned) docs go with the
  269. # %doc directive.
  270. mv $RPM_BUILD_ROOT%{_datadir}/doc/systemtap/examples examples
  271. # Fix paths in the example & testsuite scripts
  272. find examples testsuite -type f -name '*.stp' -print0 | xargs -0 sed -i -r -e '1s@^#!.+stap@#!%{_bindir}/stap@'
  273. # To make rpmlint happy, remove any .gitignore files in the testsuite.
  274. find testsuite -type f -name '.gitignore' -print0 | xargs -0 rm -f
  275. # Because "make install" may install staprun with whatever mode, the
  276. # post-processing programs rpmbuild runs won't be able to read it.
  277. # So, we change permissions so that they can read it. We'll set the
  278. # permissions back to 04110 in the %files section below.
  279. chmod 755 $RPM_BUILD_ROOT%{_bindir}/staprun
  280. #install the useful stap-prep script
  281. install -c -m 755 stap-prep $RPM_BUILD_ROOT%{_bindir}/stap-prep
  282. # Copy over the testsuite
  283. cp -rp testsuite $RPM_BUILD_ROOT%{_datadir}/systemtap
  284. %if %{with_docs}
  285. # We want the manuals in the special doc dir, not the generic doc install dir.
  286. # We build it in place and then move it away so it doesn't get installed
  287. # twice. rpm can specify itself where the (versioned) docs go with the
  288. # %doc directive.
  289. mkdir docs.installed
  290. mv $RPM_BUILD_ROOT%{_datadir}/doc/systemtap/*.pdf docs.installed/
  291. mv $RPM_BUILD_ROOT%{_datadir}/doc/systemtap/tapsets docs.installed/
  292. %if %{with_publican}
  293. mv $RPM_BUILD_ROOT%{_datadir}/doc/systemtap/SystemTap_Beginners_Guide docs.installed/
  294. %endif
  295. %endif
  296. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/
  297. install -m 755 initscript/systemtap $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/
  298. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/systemtap
  299. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/systemtap/conf.d
  300. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/systemtap/script.d
  301. install -m 644 initscript/config.systemtap $RPM_BUILD_ROOT%{_sysconfdir}/systemtap/config
  302. mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/systemtap
  303. mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/run/systemtap
  304. install -m 755 initscript/stap-server $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/
  305. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/stap-server
  306. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/stap-server/conf.d
  307. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
  308. install -m 644 initscript/config.stap-server $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/stap-server
  309. mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log/stap-server
  310. touch $RPM_BUILD_ROOT%{_localstatedir}/log/stap-server/log
  311. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d
  312. install -m 644 initscript/logrotate.stap-server $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/stap-server
  313. %clean
  314. rm -rf ${RPM_BUILD_ROOT}
  315. %pre runtime
  316. getent group stapusr >/dev/null || groupadd -g 156 -r stapusr || groupadd -r stapusr
  317. getent group stapsys >/dev/null || groupadd -g 157 -r stapsys || groupadd -r stapsys
  318. getent group stapdev >/dev/null || groupadd -g 158 -r stapdev || groupadd -r stapdev
  319. exit 0
  320. %pre server
  321. getent group stap-server >/dev/null || groupadd -g 155 -r stap-server || groupadd -r stap-server
  322. getent passwd stap-server >/dev/null || \
  323. useradd -c "Systemtap Compile Server" -u 155 -g stap-server -d %{_localstatedir}/lib/stap-server -m -r -s /sbin/nologin stap-server || \
  324. useradd -c "Systemtap Compile Server" -g stap-server -d %{_localstatedir}/lib/stap-server -m -r -s /sbin/nologin stap-server
  325. test -e ~stap-server && chmod 755 ~stap-server
  326. if [ ! -f ~stap-server/.systemtap/rc ]; then
  327. mkdir -p ~stap-server/.systemtap
  328. chown stap-server:stap-server ~stap-server/.systemtap
  329. echo "--rlimit-as=614400000 --rlimit-cpu=60 --rlimit-nproc=20 --rlimit-stack=1024000 --rlimit-fsize=51200000" > ~stap-server/.systemtap/rc
  330. chown stap-server:stap-server ~stap-server/.systemtap/rc
  331. fi
  332. exit 0
  333. %post server
  334. test -e %{_localstatedir}/log/stap-server/log || {
  335. touch %{_localstatedir}/log/stap-server/log
  336. chmod 664 %{_localstatedir}/log/stap-server/log
  337. chown stap-server:stap-server %{_localstatedir}/log/stap-server/log
  338. }
  339. # If it does not already exist, as stap-server, generate the certificate
  340. # used for signing and for ssl.
  341. if test ! -e ~stap-server/.systemtap/ssl/server/stap.cert; then
  342. runuser -s /bin/sh - stap-server -c %{_libexecdir}/%{name}/stap-gen-cert >/dev/null
  343. # Authorize the certificate as a trusted ssl peer and as a trusted signer
  344. # on the local host.
  345. %{_libexecdir}/%{name}/stap-authorize-cert ~stap-server/.systemtap/ssl/server/stap.cert %{_sysconfdir}/systemtap/ssl/client >/dev/null
  346. %{_libexecdir}/%{name}/stap-authorize-cert ~stap-server/.systemtap/ssl/server/stap.cert %{_sysconfdir}/systemtap/staprun >/dev/null
  347. fi
  348. # Activate the service
  349. /sbin/chkconfig --add stap-server
  350. exit 0
  351. %preun server
  352. # Check that this is the actual deinstallation of the package, as opposed to
  353. # just removing the old package on upgrade.
  354. if [ $1 = 0 ] ; then
  355. /sbin/service stap-server stop >/dev/null 2>&1
  356. /sbin/chkconfig --del stap-server
  357. fi
  358. exit 0
  359. %postun server
  360. # Check whether this is an upgrade of the package.
  361. # If so, restart the service if it's running
  362. if [ "$1" -ge "1" ] ; then
  363. /sbin/service stap-server condrestart >/dev/null 2>&1 || :
  364. fi
  365. exit 0
  366. %post initscript
  367. /sbin/chkconfig --add systemtap
  368. exit 0
  369. %preun initscript
  370. # Check that this is the actual deinstallation of the package, as opposed to
  371. # just removing the old package on upgrade.
  372. if [ $1 = 0 ] ; then
  373. /sbin/service systemtap stop >/dev/null 2>&1
  374. /sbin/chkconfig --del systemtap
  375. fi
  376. exit 0
  377. %postun initscript
  378. # Check whether this is an upgrade of the package.
  379. # If so, restart the service if it's running
  380. if [ "$1" -ge "1" ] ; then
  381. /sbin/service systemtap condrestart >/dev/null 2>&1 || :
  382. fi
  383. exit 0
  384. %post
  385. # Remove any previously-built uprobes.ko materials
  386. (make -C %{_datadir}/%{name}/runtime/uprobes clean) >/dev/null 2>&1 || true
  387. (/sbin/rmmod uprobes) >/dev/null 2>&1 || true
  388. %preun
  389. # Ditto
  390. (make -C %{_datadir}/%{name}/runtime/uprobes clean) >/dev/null 2>&1 || true
  391. (/sbin/rmmod uprobes) >/dev/null 2>&1 || true
  392. # ------------------------------------------------------------------------
  393. %files -f %{name}.lang
  394. # The master "systemtap" rpm doesn't include any files.
  395. %files server -f %{name}.lang
  396. %defattr(-,root,root)
  397. %{_bindir}/stap-server
  398. %dir %{_libexecdir}/%{name}
  399. %{_libexecdir}/%{name}/stap-serverd
  400. %{_libexecdir}/%{name}/stap-start-server
  401. %{_libexecdir}/%{name}/stap-stop-server
  402. %{_libexecdir}/%{name}/stap-gen-cert
  403. %{_libexecdir}/%{name}/stap-sign-module
  404. %{_mandir}/man7/stappaths.7*
  405. %{_mandir}/man8/stap-server.8*
  406. %{_sysconfdir}/rc.d/init.d/stap-server
  407. %config(noreplace) %{_sysconfdir}/logrotate.d/stap-server
  408. %dir %{_sysconfdir}/stap-server
  409. %dir %{_sysconfdir}/stap-server/conf.d
  410. %config(noreplace) %{_sysconfdir}/sysconfig/stap-server
  411. %dir %attr(0755,stap-server,stap-server) %{_localstatedir}/log/stap-server
  412. %ghost %config(noreplace) %attr(0644,stap-server,stap-server) %{_localstatedir}/log/stap-server/log
  413. %ghost %attr(0755,stap-server,stap-server) %{_localstatedir}/run/stap-server
  414. %doc initscript/README.stap-server
  415. %doc README README.unprivileged AUTHORS NEWS COPYING
  416. %files devel -f %{name}.lang
  417. %{_bindir}/stap
  418. %{_bindir}/stap-prep
  419. %{_bindir}/stap-report
  420. %dir %{_datadir}/%{name}/runtime
  421. %{_datadir}/%{name}/runtime
  422. %dir %{_datadir}/%{name}/tapset
  423. %{_datadir}/%{name}/tapset
  424. %{_mandir}/man1/stap.1*
  425. %{_mandir}/man7/stappaths.7*
  426. %doc README README.unprivileged AUTHORS NEWS COPYING
  427. %if %{with_bundled_elfutils}
  428. %dir %{_libdir}/%{name}
  429. %{_libdir}/%{name}/lib*.so*
  430. %endif
  431. %files runtime -f %{name}.lang
  432. %defattr(-,root,root)
  433. %attr(4110,root,stapusr) %{_bindir}/staprun
  434. %{_bindir}/stapsh
  435. %{_bindir}/stap-merge
  436. %{_bindir}/stap-report
  437. %dir %{_libexecdir}/%{name}
  438. %{_libexecdir}/%{name}/stapio
  439. %{_libexecdir}/%{name}/stap-env
  440. %{_libexecdir}/%{name}/stap-authorize-cert
  441. %if %{with_crash}
  442. %dir %{_libdir}/%{name}
  443. %{_libdir}/%{name}/staplog.so*
  444. %endif
  445. %{_mandir}/man7/stappaths.7*
  446. %{_mandir}/man8/staprun.8*
  447. %doc README README.security AUTHORS NEWS COPYING
  448. %files client -f %{name}.lang
  449. %defattr(-,root,root)
  450. %doc README README.unprivileged AUTHORS NEWS COPYING examples
  451. %if %{with_docs}
  452. %doc docs.installed/*.pdf
  453. %doc docs.installed/tapsets/*.html
  454. %if %{with_publican}
  455. %doc docs.installed/SystemTap_Beginners_Guide
  456. %endif
  457. %endif
  458. %{_bindir}/stap
  459. %{_bindir}/stap-prep
  460. %{_bindir}/stap-report
  461. %{_mandir}/man1/stap.1*
  462. %{_mandir}/man1/stap-merge.1*
  463. %{_mandir}/man3/*
  464. %{_mandir}/man7/stappaths.7*
  465. %dir %{_datadir}/%{name}
  466. %{_datadir}/%{name}/tapset
  467. %files initscript
  468. %defattr(-,root,root)
  469. %{_sysconfdir}/rc.d/init.d/systemtap
  470. %dir %{_sysconfdir}/systemtap
  471. %dir %{_sysconfdir}/systemtap/conf.d
  472. %dir %{_sysconfdir}/systemtap/script.d
  473. %config(noreplace) %{_sysconfdir}/systemtap/config
  474. %dir %{_localstatedir}/cache/systemtap
  475. %ghost %{_localstatedir}/run/systemtap
  476. %doc initscript/README.systemtap
  477. %files sdt-devel -f %{name}.lang
  478. %defattr(-,root,root)
  479. %{_bindir}/dtrace
  480. %{_includedir}/sys/sdt.h
  481. %{_includedir}/sys/sdt-config.h
  482. %{_mandir}/man1/dtrace.1*
  483. %doc README AUTHORS NEWS COPYING
  484. %files testsuite
  485. %defattr(-,root,root)
  486. %dir %{_datadir}/%{name}
  487. %{_datadir}/%{name}/testsuite
  488. # ------------------------------------------------------------------------
  489. %changelog
  490. * Sun Nov 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0-1
  491. - initial build for Vine Linux
  492. * Wed Jul 18 2012 Josh Stone <jistone@redhat.com> - 1.8-5
  493. - bz840902 ppc build fix (related to bz837641)
  494. * Fri Jul 13 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 1.8-4
  495. - Fix ifarch statement
  496. - use file based requires for glibc-devel on x86_64 so that we work in koji
  497. * Wed Jul 11 2012 Frank Ch. Eigler <fche@redhat.com> - 1.8-3
  498. - PR14348 task_work_add race condition fix
  499. * Mon Jul 09 2012 Josh Stone <jistone@redhat.com>
  500. - bz837641 build fix
  501. * Sun Jun 17 2012 Frank Ch. Eigler <fche@redhat.com> - 1.8-1
  502. - Upstream release.
  503. * Mon Apr 30 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 1.7-7
  504. - Enable crash support on ARM, cleanup spec
  505. * Thu Apr 19 2012 Karsten Hopp <karsten@redhat.com> - 1.7-6.1
  506. - rebuild on PPC(64) without crash, publican
  507. * Thu Mar 29 2012 Richard W.M. Jones <rjones@redhat.com> - 1.7-6
  508. - Rebuild for rpm soname bump.
  509. * Fri Mar 16 2012 Frank Ch. Eigler <fche@redhat.com> - 1.7-5
  510. - dbhole advises ARM publican/fop/java is a go for launch.
  511. * Thu Mar 01 2012 Mark Wielaard <mjw@redhat.com> - 1.7-4
  512. - ARM currently doesn't have publican/fop/java and no prelink.
  513. * Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7-3
  514. - Rebuilt for c++ ABI breakage
  515. * Wed Feb 22 2012 Frank Ch. Eigler <fche@redhat.com> - 1.7-2
  516. - CVE-2012-0875 (kernel panic when processing malformed DWARF unwind data)
  517. * Wed Feb 01 2012 Frank Ch. Eigler <fche@redhat.com> - 1.7-1
  518. - Upstream release.
  519. * Fri Jan 13 2012 David Smith <dsmith@redhat.com> - 1.6-2
  520. - Fixed /bin/mktemp require.
  521. * Mon Jul 25 2011 Stan Cox <scox@redhat.com> - 1.6-1
  522. - Upstream release.
  523. * Tue May 23 2011 Stan Cox <scox@redhat.com> - 1.5-1
  524. - Upstream release.
  525. * Mon Jan 17 2011 Frank Ch. Eigler <fche@redhat.com> - 1.4-1
  526. - Upstream release.
  527. * Wed Jul 21 2010 Josh Stone <jistone@redhat.com> - 1.3-1
  528. - Upstream release.
  529. * Mon Mar 22 2010 Frank Ch. Eigler <fche@redhat.com> - 1.2-1
  530. - Upstream release.
  531. * Mon Dec 21 2009 David Smith <dsmith@redhat.com> - 1.1-1
  532. - Upstream release.
  533. * Tue Sep 22 2009 Josh Stone <jistone@redhat.com> - 1.0-1
  534. - Upstream release.
  535. * Tue Aug 4 2009 Josh Stone <jistone@redhat.com> - 0.9.9-1
  536. - Upstream release.
  537. * Thu Jun 11 2009 Josh Stone <jistone@redhat.com> - 0.9.8-1
  538. - Upstream release.
  539. * Thu Apr 23 2009 Josh Stone <jistone@redhat.com> - 0.9.7-1
  540. - Upstream release.
  541. * Fri Mar 27 2009 Josh Stone <jistone@redhat.com> - 0.9.5-1
  542. - Upstream release.
  543. * Wed Mar 18 2009 Will Cohen <wcohen@redhat.com> - 0.9-2
  544. - Add location of man pages.
  545. * Tue Feb 17 2009 Frank Ch. Eigler <fche@redhat.com> - 0.9-1
  546. - Upstream release.
  547. * Thu Nov 13 2008 Frank Ch. Eigler <fche@redhat.com> - 0.8-1
  548. - Upstream release.
  549. * Tue Jul 15 2008 Frank Ch. Eigler <fche@redhat.com> - 0.7-1
  550. - Upstream release.
  551. * Fri Feb 1 2008 Frank Ch. Eigler <fche@redhat.com> - 0.6.1-3
  552. - Add zlib-devel to buildreq; missing from crash-devel
  553. - Process testsuite .stp files for #!stap->#!/usr/bin/stap
  554. * Fri Jan 18 2008 Frank Ch. Eigler <fche@redhat.com> - 0.6.1-1
  555. - Add crash-devel buildreq to build staplog.so crash(8) module.
  556. - Many robustness & functionality improvements:
  557. * Wed Dec 5 2007 Will Cohen <wcohen@redhat.com> - 0.6-2
  558. - Correct Source to point to location contain code.
  559. * Thu Aug 9 2007 David Smith <dsmith@redhat.com> - 0.6-1
  560. - Bumped version, added libcap-devel BuildRequires.
  561. * Wed Jul 11 2007 Will Cohen <wcohen@redhat.com> - 0.5.14-2
  562. - Fix Requires and BuildRequires for sqlite.
  563. * Tue Jul 2 2007 Frank Ch. Eigler <fche@redhat.com> - 0.5.14-1
  564. - Many robustness improvements: 1117, 1134, 1305, 1307, 1570, 1806,
  565. 2033, 2116, 2224, 2339, 2341, 2406, 2426, 2438, 2583, 3037,
  566. 3261, 3282, 3331, 3428 3519, 3545, 3625, 3648, 3880, 3888, 3911,
  567. 3952, 3965, 4066, 4071, 4075, 4078, 4081, 4096, 4119, 4122, 4127,
  568. 4146, 4171, 4179, 4183, 4221, 4224, 4254, 4281, 4319, 4323, 4326,
  569. 4329, 4332, 4337, 4415, 4432, 4444, 4445, 4458, 4467, 4470, 4471,
  570. 4518, 4567, 4570, 4579, 4589, 4609, 4664
  571. * Mon Mar 26 2007 Frank Ch. Eigler <fche@redhat.com> - 0.5.13-1
  572. - An emergency / preliminary refresh, mainly for compatibility
  573. with 2.6.21-pre kernels.
  574. * Mon Jan 1 2007 Frank Ch. Eigler <fche@redhat.com> - 0.5.12-1
  575. - Many changes, see NEWS file.
  576. * Tue Sep 26 2006 David Smith <dsmith@redhat.com> - 0.5.10-1
  577. - Added 'systemtap-runtime' subpackage.
  578. * Wed Jul 19 2006 Roland McGrath <roland@redhat.com> - 0.5.9-1
  579. - PRs 2669, 2913
  580. * Fri Jun 16 2006 Roland McGrath <roland@redhat.com> - 0.5.8-1
  581. - PRs 2627, 2520, 2228, 2645
  582. * Fri May 5 2006 Frank Ch. Eigler <fche@redhat.com> - 0.5.7-1
  583. - PRs 2511 2453 2307 1813 1944 2497 2538 2476 2568 1341 2058 2220 2437
  584. 1326 2014 2599 2427 2438 2465 1930 2149 2610 2293 2634 2506 2433
  585. * Tue Apr 4 2006 Roland McGrath <roland@redhat.com> - 0.5.5-1
  586. - Many changes, affected PRs include: 2068, 2293, 1989, 2334,
  587. 1304, 2390, 2425, 953.
  588. * Wed Feb 1 2006 Frank Ch. Eigler <fche@redhat.com> - 0.5.4-1
  589. - PRs 1916, 2205, 2142, 2060, 1379
  590. * Mon Jan 16 2006 Roland McGrath <roland@redhat.com> - 0.5.3-1
  591. - Many changes, affected PRs include: 2056, 1144, 1379, 2057,
  592. 2060, 1972, 2140, 2148
  593. * Mon Dec 19 2005 Roland McGrath <roland@redhat.com> - 0.5.2-1
  594. - Fixed build with gcc 4.1, various tapset changes.
  595. * Wed Dec 7 2005 Roland McGrath <roland@redhat.com> - 0.5.1-1
  596. - elfutils update, build changes
  597. * Fri Dec 02 2005 Frank Ch. Eigler <fche@redhat.com> - 0.5-1
  598. - Many fixes and improvements: 1425, 1536, 1505, 1380, 1329, 1828, 1271,
  599. 1339, 1340, 1345, 1837, 1917, 1903, 1336, 1868, 1594, 1564, 1276, 1295
  600. * Mon Oct 31 2005 Roland McGrath <roland@redhat.com> - 0.4.2-1
  601. - Many fixes and improvements: PRs 1344, 1260, 1330, 1295, 1311, 1368,
  602. 1182, 1131, 1332, 1366, 1456, 1271, 1338, 1482, 1477, 1194.
  603. * Wed Sep 14 2005 Roland McGrath <roland@redhat.com> - 0.4.1-1
  604. - Many fixes and improvements since 0.2.2; relevant PRs include:
  605. 1122, 1134, 1155, 1172, 1174, 1175, 1180, 1186, 1187, 1191, 1193, 1195,
  606. 1197, 1205, 1206, 1209, 1213, 1244, 1257, 1258, 1260, 1265, 1268, 1270,
  607. 1289, 1292, 1306, 1335, 1257
  608. * Wed Sep 7 2005 Frank Ch. Eigler <fche@redhat.com>
  609. - Bump version.
  610. * Wed Aug 16 2005 Frank Ch. Eigler <fche@redhat.com>
  611. - Bump version.
  612. * Wed Aug 3 2005 Martin Hunt <hunt@redhat.com> - 0.2.2-1
  613. - Add directory /var/cache/systemtap
  614. - Add stp_check to /usr/libexec/systemtap
  615. * Wed Aug 3 2005 Roland McGrath <roland@redhat.com> - 0.2.1-1
  616. - New version 0.2.1, various fixes.
  617. * Fri Jul 29 2005 Roland McGrath <roland@redhat.com> - 0.2-1
  618. - New version 0.2, requires elfutils 0.111
  619. * Mon Jul 25 2005 Roland McGrath <roland@redhat.com>
  620. - Clean up spec file, build bundled elfutils.
  621. * Thu Jul 21 2005 Martin Hunt <hunt@redhat.com>
  622. - Set Version to use version from autoconf.
  623. - Fix up some of the path names.
  624. - Add Requires and BuildRequires.
  625. * Wed Jul 19 2005 Will Cohen <wcohen@redhat.com>
  626. - Initial creation of RPM.