spice-vl.spec 7.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239
  1. # build_client:
  2. # If you want to build both client and server change value to 1
  3. # If you want to only build the server change value to 0
  4. %define build_client 1
  5. Name: spice
  6. Version: 0.12.0
  7. Release: 1%{?_dist_release}
  8. Summary: Implements the SPICE protocol
  9. Group: User Interface/Desktops
  10. License: LGPLv2+
  11. URL: http://www.spice-space.org/
  12. Source0: http://www.spice-space.org/download/releases/%{name}-%{version}.tar.bz2
  13. Source1: spice-xpi-client-spicec
  14. BuildRequires: pkgconfig
  15. BuildRequires: spice-protocol >= 0.10.1
  16. BuildRequires: zlib-devel
  17. BuildRequires: celt051-devel
  18. BuildRequires: pixman-devel alsa-lib-devel openssl-devel libjpeg-turbo-devel
  19. %if %{build_client}
  20. BuildRequires: libXinerama-devel libXrandr-devel cegui06-devel
  21. %endif
  22. BuildRequires: libcacard-devel cyrus-sasl-devel
  23. BuildRequires: pyparsing
  24. BuildRequires: autoconf automake libtool
  25. %description
  26. The Simple Protocol for Independent Computing Environments (SPICE) is
  27. a remote display system built for virtual environments which allows
  28. you to view a computing 'desktop' environment not only on the machine
  29. where it is running, but from anywhere on the Internet and from a wide
  30. variety of machine architectures.
  31. %if %{build_client}
  32. %package client
  33. Summary: Implements the client side of the SPICE protocol
  34. Group: User Interface/Desktops
  35. %description client
  36. The Simple Protocol for Independent Computing Environments (SPICE) is
  37. a remote display system built for virtual environments which allows
  38. you to view a computing 'desktop' environment not only on the machine
  39. where it is running, but from anywhere on the Internet and from a wide
  40. variety of machine architectures.
  41. This package contains the SPICE client application.
  42. %endif
  43. %package server
  44. Summary: Implements the server side of the SPICE protocol
  45. Group: System Environment/Libraries
  46. %description server
  47. The Simple Protocol for Independent Computing Environments (SPICE) is
  48. a remote display system built for virtual environments which allows
  49. you to view a computing 'desktop' environment not only on the machine
  50. where it is running, but from anywhere on the Internet and from a wide
  51. variety of machine architectures.
  52. This package contains the run-time libraries for any application that wishes
  53. to be a SPICE server.
  54. %package server-devel
  55. Summary: Header files, libraries and development documentation for spice-server
  56. Group: Development/Libraries
  57. Requires: %{name}-server = %{version}-%{release}
  58. Requires: pkgconfig
  59. %description server-devel
  60. This package contains the header files, static libraries and development
  61. documentation for spice-server. If you like to develop programs
  62. using spice-server, you will need to install spice-server-devel.
  63. %prep
  64. %setup -q
  65. %build
  66. %if %{build_client}
  67. %define configure_client --enable-client --enable-gui
  68. %else
  69. %define configure_client --disable-client
  70. %endif
  71. autoreconf -fi
  72. %configure --enable-smartcard %{configure_client}
  73. make WARN_CFLAGS='' %{?_smp_mflags}
  74. %install
  75. make DESTDIR=%{buildroot} install
  76. rm -f %{buildroot}%{_libdir}/libspice-server.a
  77. rm -f %{buildroot}%{_libdir}/libspice-server.la
  78. mkdir -p %{buildroot}%{_libexecdir}
  79. %if %{build_client}
  80. touch %{buildroot}%{_libexecdir}/spice-xpi-client
  81. install -m 0755 %{SOURCE1} %{buildroot}%{_libexecdir}/
  82. %endif
  83. %post server -p /sbin/ldconfig
  84. %postun server -p /sbin/ldconfig
  85. %if %{build_client}
  86. %files client
  87. %defattr(-,root,root,-)
  88. %doc COPYING README NEWS
  89. %{_bindir}/spicec
  90. %ghost %{_libexecdir}/spice-xpi-client
  91. %{_libexecdir}/spice-xpi-client-spicec
  92. %endif
  93. %files server
  94. %defattr(-,root,root,-)
  95. %doc COPYING README NEWS
  96. %{_libdir}/libspice-server.so.*
  97. %files server-devel
  98. %defattr(-,root,root,-)
  99. %{_includedir}/spice-server
  100. %{_libdir}/libspice-server.so
  101. %{_libdir}/pkgconfig/spice-server.pc
  102. %changelog
  103. * Sun Nov 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.0-1
  104. - initial build for Vine Linux
  105. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10.1-6
  106. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  107. * Mon May 14 2012 Alon Levy <alevy@redhat.com>
  108. - Fix mjpeg memory leak and bad behavior.
  109. - Add usbredir to list of channels for security purposes. (#819484)
  110. * Sun May 13 2012 Alon Levy <alevy@redhat.com>
  111. - Add double free fix. (#808936)
  112. %changelog
  113. * Tue Apr 24 2012 Alon Levy <alevy@redhat.com>
  114. - Add 32 bit fixes from git master. (#815717)
  115. * Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10.1-2
  116. - Rebuilt for c++ ABI breakage
  117. * Mon Jan 23 2012 Hans de Goede <hdegoede@redhat.com> - 0.10.1-1
  118. - New upstream release 0.10.1
  119. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10.0-2
  120. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  121. * Thu Nov 10 2011 Alon Levy <alevy@redhat.com> - 0.10.0-1
  122. - New upstream release 0.10.0
  123. - support spice-server.i686
  124. * Wed Sep 28 2011 Marc-André Lureau <marcandre.lureau@redhat.com> - 0.9.1-2
  125. - Provides spice-xpi-client alternative in spice-client
  126. * Thu Aug 25 2011 Hans de Goede <hdegoede@redhat.com> - 0.9.1-1
  127. - New upstream release 0.9.1
  128. * Mon Jul 25 2011 Marc-André Lureau <marcandre.lureau@redhat.com> - 0.9.0-1
  129. - New upstream release 0.9.0
  130. * Wed Apr 20 2011 Hans de Goede <hdegoede@redhat.com> - 0.8.1-1
  131. - New upstream release 0.8.1
  132. * Fri Mar 11 2011 Hans de Goede <hdegoede@redhat.com> - 0.8.0-2
  133. - Fix being unable to send ctrl+alt+key when release mouse is bound to
  134. ctrl+alt (which can happen when used from RHEV-M)
  135. * Tue Mar 1 2011 Hans de Goede <hdegoede@redhat.com> - 0.8.0-1
  136. - New upstream release 0.8.0
  137. * Fri Feb 11 2011 Hans de Goede <hdegoede@redhat.com> - 0.7.3-1
  138. - New upstream release 0.7.3
  139. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.2-2
  140. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  141. * Wed Jan 19 2011 Hans de Goede <hdegoede@redhat.com> - 0.7.2-1
  142. - New upstream release 0.7.2
  143. * Fri Dec 17 2010 Hans de Goede <hdegoede@redhat.com> - 0.7.1-1
  144. - New upstream release 0.7.1
  145. - Drop all patches (all upstreamed)
  146. - Enable smartcard (CAC) support
  147. * Wed Nov 17 2010 Hans de Goede <hdegoede@redhat.com> - 0.6.3-4
  148. - Fix the info layer not showing when used through the XPI
  149. - Do not let the connection gui flash by when a hostname has been specified
  150. on the cmdline
  151. - Fix spice client locking up when dealing with XIM input (#654265)
  152. - Fix modifier keys getting stuck (#655048)
  153. - Fix spice client crashing when dealing with XIM ibus input (#655836)
  154. - Fix spice client only showing a white screen in full screen mode
  155. * Sat Nov 6 2010 Hans de Goede <hdegoede@redhat.com> - 0.6.3-3
  156. - Log to ~/.spicec/cegui.log rather then to CEGUI.log in the cwd, this
  157. fixes spicec from aborting when run in a non writable dir (#650253)
  158. * Fri Nov 5 2010 Hans de Goede <hdegoede@redhat.com> - 0.6.3-2
  159. - Various bugfixes from upstream git:
  160. - Make spicec work together with the Firefox XPI for RHEV-M
  161. - Make sure the spicec window gets properly raised when first shown
  162. * Mon Oct 18 2010 Hans de Goede <hdegoede@redhat.com> - 0.6.3-1
  163. - Update to 0.6.3
  164. - Enable GUI
  165. * Thu Sep 30 2010 Gerd Hoffmann <kraxel@redhat.com> - 0.6.1-1
  166. - Update to 0.6.1.
  167. * Tue Aug 31 2010 Alexander Larsson <alexl@redhat.com> - 0.6.0-1
  168. - Update to 0.6.0 (stable release)
  169. * Tue Jul 20 2010 Alexander Larsson <alexl@redhat.com> - 0.5.3-1
  170. - Update to 0.5.3
  171. * Tue Jul 13 2010 Gerd Hoffmann <kraxel@redhat.com> - 0.5.2-4
  172. - Quote %% in changelog to avoid macro expansion.
  173. * Mon Jul 12 2010 Gerd Hoffmann <kraxel@redhat.com> - 0.5.2-3
  174. - %%configure handles CFLAGS automatically, no need to fiddle
  175. with %%{optflags} manually.
  176. * Mon Jul 12 2010 Gerd Hoffmann <kraxel@redhat.com> - 0.5.2-2
  177. - Fix license: LGPL.
  178. - Cleanup specfile, drop bits not needed any more with
  179. recent rpm versions (F13+).
  180. - Use optflags as-is.
  181. -
  182. * Fri Jul 9 2010 Gerd Hoffmann <kraxel@redhat.com> - 0.5.2-1
  183. - initial package.