libboost-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466
  1. %define major 1
  2. %define minor 45
  3. %define teeny 0
  4. %define tarname boost
  5. %define lnkver %{major}_%{minor}
  6. %define pkgver %{major}_%{minor}_%{teeny}
  7. Summary: Portable C++ source libraries
  8. Summary(ja): ポータブルな C++ ソースライブラリ
  9. Name: libboost
  10. Version: %{major}.%{minor}.%{teeny}
  11. Release: 2%{?_dist_release}
  12. Source0: http://downloads.sourceforge.net/%{tarname}/%{tarname}_%{pkgver}.tar.bz2
  13. Source1: user-config.jam
  14. Patch0: https://svn.boost.org/trac/boost/attachment/ticket/4688/boost_filesystem.patch
  15. License: distributable
  16. Group: System Environment/Libraries
  17. URL: http://www.boost.org/
  18. BuildRequires: python-devel apache2-devel bzip2-devel zlib-devel libicu-devel
  19. BuildRequires: libaio-devel lam
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  21. Vendor: Project Vine
  22. Distribution: Vine Linux
  23. Obsoletes: %{name}-date-time-devel %{name}-filesystem-devel %{name}-graph-devel
  24. Obsoletes: %{name}-iostreams-devel %{name}-program-options-devel
  25. Obsoletes: %{name}-python-devel %{name}-regex-devel
  26. Obsoletes: %{name}-serialization-devel %{name}-signals-devel %{name}-test-devel
  27. Obsoletes: %{name}-thread-devel %{name}-wave-devel
  28. %description
  29. Boost provides free peer-reviewed portable C++ source libraries. The emphasis
  30. is on libraries which work well with the C++ Standard Library. The libraries
  31. are intended to be widely useful, and are in regular use by thousands of
  32. programmers across a broad spectrum of applications.
  33. A further goal is to establish "existing practice" and provide reference
  34. implementations so that Boost libraries are suitable for eventual
  35. standardization. Ten Boost libraries will be included in the C++ Standards
  36. Committee's upcoming C++ Standard Library Technical Report as a step toward
  37. becoming part of a future C++ Standard.
  38. %description -l ja
  39. Boost は公開レビューされたフリーのC++ライブラリ群です。 C++ の標準ライブラリに
  40. 準拠することに重点を置いて開発されています。使いやすく、広い分野のアプリ
  41. ケーションにおいて日常的に多くの開発者に用いられることを目指しています。
  42. さらなる目標は、最終的な標準化に適合した「存在する実例」としてリファレンス実装
  43. を提供することです。10 の Boost ライブラリが、将来の C++ 標準になるための一歩
  44. として、C++ 標準化委員会が策定中の C++ 標準ライブラリテクニカルレポートに
  45. 含まれる予定です。
  46. %package devel
  47. Summary: Header files and libraries for developing apps which will use %{name}
  48. Summary(ja): %{name}の開発に必要なヘッダファイル及びライブラリ
  49. Group: Development/Libraries
  50. Requires: %{name} = %{version}-%{release}
  51. %description devel
  52. The %{name}-devel package contains the header files and libraries needed
  53. to develop programs that use the Boost library.
  54. %description devel -l ja
  55. %{name}-devel パッケージは Boost ライブラリを使うプログラムの開発に必要な
  56. ヘッダファイルやライブラリを含んでいます。
  57. %package doc
  58. Summary: Documents of %{name}
  59. Summary(ja): %{name}のドキュメント
  60. Group: Applications/Documentation
  61. Requires: %{name} = %{version}-%{release}
  62. %description doc
  63. The %{name}-doc package contains the documents about the boost library.
  64. %description doc -l ja
  65. %{name}-doc パッケージは Boost ライブラリについてのドキュメントを含んでいます。
  66. %package date-time
  67. Summary: Set of data-time libralies in %{name}
  68. Group: System Environment/Libraries
  69. Requires: %{name} = %{version}-%{release}
  70. %description date-time
  71. Set of data-time libralies in %{name}
  72. %package filesystem
  73. Summary: Set of filesystem operation libralies in %{name}
  74. Group: System Environment/Libraries
  75. Requires: %{name} = %{version}-%{release}
  76. %description filesystem
  77. Set of filesystem operation libralies in %{name}
  78. %package graph
  79. Summary: Set of Graphviz libralies in %{name}
  80. Group: System Environment/Libraries
  81. Requires: %{name} = %{version}-%{release}
  82. %description graph
  83. Set of Graphviz libralies in %{name}
  84. %package iostreams
  85. Summary: Set of streams and i/o filters libralies in %{name}
  86. Group: System Environment/Libraries
  87. Requires: %{name} = %{version}-%{release}
  88. %description iostreams
  89. Set of streams and i/o filters libralies in %{name}
  90. %package math
  91. Summary: Set of math libralies in %{name}
  92. Group: System Environment/Libraries
  93. Requires: %{name} = %{version}-%{release}
  94. %description math
  95. Set of math libralies in %{name}
  96. %package program-options
  97. Summary: Set of program options libralies in %{name}
  98. Group: System Environment/Libraries
  99. Requires: %{name} = %{version}-%{release}
  100. %description program-options
  101. Set of program options libralies in %{name}
  102. %package python
  103. Summary: Set of Python libralies in %{name}
  104. Group: System Environment/Libraries
  105. Requires: %{name} = %{version}-%{release}
  106. %description python
  107. Set of Python libralies in %{name}
  108. %package random
  109. Summary: Set of random number generation libralies in %{name}
  110. Group: System Environment/Libraries
  111. Requires: %{name} = %{version}-%{release}
  112. %description random
  113. Set of random number generation libralies in %{name}
  114. %package regex
  115. Summary: Set of regular expression libralies in %{name}
  116. Group: System Environment/Libraries
  117. Requires: %{name} = %{version}-%{release}
  118. %description regex
  119. Set of regular expression libralies in %{name}
  120. %package serialization
  121. Summary: Set of serialization libralies in %{name}
  122. Group: System Environment/Libraries
  123. Requires: %{name} = %{version}-%{release}
  124. %description serialization
  125. Set of serialization libralies in %{name}
  126. %package signals
  127. Summary: Set of signals and slots libralies in %{name}
  128. Group: System Environment/Libraries
  129. Requires: %{name} = %{version}-%{release}
  130. %description signals
  131. Set of signals and slots libralies in %{name}
  132. %package system
  133. Summary: Operating system support
  134. Group: System Environment/Libraries
  135. Requires: %{name} = %{version}-%{release}
  136. %description system
  137. Operating system support, including the diagnostics support
  138. that will be part of the C++0x standard library
  139. %package test
  140. Summary: Set of libraries for writing and executing tests in %{name}
  141. Group: System Environment/Libraries
  142. Requires: %{name} = %{version}-%{release}
  143. %description test
  144. Set of libraries for writing and executing tests in %{name}
  145. %package thread
  146. Summary: Set of multi-thread libraries in %{name}
  147. Group: System Environment/Libraries
  148. Requires: %{name} = %{version}-%{release}
  149. %description thread
  150. Set of multi-thread libraries in %{name}
  151. %package wave
  152. Summary: Set of wave libraries in %{name}
  153. Group: System Environment/Libraries
  154. Requires: %{name} = %{version}-%{release}
  155. %description wave
  156. Set of wave libraries in %{name}
  157. %prep
  158. %setup -q -n %{tarname}_%{pkgver}
  159. cp %SOURCE1 user-config.jam
  160. %patch0 -p1 -b .filesystem
  161. %build
  162. ## ./configure --prefix=/usr --libdir=%{_libdir} --with-icu
  163. ## make EXPAT_INCLUDE=/usr/include EXPAT_LIBPATH=/usr/lib
  164. ./bootstrap.sh \
  165. --prefix=%{_prefix} \
  166. --libdir=%{_libdir} \
  167. --includedir=%{_includedir} \
  168. --with-icu=%{_prefix} \
  169. --with-python-version=%{pyver}
  170. ./bjam -sICU_LINK="-L%{_libdir} -licui18n" --user-config=./user-config.jam link=shared
  171. %install
  172. rm -rf $RPM_BUILD_ROOT
  173. ## ./tools/jam/src/bin.linux*/bjam -sICU_PATH=/usr -sEXPAT_INCLUDE=/usr/include -sEXPAT_LIBPATH=/usr/lib --user-config=user-config.jam --prefix=${RPM_BUILD_ROOT}/usr --libdir=${RPM_BUILD_ROOT}%{_libdir} install
  174. ./bjam \
  175. --prefix=${RPM_BUILD_ROOT}%{_prefix} \
  176. --libdir=${RPM_BUILD_ROOT}%{_libdir} \
  177. --user-config=./user-config.jam \
  178. link=shared \
  179. install
  180. ln -s ./%{tarname} ${RPM_BUILD_ROOT}/%{_includedir}/%{tarname}-%{lnkver}
  181. # remove unuse files
  182. rm -f ${RPM_BUILD_ROOT}/%{_libdir}/%{name}_*.a
  183. # unnead for libboost-1.42
  184. ## pushd $RPM_BUILD_ROOT/%{_libdir}
  185. ## for i in libboost_*-mt.so
  186. ## do
  187. ## ln -sf $i $(echo $i | cut -f1 -d-).so
  188. ## done
  189. ## popd
  190. ## %post devel
  191. ## if [ $1 = 2 ]; then
  192. ## rm -rf %{_includedir}/%{tarname}
  193. ## fi
  194. ## ln -s %{_includedir}/%{tarname}-%{lnkver}/%{tarname} %{_includedir}/%{tarname}
  195. ##
  196. ## %postun devel
  197. ## if [ $1 = 0 ]; then
  198. ## rm -rf %{_includedir}/%{tarname}
  199. ## fi
  200. %post date-time -p /sbin/ldconfig
  201. %post filesystem -p /sbin/ldconfig
  202. %post graph -p /sbin/ldconfig
  203. %post iostreams -p /sbin/ldconfig
  204. %post math -p /sbin/ldconfig
  205. %post program-options -p /sbin/ldconfig
  206. %post python -p /sbin/ldconfig
  207. %post regex -p /sbin/ldconfig
  208. %post serialization -p /sbin/ldconfig
  209. %post signals -p /sbin/ldconfig
  210. %post system -p /sbin/ldconfig
  211. %post test -p /sbin/ldconfig
  212. %post thread -p /sbin/ldconfig
  213. %post wave -p /sbin/ldconfig
  214. %postun date-time -p /sbin/ldconfig
  215. %postun filesystem -p /sbin/ldconfig
  216. %postun graph -p /sbin/ldconfig
  217. %postun iostreams -p /sbin/ldconfig
  218. %postun math -p /sbin/ldconfig
  219. %postun program-options -p /sbin/ldconfig
  220. %postun python -p /sbin/ldconfig
  221. %postun regex -p /sbin/ldconfig
  222. %postun serialization -p /sbin/ldconfig
  223. %postun signals -p /sbin/ldconfig
  224. %postun system -p /sbin/ldconfig
  225. %postun test -p /sbin/ldconfig
  226. %postun thread -p /sbin/ldconfig
  227. %postun wave -p /sbin/ldconfig
  228. %clean
  229. rm -rf $RPM_BUILD_ROOT
  230. %files
  231. %defattr(-,root,root)
  232. %doc LICENSE_1_0.txt
  233. %files devel
  234. %defattr(-,root,root)
  235. %{_includedir}/boost/
  236. %{_includedir}/boost-%{lnkver}/
  237. %files doc
  238. %doc index.htm index.html boost.css boost.png rst.css doc libs more
  239. %files date-time
  240. %{_libdir}/%{name}_date_time*.so*
  241. %files filesystem
  242. %{_libdir}/%{name}_filesystem*.so*
  243. %files graph
  244. %{_libdir}/%{name}_graph*.so*
  245. %{_libdir}/%{name}_mpi*.so*
  246. %{_libdir}/mpi*.so*
  247. %files iostreams
  248. %{_libdir}/%{name}_iostreams*.so*
  249. %files math
  250. %{_libdir}/%{name}_math_*.so*
  251. %files program-options
  252. %{_libdir}/%{name}_program_options*.so*
  253. %files python
  254. %{_libdir}/%{name}_python*.so*
  255. %files random
  256. %{_libdir}/%{name}_random*.so*
  257. %files regex
  258. %{_libdir}/%{name}_regex*.so*
  259. %files serialization
  260. %{_libdir}/%{name}_serialization*.so*
  261. %{_libdir}/%{name}_wserialization*.so*
  262. %files signals
  263. %{_libdir}/%{name}_signals*.so*
  264. %files system
  265. %{_libdir}/%{name}_system*.so*
  266. %files test
  267. %{_libdir}/%{name}_prg_exec_monitor*.so*
  268. %{_libdir}/%{name}_unit_test_framework*.so*
  269. %files thread
  270. %{_libdir}/%{name}_thread*.so*
  271. %files wave
  272. %{_libdir}/%{name}_wave*.so*
  273. %changelog
  274. * Sun Feb 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.45.0-2
  275. - fixed crashing throwing exception
  276. "std::runtime_error: locale::facet::_S_create_c_locale name not valid"
  277. on some systems (FreeBSD and some linuxes) when current locale
  278. (LANG,LC_ALL) is not "C"
  279. * Tue Jan 18 2011 Shu KONNO <owa@bg.wakwak.com> 1.45.0-1
  280. - updated to boost_1_45_0
  281. - added random sub-package
  282. * Wed Apr 14 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.42.0-4
  283. - rebuilt again on ppc
  284. * Sat Apr 10 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.42.0-3
  285. - rebuilt with libicu-4.4
  286. * Mon Feb 08 2010 Shu KONNO <owa@bg.wakwak.com> 1.42.0-2
  287. - added "-licui18n" to bjam
  288. - added BR: lam
  289. * Sun Feb 07 2010 Shu KONNO <owa@bg.wakwak.com> 1.42.0-1
  290. - updated to boost_1_42_0
  291. - rebuilt with new toolchain and python-2.6
  292. - added user-config.jam to make libboost_mpi
  293. - added BR: libaio-devel
  294. - added %%{post,postun} -p /sbin/ldconfig
  295. - dropt no use parameter EXPAT_INCLUDE and EXPAT_LIBPATH
  296. - dropt %{_libdir}/%{name}_test_exec_monitor-*.a in %%files %{name}-test
  297. - dropt %%{post,postun} devel section
  298. * Sun Mar 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.36.0-2vl5
  299. - rebuilt with libicu-4.0.1
  300. - changed Group to System Environment/Libraries (except devel package)
  301. * Sat Aug 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.36.0-1vl5
  302. - new upstream release
  303. - add -math subpackage
  304. * Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.35.0-2vl5
  305. - build with python-2.5
  306. - add libboost_XXXX.so symlinks
  307. * Thu May 8 2008 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.35.0-1vl5
  308. - upstream release
  309. - applied new versioning policy
  310. - add EXPAT_INCLUDE and EXPAT_LIBPATH to enable GraphML support
  311. - add new package libboost-system
  312. - Obsolete: *-devel packages
  313. * Sat Sep 8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.34.1-0vl3
  314. - rebuilt with libicu-3.6
  315. - changed doc Group to Applications/Documentation
  316. * Sat Aug 18 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.34.1-0vl2
  317. - upstream release
  318. * Thu Jun 14 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.34.0-0vl3
  319. - add --libdir=%%{_libdir} to cope with x86_64 environment
  320. * Sun Jun 10 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.34.0-0vl2
  321. - upstream release
  322. - use Easy Build and Install process with ./configure
  323. - add BuildRequires: libicu-devel
  324. - remove %%{_libdir}/libboost_test_exec_monitor-*.so* from %%files -n libboost-test
  325. - add new packages: libboost-graph, libboost-graph-devel, libboost-wave
  326. - add files to doc package
  327. * Sun May 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.33.1-0vl2
  328. - rebuilt with new toolchain
  329. * Sat Feb 4 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.33.1-0vl1
  330. - upstream release
  331. * Mon Dec 12 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.33.0-0vl3
  332. - fixed typo in Groups:
  333. - devel packages also moved to Development/Libraries group
  334. * Mon Sep 19 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.33.0-0vl2
  335. - spec modified to avoid errors on non-ix86 archtecture
  336. (previously the path linuxx86 was explicitly used)
  337. * Sun Sep 11 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.33.0-0vl1
  338. - initial release for Vine Linux
  339. * Sat Sep 10 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.33.0-0vl0.3
  340. - link /usr/include/boost_%{lnkver}/boost to /usr/include/boost
  341. * Sat Sep 10 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.33.0-0vl0.2
  342. - change package name from boost to libboost
  343. - separated into sub-packages
  344. * Fri Jun 17 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.33.0-0vl0.1
  345. - upstream release
  346. - add BuildRequires: bzip2-devel zlib-devel
  347. * Fri Jun 17 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.7
  348. - added so.* file
  349. * Mon Apr 25 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.6
  350. - moved %post, %postun script to -devel package
  351. * Mon Apr 25 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.5
  352. - moved doc/html to -devel package
  353. - make a symbolic link on %{_includedir}/boost
  354. * Mon Apr 25 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.4
  355. - fixed character code to euc-jp
  356. * Mon Apr 25 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.3
  357. - add %doc files
  358. * Fri Apr 22 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.2
  359. - remove Requires
  360. - split -devel package
  361. * Fri Apr 22 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.1
  362. - initial build for Vine Linux